]> git.pld-linux.org Git - packages/python-HTMLgen.git/blame - python-HTMLgen.spec
Files for python-HTMLgen.
[packages/python-HTMLgen.git] / python-HTMLgen.spec
CommitLineData
94c879db 1Summary: class library to create HTML documents from within Python
2Name: python-HTMLgen
3Version: 2.1
4Release: 3
5Copyright: distributable
6Packager: Oliver Andrich <oli@andrich.net>
7Group: Development/Languages/Python
8Source0: HTMLgen.tar.gz
9Source1: HTMLgen.pth
10Patch0: python-HTMLgen-fixpaths.patch
11Icon: linux-python-small.gif
12BuildRoot: /tmp/py-root
13Requires: python >= 1.5
14BuildArchitectures: noarch
15
16%changelog
17* Sat Jun 30 1998 Oliver Andrich <oli@andrich.net>
18
19- updated to the HTMLgen 2.1 final version
20
21* Sat Jun 06 1998 Oliver Andrich <oli@andrich.net>
22
23- added the new standard python icon. ;-)
24
25* Sat Jun 06 1998 Oliver Andrich <oli@andrich.net>
26
27- initial release
28
29%description
30HTMLgen is a class library for the generation of HTML documents with
31Python scripts. It's used when you want to create HTML pages
32containing information which changes from time to time. For example
33you might want to have a page which provides an overall system summary
34of data collected nightly. Or maybe you have a catalog of data and
35images that you would like formed into a spiffy set of web pages for
36the world to browse. Python is a great scripting language for these
37tasks and with HTMLgen it's very straightforward to construct objects
38which are rendered out into consistently structured web pages. Of
39course, CGI scripts written in Python can take advantage of these
40classes as well.
41
42This software should work on both Unix and Macintosh and Win32
43platforms running Python 1.3 or greater. (HTMLcalendar.py requires
441.4) If you are running 1.5 the new re and string module enhancements
45are used for performance.
46
47%prep
48%setup -n HTMLgen
49%patch -p0
50
51%build
52
53%install
54mkdir -p $RPM_BUILD_ROOT/usr/lib/python1.5/site-packages/HTMLgen
55install -m 555 $RPM_SOURCE_DIR/HTMLgen.pth $RPM_BUILD_ROOT/usr/lib/python1.5/site-packages/
56install -m 555 *.py $RPM_BUILD_ROOT/usr/lib/python1.5/site-packages/HTMLgen
57
58%clean
59# Now we create the slackware packages
60if [ ! -e /tmp/SLACKWARE ]; then
61 mkdir /tmp/SLACKWARE
62fi
63cd $RPM_BUILD_ROOT
64tar cvfz /tmp/SLACKWARE/python-HTMLgen-%{PACKAGE_VERSION}-%{PACKAGE_RELEASE}.tar.gz \
65usr/lib/python1.5/site-packages/HTMLgen usr/lib/python1.5/site-packages/HTMLgen.pth
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%doc data html image README ChangeLog *.rc *.css
70/usr/lib/python1.5/site-packages/HTMLgen
71/usr/lib/python1.5/site-packages/HTMLgen.pth
This page took 0.075964 seconds and 4 git commands to generate.