]> git.pld-linux.org Git - packages/protobuf.git/blame - protobuf.spec
- pl desc
[packages/protobuf.git] / protobuf.spec
CommitLineData
f132b5a5
JR
1#
2# TODO:
3# - add bindings for java and python
4# - add vim syntax package
5#
6Summary: Protocol Buffers - Google's data interchange format
7Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
8Name: protobuf
9db55fcc 9Version: 2.0.3
f132b5a5
JR
10Release: 1
11License: BSD
12Group: Libraries
13Source0: http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
9db55fcc 14# Source0-md5: 37e6e4d63434672c70bd977be9c372cb
f132b5a5
JR
15URL: http://code.google.com/p/protobuf/
16Requires: %{name}-libs = %{version}-%{release}
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Protocol buffers are a flexible, efficient, automated mechanism
21for serializing structured data - similar to XML, but smaller,
22faster, and simpler. You define how you want your data to be
23structured once, then you can use special generated source code
24to easily write and read your structured data to and from
25a variety of data streams and using a variety of languages.
26You can even update your data structure without breaking deployed
27programs that are compiled against the "old" format.
28
29Google uses Protocol Buffers for almost all of its internal RPC
30protocols and file formats.
31
c7c7fabc
JB
32%description -l pl.UTF-8
33Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
34serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
35szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
36a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
37zapisu i odczytu danych strukturalnych do i z różnych strumieni
38danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
39danych bez psucia programów skompilowanych w oparciu o "stary" format.
40
41Google używa buforów protokołowych (Protocol Buffers) do prawie
42wszystkich wewnętrznych protokołów RPC i formatów plików.
f132b5a5
JR
43
44%package libs
45Summary: protobuf libraries
46Summary(pl.UTF-8): Biblioteki protobuf
47Group: Libraries
48
49%description libs
50protobuf libraries.
51
52%description libs -l pl.UTF-8
53Biblioteki protobuf.
54
55%package devel
56Summary: Header files for protobuf libraries
57Summary(pl.UTF-8): Pliki nagłówkowe bibliotek protobuf
58Group: Development/Libraries
59Requires: %{name}-libs = %{version}-%{release}
60
61%description devel
62Header files for protobuf libraries.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe bibliotek protobuf.
66
67%package static
68Summary: Static protobuf libraries
69Summary(pl.UTF-8): Statyczne biblioteki protobuf
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
72
73%description static
74Static protobuf libraries.
75
76%description static -l pl.UTF-8
77Statyczne biblioteki protobuf.
78
79%prep
80%setup -q
81
82%build
83%configure
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
92
93install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post libs -p /sbin/ldconfig
99%postun libs -p /sbin/ldconfig
100
101%files
102%defattr(644,root,root,755)
103%doc CHANGES.txt CONTRIBUTORS.txt README.txt
104%attr(755,root,root) %{_bindir}/protoc
105
106%files libs
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_libdir}/libproto*.so.*.*.*
9db55fcc
AM
109%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.3
110%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.3
f132b5a5
JR
111
112%files devel
113%defattr(644,root,root,755)
114%{_includedir}/google
115%attr(755,root,root) %{_libdir}/libproto*.la
116%attr(755,root,root) %{_libdir}/libproto*.so
117%{_examplesdir}/%{name}-%{version}
118
119%files static
120%defattr(644,root,root,755)
121%attr(755,root,root) %{_libdir}/libproto*.a
This page took 0.038574 seconds and 4 git commands to generate.