]> git.pld-linux.org Git - packages/protobuf.git/blame - protobuf.spec
- up to 2.0.3
[packages/protobuf.git] / protobuf.spec
CommitLineData
f132b5a5
JR
1#
2# TODO:
3# - add bindings for java and python
4# - add vim syntax package
5#
6Summary: Protocol Buffers - Google's data interchange format
7Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
8Name: protobuf
9db55fcc 9Version: 2.0.3
f132b5a5
JR
10Release: 1
11License: BSD
12Group: Libraries
13Source0: http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
9db55fcc 14# Source0-md5: 37e6e4d63434672c70bd977be9c372cb
f132b5a5
JR
15URL: http://code.google.com/p/protobuf/
16Requires: %{name}-libs = %{version}-%{release}
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Protocol buffers are a flexible, efficient, automated mechanism
21for serializing structured data - similar to XML, but smaller,
22faster, and simpler. You define how you want your data to be
23structured once, then you can use special generated source code
24to easily write and read your structured data to and from
25a variety of data streams and using a variety of languages.
26You can even update your data structure without breaking deployed
27programs that are compiled against the "old" format.
28
29Google uses Protocol Buffers for almost all of its internal RPC
30protocols and file formats.
31
32#%description -l pl.UTF-8
33
34%package libs
35Summary: protobuf libraries
36Summary(pl.UTF-8): Biblioteki protobuf
37Group: Libraries
38
39%description libs
40protobuf libraries.
41
42%description libs -l pl.UTF-8
43Biblioteki protobuf.
44
45%package devel
46Summary: Header files for protobuf libraries
47Summary(pl.UTF-8): Pliki nagłówkowe bibliotek protobuf
48Group: Development/Libraries
49Requires: %{name}-libs = %{version}-%{release}
50
51%description devel
52Header files for protobuf libraries.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe bibliotek protobuf.
56
57%package static
58Summary: Static protobuf libraries
59Summary(pl.UTF-8): Statyczne biblioteki protobuf
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64Static protobuf libraries.
65
66%description static -l pl.UTF-8
67Statyczne biblioteki protobuf.
68
69%prep
70%setup -q
71
72%build
73%configure
74%{__make}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post libs -p /sbin/ldconfig
89%postun libs -p /sbin/ldconfig
90
91%files
92%defattr(644,root,root,755)
93%doc CHANGES.txt CONTRIBUTORS.txt README.txt
94%attr(755,root,root) %{_bindir}/protoc
95
96%files libs
97%defattr(644,root,root,755)
98%attr(755,root,root) %{_libdir}/libproto*.so.*.*.*
9db55fcc
AM
99%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.3
100%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.3
f132b5a5
JR
101
102%files devel
103%defattr(644,root,root,755)
104%{_includedir}/google
105%attr(755,root,root) %{_libdir}/libproto*.la
106%attr(755,root,root) %{_libdir}/libproto*.so
107%{_examplesdir}/%{name}-%{version}
108
109%files static
110%defattr(644,root,root,755)
111%attr(755,root,root) %{_libdir}/libproto*.a
This page took 0.118065 seconds and 4 git commands to generate.