]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- mTh/master is rpm5
[packages/poldek.git] / poldek.spec
CommitLineData
7638abfc 1#
de1099c4 2# Conditional build:
9fe14a3f 3%bcond_with static # don't use shared libraries
4%bcond_without imode # don't build interactive mode
58c31de0 5%bcond_without python # don't build python bindings
cf6c3a30 6%bcond_with snap # install configs for official Th snapshot
6e185c37 7%bcond_with db60 # DB 6.0 instead of 5.2
dbf5b095 8%bcond_with rpm4 # use rpm4/db4.7 instead of rpm5
7000d724 9
e1015166 10# current snapshot name
42c61fde 11%define SNAP 2014
a584c5c5 12
373c6f03 13# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
6e185c37
JB
14# NOTE: poldek links with "system db" (-ldb) anyway if it exists
15%if %{with db60}
16%define db_pkg db6.0
17%define ver_db 6.0
18%define ver_db_rel 1
19%else
ff4e68af 20%define db_pkg db5.2
376a705c 21%define ver_db 5.2
19e679c6 22%define ver_db_rel 3
6e185c37 23%endif
5fda028a
ER
24
25%if %{with rpm4}
26%define ver_db 4.7.25
27%define ver_db_rel 1
28%define ver_rpm 4.5-49
29%else
a17726b5 30%define ver_rpm 5.4.10
5fda028a 31%endif
7000d724 32
5eb97c67 33%define rel 2
b44549bf 34Summary: RPM packages management helper tool
9c03ea8f 35Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 36Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 37Name: poldek
e8dadd74 38Version: 0.30.1
9c1c2b52 39Release: %{rel}%{?with_snap:.%{SNAP}}
9f931ada 40License: GPL v2
8efee472 41Group: Applications/System
85398bac 42#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
e5009a66 43Source0: http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
e8dadd74 44# Source0-md5: e569c8454df0932df53b09cee9998927
911a8560 45Source1: %{name}.conf
b25cb9a7 46Source2: %{name}-multilib.conf
2ccd5d66 47Source5: %{name}-aliases.conf
48Source6: %{name}.desktop
49Source7: %{name}.png
171e07f6 50Source8: %{name}-debuginfo.conf
652b5bc5 51Source9: %{name}-aidath.conf
52Source10: %{name}-multilib-aidath.conf
8db66c11 53Source11: %{name}-archive.conf
a584c5c5
JR
54Source100: %{name}-snap.conf
55Source101: %{name}-multilib-snap.conf
56Source102: %{name}-debuginfo-snap.conf
e5009a66 57Patch0: %{name}-size-type.patch
e8dadd74 58Patch1: %{name}-config.patch
39ca2371 59URL: http://poldek.pld-linux.org/
340a1e21 60BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
a4268952 61BuildRequires: autoconf
4d0dcbcf 62BuildRequires: automake >= 1:1.11
373c6f03 63BuildRequires: bzip2-devel
065b86e0 64BuildRequires: check-devel
1d67e563 65BuildRequires: docbook-dtd412-xml
22329ccf 66BuildRequires: gettext-tools
b25cb9a7
JB
67BuildRequires: libtool
68BuildRequires: libxml2-devel
fc37ede0 69BuildRequires: neon-devel
cbc6f56b 70BuildRequires: openssl-devel >= 0.9.7d
13fd950e 71BuildRequires: pcre-devel
b3ea4b51 72BuildRequires: pkgconfig
13fd950e 73BuildRequires: popt-devel
58c31de0 74%{?with_python:BuildRequires: python-devel}
b25cb9a7 75BuildRequires: readline-devel >= 5.0
373c6f03 76BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 77%{?with_python:BuildRequires: rpm-pythonprov}
65a99b8b 78BuildRequires: swig-python
340a1e21 79BuildRequires: tar >= 1:1.22
77cfda6e 80BuildRequires: xmlto
340a1e21 81BuildRequires: xz
96475e5e 82BuildRequires: zlib-devel
373c6f03 83%if %{with static}
ff4e68af 84BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
340a1e21 85BuildRequires: bzip2-static
2fac0b02 86BuildRequires: glibc-static
b25cb9a7 87BuildRequires: libxml2-static
373c6f03
JB
88BuildRequires: ncurses-static
89BuildRequires: openssl-static
90BuildRequires: pcre-static
91BuildRequires: popt-static
92BuildRequires: readline-static
93BuildRequires: rpm-static
94BuildRequires: zlib-static
373c6f03 95%endif
b25cb9a7 96Requires(triggerpostun): awk
168acc54 97Requires(triggerpostun): sed >= 4.0
ff4e68af 98Requires: %{db_pkg} >= %{ver_db}-%{ver_db_rel}
340a1e21 99Requires: %{name}-libs = %{version}-%{release}
373c6f03 100Requires: rpm >= %{ver_rpm}
530c8c41 101Requires: rpm-db-ver = %{ver_db}
5fda028a 102Requires: rpm-lib >= %{ver_rpm}
e202a52a
ER
103# vf* scripts use sed
104Requires: sed
b44549bf 105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
dcdcebb7
ER
107%define _libexecdir %{_prefix}/lib/%{name}
108
b44549bf 109%description
0fa0dc36 110poldek is an RPM package management tool which allows you to easily
111perform package verification, installation (including system
13fd950e 112installation from scratch), upgrading, and removal.
0fa0dc36 113
13fd950e
JB
114Program can be used in batch (like apt-get from Debian's APT) or
115interactive mode. The interactive mode puts you into a readline
116interface with command line autocompletion and history, similar to the
117shell mode of Perl's CPAN.
8efee472 118
9fe14a3f 119%{?with_static:This version is statically linked.}
d94b28a6 120
9fe14a3f 121%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 122#'vim
1f84648f 123
9c03ea8f
ZU
124%description -l hu.UTF-8
125poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
126csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
127nulláról), frissítést és eltávolítást.
128
129A program használható parancssorból (mint a Debian apt-get programja)
130vagy interaktív módban. Az interaktív mód egy readline környezetet
131jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
132shell módjához.
133
134%{?with_static:Ez a verzió statikusan linkelt.}
135
136%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
137
caed9b36
JR
138%description -l pl.UTF-8
139poldek jest narzędziem linii poleceń służącym do weryfikacji,
140instalacji (włączając instalację systemu od zera), aktualizacji i
141usuwania pakietów.
56e1ab51 142
caed9b36 143Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 144interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
145dopełnianiem komend i historią, podobny do trybu shell perlowego
146modułu CPAN.
8efee472 147
9fe14a3f 148%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 149
9fe14a3f 150%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 151
b25cb9a7 152%package libs
168acc54 153Summary: poldek libraries
9c03ea8f 154Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 155Summary(pl.UTF-8): Biblioteki poldka
168acc54 156Group: Libraries
b25cb9a7
JB
157
158%description libs
159poldek libraries.
160
9c03ea8f
ZU
161%description libs -l hu.UTF-8
162A poldek könyvtárai.
163
caed9b36 164%description libs -l pl.UTF-8
b25cb9a7
JB
165Biblioteki poldka.
166
167%package devel
168acc54 168Summary: Header files for poldek libraries
9c03ea8f 169Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 170Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 171Group: Development/Libraries
09d4c571 172Requires: %{name}-libs = %{version}-%{release}
b980560b 173Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
174
175%description devel
176Header files for poldek libraries.
177
9c03ea8f
ZU
178%description devel -l hu.UTF-8
179A poldek könyvtár fejlesztői fájljai.
180
caed9b36
JR
181%description devel -l pl.UTF-8
182Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
183
184%package static
168acc54 185Summary: poldek static libraries
9c03ea8f 186Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 187Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 188Group: Development/Libraries
09d4c571 189Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
190
191%description static
192poldek static libraries.
193
9c03ea8f
ZU
194%description static -l hu.UTF-8
195poldek statikus könyvtárak.
196
caed9b36 197%description static -l pl.UTF-8
b25cb9a7
JB
198Biblioteki statyczne poldka.
199
58c31de0
JB
200%package -n python-poldek
201Summary: Python modules for poldek
9c03ea8f 202Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 203Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
204Group: Libraries/Python
205Requires: %{name}-libs = %{version}-%{release}
340a1e21 206Requires: python-libs
58c31de0
JB
207
208%description -n python-poldek
209Python modules for poldek.
210
9c03ea8f
ZU
211%description -n python-poldek -l hu.UTF-8
212Python modulok poldek-hez.
213
caed9b36
JR
214%description -n python-poldek -l pl.UTF-8
215Moduły języka Python dla poldka.
58c31de0 216
03159b71 217%prep
a9c9446a 218%setup -q
85398bac 219%patch0 -p1
13aa6434 220%patch1 -p1
8dcb75fc 221
5e2c5cc3 222%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 223
0579f9b7
ER
224# cleanup backups after patching
225find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 226chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 227
b44549bf 228%build
5c81138a 229%{__gettextize}
bef9d2a3 230%{__libtoolize}
21a83253 231%{__aclocal} -I m4
d878a63c 232%{__autoheader}
21a83253
MM
233%{__autoconf}
234%{__automake}
f8e81a61 235cd tndb
313cd172 236%{__libtoolize}
5e2c5cc3
JB
237%{__aclocal}
238%{__autoheader}
239%{__autoconf}
240%{__automake}
f8e81a61 241cd ../trurlib
313cd172 242%{__libtoolize}
5e2c5cc3
JB
243%{__aclocal}
244%{__autoheader}
245%{__autoconf}
246%{__automake}
f8e81a61 247cd ..
b25cb9a7 248
3e975db6 249CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
1f84648f 250%configure \
b25cb9a7 251 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 252 %{!?with_imode:--disable-imode} \
dcdcebb7 253 --with-pkglibdir=%{_libexecdir} \
58c31de0
JB
254 --enable-nls \
255 %{?with_python:--with-python}
9fb594dc 256%{__make} -j1
a1f22296 257# --enable-trace
8efee472 258
b44549bf 259%install
260rm -rf $RPM_BUILD_ROOT
27edf30a 261install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
8efee472 262
9fb594dc 263%{__make} install -j1 \
c8f7d829 264 DESTDIR=$RPM_BUILD_ROOT
de1099c4 265
58c31de0 266%if %{with python}
9fb594dc 267%{__make} -C python -j1 install \
58c31de0
JB
268 DESTDIR=$RPM_BUILD_ROOT \
269 libdir=%{py_sitedir}
270%endif
271
5e2c5cc3 272%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 273
9639596f 274%ifarch i486 i686 ppc sparc alpha athlon
23ead09a 275 %define _ftp_arch %{_target_cpu}
36004ea3 276%endif
9639596f 277%ifarch %{x8664}
23ead09a
ER
278 %define _ftp_arch x86_64
279 %define _ftp_alt_arch i686
fabc4b40
JR
280 %define _ftp_alt2_arch x32
281%endif
282%ifarch x32
283 %define _ftp_arch x32
284 %define _ftp_alt_arch x86_64
285 %define _ftp_alt2_arch i686
36004ea3 286%endif
9639596f 287%ifarch i586
b614e8f7 288 %define _ftp_arch i486
58820d9b 289%endif
a49836bb 290%ifarch pentium2 pentium3 pentium4
23ead09a 291 %define _ftp_arch i686
36004ea3 292%endif
a49836bb 293%ifarch sparcv9 sparc64
23ead09a 294 %define _ftp_arch sparc
b614e8f7
JR
295 %define _ftp_arch %{_target_cpu}
296 %ifarch sparc64
23ead09a 297 %define _ftp_alt_arch sparcv9
23ead09a 298 %endif
652b5bc5 299%endif
32697bd0 300
b614e8f7
JR
301%define pld_conf %{SOURCE1}
302%define pld_debuginfo_conf %{SOURCE8}
303%define pld_archive_conf %{SOURCE11}
7c0e4fc5 304
fabc4b40 305%ifarch %{x8664} x32
b614e8f7 306 %define pld_multilib_conf %{SOURCE2}
fabc4b40 307 %define pld_multilib2_conf %{SOURCE2}
b614e8f7 308%endif
7c0e4fc5 309
b614e8f7
JR
310# aidath
311%ifarch sparcv9 sparc64
312 %define pld_conf %{SOURCE9}
313 %undefine pld_archive_conf
314%endif
315%ifarch sparc64
316 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 317%endif
23ead09a 318
c88cf671 319%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 320
7c0e4fc5 321%if 0%{?pld_multilib_conf:1}
c88cf671 322 %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
7c0e4fc5
ER
323%endif
324
fabc4b40
JR
325%if 0%{?pld_multilib2_conf:1}
326 %{__sed} 's|%%ARCH%%|%{_ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib2.conf
327%endif
328
7c0e4fc5 329%if 0%{?pld_debuginfo_conf:1}
c88cf671 330%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 331%endif
b25cb9a7 332
8db66c11 333%if 0%{?pld_archive_conf:1}
c88cf671 334%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
335%endif
336
7e5296f4 337# Always install snapshot configs
c88cf671 338%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5 339 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 340%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5 341 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
fabc4b40 342%ifarch %{x8664} x32
c88cf671 343 %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
a584c5c5 344 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
fabc4b40
JR
345 %{__sed} -e 's|%%ARCH%%|%{_ftp_alt2_arch}|g' \
346 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib2.conf
a584c5c5 347%endif
7e5296f4
JR
348
349%if %{with snap}
c88cf671 350%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
7e5296f4 351%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
a584c5c5 352%else
7e5296f4 353%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 354%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
355%endif
356
27edf30a 357cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 358
9e6ff4ef 359%if %{with imode}
360# add desktop file and icon
361install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
362cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
363cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 364%endif
365
b43abde7 366# sources we don't package
5e2c5cc3 367%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 368# include them in %doc
c88cf671 369%{__rm} -rf configs
b25cb9a7 370cp -a conf configs
c88cf671 371%{__rm} -f configs/Makefile*
b25cb9a7 372
62e80071 373%if %{with python}
58c31de0 374%py_postclean
5e2c5cc3 375%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 376%endif
58c31de0 377
b25cb9a7 378%find_lang %{name}
f373d903 379
b44549bf 380%clean
381rm -rf $RPM_BUILD_ROOT
382
daf0e7ce
ER
383%post
384[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
385if [ "$1" = "1" ]; then
386 # remove ignore = vserver-packages inside vserver on first install
387 {
388 while read f ctx; do
389 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
390 done </proc/self/status
391 } 2>/dev/null
392 if [ -z "$ctx" -o "$ctx" = "0" ]; then
393 VSERVER=no
394 else
395 VSERVER=yes
396 fi
397 if [ "$VSERVER" = "yes" ]; then
398 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
399 fi
400fi
b25cb9a7 401
3896c8b1
ER
402%postun -p /sbin/postshell
403-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
404
405%post libs -p /sbin/ldconfig
406%postun libs -p /sbin/ldconfig
407
b25cb9a7
JB
408%triggerpostun -- poldek < 0.19.0-1.20050613.22.0
409if [ -f /etc/poldek.conf.rpmsave ]; then
410 awk '/^source/ {
411 name = $3;
412 path = $4;
413 auto = "yes";
414 autoup = "yes";
415 type = "pdir";
f154dd55 416 pri = "";
b25cb9a7
JB
417
418 if (sub(",noauto", "", name)) {
419 auto = "no";
420 }
421
f154dd55
ER
422 # process pri=\d+
423 if (match(name, /,pri=[0-9]+/)) {
424 pri = substr(name, RSTART + 5, RLENGTH - 5);
425 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
426 }
427
b25cb9a7
JB
428 # skip ac sources. already in new config.
429 if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
430 print "";
431 print "[source]";
432 print "name = " name;
433 print "type = " type;
434 print "path = " path;
435 print "auto = " auto;
436 print "autoup = " autoup;
f154dd55
ER
437 if (pri) {
438 print "pri = " pri;
439 }
b25cb9a7
JB
440 }
441
442 }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
19cae196 443 echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
b25cb9a7
JB
444
445 # copy hold=
446 hold=$(grep ^hold /etc/poldek.conf.rpmsave)
447 if [ "$hold" ]; then
c88cf671 448 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
b25cb9a7
JB
449 fi
450fi
451
b43abde7
ER
452%triggerpostun -- poldek < 0.30-0.20080225.00.1
453if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
454 %{__sed} -i -e '/^%%include source.conf/{
455 a
456 a# /etc/poldek/repos.d/*.conf
457 a%%includedir repos.d
458 }' %{_sysconfdir}/%{name}/poldek.conf
459fi
460
461%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
462%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
463
464if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
465 cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
478b6a69 466 cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
467fi
468
469%ifarch %{x8664}
470if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
471 cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
478b6a69 472 cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
473fi
474%endif
475
767366b0 476%files -f %{name}.lang
b44549bf 477%defattr(644,root,root,755)
a9c9446a 478%doc ChangeLog README* NEWS TODO configs
b25cb9a7 479%dir %{_sysconfdir}/%{name}
08335479 480%dir %{_sysconfdir}/%{name}/repos.d
168acc54 481%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 482%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
483%attr(755,root,root) %{_bindir}/ipoldek
484%attr(755,root,root) %{_bindir}/poldek
485%attr(755,root,root) %{_bindir}/rpmvercmp
dcdcebb7
ER
486%dir %{_libexecdir}
487%attr(755,root,root) %{_libexecdir}/*
5e2c5cc3 488%{_mandir}/man1/%{name}*.1*
d8826405 489%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 490%{_infodir}/poldek.info*
9e6ff4ef 491%if %{with imode}
492%{_desktopdir}/%{name}.desktop
493%{_pixmapsdir}/%{name}.png
494%endif
27edf30a 495%dir /var/cache/%{name}
b25cb9a7 496
b43abde7 497%if %{without static}
b25cb9a7
JB
498%files libs
499%defattr(644,root,root,755)
d8aeff9a
MB
500%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
501%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
502%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
503%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
504%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
505%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
506%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
507%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
508%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
509%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
510%endif
511
512%files devel
513%defattr(644,root,root,755)
5e2c5cc3
JB
514%if %{without static}
515%attr(755,root,root) %{_libdir}/libpoclidek.so
516%attr(755,root,root) %{_libdir}/libpoldek.so
517%attr(755,root,root) %{_libdir}/libtndb.so
518%attr(755,root,root) %{_libdir}/libtrurl.so
519%attr(755,root,root) %{_libdir}/libvfile.so
520%endif
521%{_libdir}/libpoclidek.la
522%{_libdir}/libpoldek.la
523%{_libdir}/libtndb.la
524%{_libdir}/libtrurl.la
525%{_libdir}/libvfile.la
526%{_includedir}/poldek
527%{_includedir}/tndb
528%{_includedir}/trurl
529%{_includedir}/vfile
530%{_pkgconfigdir}/tndb.pc
c9a1a81d 531%{_pkgconfigdir}/trurlib.pc
b25cb9a7
JB
532
533%files static
534%defattr(644,root,root,755)
5e2c5cc3
JB
535%{_libdir}/libtndb.a
536%{_libdir}/libtrurl.a
58c31de0
JB
537
538%if %{with python}
539%files -n python-poldek
540%defattr(644,root,root,755)
541%attr(755,root,root) %{py_sitedir}/_poldekmod.so
542%{py_sitescriptdir}/poldek.py[co]
543%{py_sitescriptdir}/poldekmod.py[co]
544%endif
This page took 0.283317 seconds and 4 git commands to generate.