]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
use rpm4/db4.7 instead of rpm5 bcond for th
[packages/poldek.git] / poldek.spec
CommitLineData
7638abfc 1#
de1099c4 2# Conditional build:
9fe14a3f 3%bcond_with static # don't use shared libraries
4%bcond_without imode # don't build interactive mode
58c31de0 5%bcond_without python # don't build python bindings
cf6c3a30 6%bcond_with snap # install configs for official Th snapshot
6e185c37 7%bcond_with db60 # DB 6.0 instead of 5.2
5fda028a 8%bcond_without rpm4 # use rpm4/db4.7 instead of rpm5
7000d724 9
e1015166 10# current snapshot name
42c61fde 11%define SNAP 2014
a584c5c5 12
373c6f03 13# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
6e185c37
JB
14# NOTE: poldek links with "system db" (-ldb) anyway if it exists
15%if %{with db60}
16%define db_pkg db6.0
17%define ver_db 6.0
18%define ver_db_rel 1
19%else
ff4e68af 20%define db_pkg db5.2
376a705c 21%define ver_db 5.2
19e679c6 22%define ver_db_rel 3
6e185c37 23%endif
5fda028a
ER
24
25%if %{with rpm4}
26%define ver_db 4.7.25
27%define ver_db_rel 1
28%define ver_rpm 4.5-49
29%else
a17726b5 30%define ver_rpm 5.4.10
5fda028a 31%endif
7000d724 32
5eb97c67 33%define rel 2
b44549bf 34Summary: RPM packages management helper tool
9c03ea8f 35Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 36Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 37Name: poldek
e8dadd74 38Version: 0.30.1
9c1c2b52 39Release: %{rel}%{?with_snap:.%{SNAP}}
9f931ada 40License: GPL v2
8efee472 41Group: Applications/System
85398bac 42#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
e5009a66 43Source0: http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
e8dadd74 44# Source0-md5: e569c8454df0932df53b09cee9998927
911a8560 45Source1: %{name}.conf
b25cb9a7 46Source2: %{name}-multilib.conf
2ccd5d66 47Source5: %{name}-aliases.conf
48Source6: %{name}.desktop
49Source7: %{name}.png
171e07f6 50Source8: %{name}-debuginfo.conf
652b5bc5 51Source9: %{name}-aidath.conf
52Source10: %{name}-multilib-aidath.conf
8db66c11 53Source11: %{name}-archive.conf
a584c5c5
JR
54Source100: %{name}-snap.conf
55Source101: %{name}-multilib-snap.conf
56Source102: %{name}-debuginfo-snap.conf
e5009a66 57Patch0: %{name}-size-type.patch
e8dadd74 58Patch1: %{name}-config.patch
39ca2371 59URL: http://poldek.pld-linux.org/
340a1e21 60BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
a4268952 61BuildRequires: autoconf
4d0dcbcf 62BuildRequires: automake >= 1:1.11
373c6f03 63BuildRequires: bzip2-devel
065b86e0 64BuildRequires: check-devel
1d67e563 65BuildRequires: docbook-dtd412-xml
22329ccf 66BuildRequires: gettext-tools
b25cb9a7
JB
67BuildRequires: libtool
68BuildRequires: libxml2-devel
fc37ede0 69BuildRequires: neon-devel
cbc6f56b 70BuildRequires: openssl-devel >= 0.9.7d
13fd950e 71BuildRequires: pcre-devel
b3ea4b51 72BuildRequires: pkgconfig
13fd950e 73BuildRequires: popt-devel
58c31de0 74%{?with_python:BuildRequires: python-devel}
b25cb9a7 75BuildRequires: readline-devel >= 5.0
373c6f03 76BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 77%{?with_python:BuildRequires: rpm-pythonprov}
65a99b8b 78BuildRequires: swig-python
340a1e21 79BuildRequires: tar >= 1:1.22
77cfda6e 80BuildRequires: xmlto
340a1e21 81BuildRequires: xz
96475e5e 82BuildRequires: zlib-devel
373c6f03 83%if %{with static}
ff4e68af 84BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
340a1e21 85BuildRequires: bzip2-static
2fac0b02 86BuildRequires: glibc-static
b25cb9a7 87BuildRequires: libxml2-static
373c6f03
JB
88BuildRequires: ncurses-static
89BuildRequires: openssl-static
90BuildRequires: pcre-static
91BuildRequires: popt-static
92BuildRequires: readline-static
93BuildRequires: rpm-static
94BuildRequires: zlib-static
373c6f03 95%endif
b25cb9a7 96Requires(triggerpostun): awk
168acc54 97Requires(triggerpostun): sed >= 4.0
ff4e68af 98Requires: %{db_pkg} >= %{ver_db}-%{ver_db_rel}
340a1e21 99Requires: %{name}-libs = %{version}-%{release}
373c6f03 100Requires: rpm >= %{ver_rpm}
530c8c41 101Requires: rpm-db-ver = %{ver_db}
5fda028a 102Requires: rpm-lib >= %{ver_rpm}
e202a52a
ER
103# vf* scripts use sed
104Requires: sed
b44549bf 105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
dcdcebb7
ER
107%define _libexecdir %{_prefix}/lib/%{name}
108
b44549bf 109%description
0fa0dc36 110poldek is an RPM package management tool which allows you to easily
111perform package verification, installation (including system
13fd950e 112installation from scratch), upgrading, and removal.
0fa0dc36 113
13fd950e
JB
114Program can be used in batch (like apt-get from Debian's APT) or
115interactive mode. The interactive mode puts you into a readline
116interface with command line autocompletion and history, similar to the
117shell mode of Perl's CPAN.
8efee472 118
9fe14a3f 119%{?with_static:This version is statically linked.}
d94b28a6 120
9fe14a3f 121%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 122#'vim
1f84648f 123
9c03ea8f
ZU
124%description -l hu.UTF-8
125poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
126csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
127nulláról), frissítést és eltávolítást.
128
129A program használható parancssorból (mint a Debian apt-get programja)
130vagy interaktív módban. Az interaktív mód egy readline környezetet
131jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
132shell módjához.
133
134%{?with_static:Ez a verzió statikusan linkelt.}
135
136%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
137
caed9b36
JR
138%description -l pl.UTF-8
139poldek jest narzędziem linii poleceń służącym do weryfikacji,
140instalacji (włączając instalację systemu od zera), aktualizacji i
141usuwania pakietów.
56e1ab51 142
caed9b36 143Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 144interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
145dopełnianiem komend i historią, podobny do trybu shell perlowego
146modułu CPAN.
8efee472 147
9fe14a3f 148%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 149
9fe14a3f 150%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 151
b25cb9a7 152%package libs
168acc54 153Summary: poldek libraries
9c03ea8f 154Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 155Summary(pl.UTF-8): Biblioteki poldka
168acc54 156Group: Libraries
b25cb9a7
JB
157
158%description libs
159poldek libraries.
160
9c03ea8f
ZU
161%description libs -l hu.UTF-8
162A poldek könyvtárai.
163
caed9b36 164%description libs -l pl.UTF-8
b25cb9a7
JB
165Biblioteki poldka.
166
167%package devel
168acc54 168Summary: Header files for poldek libraries
9c03ea8f 169Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 170Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 171Group: Development/Libraries
09d4c571 172Requires: %{name}-libs = %{version}-%{release}
b980560b 173Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
174
175%description devel
176Header files for poldek libraries.
177
9c03ea8f
ZU
178%description devel -l hu.UTF-8
179A poldek könyvtár fejlesztői fájljai.
180
caed9b36
JR
181%description devel -l pl.UTF-8
182Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
183
184%package static
168acc54 185Summary: poldek static libraries
9c03ea8f 186Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 187Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 188Group: Development/Libraries
09d4c571 189Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
190
191%description static
192poldek static libraries.
193
9c03ea8f
ZU
194%description static -l hu.UTF-8
195poldek statikus könyvtárak.
196
caed9b36 197%description static -l pl.UTF-8
b25cb9a7
JB
198Biblioteki statyczne poldka.
199
58c31de0
JB
200%package -n python-poldek
201Summary: Python modules for poldek
9c03ea8f 202Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 203Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
204Group: Libraries/Python
205Requires: %{name}-libs = %{version}-%{release}
340a1e21 206Requires: python-libs
58c31de0
JB
207
208%description -n python-poldek
209Python modules for poldek.
210
9c03ea8f
ZU
211%description -n python-poldek -l hu.UTF-8
212Python modulok poldek-hez.
213
caed9b36
JR
214%description -n python-poldek -l pl.UTF-8
215Moduły języka Python dla poldka.
58c31de0 216
03159b71 217%prep
a9c9446a 218%setup -q
85398bac 219%patch0 -p1
13aa6434 220%patch1 -p1
8dcb75fc 221
5e2c5cc3 222%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 223
0579f9b7
ER
224# cleanup backups after patching
225find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 226chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 227
b44549bf 228%build
5c81138a 229%{__gettextize}
bef9d2a3 230%{__libtoolize}
21a83253 231%{__aclocal} -I m4
d878a63c 232%{__autoheader}
21a83253
MM
233%{__autoconf}
234%{__automake}
f8e81a61 235cd tndb
313cd172 236%{__libtoolize}
5e2c5cc3
JB
237%{__aclocal}
238%{__autoheader}
239%{__autoconf}
240%{__automake}
f8e81a61 241cd ../trurlib
313cd172 242%{__libtoolize}
5e2c5cc3
JB
243%{__aclocal}
244%{__autoheader}
245%{__autoconf}
246%{__automake}
f8e81a61 247cd ..
b25cb9a7 248
3e975db6 249CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
1f84648f 250%configure \
b25cb9a7 251 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 252 %{!?with_imode:--disable-imode} \
dcdcebb7 253 --with-pkglibdir=%{_libexecdir} \
58c31de0
JB
254 --enable-nls \
255 %{?with_python:--with-python}
9fb594dc 256%{__make} -j1
a1f22296 257# --enable-trace
8efee472 258
b44549bf 259%install
260rm -rf $RPM_BUILD_ROOT
27edf30a 261install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
8efee472 262
9fb594dc 263%{__make} install -j1 \
c8f7d829 264 DESTDIR=$RPM_BUILD_ROOT
de1099c4 265
58c31de0 266%if %{with python}
9fb594dc 267%{__make} -C python -j1 install \
58c31de0
JB
268 DESTDIR=$RPM_BUILD_ROOT \
269 libdir=%{py_sitedir}
270%endif
271
5e2c5cc3 272%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 273
9639596f 274%ifarch i486 i686 ppc sparc alpha athlon
23ead09a 275 %define _ftp_arch %{_target_cpu}
36004ea3 276%endif
9639596f 277%ifarch %{x8664}
23ead09a
ER
278 %define _ftp_arch x86_64
279 %define _ftp_alt_arch i686
36004ea3 280%endif
9639596f 281%ifarch i586
b614e8f7 282 %define _ftp_arch i486
58820d9b 283%endif
a49836bb 284%ifarch pentium2 pentium3 pentium4
23ead09a 285 %define _ftp_arch i686
36004ea3 286%endif
a49836bb 287%ifarch sparcv9 sparc64
23ead09a 288 %define _ftp_arch sparc
b614e8f7
JR
289 %define _ftp_arch %{_target_cpu}
290 %ifarch sparc64
23ead09a 291 %define _ftp_alt_arch sparcv9
23ead09a 292 %endif
652b5bc5 293%endif
32697bd0 294
b614e8f7
JR
295%define pld_conf %{SOURCE1}
296%define pld_debuginfo_conf %{SOURCE8}
297%define pld_archive_conf %{SOURCE11}
7c0e4fc5 298
b614e8f7
JR
299%ifarch %{x8664}
300 %define pld_multilib_conf %{SOURCE2}
301%endif
7c0e4fc5 302
b614e8f7
JR
303# aidath
304%ifarch sparcv9 sparc64
305 %define pld_conf %{SOURCE9}
306 %undefine pld_archive_conf
307%endif
308%ifarch sparc64
309 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 310%endif
23ead09a 311
c88cf671 312%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 313
7c0e4fc5 314%if 0%{?pld_multilib_conf:1}
c88cf671 315 %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
7c0e4fc5
ER
316%endif
317
318%if 0%{?pld_debuginfo_conf:1}
c88cf671 319%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 320%endif
b25cb9a7 321
8db66c11 322%if 0%{?pld_archive_conf:1}
c88cf671 323%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
324%endif
325
7e5296f4 326# Always install snapshot configs
c88cf671 327%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5 328 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 329%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5
JR
330 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
331%ifarch %{x8664}
c88cf671 332 %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
a584c5c5
JR
333 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
334%endif
7e5296f4
JR
335
336%if %{with snap}
c88cf671 337%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
7e5296f4 338%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
a584c5c5 339%else
7e5296f4 340%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 341%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
342%endif
343
27edf30a 344cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 345
9e6ff4ef 346%if %{with imode}
347# add desktop file and icon
348install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
349cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
350cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 351%endif
352
b43abde7 353# sources we don't package
5e2c5cc3 354%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 355# include them in %doc
c88cf671 356%{__rm} -rf configs
b25cb9a7 357cp -a conf configs
c88cf671 358%{__rm} -f configs/Makefile*
b25cb9a7 359
62e80071 360%if %{with python}
58c31de0 361%py_postclean
5e2c5cc3 362%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 363%endif
58c31de0 364
b25cb9a7 365%find_lang %{name}
f373d903 366
b44549bf 367%clean
368rm -rf $RPM_BUILD_ROOT
369
daf0e7ce
ER
370%post
371[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
372if [ "$1" = "1" ]; then
373 # remove ignore = vserver-packages inside vserver on first install
374 {
375 while read f ctx; do
376 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
377 done </proc/self/status
378 } 2>/dev/null
379 if [ -z "$ctx" -o "$ctx" = "0" ]; then
380 VSERVER=no
381 else
382 VSERVER=yes
383 fi
384 if [ "$VSERVER" = "yes" ]; then
385 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
386 fi
387fi
b25cb9a7 388
3896c8b1
ER
389%postun -p /sbin/postshell
390-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
391
392%post libs -p /sbin/ldconfig
393%postun libs -p /sbin/ldconfig
394
b25cb9a7
JB
395%triggerpostun -- poldek < 0.19.0-1.20050613.22.0
396if [ -f /etc/poldek.conf.rpmsave ]; then
397 awk '/^source/ {
398 name = $3;
399 path = $4;
400 auto = "yes";
401 autoup = "yes";
402 type = "pdir";
f154dd55 403 pri = "";
b25cb9a7
JB
404
405 if (sub(",noauto", "", name)) {
406 auto = "no";
407 }
408
f154dd55
ER
409 # process pri=\d+
410 if (match(name, /,pri=[0-9]+/)) {
411 pri = substr(name, RSTART + 5, RLENGTH - 5);
412 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
413 }
414
b25cb9a7
JB
415 # skip ac sources. already in new config.
416 if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
417 print "";
418 print "[source]";
419 print "name = " name;
420 print "type = " type;
421 print "path = " path;
422 print "auto = " auto;
423 print "autoup = " autoup;
f154dd55
ER
424 if (pri) {
425 print "pri = " pri;
426 }
b25cb9a7
JB
427 }
428
429 }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
19cae196 430 echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
b25cb9a7
JB
431
432 # copy hold=
433 hold=$(grep ^hold /etc/poldek.conf.rpmsave)
434 if [ "$hold" ]; then
c88cf671 435 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
b25cb9a7
JB
436 fi
437fi
438
b43abde7
ER
439%triggerpostun -- poldek < 0.30-0.20080225.00.1
440if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
441 %{__sed} -i -e '/^%%include source.conf/{
442 a
443 a# /etc/poldek/repos.d/*.conf
444 a%%includedir repos.d
445 }' %{_sysconfdir}/%{name}/poldek.conf
446fi
447
448%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
449%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
450
451if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
452 cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
478b6a69 453 cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
454fi
455
456%ifarch %{x8664}
457if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
458 cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
478b6a69 459 cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
460fi
461%endif
462
767366b0 463%files -f %{name}.lang
b44549bf 464%defattr(644,root,root,755)
a9c9446a 465%doc ChangeLog README* NEWS TODO configs
b25cb9a7 466%dir %{_sysconfdir}/%{name}
08335479 467%dir %{_sysconfdir}/%{name}/repos.d
168acc54 468%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 469%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
470%attr(755,root,root) %{_bindir}/ipoldek
471%attr(755,root,root) %{_bindir}/poldek
472%attr(755,root,root) %{_bindir}/rpmvercmp
dcdcebb7
ER
473%dir %{_libexecdir}
474%attr(755,root,root) %{_libexecdir}/*
5e2c5cc3 475%{_mandir}/man1/%{name}*.1*
d8826405 476%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 477%{_infodir}/poldek.info*
9e6ff4ef 478%if %{with imode}
479%{_desktopdir}/%{name}.desktop
480%{_pixmapsdir}/%{name}.png
481%endif
27edf30a 482%dir /var/cache/%{name}
b25cb9a7 483
b43abde7 484%if %{without static}
b25cb9a7
JB
485%files libs
486%defattr(644,root,root,755)
d8aeff9a
MB
487%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
488%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
489%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
490%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
491%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
492%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
493%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
494%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
495%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
496%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
497%endif
498
499%files devel
500%defattr(644,root,root,755)
5e2c5cc3
JB
501%if %{without static}
502%attr(755,root,root) %{_libdir}/libpoclidek.so
503%attr(755,root,root) %{_libdir}/libpoldek.so
504%attr(755,root,root) %{_libdir}/libtndb.so
505%attr(755,root,root) %{_libdir}/libtrurl.so
506%attr(755,root,root) %{_libdir}/libvfile.so
507%endif
508%{_libdir}/libpoclidek.la
509%{_libdir}/libpoldek.la
510%{_libdir}/libtndb.la
511%{_libdir}/libtrurl.la
512%{_libdir}/libvfile.la
513%{_includedir}/poldek
514%{_includedir}/tndb
515%{_includedir}/trurl
516%{_includedir}/vfile
517%{_pkgconfigdir}/tndb.pc
c9a1a81d 518%{_pkgconfigdir}/trurlib.pc
b25cb9a7
JB
519
520%files static
521%defattr(644,root,root,755)
5e2c5cc3
JB
522%{_libdir}/libtndb.a
523%{_libdir}/libtrurl.a
58c31de0
JB
524
525%if %{with python}
526%files -n python-poldek
527%defattr(644,root,root,755)
528%attr(755,root,root) %{py_sitedir}/_poldekmod.so
529%{py_sitescriptdir}/poldek.py[co]
530%{py_sitescriptdir}/poldekmod.py[co]
531%endif
This page took 0.14983 seconds and 4 git commands to generate.