]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- add ls command formatting fix patch from lp#1031767
[packages/poldek.git] / poldek.spec
CommitLineData
7638abfc 1#
de1099c4 2# Conditional build:
9fe14a3f 3%bcond_with static # don't use shared libraries
4%bcond_without imode # don't build interactive mode
58c31de0 5%bcond_without python # don't build python bindings
cf6c3a30 6%bcond_with snap # install configs for official Th snapshot
7000d724 7
a584c5c5
JR
8%if %{with snap}
9%define SNAP 2012
10%endif
11
373c6f03 12# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
530c8c41 13%define ver_db 4.7.25
473ce98d 14%define ver_db_rel 1
dda7b73c 15%define ver_rpm 4.5-49
7000d724 16
810df317 17%define snap rc5
b8e2dc6d 18%define rel 12
b44549bf 19Summary: RPM packages management helper tool
9c03ea8f 20Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 21Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 22Name: poldek
24ad8b8d 23Version: 0.30
d5caab1d 24Release: 1.%{snap}.%{rel}
9f931ada 25License: GPL v2
8efee472 26Group: Applications/System
85398bac 27#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
e46f6b38 28Source0: http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
810df317 29# Source0-md5: ab89926c28cfb6b7d72497fc37c16ac4
911a8560 30Source1: %{name}.conf
b25cb9a7 31Source2: %{name}-multilib.conf
2ccd5d66 32Source5: %{name}-aliases.conf
33Source6: %{name}.desktop
34Source7: %{name}.png
171e07f6 35Source8: %{name}-debuginfo.conf
652b5bc5 36Source9: %{name}-aidath.conf
37Source10: %{name}-multilib-aidath.conf
8db66c11 38Source11: %{name}-archive.conf
a584c5c5
JR
39Source100: %{name}-snap.conf
40Source101: %{name}-multilib-snap.conf
41Source102: %{name}-debuginfo-snap.conf
85398bac
MB
42Patch0: %{name}-vserver-packages.patch
43Patch1: %{name}-config.patch
a9c9446a 44Patch2: %{name}-size-type.patch
f8e81a61 45Patch3: %{name}-Os-fail-workaround.patch
f4205795 46Patch4: %{name}-git.patch
5e2c5cc3 47Patch5: %{name}-am.patch
0295a82d
ER
48Patch6: https://bugs.launchpad.net/poldek/+bug/1031767/+attachment/3252805/+files/%{name}-ls-space-lp1031767.patch
49# Patch6-md5: 9ba0f7abdb2ba1051e1a396f9daec606
39ca2371 50URL: http://poldek.pld-linux.org/
a4268952 51BuildRequires: autoconf
b25cb9a7 52BuildRequires: automake
373c6f03 53BuildRequires: bzip2-devel
065b86e0 54BuildRequires: check-devel
530c8c41 55BuildRequires: db-devel >= %{ver_db}-%{ver_db_rel}
1d67e563 56BuildRequires: docbook-dtd412-xml
f77a8b4c 57BuildRequires: gettext-devel
b25cb9a7
JB
58BuildRequires: libtool
59BuildRequires: libxml2-devel
fc37ede0 60BuildRequires: neon-devel
cbc6f56b 61BuildRequires: openssl-devel >= 0.9.7d
13fd950e 62BuildRequires: pcre-devel
b3ea4b51 63BuildRequires: pkgconfig
13fd950e 64BuildRequires: popt-devel
58c31de0 65%{?with_python:BuildRequires: python-devel}
b25cb9a7 66BuildRequires: readline-devel >= 5.0
373c6f03 67BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 68%{?with_python:BuildRequires: rpm-pythonprov}
65a99b8b 69BuildRequires: swig-python
77cfda6e 70BuildRequires: xmlto
96475e5e 71BuildRequires: zlib-devel
373c6f03
JB
72%if %{with static}
73BuildRequires: bzip2-static
530c8c41 74BuildRequires: db-static >= %{ver_db}-%{ver_db_rel}
2fac0b02 75BuildRequires: glibc-static
acb26797 76BuildRequires: libselinux-static
b25cb9a7 77BuildRequires: libxml2-static
373c6f03
JB
78BuildRequires: ncurses-static
79BuildRequires: openssl-static
80BuildRequires: pcre-static
81BuildRequires: popt-static
82BuildRequires: readline-static
83BuildRequires: rpm-static
84BuildRequires: zlib-static
373c6f03 85%endif
b25cb9a7 86Requires(triggerpostun): awk
168acc54 87Requires(triggerpostun): sed >= 4.0
09d4c571 88Requires: %{name}-libs = %{version}-%{release}
530c8c41 89Requires: db >= %{ver_db}-%{ver_db_rel}
373c6f03 90Requires: rpm >= %{ver_rpm}
530c8c41 91Requires: rpm-db-ver = %{ver_db}
78b0cd64 92Requires: rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
e202a52a
ER
93# vf* scripts use sed
94Requires: sed
b44549bf 95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97%description
0fa0dc36 98poldek is an RPM package management tool which allows you to easily
99perform package verification, installation (including system
13fd950e 100installation from scratch), upgrading, and removal.
0fa0dc36 101
13fd950e
JB
102Program can be used in batch (like apt-get from Debian's APT) or
103interactive mode. The interactive mode puts you into a readline
104interface with command line autocompletion and history, similar to the
105shell mode of Perl's CPAN.
8efee472 106
9fe14a3f 107%{?with_static:This version is statically linked.}
d94b28a6 108
9fe14a3f 109%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 110#'vim
1f84648f 111
9c03ea8f
ZU
112%description -l hu.UTF-8
113poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
114csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
115nulláról), frissítést és eltávolítást.
116
117A program használható parancssorból (mint a Debian apt-get programja)
118vagy interaktív módban. Az interaktív mód egy readline környezetet
119jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
120shell módjához.
121
122%{?with_static:Ez a verzió statikusan linkelt.}
123
124%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
125
caed9b36
JR
126%description -l pl.UTF-8
127poldek jest narzędziem linii poleceń służącym do weryfikacji,
128instalacji (włączając instalację systemu od zera), aktualizacji i
129usuwania pakietów.
56e1ab51 130
caed9b36 131Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 132interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
133dopełnianiem komend i historią, podobny do trybu shell perlowego
134modułu CPAN.
8efee472 135
9fe14a3f 136%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 137
9fe14a3f 138%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 139
b25cb9a7 140%package libs
168acc54 141Summary: poldek libraries
9c03ea8f 142Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 143Summary(pl.UTF-8): Biblioteki poldka
168acc54 144Group: Libraries
b25cb9a7
JB
145
146%description libs
147poldek libraries.
148
9c03ea8f
ZU
149%description libs -l hu.UTF-8
150A poldek könyvtárai.
151
caed9b36 152%description libs -l pl.UTF-8
b25cb9a7
JB
153Biblioteki poldka.
154
155%package devel
168acc54 156Summary: Header files for poldek libraries
9c03ea8f 157Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 158Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 159Group: Development/Libraries
09d4c571 160Requires: %{name}-libs = %{version}-%{release}
b980560b 161Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
162
163%description devel
164Header files for poldek libraries.
165
9c03ea8f
ZU
166%description devel -l hu.UTF-8
167A poldek könyvtár fejlesztői fájljai.
168
caed9b36
JR
169%description devel -l pl.UTF-8
170Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
171
172%package static
168acc54 173Summary: poldek static libraries
9c03ea8f 174Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 175Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 176Group: Development/Libraries
09d4c571 177Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
178
179%description static
180poldek static libraries.
181
9c03ea8f
ZU
182%description static -l hu.UTF-8
183poldek statikus könyvtárak.
184
caed9b36 185%description static -l pl.UTF-8
b25cb9a7
JB
186Biblioteki statyczne poldka.
187
58c31de0
JB
188%package -n python-poldek
189Summary: Python modules for poldek
9c03ea8f 190Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 191Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
192Group: Libraries/Python
193Requires: %{name}-libs = %{version}-%{release}
194%pyrequires_eq python-libs
195
196%description -n python-poldek
197Python modules for poldek.
198
9c03ea8f
ZU
199%description -n python-poldek -l hu.UTF-8
200Python modulok poldek-hez.
201
caed9b36
JR
202%description -n python-poldek -l pl.UTF-8
203Moduły języka Python dla poldka.
58c31de0 204
03159b71 205%prep
a9c9446a 206%setup -q
85398bac 207%patch0 -p1
13aa6434
AM
208%patch1 -p1
209%patch2 -p1
f8e81a61 210%patch3 -p1
e790f566 211%patch4 -p1
5e2c5cc3 212%patch5 -p1
0295a82d 213%patch6 -p1
8dcb75fc 214
5e2c5cc3 215%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 216
0579f9b7
ER
217# cleanup backups after patching
218find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 219chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 220
b44549bf 221%build
bef9d2a3 222%{__libtoolize}
21a83253 223%{__aclocal} -I m4
d878a63c 224%{__autoheader}
21a83253
MM
225%{__autoconf}
226%{__automake}
f8e81a61 227cd tndb
313cd172 228%{__libtoolize}
5e2c5cc3
JB
229%{__aclocal}
230%{__autoheader}
231%{__autoconf}
232%{__automake}
f8e81a61 233cd ../trurlib
313cd172 234%{__libtoolize}
5e2c5cc3
JB
235%{__aclocal}
236%{__autoheader}
237%{__autoconf}
238%{__automake}
f8e81a61 239cd ..
b25cb9a7 240
5e2c5cc3 241CPPFLAGS="%{rpmcppflags} -std=gnu99"
1f84648f 242%configure \
b25cb9a7 243 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 244 %{!?with_imode:--disable-imode} \
58c31de0
JB
245 --enable-nls \
246 %{?with_python:--with-python}
9fb594dc 247%{__make} -j1
a1f22296 248# --enable-trace
8efee472 249
b44549bf 250%install
251rm -rf $RPM_BUILD_ROOT
27edf30a 252install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
8efee472 253
9fb594dc 254%{__make} install -j1 \
c8f7d829 255 DESTDIR=$RPM_BUILD_ROOT
de1099c4 256
58c31de0 257%if %{with python}
9fb594dc 258%{__make} -C python -j1 install \
58c31de0
JB
259 DESTDIR=$RPM_BUILD_ROOT \
260 libdir=%{py_sitedir}
261%endif
262
5e2c5cc3 263%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 264
9639596f 265%ifarch i486 i686 ppc sparc alpha athlon
23ead09a 266 %define _ftp_arch %{_target_cpu}
36004ea3 267%endif
9639596f 268%ifarch %{x8664}
23ead09a
ER
269 %define _ftp_arch x86_64
270 %define _ftp_alt_arch i686
36004ea3 271%endif
9639596f 272%ifarch i586
b614e8f7 273 %define _ftp_arch i486
58820d9b 274%endif
a49836bb 275%ifarch pentium2 pentium3 pentium4
23ead09a 276 %define _ftp_arch i686
36004ea3 277%endif
a49836bb 278%ifarch sparcv9 sparc64
23ead09a 279 %define _ftp_arch sparc
b614e8f7
JR
280 %define _ftp_arch %{_target_cpu}
281 %ifarch sparc64
23ead09a 282 %define _ftp_alt_arch sparcv9
23ead09a 283 %endif
652b5bc5 284%endif
32697bd0 285
b614e8f7
JR
286%define pld_conf %{SOURCE1}
287%define pld_debuginfo_conf %{SOURCE8}
288%define pld_archive_conf %{SOURCE11}
7c0e4fc5 289
b614e8f7
JR
290%ifarch %{x8664}
291 %define pld_multilib_conf %{SOURCE2}
292%endif
7c0e4fc5 293
b614e8f7
JR
294# aidath
295%ifarch sparcv9 sparc64
296 %define pld_conf %{SOURCE9}
297 %undefine pld_archive_conf
298%endif
299%ifarch sparc64
300 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 301%endif
23ead09a 302
c88cf671 303%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 304
7c0e4fc5 305%if 0%{?pld_multilib_conf:1}
c88cf671 306 %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
7c0e4fc5
ER
307%endif
308
309%if 0%{?pld_debuginfo_conf:1}
c88cf671 310%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 311%endif
b25cb9a7 312
8db66c11 313%if 0%{?pld_archive_conf:1}
c88cf671 314%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
315%endif
316
a584c5c5 317%if %{with snap}
c88cf671 318%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5 319 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 320%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5
JR
321 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
322%ifarch %{x8664}
c88cf671 323 %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
a584c5c5
JR
324 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
325%endif
c88cf671 326%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5 327%else
c88cf671 328%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
329%endif
330
27edf30a 331cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 332
9e6ff4ef 333%if %{with imode}
334# add desktop file and icon
335install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
336cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
337cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 338%endif
339
b43abde7 340# sources we don't package
5e2c5cc3 341%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 342# include them in %doc
c88cf671 343%{__rm} -rf configs
b25cb9a7 344cp -a conf configs
c88cf671 345%{__rm} -f configs/Makefile*
b25cb9a7 346
62e80071 347%if %{with python}
58c31de0 348%py_postclean
5e2c5cc3 349%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 350%endif
58c31de0 351
b25cb9a7 352%find_lang %{name}
f373d903 353
b44549bf 354%clean
355rm -rf $RPM_BUILD_ROOT
356
daf0e7ce
ER
357%post
358[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
359if [ "$1" = "1" ]; then
360 # remove ignore = vserver-packages inside vserver on first install
361 {
362 while read f ctx; do
363 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
364 done </proc/self/status
365 } 2>/dev/null
366 if [ -z "$ctx" -o "$ctx" = "0" ]; then
367 VSERVER=no
368 else
369 VSERVER=yes
370 fi
371 if [ "$VSERVER" = "yes" ]; then
372 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
373 fi
374fi
b25cb9a7 375
3896c8b1
ER
376%postun -p /sbin/postshell
377-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
378
379%post libs -p /sbin/ldconfig
380%postun libs -p /sbin/ldconfig
381
b25cb9a7
JB
382%triggerpostun -- poldek < 0.19.0-1.20050613.22.0
383if [ -f /etc/poldek.conf.rpmsave ]; then
384 awk '/^source/ {
385 name = $3;
386 path = $4;
387 auto = "yes";
388 autoup = "yes";
389 type = "pdir";
f154dd55 390 pri = "";
b25cb9a7
JB
391
392 if (sub(",noauto", "", name)) {
393 auto = "no";
394 }
395
f154dd55
ER
396 # process pri=\d+
397 if (match(name, /,pri=[0-9]+/)) {
398 pri = substr(name, RSTART + 5, RLENGTH - 5);
399 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
400 }
401
b25cb9a7
JB
402 # skip ac sources. already in new config.
403 if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
404 print "";
405 print "[source]";
406 print "name = " name;
407 print "type = " type;
408 print "path = " path;
409 print "auto = " auto;
410 print "autoup = " autoup;
f154dd55
ER
411 if (pri) {
412 print "pri = " pri;
413 }
b25cb9a7
JB
414 }
415
416 }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
19cae196 417 echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
b25cb9a7
JB
418
419 # copy hold=
420 hold=$(grep ^hold /etc/poldek.conf.rpmsave)
421 if [ "$hold" ]; then
c88cf671 422 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
b25cb9a7
JB
423 fi
424fi
425
b43abde7
ER
426%triggerpostun -- poldek < 0.30-0.20080225.00.1
427if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
428 %{__sed} -i -e '/^%%include source.conf/{
429 a
430 a# /etc/poldek/repos.d/*.conf
431 a%%includedir repos.d
432 }' %{_sysconfdir}/%{name}/poldek.conf
433fi
434
435%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
436%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
437
438if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
439 cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
478b6a69 440 cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
441fi
442
443%ifarch %{x8664}
444if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
445 cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
478b6a69 446 cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
447fi
448%endif
449
767366b0 450%files -f %{name}.lang
b44549bf 451%defattr(644,root,root,755)
a9c9446a 452%doc ChangeLog README* NEWS TODO configs
b25cb9a7 453%dir %{_sysconfdir}/%{name}
08335479 454%dir %{_sysconfdir}/%{name}/repos.d
168acc54 455%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 456%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
457%attr(755,root,root) %{_bindir}/ipoldek
458%attr(755,root,root) %{_bindir}/poldek
459%attr(755,root,root) %{_bindir}/rpmvercmp
b25cb9a7
JB
460%dir %{_libdir}/%{name}
461%attr(755,root,root) %{_libdir}/%{name}/*
5e2c5cc3 462%{_mandir}/man1/%{name}*.1*
d8826405 463%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 464%{_infodir}/poldek.info*
9e6ff4ef 465%if %{with imode}
466%{_desktopdir}/%{name}.desktop
467%{_pixmapsdir}/%{name}.png
468%endif
27edf30a 469%dir /var/cache/%{name}
b25cb9a7 470
b43abde7 471%if %{without static}
b25cb9a7
JB
472%files libs
473%defattr(644,root,root,755)
d8aeff9a
MB
474%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
475%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
476%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
477%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
478%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
479%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
480%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
481%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
482%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
483%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
484%endif
485
486%files devel
487%defattr(644,root,root,755)
5e2c5cc3
JB
488%if %{without static}
489%attr(755,root,root) %{_libdir}/libpoclidek.so
490%attr(755,root,root) %{_libdir}/libpoldek.so
491%attr(755,root,root) %{_libdir}/libtndb.so
492%attr(755,root,root) %{_libdir}/libtrurl.so
493%attr(755,root,root) %{_libdir}/libvfile.so
494%endif
495%{_libdir}/libpoclidek.la
496%{_libdir}/libpoldek.la
497%{_libdir}/libtndb.la
498%{_libdir}/libtrurl.la
499%{_libdir}/libvfile.la
500%{_includedir}/poldek
501%{_includedir}/tndb
502%{_includedir}/trurl
503%{_includedir}/vfile
504%{_pkgconfigdir}/tndb.pc
b25cb9a7
JB
505
506%files static
507%defattr(644,root,root,755)
5e2c5cc3
JB
508%{_libdir}/libtndb.a
509%{_libdir}/libtrurl.a
58c31de0
JB
510
511%if %{with python}
512%files -n python-poldek
513%defattr(644,root,root,755)
514%attr(755,root,root) %{py_sitedir}/_poldekmod.so
515%{py_sitescriptdir}/poldek.py[co]
516%{py_sitescriptdir}/poldekmod.py[co]
517%endif
This page took 0.15885 seconds and 4 git commands to generate.