]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- detected more bugs to do
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
ca0db386 3# - cpdf.so needs -lgd
4a3031fc
JB
4# - memleak detected (even with no modules loaded):
5# $ php -i >/dev/null
6# /home/comp/rpm/BUILD/php-5.0.4/main/fopen_wrappers.c(548) : Freeing 0x08052970 (17 bytes), script=-
7# === Total 1 memory leaks detected ===
8# - loading pgsql+mnogosearch+snmp (only in this order!) causes php -i to SEGV on exit
9# (postgresql-libs-8.0.1-1, net-snmp-libs-5.2.1-0.2, mnogosearch-lib-3.2.32-1)
10# (only php.cli; php.cgi and apache2 module are not affected)
11#
54eb743b 12# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
13# - think of including support for:
14# - mcve,
15# - ovrimos,
16# - pfpro,
17# - ircg,
18# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
19# - deal with modules removed from php and not moved to PECL
20# (existing only in php4):
737e42ad 21# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd
JB
22# - enabling sybase+sybase_ct+mssql together causes SEGV beside warnings
23# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 24# - make additional headers added by mail patch configurable
543a3683 25# - apply -hardened patch by default ?
82bb3a40 26#
6f91d99f
JB
27# Conditional build:
28%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 29%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
4f8ad92f 30%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 31%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 32%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
33%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
34%bcond_with oracle # with oracle extension module (BR: proprietary libs)
74f7e4ba 35%bcond_with apache1 # build with apache1
ec7c6e14 36%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
37%bcond_without cpdf # without cpdf extension module
38%bcond_without curl # without CURL extension module
8c91402c 39%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f
JB
40%bcond_without imap # without IMAP extension module
41%bcond_without interbase # without InterBase extension module
42%bcond_without ldap # without LDAP extension module
43%bcond_without mhash # without mhash extension module
44%bcond_without ming # without ming extension module
45%bcond_without mm # without mm support for session storage
46%bcond_without mnogosearch # without mnogosearch extension module
47%bcond_without msession # without msession extension module
48%bcond_without mssql # without MS SQL extension module
49%bcond_without odbc # without ODBC extension module
50%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
51%bcond_without pcre # without PCRE extension module
6f91d99f 52%bcond_without pgsql # without PostgreSQL extension module
274395e3 53%bcond_without pspell # without pspell extension module
6f91d99f 54%bcond_without recode # without recode extension module
6f91d99f 55%bcond_without snmp # without SNMP extension module
8c91402c 56%bcond_without sqlite # without SQLite extension module
41a6f471 57%bcond_without sybase # without Sybase extension module
4cc60252 58%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 59%bcond_without tidy # without Tidy extension module
6f91d99f
JB
60%bcond_without wddx # without WDDX extension module
61%bcond_without xmlrpc # without XML-RPC extension module
74f7e4ba
ER
62
63%define _apache2 %{?with_apache1:0}%{!?with_apache1:1}
7f3d706a 64%if %{_apache2}
41a9af21 65%define apxs /usr/sbin/apxs
7f3d706a
ER
66%else
67%define apxs /usr/sbin/apxs1
68%endif
6f91d99f 69# some problems with apache 2.x
ab092fe1 70%if %{_apache2}
6f91d99f 71%undefine with_mm
ab092fe1 72%endif
c37dabc8 73%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
6f91d99f 74%undefine with_interbase
52bba439 75%endif
6e4962cf 76# x86-only lib
52bba439 77%ifnarch %{ix86}
6f91d99f 78%undefine with_msession
c2388c7d 79%endif
6f91d99f 80%include /usr/lib/rpm/macros.php
caff8ce9 81Summary: The PHP HTML-embedded scripting language for use with Apache
82Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 83