]> git.pld-linux.org Git - projects/template-specs.git/blame - php-pecl.spec
- fixed package status information
[projects/template-specs.git] / php-pecl.spec
CommitLineData
a7223ec4
AG
1%define _modname -
2%define _status -
3Summary: %{_modname} -
4Summary(pl): %{_modname} -
5Name: php-pecl-%{_modname}
6Version: 1.0
7Release: 1
8License: PHP 2.02
9Group: Development/Languages/PHP
10Source0: http://pear.php.net/get/%{_modname}-%{version}.tgz
11URL: http://pear.php.net/
12BuildRequires: libtool
13BuildRequires: php-devel
14Requires: php-common
15Obsoletes: php-pear-%{_modname}
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _sysconfdir /etc/php
19%define extensionsdir %{_libdir}/php
20
21%description
22
751ba5e6 23This extension has in PEAR status: %{_status}
a7223ec4
AG
24
25%description -l pl
26
751ba5e6 27To rozszerzenie ma w PEAR status: %{_status}
a7223ec4
AG
28
29%prep
30%setup -q -c
31
32%build
33cd %{_modname}-%{version}
34phpize
35%configure
36%{__make}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40install -d $RPM_BUILD_ROOT%{extensionsdir}
41
42install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%post
48%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
49
50%preun
51if [ "$1" = "0" ]; then
52 %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
53fi
54
55%files
56%defattr(644,root,root,755)
57%attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.085771 seconds and 4 git commands to generate.