]> git.pld-linux.org Git - packages/perl-XML-SAX-ExpatXS.git/blame - perl-XML-SAX-ExpatXS.spec
- rel 3
[packages/perl-XML-SAX-ExpatXS.git] / perl-XML-SAX-ExpatXS.spec
CommitLineData
6a8636ea 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir XML
7%define pnam SAX-ExpatXS
8Summary: XML::SAX::ExpatXS - Perl SAX 2 XS extension to Expat parser
16f28937 9Summary(pl.UTF-8): XML::SAX::ExpatXS - rozszerzenie XS Perla SAX 2 do analizatora Expat
6a8636ea 10Name: perl-XML-SAX-ExpatXS
61fc87c6 11Version: 1.20
ec4393b6 12Release: 3
6a8636ea 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
61fc87c6 17# Source0-md5: fb6592f799316c588202f54a845ebbff
6a8636ea 18BuildRequires: expat-devel
19%if %{with tests}
20BuildRequires: perl-XML-SAX >= 0.12
21%endif
22BuildRequires: perl-devel >= 1:5.8.0
23BuildRequires: rpm-perlprov >= 4.1-13
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27XML::SAX::ExpatXS is a direct XS extension to Expat XML parser. It
28implements Perl SAX 2.1 interface.
29
9a582c25
JR
30%description -l pl.UTF-8
31XML::SAX::ExpatXS to bezpośrednie rozszerzenie XS do analizatora XML-a
11d76eb6
JB
32Expat. Implementuje interfejs Perla SAX 2.1.
33
6a8636ea 34%prep
35%setup -q -n %{pdir}-%{pnam}-%{version}
36
37# we want to add_parser in post, not on make install
e73601bc 38head -n 98 Makefile.PL > Makefile.PL.tmp
6a8636ea 39mv -f Makefile.PL.tmp Makefile.PL
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make}
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58umask 022
59%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::ExpatXS))->save_parsers()"
60
61%postun
62if [ "$1" = "0" ]; then
63 umask 022
64 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::ExpatXS))->save_parsers()"
65fi
66
67%files
68%defattr(644,root,root,755)
69%doc Changes
70%{perl_vendorarch}/XML/SAX/*
b2b8b365
ER
71%dir %{perl_vendorarch}/XML/SAX
72%dir %{perl_vendorarch}/auto/XML/SAX
e73601bc 73%dir %{perl_vendorarch}/auto/XML/SAX/ExpatXS
f2400be7 74%attr(755,root,root) %{perl_vendorarch}/auto/XML/SAX/ExpatXS/*.so
e73601bc 75%{perl_vendorarch}/auto/XML/SAX/ExpatXS/*.bs
6a8636ea 76%{_mandir}/man3/*
This page took 0.0652740000000001 seconds and 4 git commands to generate.