]> git.pld-linux.org Git - packages/perl-XML-SAX-ExpatXS.git/blame - perl-XML-SAX-ExpatXS.spec
- initial revision
[packages/perl-XML-SAX-ExpatXS.git] / perl-XML-SAX-ExpatXS.spec
CommitLineData
6a8636ea 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir XML
7%define pnam SAX-ExpatXS
8Summary: XML::SAX::ExpatXS - Perl SAX 2 XS extension to Expat parser
9Name: perl-XML-SAX-ExpatXS
10Version: 1.08
11Release: 0.1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 1304d9ed3ca598ea000ea559dd387e88
17BuildRequires: expat-devel
18%if %{with tests}
19BuildRequires: perl-XML-SAX >= 0.12
20%endif
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26XML::SAX::ExpatXS is a direct XS extension to Expat XML parser. It
27implements Perl SAX 2.1 interface.
28
29%prep
30%setup -q -n %{pdir}-%{pnam}-%{version}
31
32# we want to add_parser in post, not on make install
33head -n 11 Makefile.PL > Makefile.PL.tmp
34mv -f Makefile.PL.tmp Makefile.PL
35
36%build
37%{__perl} Makefile.PL \
38 INSTALLDIRS=vendor
39%{__make}
40
41%{?with_tests:%{__make} test}
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46%{__make} install \
47 DESTDIR=$RPM_BUILD_ROOT
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%post
53umask 022
54%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::ExpatXS))->save_parsers()"
55
56%postun
57if [ "$1" = "0" ]; then
58 umask 022
59 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::ExpatXS))->save_parsers()"
60fi
61
62%files
63%defattr(644,root,root,755)
64%doc Changes
65%{perl_vendorarch}/XML/SAX/*
66%{perl_vendorarch}/auto/XML/SAX/*
67%{_mandir}/man3/*
This page took 0.133569 seconds and 4 git commands to generate.