]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blame - perl-XML-LibXML.spec
- tabs in preamble
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
CommitLineData
c3053b4d 1#
2# Conditional build:
d2bc690b 3%bcond_without tests # do not perform "make test"
c3053b4d 4#
faa96313 5# TODO:
6# - add pod files to spec
7#
93b10e78 8%include /usr/lib/rpm/macros.perl
9a0b3960 9%define pdir XML
10%define pnam LibXML
1968b26e 11%define base_version 1.61
5b1cc450 12Summary: XML::LibXML - interface to the GNOME libxml2 library
ae85d059 13Summary(pl.UTF-8): XML::LibXML - interfejs do biblioteki libxml2 z GNOME
70aff09e 14Name: perl-XML-LibXML
1968b26e 15Version: %{base_version}_003
16%define ver %(echo %version | tr -d _)
17Release: 1
35b66355 18# same as perl
d2bc690b 19License: GPL v1+ or Artistic
93b10e78 20Group: Development/Languages/Perl
1968b26e 21Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{ver}.tar.gz
22# Source0-md5: 2196bc8db0f2047c432a90c345ca9c63
35b66355 23BuildRequires: gdome2-devel >= 0.7.3
46f69d6d 24BuildRequires: libxml2-devel >= 2.5.10
88362b24 25BuildRequires: perl-XML-LibXML-Common
0042f58e 26BuildRequires: perl-XML-NamespaceSupport >= 1.07
c3053b4d 27BuildRequires: perl-XML-SAX >= 0.11
46f69d6d 28BuildRequires: perl-devel >= 1:5.8.0
e086ce6b 29BuildRequires: pkgconfig
38915a66 30BuildRequires: rpm-perlprov >= 4.1-13
46f69d6d 31Requires: libxml2 >= 2.5.10
88362b24 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93b10e78 33
34%description
25829699 35This module implements much of the DOM Level 2 API as an interface to
a559f02a 36the GNOME libxml2 library. This makes it a fast and highly capable
25829699
JB
37validating XML parser library, as well as a high performance DOM.
38
89406f45
JR
39%description -l pl.UTF-8
40Ten moduł to implementacja większości API DOM Level 2 jako interfejsu
41do biblioteki GNOME libxml2. Daje to szybki i o dużych możliwościach
42parser sprawdzający poprawność XML-a, a także wysoko wydajny DOM.
93b10e78 43
44%package SAX
46f69d6d 45Summary: XML::LibXML::SAX Perl module - XML::LibXML direct SAX parser
ae85d059 46Summary(pl.UTF-8): Moduł Perla XML::LibXML::SAX - bezpośredni parser SAX z XML::LibXML
93b10e78 47Group: Development/Languages/Perl
3f1d5dc1 48Requires: %{name} = %{version}-%{release}
93b10e78 49
50%description SAX
25829699 51This class allows you to generate SAX2 events using LibXML. Note that
64c92586 52this is not a stream based parser, instead it parses documents into a
53DOM and traverses the DOM tree. The reason being that libxml2's stream
54based parsing is extremely primitive, and would require an extreme
55amount of work to allow SAX2 parsing in a stream manner.
25829699 56
89406f45
JR
57%description SAX -l pl.UTF-8
58Ta klasa pozwala generować zdarzenia SAX2 przy użyciu LibXML2. To nie
59jest parser bazujący na strumieniach - przetwarza dokumenty na DOM i
60następnie wędruje po drzewie DOM. Wynika to z faktu, że w libxml2
61parsowanie oparte na strumieniach jest bardzo prymitywne i wymagałoby
62wiele pracy, aby umożliwić strumieniowe parsowanie SAX2.
93b10e78 63
64%prep
1968b26e 65%setup -q -n %{pdir}-%{pnam}-%{base_version}
93b10e78 66
67%build
0de22b55
AG
68SKIP_SAX_INSTALL=true;
69export SKIP_SAX_INSTALL
d7823dc1 70
38915a66 71%{__perl} Makefile.PL \
64a03af0 72 INSTALLDIRS=vendor
e086ce6b
JB
73%{__make} \
74 OPTIMIZE="%{rpmcflags}"
93b10e78 75
46f69d6d 76%{?with_tests:%{__make} test}
c3053b4d 77
93b10e78 78%install
79rm -rf $RPM_BUILD_ROOT
80install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
e086ce6b
JB
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
93b10e78 84install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
87install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
88
89install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
90install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
91
88362b24
JB
92%clean
93rm -rf $RPM_BUILD_ROOT
d238a71d 94
93b10e78 95%post SAX
4538f7d7 96umask 022
35b66355 97%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
93b10e78 98
99%preun SAX
05892067
JB
100if [ "$1" = "0" ]; then
101 umask 022
102 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
103fi
93b10e78 104
93b10e78 105%files
106%defattr(644,root,root,755)
c3053b4d 107%doc Changes README
38915a66 108%{perl_vendorarch}/XML/LibXML.pm
e086ce6b 109%{perl_vendorarch}/XML/LibXML/[!S]*.pm
38915a66 110%{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
111%attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
13a12d43 112%{_mandir}/man3/XML::LibXML.3pm*
e086ce6b 113%{_mandir}/man3/XML::LibXML::[!S]*
1968b26e 114%{_mandir}/man3/XML::LibXML::S[!A]*
c3053b4d 115%dir %{_examplesdir}/%{name}-%{version}
116%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
e086ce6b 117%{_examplesdir}/%{name}-%{version}/[!x]*
93b10e78 118
119%files SAX
120%defattr(644,root,root,755)
38915a66 121%dir %{perl_vendorarch}/XML/LibXML/SAX
122%{perl_vendorarch}/XML/LibXML/SAX.pm
123%{perl_vendorarch}/XML/LibXML/SAX/*.pm
0042f58e 124%{_mandir}/man3/XML::LibXML::SAX.3pm*
93b10e78 125%{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.052811 seconds and 4 git commands to generate.