]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blame - perl-XML-LibXML.spec
- not needed in 1.65
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
CommitLineData
c3053b4d 1#
2# Conditional build:
d2bc690b 3%bcond_without tests # do not perform "make test"
c3053b4d 4#
93b10e78 5%include /usr/lib/rpm/macros.perl
9a0b3960 6%define pdir XML
7%define pnam LibXML
5b1cc450 8Summary: XML::LibXML - interface to the GNOME libxml2 library
ae85d059 9Summary(pl.UTF-8): XML::LibXML - interfejs do biblioteki libxml2 z GNOME
70aff09e 10Name: perl-XML-LibXML
418efe13 11Version: 1.65
e9816160 12Release: 1
35b66355 13# same as perl
d2bc690b 14License: GPL v1+ or Artistic
93b10e78 15Group: Development/Languages/Perl
e9816160 16Source0: http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
418efe13 17# Source0-md5: 7871c21078f706690cda9ca68d4ddac6
5c9eff29 18URL: http://search.cpan.org/dist/XML-LibXML/
35b66355 19BuildRequires: gdome2-devel >= 0.7.3
46f69d6d 20BuildRequires: libxml2-devel >= 2.5.10
88362b24 21BuildRequires: perl-XML-LibXML-Common
0042f58e 22BuildRequires: perl-XML-NamespaceSupport >= 1.07
c3053b4d 23BuildRequires: perl-XML-SAX >= 0.11
46f69d6d 24BuildRequires: perl-devel >= 1:5.8.0
e086ce6b 25BuildRequires: pkgconfig
38915a66 26BuildRequires: rpm-perlprov >= 4.1-13
46f69d6d 27Requires: libxml2 >= 2.5.10
7a25fbd0 28Provides: perl-XML-LibXML-XPathContext = %{version}
29Obsoletes: perl-XML-LibXML-XPathContext <= 0:0.07
88362b24 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93b10e78 31
32%description
25829699 33This module implements much of the DOM Level 2 API as an interface to
a559f02a 34the GNOME libxml2 library. This makes it a fast and highly capable
25829699
JB
35validating XML parser library, as well as a high performance DOM.
36
89406f45
JR
37%description -l pl.UTF-8
38Ten moduł to implementacja większości API DOM Level 2 jako interfejsu
39do biblioteki GNOME libxml2. Daje to szybki i o dużych możliwościach
40parser sprawdzający poprawność XML-a, a także wysoko wydajny DOM.
93b10e78 41
42%package SAX
46f69d6d 43Summary: XML::LibXML::SAX Perl module - XML::LibXML direct SAX parser
ae85d059 44Summary(pl.UTF-8): Moduł Perla XML::LibXML::SAX - bezpośredni parser SAX z XML::LibXML
93b10e78 45Group: Development/Languages/Perl
3f1d5dc1 46Requires: %{name} = %{version}-%{release}
93b10e78 47
48%description SAX
25829699 49This class allows you to generate SAX2 events using LibXML. Note that
64c92586 50this is not a stream based parser, instead it parses documents into a
51DOM and traverses the DOM tree. The reason being that libxml2's stream
52based parsing is extremely primitive, and would require an extreme
53amount of work to allow SAX2 parsing in a stream manner.
25829699 54
89406f45
JR
55%description SAX -l pl.UTF-8
56Ta klasa pozwala generować zdarzenia SAX2 przy użyciu LibXML2. To nie
57jest parser bazujący na strumieniach - przetwarza dokumenty na DOM i
58następnie wędruje po drzewie DOM. Wynika to z faktu, że w libxml2
59parsowanie oparte na strumieniach jest bardzo prymitywne i wymagałoby
60wiele pracy, aby umożliwić strumieniowe parsowanie SAX2.
93b10e78 61
62%prep
e9816160 63%setup -q -n %{pdir}-%{pnam}-%{version}
93b10e78 64
65%build
0de22b55
AG
66SKIP_SAX_INSTALL=true;
67export SKIP_SAX_INSTALL
d7823dc1 68
38915a66 69%{__perl} Makefile.PL \
64a03af0 70 INSTALLDIRS=vendor
e086ce6b
JB
71%{__make} \
72 OPTIMIZE="%{rpmcflags}"
93b10e78 73
46f69d6d 74%{?with_tests:%{__make} test}
c3053b4d 75
93b10e78 76%install
77rm -rf $RPM_BUILD_ROOT
78install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
e086ce6b
JB
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
93b10e78 82install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
85install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
86
87install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
88install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
89
88362b24
JB
90%clean
91rm -rf $RPM_BUILD_ROOT
d238a71d 92
93b10e78 93%post SAX
4538f7d7 94umask 022
35b66355 95%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
93b10e78 96
97%preun SAX
05892067
JB
98if [ "$1" = "0" ]; then
99 umask 022
100 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
101fi
93b10e78 102
93b10e78 103%files
104%defattr(644,root,root,755)
c3053b4d 105%doc Changes README
38915a66 106%{perl_vendorarch}/XML/LibXML.pm
e086ce6b 107%{perl_vendorarch}/XML/LibXML/[!S]*.pm
38915a66 108%{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
109%attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
13a12d43 110%{_mandir}/man3/XML::LibXML.3pm*
e086ce6b 111%{_mandir}/man3/XML::LibXML::[!S]*
1968b26e 112%{_mandir}/man3/XML::LibXML::S[!A]*
c3053b4d 113%dir %{_examplesdir}/%{name}-%{version}
114%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
e086ce6b 115%{_examplesdir}/%{name}-%{version}/[!x]*
93b10e78 116
117%files SAX
118%defattr(644,root,root,755)
38915a66 119%dir %{perl_vendorarch}/XML/LibXML/SAX
120%{perl_vendorarch}/XML/LibXML/SAX.pm
121%{perl_vendorarch}/XML/LibXML/SAX/*.pm
0042f58e 122%{_mandir}/man3/XML::LibXML::SAX.3pm*
93b10e78 123%{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.131022 seconds and 4 git commands to generate.