]> git.pld-linux.org Git - packages/perl-XML-Driver-HTML.git/blame - perl-XML-Driver-HTML.spec
- new
[packages/perl-XML-Driver-HTML.git] / perl-XML-Driver-HTML.spec
CommitLineData
926ff32e 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir XML
7%define pnam Driver-HTML
8Summary: XML::Driver::HTML - SAX Driver for non wellformed HTML
9#Summary(pl):
10Name: perl-XML-Driver-HTML
11Version: 0.06
12Release: 1
13# (c) 2001 GNU General Public License
14License: GPL
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 43f29d0060b4e22687ed91e651f0addb
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-HTML-Parser >= 3.07
22BuildRequires: perl-HTML-Tree >= 2.96
23BuildRequires: perl-libxml >= 0.06
24BuildRequires: perl-XML-Handler-YAWriter >= 0.20
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30XML::Driver::HTML is a SAX Driver for HTML. There is no need for the
31HTML input to be weel formed, as XML::Driver::HTML is generating its SAX
32events by walking a HTML::TreeBuilder object. The simplest kind of use, is
33a filter from HTML to XHTML using XML::Handler::YAWriter as a SAX Handler.
34
35# %description -l pl
36# TODO
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make}
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%attr(755,root,root) %{_bindir}/*
60%{perl_vendorlib}/XML/Driver/*.pm
61%{_mandir}/man?/*
This page took 0.067657 seconds and 4 git commands to generate.