]> git.pld-linux.org Git - packages/perl-XML-DOM.git/blame - perl-XML-DOM.spec
- initial release
[packages/perl-XML-DOM.git] / perl-XML-DOM.spec
CommitLineData
b0311bcd 1
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%include /usr/lib/rpm/macros.perl
6%define pdir XML
7%define pnam DOM
8Summary: Build DOM Level 1 compliant document structures
9Name: perl-XML-DOM
10Version: 1.43
11Release: 1
12License: Unknown
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: e4c3fdd46e7ada0f9db326b493058d4d
16BuildRequires: perl-devel >= 5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18%if %{with tests}
19BuildRequires: perl-XML-RegExp
20BuildRequires: perl-libxml >= 0.07
21BuildRequires: perl-libwww
22BuildRequires: perl-XML-Parser >= 2.30
23%endif
24Obsoletes: perl-libxml-enno
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28#%define _noautoreq 'perl(XML::DOM)' 'perl-(
29
30%description
31This is a Perl extension to XML::Parser. It adds a new 'Style' to
32XML::Parser, called 'Dom', that allows XML::Parser to build an Object
33Oriented datastructure with a DOM Level 1 compliant interface.
34However, there is a new DOM module, XML::GDOME which is under active
35development and significantly faster than XML::DOM, since it is based
36on the libgdome C library.
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44
45%{__make}
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc Changes README
60%dir %{perl_vendorlib}/XML/DOM
61%{perl_vendorlib}/XML/DOM.pm
62%{perl_vendorlib}/XML/DOM/*.pm
63%{perl_vendorlib}/XML/Handler/*
64%{_mandir}/man3/*
This page took 0.080928 seconds and 4 git commands to generate.