]> git.pld-linux.org Git - packages/perl-Wx.git/blame - perl-Wx.spec
- fixed wx variant selection
[packages/perl-Wx.git] / perl-Wx.spec
CommitLineData
4de6ff00
JB
1#
2# Conditional build:
5e909227
JB
3%bcond_without unicode # ANSI instead of Unicode version of wxGTK
4%bcond_with gtk3 # wxGTK3 instead of wxGTK2
5%bcond_with tests # "make test" (requires $DISPLAY)
4de6ff00 6#
5e909227
JB
7%define wxpkg wxGTK%{?with_gtk3:3}%{!?with_gtk3:2}%{?with_unicode:-unicode}
8%define wx_ver %(rpm -q wxWidgets-devel --qf '%%{VERSION}')
9%define wx_ver_tag %(echo %{wx_ver} | tr . _)
10%define alien_wxcfg gtk%{!?with_gtk3:2}_%{wx_ver_tag}%{?with_unicode:_uni}_gcc_3_4
deb8018a
11%include /usr/lib/rpm/macros.perl
12Summary: wxPerl - a Perl wrapper for the wxWidgets C++ GUI toolkit
5cb4cb25 13Summary(pl.UTF-8): wxPerl - wrapper toolkitu graficznego C++ wxWidgets dla Perla
deb8018a 14Name: perl-Wx
6cb4758e 15Version: 0.9923
5e909227 16Release: 1
deb8018a
17# same as perl
18License: GPL v1+ or Artistic
19Group: Development/Languages/Perl
20Source0: http://www.cpan.org/modules/by-module/Wx/Wx-%{version}.tar.gz
6cb4758e 21# Source0-md5: 16f203d0e3bf9ecc7f830f10bf165c5e
1e70ffa7 22URL: http://wxperl.sourceforge.net/
5e909227
JB
23BuildRequires: perl-Alien-wxWidgets >= 0.25
24BuildRequires: perl-ExtUtils-MakeMaker >= 6.46
25BuildRequires: perl-ExtUtils-ParseXS >= 3.15
26BuildRequires: perl-ExtUtils-XSpp >= 0.16_02
27%if %{with tests}
28BuildRequires: perl-Test-Harness >= 2.26
29BuildRequires: perl-Test-Simple >= 0.45
30%endif
deb8018a 31BuildRequires: perl-devel >= 1:5.8.0
5e909227
JB
32# require Alien::wxWidgets with config for desired wx variant
33BuildRequires: perl(Alien::wxWidgets::Config::%{alien_wxcfg})
34BuildRequires: perl(File::Spec::Functions) >= 0.82
35BuildRequires: perl(if) >= 0.03
deb8018a 36BuildRequires: rpm-perlprov >= 4.1-13
5e909227
JB
37BuildRequires: %{wxpkg}-devel >= 2.6.3-1
38Requires: perl-Alien-wxWidgets >= 0.25
deb8018a
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
5e909227 42wxPerl is a Perl wrapper for the wxWidgets C++ GUI toolkit.
deb8018a 43
e9053be2 44%description -l pl.UTF-8
5e909227
JB
45wxPerl to wrapper toolkitu graficznego C++ wxWidgets dla Perla.
46
47%package devel
48Summary: Development package for wxPerl
49Summary(pl.UTF-8): Pakiet do rozwijania oprogramowania przy użyciu wxPerla
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: %{wxpkg}-devel >= 2.6.3-1
53
54%description devel
55Development package for wxPerl.
56
57%description devel -l pl.UTF-8
58Pakiet do rozwijania oprogramowania przy użyciu wxPerla.
deb8018a
59
60%prep
61%setup -q -n Wx-%{version}
62
63%build
deb8018a 64%{__perl} Makefile.PL \
335c9ce5
JB
65 INSTALLDIRS=vendor \
66 --wx-toolkit=gtk%{!?with_gtk3:2} \
67 --%{!?with_unicode:no-}wx-unicode
deb8018a 68%{__make} \
5e909227 69 CC="%{__cxx}" \
1e70ffa7 70 OPTIMIZE="%{rpmcflags}"
deb8018a 71
5e909227
JB
72%{?with_tests:%{__make} test}
73
deb8018a
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} install \
78 DESTDIR=$RPM_BUILD_ROOT
79
5e909227
JB
80%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/*.pod
81
82# not this OS
83%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/build/MakeMaker/{MacOSX,Win32}* \
84 $RPM_BUILD_ROOT%{_mandir}/man3/Wx::build::MakeMaker::Win32_MSVC.3pm
85
deb8018a
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
5e909227
JB
91%doc README.txt docs/todo.txt
92%{perl_vendorarch}/Wx.pm
93%dir %{perl_vendorarch}/Wx
94%{perl_vendorarch}/Wx/Perl
95%{perl_vendorarch}/Wx/*.pm
96%{perl_vendorarch}/Wx/typemap
deb8018a 97%dir %{perl_vendorarch}/auto/Wx
5e909227
JB
98%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Wx.so
99%dir %{perl_vendorarch}/auto/Wx/AUI
100%attr(755,root,root) %{perl_vendorarch}/auto/Wx/AUI/AUI.so
deb8018a 101%dir %{perl_vendorarch}/auto/Wx/Calendar
5e909227 102%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Calendar/Calendar.so
deb8018a 103%dir %{perl_vendorarch}/auto/Wx/DND
5e909227
JB
104%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DND/DND.so
105%dir %{perl_vendorarch}/auto/Wx/DataView
106%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DataView/DataView.so
107%dir %{perl_vendorarch}/auto/Wx/DateTime
108%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DateTime/DateTime.so
deb8018a 109%dir %{perl_vendorarch}/auto/Wx/DocView
5e909227 110%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DocView/DocView.so
deb8018a 111%dir %{perl_vendorarch}/auto/Wx/FS
5e909227 112%attr(755,root,root) %{perl_vendorarch}/auto/Wx/FS/FS.so
deb8018a 113%dir %{perl_vendorarch}/auto/Wx/Grid
5e909227 114%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Grid/Grid.so
deb8018a 115%dir %{perl_vendorarch}/auto/Wx/Help
5e909227 116%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Help/Help.so
deb8018a 117%dir %{perl_vendorarch}/auto/Wx/Html
5e909227
JB
118%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Html/Html.so
119%dir %{perl_vendorarch}/auto/Wx/IPC
120%attr(755,root,root) %{perl_vendorarch}/auto/Wx/IPC/IPC.so
deb8018a 121%dir %{perl_vendorarch}/auto/Wx/MDI
5e909227
JB
122%attr(755,root,root) %{perl_vendorarch}/auto/Wx/MDI/MDI.so
123%dir %{perl_vendorarch}/auto/Wx/Media
124%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Media/Media.so
125%dir %{perl_vendorarch}/auto/Wx/PerlTest
126%attr(755,root,root) %{perl_vendorarch}/auto/Wx/PerlTest/PerlTest.so
deb8018a 127%dir %{perl_vendorarch}/auto/Wx/Print
5e909227
JB
128%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Print/Print.so
129%dir %{perl_vendorarch}/auto/Wx/PropertyGrid
130%attr(755,root,root) %{perl_vendorarch}/auto/Wx/PropertyGrid/PropertyGrid.so
131%dir %{perl_vendorarch}/auto/Wx/Ribbon
132%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Ribbon/Ribbon.so
133%dir %{perl_vendorarch}/auto/Wx/RichText
134%attr(755,root,root) %{perl_vendorarch}/auto/Wx/RichText/RichText.so
deb8018a 135%dir %{perl_vendorarch}/auto/Wx/STC
5e909227
JB
136%attr(755,root,root) %{perl_vendorarch}/auto/Wx/STC/STC.so
137%dir %{perl_vendorarch}/auto/Wx/Socket
138%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Socket/Socket.so
139%dir %{perl_vendorarch}/auto/Wx/WebView
140%attr(755,root,root) %{perl_vendorarch}/auto/Wx/WebView/WebView.so
deb8018a 141%dir %{perl_vendorarch}/auto/Wx/XRC
5e909227
JB
142%attr(755,root,root) %{perl_vendorarch}/auto/Wx/XRC/XRC.so
143%{_mandir}/man3/Wx.3pm*
144%{_mandir}/man3/Wx::Api.3pm*
145%{_mandir}/man3/Wx::Loader.3pm*
146%{_mandir}/man3/Wx::NewClass.3pm*
147%{_mandir}/man3/Wx::Perl::*.3pm*
148%{_mandir}/man3/Wx::Socket.3pm*
149%{_mandir}/man3/Wx::Thread.3pm*
150
151%files devel
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_bindir}/wxperl_overload
154%{perl_vendorarch}/Wx/Overload
155%{perl_vendorarch}/Wx/XSP
156%{perl_vendorarch}/Wx/build
157%{perl_vendorarch}/Wx/cpp
158%{_mandir}/man1/wxperl_overload.1p*
159%{_mandir}/man3/Wx::XSP::*.3pm*
160%{_mandir}/man3/Wx::build::*.3pm*
This page took 0.355468 seconds and 4 git commands to generate.