]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blame - perl-Verilog-Perl.spec
- up to 3.313
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
CommitLineData
575cc060
ER
1# TODO
2# - should use CXX/CC make options not CC for .cpp compile!
3# - maybe bin/man1 should be moved to another package
c55bcf2a
MP
4#
5# Conditional build:
6%bcond_without tests # do not perform "make test"
7#
8%include /usr/lib/rpm/macros.perl
9%define pdir Verilog
10%define pnam Perl
3625327e
JB
11Summary: Verilog::Perl - an Perl way to handle Verilog files
12Summary(pl.UTF-8): Verilog::Perl - perlowy sposób obsługi plików Verilog
c55bcf2a 13Name: perl-Verilog-Perl
e79ccc52 14Version: 3.313
7bc8a462 15Release: 1
c55bcf2a
MP
16License: LGPL or Perl Artistic License
17Group: Development/Languages/Perl
59abe66e 18Source0: http://www.cpan.org/modules/by-module/Verilog/%{pdir}-%{pnam}-%{version}.tar.gz
e79ccc52 19# Source0-md5: 13fbacac8b79df4de9217227c39160ff
3625327e 20URL: http://search.cpan.org/dist/Verilog-Perl/
0a8dde1e 21BuildRequires: flex
c55bcf2a
MP
22BuildRequires: perl-devel >= 1:5.8.0
23BuildRequires: rpm-perlprov >= 4.1-13
c55bcf2a
MP
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
3625327e
JB
27Verilog::Parser, Verilog::Preproc, and other Perl modules useful for
28manipulation of Verilog files. The Verilog::Parser package will
29tokenize a Verilog file when the parse() method is called and invoke
30various callback methods. This is useful for extracting information
31and editing files while retaining all context. For netlist like
32extractions, see Verilog::Netlist. Verilog::Preproc reads Verilog
33files, and preprocesses them according to the Verilog 2001
34specification. Programs can be easily converted from reading a
c55bcf2a 35IO::File into reading preprocessed output from Verilog::Preproc.
3625327e
JB
36Verilog::Netlist contains interconnect information about a whole
37design database.
c55bcf2a 38
3625327e
JB
39%description -l pl.UTF-8
40Verilog::Parser, Verilog::Preproc i inne moduły Perla przydatne do
41obróbki plików Verilog. Pakiet Verilog::Parser po wywołaniu metody
42parse() zamienia plik Verilog na tokeny i wykonuje różne metody
43wywołań zwrotnych. Jest to przydatne przy wyciąganiu informacji i
44modyfikowaniu plików z zachowaniem całego kontekstu. Do wyciągania
45informacji w stylu netlist można użyć Verilog::Netlist.
46Verilog::Preproc czyta pliki Verilog i przetwarza je zgodnie ze
47specyfikacją Verilog 2001. Można łatwo przekształcać programy z
48odczytu za pomocą IO::File na czytanie przetworzonego wyjścia z
49Verilog::Preproc. Verilog::Netlist zawiera dołączone informacje o
50całej bazie projektu.
c55bcf2a
MP
51
52%prep
53%setup -q -n %{pdir}-%{pnam}-%{version}
54
55%build
56%{__perl} Makefile.PL \
57 INSTALLDIRS=vendor
1a7b2032 58%{__make} \
575cc060 59 CC="%{__cxx}" \
1a7b2032 60 OPTIMIZE="%{rpmcflags}"
c55bcf2a
MP
61
62%{?with_tests:%{__make} test}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67%{__make} install \
68 DESTDIR=$RPM_BUILD_ROOT
69
e0920f7b 70rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Verilog/Verilog-Perl.pod
71rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Verilog/Language/.packlist
72
c55bcf2a
MP
73%clean
74rm -rf $RPM_BUILD_ROOT
75
c55bcf2a
MP
76%files
77%defattr(644,root,root,755)
78%doc Changes README
3625327e 79%attr(755,root,root) %{_bindir}/*
c55bcf2a
MP
80%dir %{perl_vendorarch}/Verilog
81%{perl_vendorarch}/Verilog/*.pm
82%dir %{perl_vendorarch}/Verilog/Netlist
83%{perl_vendorarch}/Verilog/Netlist/*.pm
575cc060 84%dir %{perl_vendorarch}/auto/Verilog
c55bcf2a 85%dir %{perl_vendorarch}/auto/Verilog/Preproc
1a7b2032
JB
86%{perl_vendorarch}/auto/Verilog/Preproc/Preproc.bs
87%attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.so
9a4bcdd4
MP
88%dir %{perl_vendorarch}/auto/Verilog/Parser
89%{perl_vendorarch}/auto/Verilog/Parser/Parser.bs
90%attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Parser/Parser.so
c55bcf2a 91%{_mandir}/man1/*
3625327e 92%{_mandir}/man3/*
This page took 0.048794 seconds and 4 git commands to generate.