]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blame - perl-Verilog-Perl.spec
rebuild with perl 5.34.0
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
CommitLineData
575cc060
ER
1# TODO
2# - should use CXX/CC make options not CC for .cpp compile!
3# - maybe bin/man1 should be moved to another package
c55bcf2a
MP
4#
5# Conditional build:
6%bcond_without tests # do not perform "make test"
7#
c55bcf2a
MP
8%define pdir Verilog
9%define pnam Perl
3625327e
JB
10Summary: Verilog::Perl - an Perl way to handle Verilog files
11Summary(pl.UTF-8): Verilog::Perl - perlowy sposób obsługi plików Verilog
c55bcf2a 12Name: perl-Verilog-Perl
317b36bf 13Version: 3.416
2ad95d6c 14Release: 8
c55bcf2a
MP
15License: LGPL or Perl Artistic License
16Group: Development/Languages/Perl
59abe66e 17Source0: http://www.cpan.org/modules/by-module/Verilog/%{pdir}-%{pnam}-%{version}.tar.gz
317b36bf 18# Source0-md5: eeae6411b8fd9cdda04fea065065b2ac
3625327e 19URL: http://search.cpan.org/dist/Verilog-Perl/
0a8dde1e 20BuildRequires: flex
c55bcf2a
MP
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
c55bcf2a
MP
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
3625327e
JB
26Verilog::Parser, Verilog::Preproc, and other Perl modules useful for
27manipulation of Verilog files. The Verilog::Parser package will
28tokenize a Verilog file when the parse() method is called and invoke
29various callback methods. This is useful for extracting information
30and editing files while retaining all context. For netlist like
31extractions, see Verilog::Netlist. Verilog::Preproc reads Verilog
32files, and preprocesses them according to the Verilog 2001
33specification. Programs can be easily converted from reading a
c55bcf2a 34IO::File into reading preprocessed output from Verilog::Preproc.
3625327e
JB
35Verilog::Netlist contains interconnect information about a whole
36design database.
c55bcf2a 37
3625327e
JB
38%description -l pl.UTF-8
39Verilog::Parser, Verilog::Preproc i inne moduły Perla przydatne do
40obróbki plików Verilog. Pakiet Verilog::Parser po wywołaniu metody
41parse() zamienia plik Verilog na tokeny i wykonuje różne metody
42wywołań zwrotnych. Jest to przydatne przy wyciąganiu informacji i
43modyfikowaniu plików z zachowaniem całego kontekstu. Do wyciągania
44informacji w stylu netlist można użyć Verilog::Netlist.
45Verilog::Preproc czyta pliki Verilog i przetwarza je zgodnie ze
46specyfikacją Verilog 2001. Można łatwo przekształcać programy z
47odczytu za pomocą IO::File na czytanie przetworzonego wyjścia z
48Verilog::Preproc. Verilog::Netlist zawiera dołączone informacje o
49całej bazie projektu.
c55bcf2a
MP
50
51%prep
52%setup -q -n %{pdir}-%{pnam}-%{version}
53
54%build
55%{__perl} Makefile.PL \
56 INSTALLDIRS=vendor
1a7b2032 57%{__make} \
575cc060 58 CC="%{__cxx}" \
1a7b2032 59 OPTIMIZE="%{rpmcflags}"
c55bcf2a
MP
60
61%{?with_tests:%{__make} test}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%{__make} install \
67 DESTDIR=$RPM_BUILD_ROOT
68
e0920f7b 69rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Verilog/Verilog-Perl.pod
70rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Verilog/Language/.packlist
71
c55bcf2a
MP
72%clean
73rm -rf $RPM_BUILD_ROOT
74
c55bcf2a
MP
75%files
76%defattr(644,root,root,755)
77%doc Changes README
3625327e 78%attr(755,root,root) %{_bindir}/*
c55bcf2a
MP
79%dir %{perl_vendorarch}/Verilog
80%{perl_vendorarch}/Verilog/*.pm
81%dir %{perl_vendorarch}/Verilog/Netlist
82%{perl_vendorarch}/Verilog/Netlist/*.pm
575cc060 83%dir %{perl_vendorarch}/auto/Verilog
c55bcf2a 84%dir %{perl_vendorarch}/auto/Verilog/Preproc
1a7b2032 85%attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.so
9a4bcdd4 86%dir %{perl_vendorarch}/auto/Verilog/Parser
9a4bcdd4 87%attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Parser/Parser.so
c55bcf2a 88%{_mandir}/man1/*
3625327e 89%{_mandir}/man3/*
This page took 0.405981 seconds and 4 git commands to generate.