]> git.pld-linux.org Git - packages/perl-Tie-RefHash-Weak.git/blame - perl-Tie-RefHash-Weak.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Tie-RefHash-Weak.git] / perl-Tie-RefHash-Weak.spec
CommitLineData
17e4b26a
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Tie
6%define pnam RefHash-Weak
17e4b26a
ER
7Summary: Tie::RefHash::Weak - A Tie::RefHash subclass with weakened references in the keys
8Name: perl-Tie-RefHash-Weak
9Version: 0.09
10Release: 1
11# same as perl
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Tie/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: c7c6793fab417c9761d88f596dfb32e9
16URL: http://search.cpan.org/dist/Tie-RefHash-Weak/
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19%if %{with tests}
20BuildRequires: perl-Task-Weaken
21BuildRequires: perl-Variable-Magic
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27The Tie::RefHash module can be used to access hashes by reference.
28This is useful when you index by object, for example.
29
30The problem with Tie::RefHash, and cross indexing, is that sometimes
31the index should not contain strong references to the objecs.
32Tie::RefHash's internal structures contain strong references to the
33key, and provide no convenient means to make those references weak.
34
35This subclass of Tie::RefHash has weak keys, instead of strong ones.
36The values are left unaltered, and you'll have to make sure there are
37no strong references there yourself.
38
39%prep
40%setup -q -n %{pdir}-%{pnam}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51%{__make} pure_install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc Changes TODO
60%{perl_vendorlib}/Tie/RefHash/Weak.pm
61%{_mandir}/man3/Tie::RefHash::Weak.3pm*
This page took 0.06526 seconds and 4 git commands to generate.