]> git.pld-linux.org Git - packages/perl-Sys-Virt.git/blame - perl-Sys-Virt.spec
- too many dirs
[packages/perl-Sys-Virt.git] / perl-Sys-Virt.spec
CommitLineData
76469483
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Sys
6%define pnam Virt
7%include /usr/lib/rpm/macros.perl
8Summary: Sys::Virt - Represent and manage a libvirt hypervisor connection
aac3af46 9#Summary(pl.UTF-8):
76469483
JR
10Name: perl-Sys-Virt
11Version: 0.2.6
12Release: 1
13License: GPL
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: a4ca5735791e132320bd8546c5deacae
17URL: http://search.cpan.org/dist/Sys-Virt/
18BuildRequires: libvirt-devel
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl(Test::Pod)
23BuildRequires: perl(Test::Pod::Coverage)
24BuildRequires: perl(XML::XPath)
25BuildRequires: perl(XML::XPath::XMLParser)
26%endif
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
aac3af46
JR
30The Sys::Virt module provides a Perl XS binding to the libvirt virtual
31machine management APIs. This allows machines running within arbitrary
32virtualization containers to be managed with a consistent API.
76469483 33
aac3af46 34# %description -l pl.UTF-8 # TODO
76469483
JR
35
36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
39%build
40%{__perl} Makefile.PL \
41 INSTALLDIRS=vendor
42%{__make} -j1 \
43 CC="%{__cc}" \
44 OPTIMIZE="%{rpmcflags}"
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} pure_install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc AUTHORS CHANGES INSTALL README
76469483
JR
63%dir %{perl_vendorarch}/Sys/Virt
64%{perl_vendorarch}/Sys/*.pm
65%{perl_vendorarch}/Sys/Virt/*.pm
66%dir %{perl_vendorarch}/auto/Sys/Virt
67%{perl_vendorarch}/auto/Sys/Virt/*.bs
68%attr(755,root,root) %{perl_vendorarch}/auto/Sys/Virt/*.so
69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.064935 seconds and 4 git commands to generate.