]> git.pld-linux.org Git - packages/perl-SOAP-Lite.git/blame - perl-SOAP-Lite.spec
- unified sf URL
[packages/perl-SOAP-Lite.git] / perl-SOAP-Lite.spec
CommitLineData
31bb3d7a 1#
cec64d79 2# TOGO: package new files
3#
31bb3d7a 4# Conditional build:
c27651d1 5%bcond_with tests # perform "make test"
8649fb51 6%bcond_with MQ # build MQ subpackage (require commercial software to use)
c27651d1 7#
31bb3d7a 8%include /usr/lib/rpm/macros.perl
c233da80 9%define pdir SOAP
10%define pnam Lite
6ec1dd5b 11%define real_version %(echo %{version} | sed 's/[a-zA-Z]//')
31bb3d7a 12Summary: SOAP::Lite - Client and server side SOAP implementation
46602663 13Summary(pl.UTF-8): SOAP::Lite - implementacja SOAP po stronie klienta i serwera
31bb3d7a 14Name: perl-SOAP-Lite
ad0c7caf 15Version: 0.70_04
cec64d79 16Release: 0.1
059ef63a 17# same as perl
18License: GPL v1+ or Artistic
31bb3d7a 19Group: Development/Languages/Perl
d119b78a 20Source0: http://dl.sourceforge.net/soaplite/%{pdir}-%{pnam}-%{version}.tar.gz
ad0c7caf 21# Source0-md5: 7e66fab942b527d4ddb573874e639110
31bb3d7a 22URL: http://www.soaplite.com/
c27651d1 23%if %{with tests}
31bb3d7a 24# this list is probably incomplete
31bb3d7a 25BuildRequires: apache-mod_perl
26BuildRequires: perl-Compress-Zlib
27BuildRequires: perl-Crypt-SSLeay
28BuildRequires: perl-FCGI
29BuildRequires: perl-IO-Socket-SSL
31bb3d7a 30BuildRequires: perl-MIME-Base64
31BuildRequires: perl-MIME-Lite
32BuildRequires: perl-MIME-tools
33BuildRequires: perl-Net-Jabber
34BuildRequires: perl-URI
6ec1dd5b
ER
35BuildRequires: perl-libnet
36BuildRequires: perl-libwww
31bb3d7a 37%endif
003420a4 38BuildRequires: perl-devel >= 1:5.8.0
ca70e9cc 39BuildRequires: rpm-perlprov >= 4.1-13
31bb3d7a 40BuildArch: noarch
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44SOAP::Lite is a collection of Perl modules which provides a simple and
45lightweight interface to the Simple Object Access Protocol (SOAP) both
46on client and server side.
47
22bcd800
JR
48%description -l pl.UTF-8
49SOAP::Lite to zestaw modułów Perla udostępniających prosty i lekki
50interfejs do protokołu SOAP (Simple Object Access Protocol) zarówno po
6ec1dd5b 51stronie klienta, jak i serwera.
31bb3d7a 52
896d4f45 53%package JABBER
54Summary: Net::Jabber support for SOAP::Lite
46602663 55Summary(pl.UTF-8): Obsługa Net::Jabber dla SOAP::Lite
896d4f45 56Group: Development/Languages/Perl
57
58%description JABBER
59JABBER transport support for SOAP::Lite (SOAP::Transport::JABBER).
60
22bcd800
JR
61%description JABBER -l pl.UTF-8
62Obsługa transportu JABBER dla SOAP::Lite (SOAP::Transport::JABBER).
896d4f45 63
64%package MQ
65Summary: MQ transport support for SOAP::Lite (SOAP::Transport::MQ)
46602663 66Summary(pl.UTF-8): Obsługa transportu MQ dla SOAP::Lite (SOAP::Transport::MQ)
896d4f45 67Group: Development/Languages/Perl
68
69%description MQ
70MQ transport support for SOAP::Lite (SOAP::Transport::MQ).
71
22bcd800
JR
72%description MQ -l pl.UTF-8
73Obsługa transportu MQ dla SOAP::Lite (SOAP::Transport::MQ).
896d4f45 74
31bb3d7a 75%package examples
76Summary: SOAP::Lite - examples
46602663 77Summary(pl.UTF-8): Przykłady użycia SOAP::Lite
31bb3d7a 78Group: Development/Languages/Perl
79
80%description examples
81Examples for SOAP::Lite.
82
22bcd800
JR
83%description examples -l pl.UTF-8
84Przykłady użycia SOAP::Lite.
f98f94bf 85
31bb3d7a 86%prep
21071a3c 87%setup -q -n %{pdir}-%{pnam}-%{real_version}
31bb3d7a 88%{__chmod} u+rw . -R
89
90%build
ca70e9cc 91%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"SOAP::Lite")' \
92 INSTALLDIRS=vendor
31bb3d7a 93%{__make}
94
c27651d1 95%{?with_tests:%{__make} test}
31bb3d7a 96
97%install
98rm -rf $RPM_BUILD_ROOT
71c0c1db 99install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
31bb3d7a 100
71c0c1db
PG
101%{__make} install \
102 DESTDIR=$RPM_BUILD_ROOT
6ec1dd5b 103cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
31bb3d7a 104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(644,root,root,755)
110%doc Changes README
ca70e9cc 111%{perl_vendorlib}/Apache/*.pm
112%dir %{perl_vendorlib}/Apache/XMLRPC
113%{perl_vendorlib}/Apache/XMLRPC/*.pm
114%{perl_vendorlib}/IO/*.pm
115%{perl_vendorlib}/SOAP/*.pm
116%{perl_vendorlib}/SOAP/Transport/[FHILPT]*.pm
117%{perl_vendorlib}/SOAP/Transport/MAILTO.pm
118%dir %{perl_vendorlib}/UDDI
119%{perl_vendorlib}/UDDI/*.pm
120%{perl_vendorlib}/XML/Parser/*.pm
121%dir %{perl_vendorlib}/XMLRPC
122%{perl_vendorlib}/XMLRPC/*.pm
123%dir %{perl_vendorlib}/XMLRPC/Transport
124%{perl_vendorlib}/XMLRPC/Transport/*.pm
896d4f45 125%{_mandir}/man3/Apache*
126%{_mandir}/man3/UDDI*
127%{_mandir}/man3/XML*
128%{_mandir}/man3/SOAP::Lite*
129%{_mandir}/man3/SOAP::Test*
130%{_mandir}/man3/SOAP::Transport::[FHILPT]*
896d4f45 131
8649fb51 132%if %{with MQ}
896d4f45 133%files MQ
134%defattr(644,root,root,755)
ca70e9cc 135%{perl_vendorlib}/SOAP/Transport/MQ.pm
896d4f45 136%{_mandir}/man3/*::MQ.*
8649fb51 137%endif
896d4f45 138
139%files JABBER
140%defattr(644,root,root,755)
ca70e9cc 141%{perl_vendorlib}/SOAP/Transport/JABBER.pm
896d4f45 142%{_mandir}/man3/*JABBER*
31bb3d7a 143
144%files examples
145%defattr(644,root,root,755)
146%{_examplesdir}/%{name}-%{version}
This page took 0.081196 seconds and 4 git commands to generate.