]> git.pld-linux.org Git - packages/perl-Params-Coerce.git/blame - perl-Params-Coerce.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Params-Coerce.git] / perl-Params-Coerce.spec
CommitLineData
1cc55b6c 1#
2# Conditional build:
3%bcond_without autodeps # don't BR packages needed only for resolving deps
4%bcond_without tests # do not perform "make test"
5#
1cc55b6c 6%define pdir Params
7%define pnam Coerce
10f87099
JB
8Summary: Params::Coerce - allows your classes to do coercion of parameters
9Summary(pl.UTF-8): Params::Coerce - umożliwienie klasom jawnej kowersji typów parametrów
1cc55b6c 10Name: perl-Params-Coerce
11Version: 0.14
12Release: 1
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: a8439ea6777c9156424ef6dd74c83945
17URL: http://search.cpan.org/dist/Params-Coerce/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with autodeps} || %{with tests}
21BuildRequires: perl-Params-Util >= 0.05
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27A big part of good API design is that we should be able to be flexible
28in the ways that we take parameters.
29
30Params::Coerce attempts to encourage this, by making it easier to take
10f87099 31a variety of different arguments, while adding negligible additional
1cc55b6c 32complexity to your code.
33
10f87099 34"Coercion" in computing terms generally refers to "implicit type
1cc55b6c 35conversion". This is where data and object are converted from one type
36to another behind the scenes, and you just just magically get what you
37need.
38
1cc55b6c 39%description -l pl.UTF-8
40Dużą częścią dobrego projektu API jest możliwość elastycznego
10f87099
JB
41przekazywania parametrów.
42
43Params::Coerce próbuje zachęcić do tego poprzez ułatwianie
44przyjmowania różnych argumentów przy zaniedbywalnie małej komplikacji
45kodu.
1cc55b6c 46
10f87099
JB
47"Coercion" oznacza "domyślną konwersję typów". Dotyczy to sytuacji,
48kiedy dane i obiekty są w tle konwertowane z jednego typu do innego i
49magicznie otrzymuje się to, co potrzeba.
1cc55b6c 50
51%prep
52%setup -q -n %{pdir}-%{pnam}-%{version}
53
54%build
55%{__perl} Makefile.PL \
56 INSTALLDIRS=vendor
57%{__make}
58
59%{?with_tests:%{__make} test}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64%{__make} install \
65 DESTDIR=$RPM_BUILD_ROOT
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc Changes README
10f87099
JB
73%{perl_vendorlib}/Params/Coerce.pm
74%{_mandir}/man3/Params::Coerce.3pm*
This page took 0.087403 seconds and 4 git commands to generate.