]> git.pld-linux.org Git - packages/perl-POE.git/blame - perl-POE.spec
- new
[packages/perl-POE.git] / perl-POE.spec
CommitLineData
3cc62918 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir POE
7Summary: POE - multitasking and networking framework for perl
8#Summary(pl):
9Name: perl-POE
10Version: 0.26
11Release: 1
12# same as perl
13License: GPL/Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16URL: http://poe.perl.org/
17BuildRequires: perl-devel >= 5.6
18BuildRequires: rpm-perlprov >= 4.1-13
19%if %{!?_without_tests:1}0
20BuildRequires: perl(Filter::Util::Call) >= 1.04
21BuildRequires: perl-Compress-Zlib
22BuildRequires: perl-Curses
23BuildRequires: perl-Event
24BuildRequires: perl-IO-Tty
25BuildRequires: perl-Storable
26BuildRequires: perl-Term-ReadKey
27BuildRequires: perl-Time-HiRes
28BuildRequires: perl-URI
29BuildRequires: perl-libwww
30%endif
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _noautoreq perl(Curses) perl(HTTP::Date) perl(HTTP::Request) perl(HTTP::Response) perl(HTTP::Status) perl(URI) perl(Term::Cap) perl(Term::ReadKey)
35
36%description
37POE is an acronym of "Perl Object Environment". It's a networking
38and multitasking (some say cooperative threading) framework for Perl.
39It has been in active development since 1996, with its first open
40release in 1998. O'Reilly's Perl Conference (now OSCON) named POE
41"Best New Module" in 1999.
42
43POE has been used in mission-critical systems such as internetworked
44financial markets, file systems, commerce and application servers.
45It has been used in projects ranging from a few lines of code to tens
46of thousands.
47
48POE is compatible with perl versions as old as 5.005_03.
49
50POE includes an evolving component framework. Components are high-level,
51modular, reusable pieces of programs. Several components have been
52published on the CPAN, and more are listed on POE's web site.
53
54POE includes components and libraries for making quick work of network
55clients, servers, and peers. A simple stand-alone web application takes
56about 30 lines of code, most of which is your own custom logic.
57
58# %description -l pl
59# TODO
60
61%prep
62%setup -q -n %{pdir}-%{version}
63
64%build
65%{__perl} Makefile.PL \
66 INSTALLDIRS=vendor \
67 --default
68%{__make}
69
70%if %{!?_without_tests:1}0
71%{__chmod} 000 t/06_tk.t t/21_gtk.t
72%{__make} test
73%endif
74
75install -d $RPM_BUILD_ROOT%{perl_vendorlib}/POE/Component/CD
76
77install -d $RPM_BUILD_ROOT%{_examplesdir}
78cp -r samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%{__make} install \
84 DESTDIR=$RPM_BUILD_ROOT
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc CHANGES NEEDS README TODO
92%{perl_vendorlib}/%{pdir}
93%{_mandir}/man3/*
This page took 0.062071 seconds and 4 git commands to generate.