]> git.pld-linux.org Git - packages/perl-POE-Component-Pluggable.git/blame - perl-POE-Component-Pluggable.spec
- initial
[packages/perl-POE-Component-Pluggable.git] / perl-POE-Component-Pluggable.spec
CommitLineData
67693dbb 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir POE
7%define pnam Component-Pluggable
8Summary: POE::Component::Pluggable - A base class for creating plugin-enabled POE Components
9Summary(pl.UTF-8): POE::Component::Pluggable - klasa bazowa do tworzenia komponentów POE jako wtyczek
10Name: perl-POE-Component-Pluggable
11Version: 1.24
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 6627cbbb234c1295b63e23f88b8de976
18URL: http://search.cpan.org/dist/POE-Component-Pluggable/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-ExtUtils-MakeMaker >= 6.42
23BuildRequires: perl-POE >= 1.004
24BuildRequires: perl-Task-Weaken
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30POE::Component::Pluggable is a base class for creating plugin enabled
31POE Components. It is a generic port of POE::Component::IRC's plugin
32system.
33
34If your component dispatches events to registered POE sessions, then
35POE::Component::Pluggable may be a good fit for you.
36
37%description -l pl.UTF-8
38POE::Component::Pluggable jest klasą bazową dla tworzenia komponentów
39POE jako wtyczek. Jest to ogólny port systemu wtyczek
40POE::Component::IRC.
41
42%prep
43%setup -q -n %{pdir}-%{pnam}-%{version}
44
45%build
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48%{__make}
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc Changes README
67%{perl_vendorlib}/POE/Component/*.pm
68%{perl_vendorlib}/POE/Component/Pluggable
69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.077476 seconds and 4 git commands to generate.