]> git.pld-linux.org Git - packages/perl-PAR-Dist.git/blame - perl-PAR-Dist.spec
- initial revision
[packages/perl-PAR-Dist.git] / perl-PAR-Dist.spec
CommitLineData
1f618b70 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir PAR
7%define pnam Dist
8Summary: Create and manipulate PAR distributions
9Name: perl-%{pdir}-%{pnam}
10Version: 0.05
11Release: 1
12License: Same as Perl itself
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15URL: http://par.perl.org
16BuildRequires: perl-devel >= 5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22This module creates and manipulates PAR distributions. They are archi-
23tecture-specific PAR files, containing everything under blib/ of CPAN
24distributions after their "make" or "Build" stage, a META.yml describ-
25ing metadata of the original CPAN distribution, and a MANIFEST detail-
26ing all files within it. Digitally signed PAR distributions will also
27contain a SIGNATURE file.
28
29%prep
30%setup -q -n %{pdir}-%{pnam}-%{version}
31
32%build
33%{__perl} Makefile.PL \
34 INSTALLDIRS=vendor
35%{__make}
36%{!?_without_tests:%{__make} test}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
41%{__make} install \
42 DESTDIR=$RPM_BUILD_ROOT
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(644,root,root,755)
49%doc Changes README
50%dir %{perl_vendorlib}/PAR
51%{perl_vendorlib}/PAR/*.pm
52%{_mandir}/man3/*
This page took 0.043104 seconds and 4 git commands to generate.