]> git.pld-linux.org Git - packages/perl-Math-Geometry-Voronoi.git/blame - perl-Math-Geometry-Voronoi.spec
- release 6 (by relup.sh)
[packages/perl-Math-Geometry-Voronoi.git] / perl-Math-Geometry-Voronoi.spec
CommitLineData
a3649d16
AM
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Math
6%define pnam Geometry-Voronoi
7%include /usr/lib/rpm/macros.perl
8Summary: Math::Geometry::Voronoi - compute Voronoi diagrams from sets of points
9Name: perl-Math-Geometry-Voronoi
10Version: 1.3
15fbdd27 11Release: 6
a3649d16
AM
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: 44392be55ff56870aaff286dd735a5e2
16URL: http://search.cpan.org/dist/Math-Geometry-Voronoi/
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19%if %{with tests}
20BuildRequires: perl-Class-Accessor
21BuildRequires: perl-Params-Validate
22%endif
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This module computes Voronoi diagrams from a set of input points. Info
27on Voronoi diagrams can be found here:
28
29http://en.wikipedia.org/wiki/Voronoi_diagram
30
31This module is a wrapper around a C implementation found here:
32
33http://www.derekbradley.ca/voronoi.html
34
35Which is itself a modification of code by Steve Fortune, the inventor
36of the algorithm used (Fortune's algorithm):
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make} \
45 CC="%{__cc}" \
46 OPTIMIZE="%{rpmcflags}"
47
48%{?with_tests:%{__make} test}
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%{__make} pure_install \
54 DESTDIR=$RPM_BUILD_ROOT
55
56install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc Changes README
65%{perl_vendorarch}/Math/Geometry/Voronoi.pm
66%dir %{perl_vendorarch}/auto/Math/Geometry/Voronoi
67%attr(755,root,root) %{perl_vendorarch}/auto/Math/Geometry/Voronoi/Voronoi.so
68%{_mandir}/man3/*
69%{_examplesdir}/%{name}-%{version}
This page took 0.157751 seconds and 4 git commands to generate.