]> git.pld-linux.org Git - packages/perl-Math-ConvexHull-MonotoneChain.git/blame - perl-Math-ConvexHull-MonotoneChain.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Math-ConvexHull-MonotoneChain.git] / perl-Math-ConvexHull-MonotoneChain.spec
CommitLineData
8131c086
AM
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Math
6%define pnam ConvexHull-MonotoneChain
8131c086
AM
7Summary: Math::ConvexHull::MonotoneChain - Andrew's monotone chain algorithm for finding a convex hull in 2D
8Name: perl-Math-ConvexHull-MonotoneChain
9Version: 0.01
503e58cd 10Release: 7
8131c086
AM
11License: Perl
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
14# Source0-md5: eaac1a9350f914fea5bbce2029b95b57
15URL: http://search.cpan.org/dist/Math-ConvexHull-MonotoneChain/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21This is somewhat experimental still.
22
23This (XS) module optionally exports a single function convex_hull
24which calculates the convex hull of the input points and returns it.
25The algorithm is O(n log n) due to having to sort the input list, but
26should be somewhat faster than a plain Graham's scan (also O(n log n))
27in practice since it avoids polar coordinates.
28
29%prep
30%setup -q -n %{pdir}-%{pnam}-%{version}
31
32%build
33%{__perl} Makefile.PL \
34 INSTALLDIRS=vendor
35%{__make} \
36 CC="%{__cc}" \
37 OPTIMIZE="%{rpmcflags}"
38
39%{?with_tests:%{__make} test}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43
44%{__make} pure_install \
45 DESTDIR=$RPM_BUILD_ROOT
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%doc Changes
fbeb240c 53%dir %{perl_vendorarch}/Math/ConvexHull
8131c086 54%{perl_vendorarch}/Math/ConvexHull/MonotoneChain.pm
fbeb240c 55%dir %{perl_vendorarch}/auto/Math/ConvexHull
8131c086
AM
56%dir %{perl_vendorarch}/auto/Math/ConvexHull/MonotoneChain
57%attr(755,root,root) %{perl_vendorarch}/auto/Math/ConvexHull/MonotoneChain/MonotoneChain.so
58%{_mandir}/man3/*
This page took 0.094058 seconds and 4 git commands to generate.