]> git.pld-linux.org Git - packages/perl-JSON-XS.git/blame - perl-JSON-XS.spec
- release 3
[packages/perl-JSON-XS.git] / perl-JSON-XS.spec
CommitLineData
d06aa346
AF
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir JSON
7%define pnam XS
8Summary: JSON::XS - JSON serialising/deserialising, done correctly and fast
cec964cc 9Summary(pl.UTF-8): JSON::JS - serializacja/deserializacja JSON wykonana poprawnie i szybko
d06aa346 10Name: perl-JSON-XS
7d069ff1 11Version: 2.01
cdb8dc8c 12Release: 3
d06aa346
AF
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
cec964cc 16Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{pnam}-%{version}.tar.gz
7d069ff1 17# Source0-md5: 9e802215f9c915f2b3edfaeaba8cf2fb
cec964cc 18URL: http://search.cpan.org/dist/JSON-XS/
d06aa346
AF
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
d06aa346
AF
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24This module converts Perl data structures to JSON and vice versa. Its
25primary goal is to be correct and its secondary goal is to be
26fast. To reach the latter goal it was written in C.
27
28As this is the n-th-something JSON module on CPAN, what was the reason
29to write yet another JSON module? While it seems there are many JSON
cec964cc
JB
30modules, none of them correctly handle all corner cases, and in most
31cases their maintainers are unresponsive, gone missing, or not
32listening to bug reports for other reasons.
d06aa346 33
cec964cc
JB
34%description -l pl.UTF-8
35Ten moduł konwertuje struktury danych Perla do formatu JSON i
36odwrotnie. Jego podstawowym celem jest poprawne działanie, a drugim -
37szybkość. W celu osiągnięcia tego drugiego celu został napisany w C.
d06aa346 38
cec964cc
JB
39Jako że jest to już któryś moduł JSON w CPAN-ie, musiała istnieć jakaś
40przyczyna dla napisania kolejnego modułu JSON. O ile istnieje wiele
41takich modułów, żaden z nich nie obsługiwał wszystkich skrajnych
42przypadków i w większości przypadków utrzymujący moduły nie
43odpowiadali, zaginęli lub z innych powodów nie zwracali uwagi na
44zgłoszenia błędów.
d06aa346
AF
45
46%prep
47%setup -q -n %{pdir}-%{pnam}-%{version}
48
49%build
50%{__perl} Makefile.PL \
51 INSTALLDIRS=vendor
52%{__make} \
0e022f03 53 CC="%{__cc}" \
d06aa346
AF
54 OPTIMIZE="%{rpmcflags}"
55
56%{?with_tests:%{__make} test}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc Changes README
73%{perl_vendorarch}/JSON/*.pm
7d069ff1 74%{perl_vendorarch}/JSON/XS
cddcb278 75%dir %{perl_vendorarch}/auto/JSON
d06aa346 76%dir %{perl_vendorarch}/auto/JSON/XS
d06aa346
AF
77%attr(755,root,root) %{perl_vendorarch}/auto/JSON/XS/*.so
78%{_mandir}/man3/*
79%{_examplesdir}/%{name}-%{version}
This page took 0.078611 seconds and 4 git commands to generate.