]> git.pld-linux.org Git - packages/perl-Email-Abstract.git/blame - perl-Email-Abstract.spec
- BuildRequires: perl-Email-Simple, perl-Module-Pluggable
[packages/perl-Email-Abstract.git] / perl-Email-Abstract.spec
CommitLineData
d977f7d1
AG
1# ToDo:
2# - pl summary/description
5e47a3fa
AG
3#
4# Conditional build:
5%bcond_without tests # do not perform "make test"
6#
7%include /usr/lib/rpm/macros.perl
8%define pdir Email
9%define pnam Abstract
10Summary: Unified interface to mail representations
11Summary(pl): Zunifikiowany interfejs do prezentacji maili
12Name: perl-%{pdir}-%{pnam}
13Version: 1.0
14Release: 1
15# note if it is "same as perl"
16License: GPL v1+ or Artistic
17Group: Development/Languages/Perl
18Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
19# Source0-md5: ed5f792c40511b23356cefeea22b0703
d977f7d1
AG
20BuildRequires: perl-Email-Simple
21BuildRequires: perl-Module-Pluggable
5e47a3fa
AG
22BuildRequires: perl-devel >= 1:5.8.0
23BuildRequires: rpm-perlprov >= 4.1-13
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
5e47a3fa
AG
27%description
28Email::Abstract provides module writers with the ability to write
29representation-independent mail handling code. For instance, in the
30cases of Mail::Thread or Mail::ListDetector, a key part of the code
31involves reading the headers from a mail object. Where previously one
32would either have to specify the mail class required, or to build a
33new object from scratch, Email::Abstract can be used to perform
34certain simple operations on an object regardless of its underlying
35representation.
36
37Email::Abstract currently supports Mail::Internet, MIME::Entity,
38Mail::Message, Email::Simple and Email::MIME. Other representations
39are encouraged to create their own Email::Abstract::* class by copying
40Email::Abstract::EmailSimple. All modules installed under the
41Email::Abstract hierarchy will be automatically picked up and used.
42
43#%description -l pl
44
45%prep
46%setup -q -n %{pdir}-%{pnam}-%{version}
47
48%build
5e47a3fa
AG
49%{__perl} Makefile.PL \
50 INSTALLDIRS=vendor
51
52%{__make}
5e47a3fa
AG
53
54%{?with_tests:%{__make} test}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59%{__make} install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%doc Changes README
5e47a3fa
AG
68%{perl_vendorlib}/Email/Abstract.pm
69%{perl_vendorlib}/Email/Abstract
70%{_mandir}/man3/*
This page took 0.063237 seconds and 4 git commands to generate.