]> git.pld-linux.org Git - packages/perl-Device-USB.git/blame - perl-Device-USB.spec
- updated to 0.29
[packages/perl-Device-USB.git] / perl-Device-USB.spec
CommitLineData
912a3b4b 1#
2# Conditional build:
45fc015c 3%bcond_with tests # perform "make test"
912a3b4b 4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Device
7%define pnam USB
8Summary: Device::USB - Use libusb to access USB devices
9Name: perl-Device-USB
45fc015c 10Version: 0.29
912a3b4b 11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://search.cpan.org/CPAN/authors/id/G/GW/GWADEJ/Device-USB-%{version}.tar.gz
45fc015c 16# Source0-md5: 34dff1d278c5496069ad73a1ef956bf4
912a3b4b 17URL: http://search.cpan.org/dist/Device-USB/
18BuildRequires: libusb-devel
19BuildRequires: perl-Inline
20BuildRequires: perl-Inline-C
21BuildRequires: perl-Parse-RecDescent
22BuildRequires: perl-devel >= 1:5.8.0
23BuildRequires: rpm-perlprov >= 4.1-13
912a3b4b 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This module provides a Perl interface to the C library libusb. This
28library supports a relatively full set of functionality to access a
29USB device. In addition to the libusb, functioality, Device::USB
30provides a few convenience features that are intended to produce a
31more Perl-ish interface.
32
33%prep
34%setup -q -n %{pdir}-%{pnam}-%{version}
35
36%build
37%{__perl} Makefile.PL \
38 INSTALLDIRS=vendor
39%{__make}
40
41%{?with_tests:%{__make} test}
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46%{__make} pure_install \
47 DESTDIR=$RPM_BUILD_ROOT
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(644,root,root,755)
54%doc Changes README
55%{perl_vendorarch}/Device/*.pm
56%{perl_vendorarch}/Device/USB
57%attr(755,root,root) %{perl_vendorarch}/Device/dump_usb.pl
58%dir %{perl_vendorarch}/auto/Device/USB
59%{perl_vendorarch}/auto/Device/USB/*.bs
60%attr(755,root,root) %{perl_vendorarch}/auto/Device/USB/*.so
61%{_mandir}/man3/*
This page took 0.050928 seconds and 4 git commands to generate.