]> git.pld-linux.org Git - packages/perl-DBIx-Class.git/blame - perl-DBIx-Class.spec
- version 0.08012
[packages/perl-DBIx-Class.git] / perl-DBIx-Class.spec
CommitLineData
28e72b45 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir DBIx
7%define pnam Class
8Summary: DBIx::Class - Extensible and flexible object <-> relational mapper
b40db49d 9Summary(pl.UTF-8): DBIx::Class - rozszerzalne i elastyczne wiązanie obiektów <-> relacji
28e72b45 10Name: perl-DBIx-Class
56c77dbb 11Version: 0.08012
12Release: 1
28e72b45 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
2de26f35 16Source0: http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
56c77dbb 17# Source0-md5: 8d8c526f812d6213a04c6644d52a44b1
2de26f35 18URL: http://search.cpan.org/dist/DBIx-Class/
28e72b45 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
68c9fde7 22BuildRequires: perl-Carp-Clan
fa300319 23BuildRequires: perl-Class-Accessor-Chained
470df693 24BuildRequires: perl-Class-Accessor-Grouped >= 0.05002
209a3938 25BuildRequires: perl-Class-C3 >= 0.13
26BuildRequires: perl-Class-C3-Componentised
68c9fde7 27BuildRequires: perl-Class-Data-Accessor >= 0.01
209a3938 28BuildRequires: perl-Class-Inspector >= 1.16
d28fa658 29BuildRequires: perl-Class-Trigger
209a3938 30BuildRequires: perl-DBD-SQLite >= 1.13
68c9fde7 31BuildRequires: perl-DBI >= 1.40
d28fa658 32BuildRequires: perl-DBIx-ContextualFetch
33BuildRequires: perl-Data-Page >= 2.00
34BuildRequires: perl-Data-UUID
209a3938 35BuildRequires: perl-DateTime
28e72b45 36BuildRequires: perl-Module-Find
b0cc6892 37BuildRequires: perl-PadWalker >= 1.0
28e72b45 38BuildRequires: perl-SQL-Abstract >= 1.2
39BuildRequires: perl-SQL-Abstract-Limit >= 0.11
d28fa658 40BuildRequires: perl-SQL-Translator
209a3938 41BuildRequires: perl-Scope-Guard >= 0.03
d28fa658 42BuildRequires: perl-Test-Memory-Cycle
28e72b45 43%endif
44BuildArch: noarch
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
bb417167 47# Only APR::UUID is available in PLD. And if it was we would still
68c9fde7 48# need only one of Data::UUID, Data::Uniqid, APR::UUID or UUID at any
49# time to get full functionality
6de6ed6d 50%define _noautoreq 'perl(Data::Uniqid)' 'perl(UUID)' 'perl(APR::UUID)' 'perl(JSON)' 'perl(DBD::Multi)' 'perl(DBIC::SQL::Abstract)'
68c9fde7 51
28e72b45 52%description
ea7faab8
JB
53DBIx::Class is a SQL to OOP mapper, inspired by the Class::DBI
54framework, and meant to support compability with it, while
55restructuring the insides, and making it possible to support some new
56features like self-joins, distinct, group bys and more.
28e72b45 57
58It's currently considered EXPERIMENTAL - bring this near a production
ea7faab8
JB
59database at your own risk! The API is *not* fixed yet, although most
60of the primitives should be good for the future and any API changes
61will be posted to the mailing list before they're committed.
28e72b45 62
c133fc03
JR
63%description -l pl.UTF-8
64DBIx::Class to klasa odwzorowująca SQL na OOP, zainspirowana
65szkieletem Class::DBI, mająca obsługiwać kompatibilność z nim, ale
66restrukturyzując wnętrzności i umożliwiając obsługę niektórych nowych
67możliwości, takie jak "self-join", "distinct", "group by" i inne.
28e72b45 68
c133fc03
JR
69Ten moduł jest aktualnie uważany za EKSPERYMENTALNY - zbliżać go do
70baz produkcyjnych można tylko na własne ryzyko! API nie zostało
71jeszcze ustalone, choć większość prymitywów powinna być dobra na
72przyszłość i każda zmiana API jest wysyłana na listę dyskusyjną przed
ea7faab8 73zatwierdzeniem.
28e72b45 74
82abf19e 75%package -n perl-SQL-Translator-DBIx-Class
76Summary: DBIx::Class schema parser and file producer
b40db49d 77Summary(pl.UTF-8): Narzędzie do analizy schematów i tworzenia plików DBIx::Class
82abf19e 78Group: Development/Languages/Perl
79
80%description -n perl-SQL-Translator-DBIx-Class
81This package contains SQL::Translator (sqlfairy) parser for
8b743272
JB
82DBIx::Class::Schema objects and producer for DBIx::Class files.
83
c133fc03
JR
84%description -n perl-SQL-Translator-DBIx-Class -l pl.UTF-8
85Ten pakiet zawiera analizator SQL::Translator (sqlfairy) dla obiektów
86DBIx::Class::Schema oraz generator plików DBIx::Class.
82abf19e 87
28e72b45 88%prep
89%setup -q -n %{pdir}-%{pnam}-%{version}
90
6de6ed6d 91# SQL::Translator is FUBAR
92mv t/94versioning.t{,.fubar}
93
28e72b45 94%build
889ed4cc 95%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"DBIx::Class", EXE_FILES=>[<script/*>])' \
209a3938 96 INSTALLDIRS=vendor
97%{__make}
28e72b45 98
209a3938 99%{?with_tests:%{__make} test}
28e72b45 100
101%install
102rm -rf $RPM_BUILD_ROOT
103
209a3938 104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
106
82abf19e 107install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DBIx/Class/Schema
28e72b45 108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files
113%defattr(644,root,root,755)
889ed4cc 114%doc Changes
b0cc6892 115%attr(755,root,root) %{_bindir}/*
28e72b45 116%{perl_vendorlib}/DBIx/*.pm
117%{perl_vendorlib}/DBIx/Class
118%{_mandir}/man3/*
b0cc6892 119%{_mandir}/man1/*
82abf19e 120
121%files -n perl-SQL-Translator-DBIx-Class
122%defattr(644,root,root,755)
123%{perl_vendorlib}/SQL/Translator/Parser/*
124%{perl_vendorlib}/SQL/Translator/Producer/*
This page took 0.053074 seconds and 4 git commands to generate.