]> git.pld-linux.org Git - packages/perl-Coro.git/blame - perl-Coro.spec
- fixed path to perl binary
[packages/perl-Coro.git] / perl-Coro.spec
CommitLineData
1c4a8a32 1# NOTE: perl-AnyEvent requires perl(Core::{Event,Signal})
a7b1870a
AM
2#
3# Conditional build:
4%bcond_without tests # do not perform "make test"
5#
6%include /usr/lib/rpm/macros.perl
7%define pdir Coro
8%define pnam Coro
9Summary: Coro - do events the coro-way
3511a7f7 10Summary(pl.UTF-8): Coro - obsługa zdarzeń na sposób coro
a7b1870a 11Name: perl-Coro
2d407183 12Version: 6.06
ea9d2bf4 13Release: 1
a7b1870a
AM
14# same as perl
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
620371d5 17Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
2d407183 18# Source0-md5: 2ee54f58bced7471f77149e97c73a94f
f0cda515 19Patch0: kill-blocked-test.patch
15fe6aa3 20URL: http://search.cpan.org/dist/Coro/
1c056a72 21BuildRequires: perl-AnyEvent >= 2:5.0
22BuildRequires: perl-EV >= 1:3.3
28f3a076 23BuildRequires: perl-Event >= 1.08
620371d5 24BuildRequires: perl-devel >= 1:5.8.2
a7b1870a 25BuildRequires: rpm-perlprov >= 4.1-13
156477a5 26BuildRequires: sed >= 4.0
ea9d2bf4 27%if %{with tests}
620371d5 28BuildRequires: perl-Guard >= 0.5
620371d5
JB
29BuildRequires: perl-Storable >= 2.15
30BuildRequires: perl-Time-HiRes
31BuildRequires: perl-common-sense
ea9d2bf4 32%endif
a7b1870a
AM
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36This module enables you to create programs using the powerful Event
37model (and module), while retaining the linear style known from simple
38or threaded programs.
39
4462add0
JR
40%description -l pl.UTF-8
41Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
42(i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
43wątkowych programów.
15fe6aa3 44
a7b1870a
AM
45%prep
46%setup -q -n %{pnam}-%{version}
f0cda515 47%patch0 -p1
a7b1870a 48
156477a5 49%{__sed} -i "s^/opt/bin/perl^%{_bindir}/perl^" Coro/jit*pl
50
a7b1870a 51%build
1c056a72 52echo "y" | %{__perl} Makefile.PL \
a7b1870a
AM
53 INSTALLDIRS=vendor
54%{__make} \
304ecfbc 55 CC="%{__cc}" \
a7b1870a
AM
56 OPTIMIZE="%{rpmcflags}"
57
1c056a72 58%{?with_tests:%{__make} -j1 test}
a7b1870a
AM
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
88fcb4b4 71%doc Changes INSTALL README README.linux-glibc
a7b1870a
AM
72%{perl_vendorarch}/Coro.pm
73%{perl_vendorarch}/Coro
74%dir %{perl_vendorarch}/auto/Coro
ea9d2bf4 75%dir %{perl_vendorarch}/auto/Coro/EV
620371d5
JB
76%{perl_vendorarch}/auto/Coro/EV/EV.bs
77%attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
88fcb4b4 78%dir %{perl_vendorarch}/auto/Coro/Event
620371d5
JB
79%{perl_vendorarch}/auto/Coro/Event/Event.bs
80%attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
88fcb4b4 81%dir %{perl_vendorarch}/auto/Coro/State
620371d5
JB
82%{perl_vendorarch}/auto/Coro/State/State.bs
83%attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
84%{_mandir}/man3/Coro*.3pm*
This page took 0.37523 seconds and 4 git commands to generate.