]> git.pld-linux.org Git - packages/perl-Algorithm-Huffman.git/blame - perl-Algorithm-Huffman.spec
- new, STBR
[packages/perl-Algorithm-Huffman.git] / perl-Algorithm-Huffman.spec
CommitLineData
ba5ab7fb 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4%include /usr/lib/rpm/macros.perl
5%define pdir Algorithm
6%define pnam Huffman
7Summary: Algorithm::Huffman - Implementation of the Huffman algorithm
8Summary(pl): Algorithm::Huffman - Implementacja algorytmu Huffmana
9Name: perl-Algorithm-Huffman
10Version: 0.05
11Release: 1
12License: GPL/Artistic
13Group: Development/Languages/Perl
14Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15BuildRequires: perl >= 5.6
16BuildRequires: rpm-perlprov >= 3.0.3-26
17%if %{?_without_tests:0}%{!?_without_tests:1}
18BuildRequires: perl-Heap
19BuildRequires: perl-Scalar-List-Utils
20BuildRequires: perl-String-Random
21BuildRequires: perl-Test-Exception
22BuildRequires: perl-Test-ManyParams
23BuildRequires: perl-Test-Simple
24BuildRequires: perl-Tree-DAG_Node
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30This modules implements the huffman algorithm. The aim is to create
31a good coding scheme for a given list of different characters (or even
32strings) and their occurence numbers.
33
34# %description -l pl
35# TODO
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
40%build
41perl Makefile.PL
42%{__make}
43
44%{!?_without_tests:%{__make} test}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%{perl_sitelib}/%{pdir}/*.pm
57%{_mandir}/man3/*
This page took 0.087619 seconds and 4 git commands to generate.