]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
- forced password change
[packages/openssh.git] / openssh.spec
CommitLineData
52000378
AF
1Summary: OpenSSH free Secure Shell (SSH) implementation
2Name: openssh
3Version: 1.2pre15
4Release: 2
ec00afd0 5Source0: http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
52000378
AF
6Source1: opensshd.conf
7Source2: openssh.conf
8Source3: opensshd.init
9Source4: opensshd.pamd
10Source5: openssh.sysconfig
ec00afd0 11Source6: passwd.pamd
52000378
AF
12Patch0: openssh-ssl.patch
13Patch1: openssh-DESTDIR.patch
ec00afd0 14Patch2: openssh-PAM_NEW_AUTHTOK.patch
52000378
AF
15License: BSD
16Group: Applications/Networking
17Group(pl): Aplikacje/Sieciowe
18BuildRequires: openssl-devel
19BuildRequires: zlib-devel
20BuildRequires: pam-devel
21BuildRequires: XFree86-devel
22BuildRequires: gnome-libs-devel
23BuildRoot: /tmp/%{name}-%{version}-root
24Obsoletes: ssh
25
b7b47957 26%define _sysconfdir /etc/ssh
6fe24471
AF
27
28%description
29Ssh (Secure Shell) a program for logging into a remote machine and for
30executing commands in a remote machine. It is intended to replace
31rlogin and rsh, and provide secure encrypted communications between
32two untrusted hosts over an insecure network. X11 connections and
33arbitrary TCP/IP ports can also be forwarded over the secure channel.
34
35OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
36up to date in terms of security and features, as well as removing all
37patented algorithms to seperate libraries (OpenSSL).
38
52000378
AF
39This package includes the core files necessary for both the OpenSSH
40client and server. To make this package useful, you should also
41install openssh-clients, openssh-server, or both.
6fe24471 42
52000378
AF
43%package clients
44Summary: OpenSSH Secure Shell protocol clients
45Requires: openssh
46Group: Applications/Networking
47Group(pl): Aplikacje/Sieciowe
48Obsoletes: ssh-clients
49Requires: %{name} = %{version}
6fe24471 50
52000378
AF
51%description clients
52Ssh (Secure Shell) a program for logging into a remote machine and for
53executing commands in a remote machine. It is intended to replace
54rlogin and rsh, and provide secure encrypted communications between
55two untrusted hosts over an insecure network. X11 connections and
56arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 57
52000378
AF
58OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
59up to date in terms of security and features, as well as removing all
60patented algorithms to seperate libraries (OpenSSL).
61
62This package includes the clients necessary to make encrypted connections
63to SSH servers.
64
65%package server
66Summary: OpenSSH Secure Shell protocol server (sshd)
67Requires: openssh chkconfig >= 0.9
68Group: Networking/Daemons
69Group(pl): Sieciowe/Serwery
70Obsoletes: ssh-server
71Requires: rc-scripts
72Prereq: %{name} = %{version}
73
74%description server
75Ssh (Secure Shell) a program for logging into a remote machine and for
76executing commands in a remote machine. It is intended to replace
77rlogin and rsh, and provide secure encrypted communications between
78two untrusted hosts over an insecure network. X11 connections and
79arbitrary TCP/IP ports can also be forwarded over the secure channel.
80
81OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
82up to date in terms of security and features, as well as removing all
83patented algorithms to seperate libraries (OpenSSL).
84
85This package contains the secure shell daemon. The sshd is the server
86part of the secure shell protocol and allows ssh clients to connect to
87your host.
6fe24471 88
52000378
AF
89%package askpass
90Summary: OpenSSH GNOME passphrase dialog
91Group: Applications/Networking
92Group(pl): Aplikacje/Sieciowe
93Requires: %{name} = %{version}
94Obsoletes: ssh-extras
95Obsoletes: ssh-askpass
96
97%description askpass
98Ssh (Secure Shell) a program for logging into a remote machine and for
99executing commands in a remote machine. It is intended to replace
100rlogin and rsh, and provide secure encrypted communications between
101two untrusted hosts over an insecure network. X11 connections and
102arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
105up to date in terms of security and features, as well as removing all
106patented algorithms to seperate libraries (OpenSSL).
107
108This package contains the GNOME passphrase dialog.
109
110
111%prep
112%setup -q
113%patch0 -p1
114%patch1 -p1
ec00afd0 115%patch2 -p1
52000378
AF
116
117%build
118autoconf
119%configure \
120 --with-gnome-askpass
121make
6fe24471
AF
122
123%install
124rm -rf $RPM_BUILD_ROOT
6fe24471 125
52000378
AF
126install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
127
128make install \
129 DESTDIR="$RPM_BUILD_ROOT"
130
131install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
ec00afd0 132install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
52000378 133install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
b7b47957 134install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
52000378
AF
135install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
136install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
137
138gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
139 $RPM_BUILD_ROOT/%{_mandir}/man*/*
140
6fe24471
AF
141%clean
142rm -rf $RPM_BUILD_ROOT
143
52000378
AF
144%post server
145/sbin/chkconfig --add sshd
146if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
147 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
6fe24471 148fi
52000378 149if test -r /var/run/sshd.pid
6fe24471 150then
52000378 151 /etc/rc.d/init.d/sshd restart >&2
6fe24471 152fi
ec00afd0
JR
153if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
154 echo "ssh" >> /etc/security/passwd.conf
155fi
6fe24471 156
52000378 157%preun server
6fe24471
AF
158if [ "$1" = 0 ]
159then
52000378
AF
160 /etc/rc.d/init.d/sshd stop >&2
161 /sbin/chkconfig --del sshd
6fe24471
AF
162fi
163
164%files
52000378
AF
165%defattr(644,root,root,755)
166%doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
167%attr(755,root,root) %{_bindir}/ssh-keygen
168%{_mandir}/man1/ssh-keygen.1*
169%dir %{_sysconfdir}
170
171%files clients
172%defattr(644,root,root,755)
173# suid root ?
174#%attr(4755,root,root) %{_bindir}/ssh
175%attr(0755,root,root) %{_bindir}/ssh
176%attr(0755,root,root) %{_bindir}/ssh-agent
177%attr(0755,root,root) %{_bindir}/ssh-add
178#%attr(0755,root,root) %{_bindir}/slogin
179%attr(755,root,root) %{_bindir}/scp
180%{_mandir}/man1/scp.1*
181%{_mandir}/man1/ssh.1*
182%{_mandir}/man1/ssh-agent.1*
183%{_mandir}/man1/ssh-add.1*
184#%{_mandir}/man1/slogin.1
185%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
186
187%files server
188%defattr(644,root,root,755)
189%attr(755,root,root) %{_sbindir}/sshd
190%{_mandir}/man8/sshd.8*
191%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
192%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
193%attr(754,root,root) /etc/rc.d/init.d/sshd
194%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
195
196%files askpass
197%defattr(644,root,root,755)
198%dir %{_libexecdir}/ssh
199%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.073042 seconds and 4 git commands to generate.