]> git.pld-linux.org Git - packages/ogre.git/blame - ogre.spec
- cosmetics
[packages/ogre.git] / ogre.spec
CommitLineData
9a844174 1#
24de43d3 2# TODO: - bconds for rest of the plugins
97e35e3f 3#
ec69de3b 4# Conditional build:
e5191430 5%bcond_with cg # build with cg
ec69de3b 6
7%ifnarch %{ix86} %{x8664}
8%undefine with_cg
9%endif
10
b2370b1e 11%define _ver %(echo %{version} | tr . -)
8f1da734 12Summary: Object-oriented Graphics Rendering Engine
a6ddced0 13Summary(pl.UTF-8): OGRE - zorientowany obiektowo silnik renderowania grafiki
8f65a5c8 14Name: ogre
24de43d3 15Version: 1.7.0p1
16Release: 0.1
8f65a5c8
MP
17License: LGPL
18Group: Applications
24de43d3 19Source0: http://downloads.sourceforge.net/ogre/%{name}-v%{_ver}.tar.bz2
20# Source0-md5: ac06fcb8f550019f4f12e5ca27699063
8f65a5c8 21URL: http://www.ogre3d.org/
9a844174 22BuildRequires: CEGUI-devel
4e8fe5dd 23BuildRequires: FreeImage-devel
3adfbe3b 24BuildRequires: OpenEXR-devel
ea55bb23 25BuildRequires: OpenGL-GLU-devel
ec69de3b 26%{?with_cg:BuildRequires: cg-devel}
24de43d3 27BuildRequires: cmake
2fab5382
JB
28BuildRequires: cppunit-devel >= 1.10.0
29BuildRequires: freetype-devel >= 2.1.0
3c1803c9 30BuildRequires: libstdc++-devel
2fab5382 31BuildRequires: pkgconfig
9a844174 32BuildRequires: xorg-lib-libXaw-devel
33BuildRequires: xorg-lib-libXrandr-devel
34BuildRequires: xorg-lib-libXxf86vm-devel
35BuildRequires: xorg-proto-xf86vidmodeproto-devel
2fab5382 36BuildRequires: zlib-devel
8f65a5c8 37BuildRequires: zziplib-devel
8f65a5c8
MP
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
8f1da734 41Object-oriented Graphics Rendering Engine.
8f65a5c8 42
7dc45d8f 43%description -l pl.UTF-8
8f1da734 44OGRE - zorientowany obiektowo silnik renderowania grafiki
8f65a5c8 45
8f65a5c8 46%package devel
e1d4315b 47Summary: Header files for OGRE library
a6ddced0 48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OGRE
8f65a5c8 49Group: Development/Libraries
8f1da734 50Requires: %{name} = %{version}-%{release}
9a844174 51Requires: FreeImage-devel
ea55bb23
JB
52Requires: freetype-devel >= 2.1.0
53Requires: libstdc++-devel
54Requires: zlib-devel
55Requires: zziplib-devel
56# libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
8f65a5c8
MP
57
58%description devel
59This is the package containing the header files for OGRE library.
60
7dc45d8f
JR
61%description devel -l pl.UTF-8
62Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
8f1da734
JB
63
64%package examples
65Summary: OGRE samples
a6ddced0 66Summary(pl.UTF-8): Przykłady do OGRE
8f1da734
JB
67Group: Applications
68
69%description examples
70OGRE samples.
71
7dc45d8f
JR
72%description examples -l pl.UTF-8
73Przykłady do OGRE.
8f65a5c8
MP
74
75%prep
e4e4f139 76%setup -q -n %{name}
8f65a5c8 77
8f65a5c8 78%build
24de43d3 79install -d build
80cd build
81%cmake .. \
82 -DCMAKE_INSTALL_PREFIX="%{_prefix}"
8f65a5c8
MP
83
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
9a844174 88
8f65a5c8 89install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
8f1da734 90cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
8f65a5c8 91
74809f5e 92%{__make} -C build install \
8f65a5c8
MP
93 DESTDIR=$RPM_BUILD_ROOT
94
ea55bb23
JB
95rm -f $RPM_BUILD_ROOT%{_libdir}/OGRE/*.la
96
8f65a5c8
MP
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(644,root,root,755)
24de43d3 105%doc AUTHORS BUGS README
8f65a5c8 106%attr(755,root,root) %{_bindir}/Ogre*
8f1da734 107%dir %{_libdir}/OGRE
6d5988b4 108%attr(755,root,root) %{_libdir}/OGRE/*.so
24de43d3 109%attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
110%attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
111%attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
112%attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
113%attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
8f65a5c8
MP
114
115%files devel
116%defattr(644,root,root,755)
24de43d3 117%attr(755,root,root) %{_libdir}/libOgreMain.so
118%attr(755,root,root) %{_libdir}/libOgrePaging.so
119%attr(755,root,root) %{_libdir}/libOgreProperty.so
120%attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
121%attr(755,root,root) %{_libdir}/libOgreTerrain.so
8f1da734 122%{_includedir}/OGRE
8f65a5c8 123%{_pkgconfigdir}/OGRE.pc
24de43d3 124%{_pkgconfigdir}/OGRE-PCZ.pc
125%{_pkgconfigdir}/OGRE-Paging.pc
126%{_pkgconfigdir}/OGRE-Property.pc
127%{_pkgconfigdir}/OGRE-RTShaderSystem.pc
128%{_pkgconfigdir}/OGRE-Terrain.pc
8f65a5c8
MP
129
130%files examples
131%defattr(644,root,root,755)
132%{_examplesdir}/%{name}-%{version}
This page took 0.111441 seconds and 4 git commands to generate.