]> git.pld-linux.org Git - packages/net-snmp.git/blame - net-snmp.spec
- release 2
[packages/net-snmp.git] / net-snmp.spec
CommitLineData
ff3b83c0 1# TODO
0ef2b96e 2# - make noarch -n mibs-net-snmp package (need separate .spec then)
15c329ac 3# - FHS: #define NETSNMP_AGENTX_SOCKET "/var/agentx/master"
990f7362 4# - php-snmp (and likely other bindings) use only %{_libdir}/libnetsnmp.so.*, move other libs back to main (daemon) package?
ad841d97
JB
5#
6# Conditional build:
7%bcond_without autodeps # don't BR packages only for deps resolving
7470cbdb
JK
8%bcond_without rpm # don't include RPM support
9%bcond_without kerberos5 # don't include kerberos support
10%bcond_without lm_sensors # don't include sensors support
11%bcond_without perl # don't include Perl modules and utils
12%bcond_without python # don't include Python modules
c4627f0b 13%bcond_without static_libs # don't build static library
15c329ac
ER
14
15%ifnarch %{ix86} %{x8664}
16%undefine with_lm_sensors
17%endif
18
cd697e1b 19%define so_version 30
ea774f60
AF
20%include /usr/lib/rpm/macros.perl
21Summary: A collection of SNMP protocol tools
7d4e48ba
ER
22Summary(es.UTF-8): Agente SNMP de la UCD
23Summary(pl.UTF-8): Kolekcja narzędzi do obsługi protokołu SNMP
24Summary(pt_BR.UTF-8): Agente SNMP da UCD
25Summary(ru.UTF-8): Набор утилит для протокола SNMP от UC-Davis
26Summary(uk.UTF-8): Набір утиліт для протоколу SNMP від UC-Davis
ea774f60 27Name: net-snmp
cd697e1b 28Version: 5.7
f57312ac 29Release: 2
ea774f60
AF
30License: BSD-like
31Group: Networking/Daemons
afbe2a1a 32Source0: http://downloads.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
cd697e1b 33# Source0-md5: 1038e960d6d616c64c0979180daf0e19
ea774f60 34Source1: %{name}d.init
6810e918 35Source2: %{name}d.conf
ea774f60
AF
36Source3: %{name}d.sysconfig
37Source4: %{name}trapd.init
6810e918 38Source5: %{name}trapd.conf
ea774f60 39Source6: %{name}trapd.sysconfig
ee18f99a 40Source7: ucd-ipchains.tar.gz
6789d157 41# Source7-md5: 29949f1008f1a04d6efefd5b3ea607da
ca8f0b18 42Source8: snmpd.upstart
ee18f99a
AM
43Patch0: %{name}-acfix.patch
44Patch1: %{name}-rpm-implicit-libs.patch
45Patch2: %{name}-config-noflags.patch
82f38c90
JB
46Patch3: %{name}-manpage.patch
47Patch4: %{name}-link.patch
48Patch5: %{name}-llinterfaces.patch
49Patch6: %{name}-kernel_headers.patch
50Patch7: %{name}-rpmpath.patch
51Patch8: %{name}-snmpksm.patch
52Patch9: %{name}-python.patch
713ab55c 53Patch10: %{name}-lvalue.patch
9f68faa0 54Patch11: %{name}-defaultconfig.patch
c4627f0b 55Patch12: %{name}-use-rpm-hrmib.patch
afbe2a1a 56Patch13: %{name}-TCP_STATS_CACHE_TIMEOUT.patch
c7c88145 57Patch14: %{name}-libnl.patch
ea774f60 58URL: http://www.net-snmp.org/
8acd0167 59BuildRequires: autoconf >= 2.63
ea774f60 60BuildRequires: automake
e43a09d3 61BuildRequires: elfutils-devel
335d4745 62%{?with_kerberos5:BuildRequires: heimdal-devel}
c7c88145 63BuildRequires: libnl-devel >= 1:3.0
108aee97 64BuildRequires: libssh2-devel
ea774f60
AF
65BuildRequires: libtool >= 1.4
66BuildRequires: libwrap-devel
0e59b3ea 67%{?with_lm_sensors:BuildRequires: lm_sensors-devel >= 3.0.1}
2e25f11c 68BuildRequires: openssl-devel >= 0.9.7d
108aee97 69BuildRequires: pciutils-devel
ad841d97
JB
70%{?with_autodeps:BuildRequires: perl-Term-ReadKey}
71BuildRequires: perl-devel >= 1:5.8.0
7470cbdb 72%if %{with python}
5d80d411 73BuildRequires: python-devel
ed50280b 74BuildRequires: python-modules
c2ceb56d 75BuildRequires: python-setuptools
ed50280b 76BuildRequires: rpm-pythonprov
7470cbdb
JK
77%endif
78%if %{with rpm}
2bacb8e1 79BuildRequires: rpm
ea774f60 80BuildRequires: rpm-perlprov >= 3.0.3-16
7470cbdb 81%endif
60ea29dc 82BuildRequires: rpmbuild(macros) >= 1.527
ea774f60 83Requires(post,preun): /sbin/chkconfig
b0389a15 84Requires: %{name}-libs = %{version}-%{release}
ea774f60 85Requires: /usr/bin/setsid
0ef2b96e 86Requires: mibs-%{name} = %{version}-%{release}
4ea247ad 87Requires: rc-scripts >= 0.4.3.0
ea774f60 88Provides: snmpd
ea774f60
AF
89Obsoletes: cmu-snmp
90Obsoletes: snmpd
e93f5ac2 91Obsoletes: ucd-snmp
c4627f0b 92Conflicts: rpm < 4.4.9-43.11
fa43c632 93BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ea774f60 94
37498b4b
AM
95# linking libraries is ugly in this package
96%define no_install_post_check_so 1
97
ea774f60
AF
98%define logfile /var/log/snmpd.log
99
100%description
101SNMP (Simple Network Management Protocol) is a protocol used for
531ca0ff 102network management (hence the name). The net-snmp project includes
ea774f60
AF
103various SNMP tools: an extensible agent, an SNMP library, tools for
104requesting or setting information from SNMP agents, tools for
105generating and handling SNMP traps, a version of the netstat command
106which uses SNMP, and a Tk/Perl mib browser. This package contains the
107snmpd daemon, documentation, etc.
108
b1738c7c
JR
109%description -l es.UTF-8
110Este paquete se deriva de la implementación del Protocolo Simple de
111Gestión de Redes versión 2 (SNMPv2) de la Universidad Carnegie Mellon.
112Útil para administrar redes y hacer contabilidad.
113
114%description -l pl.UTF-8
115SNMP (Simple Network Management Protocol) jest protokołem używanym do
116zarządzania sieciami. Pakiet zawiera narzędzia: rozbudowywalnego
117agenta, bibliotekę SNMP, narzędzia do odpytywania oraz ustawiania
118informacji poprzez agentów SNMP, narzędzia do generowania i obsługi
119pułapek SNMP, wersję komendy netstat używającą SNMP, przeglądarkę mib
120w Tk/Perl, demona, dokumentację itp.
121
122%description -l pt_BR.UTF-8
123Este pacote é derivado da implementação do Protocolo Simples de
124Gerenciamento de Redes versão 2 (SNMPv2) da Universidade Carnegie
125Mellon. Útil para gerenciar redes e fazer contabilidade.
126
127%description -l ru.UTF-8
128SNMP (Simple Network Management Protocol) - это протокол, используемый
129для управления сетью (отсюда и название). Проект net-snmp включает
130разнообразные SNMP-утилиты: расширяемый агент, библиотека SNMP,
131утилиты для запроса или установки информации от SNMP-агентов, утилиты
132для генерации и обработки SNMP-трапов, версия команды netstat,
133использующей SNMP, и mib-браузер на Tk/Perl. Этот пакет содержит
134демоны snmpd и snmptrapd, документацию и т.д.
135
136%description -l uk.UTF-8
137SNMP (Simple Network Management Protocol) - це протокол, який
138використовують для керування мережею (звідси і назва). Проект net-snmp
139містить різноманітні SNMP-утиліти: розширюваний агент, бібліотека
140SNMP, утиліти для запросу та встановлення інформації від NMP-агентів,
141утиліти для генерації та обробки SNMP-трапів, версія команди netstat,
142яка використовує SNMP, та mib-браузер на Tk/Perl. Цей пакет містить
143демони snmpd та snmptrapd, документацію і т.і.
ea774f60
AF
144
145%package libs
e93f5ac2 146Summary: NET SNMP libraries
7d4e48ba 147Summary(pl.UTF-8): Biblioteki SNMP
ea774f60 148Group: Libraries
0ef2b96e 149Suggests: mibs-%{name}
5ae1bff8 150Obsoletes: net-snmp-compat-libs
60e7e283 151Obsoletes: ucd-snmp-libs
ea774f60
AF
152
153%description libs
e93f5ac2 154NET SNMP libraries.
ea774f60 155
b1738c7c 156%description libs -l pl.UTF-8
ea774f60
AF
157Biblioteki SNMP.
158
ea774f60 159%package devel
531ca0ff 160Summary: The development environment for the net-snmp project
7d4e48ba
ER
161Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
162Summary(pl.UTF-8): Pliki dla programistów używających bibliotek net-snmp
163Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
164Summary(ru.UTF-8): Среда разработки для проекта UCD-SNMP
165Summary(uk.UTF-8): Середовище розробки для проекту UCD-SNMP
ea774f60 166Group: Development/Libraries
9274a72b 167Requires: %{name}-libs = %{version}-%{release}
e43a09d3 168Requires: elfutils-devel
335d4745 169%{?with_kerberos5:Requires: heimdal-devel}
ba3da9c3 170Requires: libnl-devel >= 1:1.1
b0389a15 171Requires: libwrap-devel
0e59b3ea 172%{?with_lm_sensors:Requires: lm_sensors-devel >= 3.0.1}
8d251b9e 173Requires: openssl-devel >= 0.9.7c
60e7e283 174Obsoletes: ucd-snmp-devel
ea774f60
AF
175
176%description devel
177The ucd-snmp-devel package contains the development libraries and
531ca0ff 178header files for use with the net-snmp project's network management
ea774f60
AF
179tools.
180
b1738c7c
JR
181%description devel -l es.UTF-8
182Estas son las bibliotecas y archivos de inclusión para desarrollo con
183el SNMP de la UCD. Con este paquete es posible la creación de
184programas para uso en la gestión de redes.
ea774f60 185
b1738c7c
JR
186%description devel -l pl.UTF-8
187Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
188aplikacji używających protokołu SNMP.
ea774f60 189
b1738c7c
JR
190%description devel -l pt_BR.UTF-8
191Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
192com o SNMP da UCD. Com este pacote é possível a criação de programas
ea774f60
AF
193para uso no gerenciamento de redes.
194
b1738c7c
JR
195%description devel -l ru.UTF-8
196Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
197использования с утилитами управления сетью проекта net-snmp.
ea774f60 198
b1738c7c
JR
199%description devel -l uk.UTF-8
200Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
201використання з утилітами керування мережею проекту net-snmp.
ea774f60
AF
202
203%package static
531ca0ff 204Summary: Static net-snmp libraries
7d4e48ba
ER
205Summary(pl.UTF-8): Statyczne biblioteki net-snmp
206Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com ucd-snmp
207Summary(ru.UTF-8): Статические библиотеки для проекта net-snmp
208Summary(uk.UTF-8): Статичні бібліотеки для проекту net-snmp
ea774f60 209Group: Development/Libraries
9274a72b 210Requires: %{name}-devel = %{version}-%{release}
60e7e283 211Obsoletes: ucd-snmp-static
ea774f60
AF
212
213%description static
531ca0ff 214Static net-snmp libraries.
ea774f60 215
b1738c7c 216%description static -l pl.UTF-8
531ca0ff 217Statyczne biblioteki net-snmp.
ea774f60 218
b1738c7c
JR
219%description static -l pt_BR.UTF-8
220Bibliotecas estáticas para desenvolvimento com net-snmp.
531ca0ff 221
e93f5ac2
AF
222%package compat-devel
223Summary: The development environment for the UCD-SNMP project
7d4e48ba
ER
224Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
225Summary(pl.UTF-8): Pliki dla programistów używających bibliotek UCD-SNMP
226Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
227Summary(ru.UTF-8): Среда разработки для проекта UCD-SNMP
228Summary(uk.UTF-8): Середовище розробки для проекту UCD-SNMP
e93f5ac2 229Group: Development/Libraries
63f88f63 230Requires: %{name}-devel = %{version}-%{release}
9274a72b 231Requires: openssl-devel >= 0.9.7d
e93f5ac2
AF
232Obsoletes: cmu-snmp-devel
233Obsoletes: ucd-snmp-devel
234
235%description compat-devel
236The ucd-snmp-devel package contains the development libraries and
237header files for use with the UCD-SNMP project's network management
238tools.
239
b1738c7c
JR
240%description compat-devel -l es.UTF-8
241Estas son las bibliotecas y archivos de inclusión para desarrollo con
242el SNMP de la UCD. Con este paquete es posible la creación de
243programas para uso en la gestión de redes.
e93f5ac2 244
b1738c7c
JR
245%description compat-devel -l pl.UTF-8
246Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
247aplikacji używających protokołu SNMP.
e93f5ac2 248
b1738c7c
JR
249%description compat-devel -l pt_BR.UTF-8
250Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
251com o SNMP da UCD. Com este pacote é possível a criação de programas
e93f5ac2
AF
252para uso no gerenciamento de redes.
253
b1738c7c
JR
254%description compat-devel -l ru.UTF-8
255Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
256использования с утилитами управления сетью проекта UCD-SNMP.
e93f5ac2 257
b1738c7c
JR
258%description compat-devel -l uk.UTF-8
259Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
260використання з утилітами керування мережею проекту UCD-SNMP.
e93f5ac2
AF
261
262%package compat-static
263Summary: Static UCD-SNMP libraries
7d4e48ba
ER
264Summary(pl.UTF-8): Statyczne biblioteki UCD-SNMP
265Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com ucd-snmp
266Summary(ru.UTF-8): Статические библиотеки для проекта UCD-SNMP
267Summary(uk.UTF-8): Статичні бібліотеки для проекту UCD-SNMP
e93f5ac2 268Group: Development/Libraries
9274a72b 269Requires: %{name}-compat-devel = %{version}-%{release}
e93f5ac2
AF
270Obsoletes: ucd-snmp-static
271
272%description compat-static
273Static UCD-SNMP libraries.
274
b1738c7c 275%description compat-static -l pl.UTF-8
531ca0ff 276Statyczne biblioteki UCD-SNMP.
e93f5ac2 277
b1738c7c
JR
278%description compat-static -l pt_BR.UTF-8
279Bibliotecas estáticas para desenvolvimento com ucd-snmp.
531ca0ff 280
15c329ac
ER
281%package -n mibs-net-snmp
282Summary: Net-SNMP provided MIBs
7d4e48ba 283Summary(pl.UTF-8): Baza danych MIB
531ca0ff 284Group: Applications/System
15c329ac
ER
285Requires: mibs-dirs
286Obsoletes: net-snmp-mibs
9274a72b 287Conflicts: ucd-snmp-libs
531ca0ff 288
15c329ac
ER
289%description -n mibs-net-snmp
290Net-SNMP provided MIBs (Management Information Base).
531ca0ff 291
15c329ac 292%description -n mibs-net-snmp -l pl.UTF-8
531ca0ff
JB
293Baza danych MIB.
294
295%package snmptrapd
296Summary: SNMP trap daemon
7d4e48ba 297Summary(pl.UTF-8): Demon obsługujący pułapki SNMP
531ca0ff 298Group: Applications/System
531ca0ff 299Requires(post,preun): /sbin/chkconfig
b0389a15
ER
300Requires: %{name} = %{version}-%{release}
301Requires: rc-scripts >= 0.2.0
531ca0ff
JB
302Obsoletes: cmu-snmp-utils
303Obsoletes: ucd-snmp-snmptrapd
304
305%description snmptrapd
306The ucd-snmp-snmptrapd package contains snmp trap daemon.
307
b1738c7c
JR
308%description snmptrapd -l pl.UTF-8
309Pakiet zawiera demon obsługujący pułapki SNMP.
531ca0ff
JB
310
311%package utils
312Summary: Network management utilities using SNMP, from the NET-SNMP project
7d4e48ba
ER
313Summary(es.UTF-8): Utilitarios del SNMP de la UCD
314Summary(pl.UTF-8): Narzędzia używające protokołu SNMP
315Summary(pt_BR.UTF-8): Utilitários do SNMP da UCD
316Summary(ru.UTF-8): Утилиты управления сетью по SNMP из проекта NET-SNMP
317Summary(uk.UTF-8): Утиліти керування мережею по SNMP з проекту NET-SNMP
531ca0ff 318Group: Applications/System
9274a72b 319Requires: %{name}-libs = %{version}-%{release}
0ef2b96e 320Suggests: mibs-%{name} = %{version}-%{release}
531ca0ff
JB
321Obsoletes: cmu-snmp-utils
322Obsoletes: ucd-snmp-utils
323
324%description utils
325This package contains various utilities for managing your network
326using the SNMP protocol.
327
b1738c7c 328%description utils -l es.UTF-8
531ca0ff
JB
329Varios utilitarios para uso con el SNMP de la UCD. Contiene
330utilitarios como: snmpwalk, snmptest y otros.
331
b1738c7c
JR
332%description utils -l pl.UTF-8
333Różnego rodzaju narzędzia do zarządzania siecią przy użyciu protokołu
531ca0ff
JB
334SNMP.
335
b1738c7c
JR
336%description utils -l pt_BR.UTF-8
337Vários utilitários para uso com o SNMP da UCD. Contém utilitários
531ca0ff
JB
338como: snmpwalk, snmptest e outros.
339
b1738c7c
JR
340%description utils -l ru.UTF-8
341Пакет ucd-snmp-utils содержит разнообразные утилиты для использования
342в проекте управления сетью net-snmp.
531ca0ff 343
b1738c7c
JR
344%description utils -l uk.UTF-8
345Пакет ucd-snmp-utils містить різноманітні утиліти для використання в
346проекті керування мережею net-snmp.
531ca0ff
JB
347
348%package -n perl-SNMP
349Summary: SNMP and NetSNMP::* Perl modules
7d4e48ba 350Summary(pl.UTF-8): Moduły Perla SNMP oraz NetSNMP::*
531ca0ff 351Group: Development/Languages/Perl
9274a72b
JB
352Requires: %{name}-libs = %{version}-%{release}
353Conflicts: ucd-snmp-utils-perl
531ca0ff
JB
354
355%description -n perl-SNMP
356SNMP and NetSNMP::* Perl modules - Perl interface to net-snmp.
357
b1738c7c
JR
358%description -n perl-SNMP -l pl.UTF-8
359Moduły Perla SNMP oraz NetSNMP::* - perlowy interfejs do net-snmp.
531ca0ff
JB
360
361%package utils-perl
362Summary: Perl utilities for network management using SNMP
7d4e48ba 363Summary(pl.UTF-8): Perlowe narzędzia używające protokołu SNMP
531ca0ff 364Group: Applications/System
9274a72b 365Requires: perl-SNMP = %{version}-%{release}
531ca0ff
JB
366Obsoletes: cmu-snmp-utils
367Obsoletes: ucd-snmp-utils-perl
368
369%description utils-perl
370This package contains various Perl utilities for managing your network
371using the SNMP protocol.
372
b1738c7c
JR
373%description utils-perl -l pl.UTF-8
374Perlowe narzędzia do zarządzania siecią przy użyciu protokołu SNMP.
e93f5ac2
AF
375
376%package snmpconf
531ca0ff 377Summary: snmpconf - creating and modifying SNMP configuration files
7d4e48ba 378Summary(pl.UTF-8): snmpconf - tworzenie i modyfikowanie plików konfiguracyjnych SNMP
e93f5ac2 379Group: Applications/System
9274a72b
JB
380Requires: %{name} = %{version}-%{release}
381Requires: perl-SNMP = %{version}-%{release}
e93f5ac2
AF
382
383%description snmpconf
531ca0ff
JB
384snmpconf is a simple Perl script that walks you through setting up a
385configuration file step by step. It should be fairly straight forward
386to use.
387
b1738c7c
JR
388%description snmpconf -l pl.UTF-8
389snmpconf to prosty skrypt Perla pozwalający na tworzenie pliku
390konfiguracyjnego krok po kroku. Powinien być w miarę prosty w użyciu.
e93f5ac2
AF
391
392%package tkmib
2ffae1a4 393Summary: MIB browser in Tk
7d4e48ba 394Summary(pl.UTF-8): Przeglądarka MIB-ów w Tk
e93f5ac2 395Group: Applications/System
9274a72b 396Requires: perl-SNMP = %{version}-%{release}
531ca0ff 397Requires: perl-Tk
e93f5ac2
AF
398
399%description tkmib
2ffae1a4 400MIB browser in Tk.
531ca0ff 401
b1738c7c
JR
402%description tkmib -l pl.UTF-8
403Przeglądarka MIB-ów w Tk.
e93f5ac2 404
a5fe3234
JB
405%package -n python-netsnmp
406Summary: Python netsnmp extension module
7d4e48ba 407Summary(pl.UTF-8): Moduł rozszerzenia netsnmp dla Pythona
a5fe3234
JB
408Group: Libraries/Python
409Requires: %{name}-libs = %{version}-%{release}
410
411%description -n python-netsnmp
412The 'netsnmp' Python extension module provides a full featured,
413tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
414
b1738c7c
JR
415%description -n python-netsnmp -l pl.UTF-8
416Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
417SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
a5fe3234 418
ea774f60 419%prep
797d6879 420%setup -q -a7
ea774f60
AF
421%patch1 -p1
422%patch2 -p1
423%patch3 -p1
531ca0ff 424%patch4 -p1
edf6eebd
JB
425%patch5 -p1
426%patch6 -p1
8a2022cc 427%patch7 -p1
9274a72b 428%patch8 -p1
f42492ff 429%patch9 -p1
713ab55c 430%patch10 -p1
9f68faa0 431%patch11 -p1
c4627f0b 432%patch12 -p1
cf3659bc 433%patch13 -p1
c7c88145 434%patch14 -p1
ea774f60
AF
435
436%build
437%{__libtoolize}
849c236b 438%{__aclocal} -I m4
ea774f60 439%{__autoconf}
564bc1fe 440%{__autoheader}
eca4ed56 441cp -f /usr/share/automake/config.sub .
15c329ac
ER
442
443MIBS="\
444host agentx smux \
445mibII/mta_sendmail \
446disman/event disman/schedule \
447ucd-snmp/diskio \
448target \
449misc/ipfwacc \
450"
451
452%if %{with lm_sensors}
453MIBS="$MIBS ucd-snmp/lmsensorsMib"
454%endif
455
60ea29dc
AF
456# ksm must be first in --with-security-modules
457# usm is always enabled
ea774f60 458%configure \
27b5f5a2
JR
459 --disable-debugging \
460 --enable-as-needed \
60ea29dc 461 %{__disable static_libs static} \
c05d0e2e 462 --with-cflags="%{rpmcflags} %{rpmcppflags} -I/usr/include/et" \
ea774f60 463 --with-ldflags="%{rpmldflags}" \
c74e79f9
JB
464 --with-defaults \
465 --with-default-snmp-version=3 \
60ea29dc
AF
466 %{__with_without kerberos5 krb5} \
467 --with-openssl \
468 --with-libwrap \
570a6707 469 --with-logfile=%{logfile} \
60ea29dc
AF
470 --with-zlib\
471 --with-bzip2 \
39132f8f 472 --with-nl \
60ea29dc
AF
473 %{__with_without perl perl-modules} \
474 %{__with_without python python-modules} \
2d9facbb 475 --enable-local-smux \
15c329ac
ER
476 --with-mibdirs='$HOME/.snmp/mibs:/usr/share/mibs:%{_datadir}/snmp/mibs' \
477 --with-mib-modules="$MIBS" \
60ea29dc 478 --with-security-modules="%{?with_kerberos5:ksm }tsm" \
ea774f60 479 --with-sys-contact="root@localhost" \
c74e79f9 480 --with-sys-location="Unknown" \
108aee97 481 --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback Alias DTLSUDP TLSTCP SSH" \
27b5f5a2
JR
482 --with-persistent-directory="/var/lib/net-snmp" \
483 --enable-ucd-snmp-compatibility \
7470cbdb 484 --enable-ipv6 \
39132f8f 485 %{!?debug:--disable-debugging} \
60ea29dc 486 %{__with_without rpm}
2d4ec541 487
cb52cd5b 488%{__make} -j1
ea774f60 489
531ca0ff 490cd perl
531ca0ff 491%{__perl} Makefile.PL \
2b15ac96 492 -NET-SNMP-IN-SOURCE=true \
531ca0ff 493 INSTALLDIRS=vendor \
c05d0e2e 494 OPTIMIZE="%{rpmcflags} %{rpmcppflags}" \
531ca0ff 495 </dev/null
2b15ac96 496
531ca0ff
JB
497# avoid rpaths generated by MakeMaker
498perl -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
499
d59f5301
JK
500%{__make} \
501 LDFLAGS="%{rpmldflags}"
ea774f60
AF
502
503%install
504rm -rf $RPM_BUILD_ROOT
d85a4807 505install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
ea774f60 506
3793442d 507%{__make} -j1 install \
15c329ac 508 mibdir=%{_datadir}/mibs \
543e900e 509 DESTDIR=$RPM_BUILD_ROOT
ea774f60 510
4e14f05b 511cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
6810e918 512:> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.local.conf
6e818aed 513:> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmp.conf
e93f5ac2 514:> $RPM_BUILD_ROOT%{logfile}
ea774f60 515
570a6707 516install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
4e14f05b
ER
517cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
518cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
ea774f60 519
570a6707 520install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
4e14f05b
ER
521cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
522cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
ea774f60 523
ca8f0b18
ER
524install -d $RPM_BUILD_ROOT/etc/init
525cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/snmpd.conf
526
531ca0ff 527cd perl
3793442d 528%{__make} -j1 install \
531ca0ff 529 DESTDIR=$RPM_BUILD_ROOT
9274a72b 530
531ca0ff 531install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
570a6707 532install -p SNMP/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
b572d007 533cd ..
ea774f60 534
9274a72b 535# IP-Filter (non-Linux)
63f88f63 536%{__rm} $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
9274a72b 537
63f88f63 538%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/Makefile.subs.pl
108aee97
JB
539%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/NetSNMP.{bs,so}
540rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
3a0b5f9c 541rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/.packlist
7f35dfac 542
c4627f0b
ER
543%if %{with static_libs}
544# hack: convert DynaLoader.a inside .a file to .o, as strip(1) would otherwise say invalid argument
545for a in $RPM_BUILD_ROOT%{_libdir}/libnet*.a; do
546 rm -f *.o *.a
547 ar x $a DynaLoader.a
548 if [ -f DynaLoader.a ]; then
549 ar x DynaLoader.a
550 ar cr $a DynaLoader.o
551 ar d $a DynaLoader.a
552 # remove second file too
553 ar d $a DynaLoader.a
554 fi
555done
2bacb8e1 556%else
63f88f63 557%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
c4627f0b
ER
558%endif
559
8aa6620b 560%if %{with python}
ae60ec22
JB
561%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/tests
562%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/*.py
8aa6620b 563%endif
ae60ec22 564
ea774f60
AF
565%clean
566rm -rf $RPM_BUILD_ROOT
567
e93f5ac2 568%post
ea774f60
AF
569touch %{logfile}
570chmod 640 %{logfile}
fa43c632
ER
571/sbin/chkconfig --add snmpd
572%service snmpd restart "snmpd daemon"
ea774f60 573
60e7e283
AF
574%preun
575if [ "$1" = "0" ]; then
fa43c632 576 %service snmpd stop
60e7e283
AF
577 /sbin/chkconfig --del snmpd
578fi
ea774f60
AF
579
580%post libs -p /sbin/ldconfig
581%postun libs -p /sbin/ldconfig
582
5b201584
JB
583%triggerpostun -- ucd-snmp
584/sbin/chkconfig --add snmpd
585
e93f5ac2 586%post snmptrapd
ea774f60
AF
587touch %{logfile}
588chmod 640 %{logfile}
fa43c632
ER
589/sbin/chkconfig --add snmptrapd
590%service snmptrapd restart "snmp trap daemon"
ea774f60 591
60e7e283
AF
592%preun snmptrapd
593if [ "$1" = "0" ]; then
fa43c632 594 %service snmptrapd stop
60e7e283
AF
595 /sbin/chkconfig --del snmptrapd
596fi
ea774f60 597
605b587c 598%triggerpostun snmptrapd -- ucd-snmp-snmptrapd
5b201584
JB
599/sbin/chkconfig --add snmptrapd
600
ea774f60
AF
601%files
602%defattr(644,root,root,755)
108aee97 603%doc AGENT.txt CHANGES COPYING ChangeLog EXAMPLE.conf{,.def} FAQ NEWS README{,.agent-mibs,.agentx,.snmpv3,.sql,.thread} TODO local
ea774f60 604
60e7e283 605%attr(754,root,root) /etc/rc.d/init.d/snmpd
9e8f34e2 606%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmpd
ca8f0b18 607%config(noreplace) %verify(not md5 mtime size) /etc/init/snmpd.conf
ea774f60 608
9e8f34e2
JB
609%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.conf
610%attr(640,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.local.conf
ea774f60
AF
611
612%attr(755,root,root) %{_sbindir}/snmpd
cf3659bc 613%attr(755,root,root) %{_bindir}/net-snmp-create-v3-user
108aee97 614%attr(755,root,root) %{_bindir}/sshtosnmp
230d3f00
ER
615%dir %{_libdir}/snmp
616%dir %{_libdir}/snmp/dlmod
108aee97 617%attr(755,root,root) %{_datadir}/snmp/snmp_perl.pl
cf3659bc 618%{_mandir}/man1/net-snmp-create-v3-user.1*
ea774f60 619%{_mandir}/man5/snmpd.conf.5*
a23e7817
JB
620%{_mandir}/man5/snmpd.examples.5*
621%{_mandir}/man5/snmpd.internal.5*
ea774f60 622%{_mandir}/man5/variables.5*
531ca0ff 623%{_mandir}/man8/snmpd.8*
ea774f60 624
96249811
ER
625%dir %attr(700,root,root) /var/lib/net-snmp
626
e93f5ac2 627%attr(640,root,root) %ghost %{logfile}
ea774f60
AF
628
629%files libs
630%defattr(644,root,root,755)
afbe2a1a
JB
631%attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*.*
632%attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*.*
633%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*.*
634%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so.*.*.*
635%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so.*.*.*
cf3659bc
AM
636%attr(755,root,root) %ghost %{_libdir}/libnetsnmp.so.%{so_version}
637%attr(755,root,root) %ghost %{_libdir}/libnetsnmpagent.so.%{so_version}
638%attr(755,root,root) %ghost %{_libdir}/libnetsnmphelpers.so.%{so_version}
639%attr(755,root,root) %ghost %{_libdir}/libnetsnmpmibs.so.%{so_version}
640%attr(755,root,root) %ghost %{_libdir}/libnetsnmptrapd.so.%{so_version}
108aee97
JB
641%dir %{_sysconfdir}/snmp
642%dir %{_datadir}/snmp
ea774f60 643
531ca0ff
JB
644%files devel
645%defattr(644,root,root,755)
646%attr(755,root,root) %{_bindir}/mib2c
f2ba5e16 647%attr(755,root,root) %{_bindir}/mib2c-update
531ca0ff 648%attr(755,root,root) %{_bindir}/net-snmp-config
2bacb8e1
ER
649%attr(755,root,root) %{_libdir}/libnetsnmp.so
650%attr(755,root,root) %{_libdir}/libnetsnmpagent.so
651%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so
07ee8549 652%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so
653%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so
2bacb8e1
ER
654%{_libdir}/libnetsnmp.la
655%{_libdir}/libnetsnmpagent.la
656%{_libdir}/libnetsnmphelpers.la
07ee8549 657%{_libdir}/libnetsnmpmibs.la
658%{_libdir}/libnetsnmptrapd.la
531ca0ff
JB
659%{_includedir}/net-snmp
660%{_datadir}/snmp/mib2c*
661%{_mandir}/man1/mib2c.1*
a5fe3234
JB
662%{_mandir}/man1/mib2c-update.1*
663%{_mandir}/man1/net-snmp-config.1*
bdee8ff5 664%{_mandir}/man3/[!NS]*
f2ba5e16 665%{_mandir}/man5/mib2c.conf.5*
531ca0ff 666
c4627f0b 667%if %{with static_libs}
531ca0ff
JB
668%files static
669%defattr(644,root,root,755)
afbe2a1a
JB
670%{_libdir}/libnetsnmp.a
671%{_libdir}/libnetsnmpagent.a
672%{_libdir}/libnetsnmphelpers.a
673%{_libdir}/libnetsnmpmibs.a
674%{_libdir}/libnetsnmptrapd.a
c4627f0b 675%endif
531ca0ff 676
531ca0ff
JB
677%files compat-devel
678%defattr(644,root,root,755)
679%attr(755,root,root) %{_libdir}/libsnmp.so
680%{_libdir}/libsnmp.la
681%{_includedir}/ucd-snmp
682
c4627f0b 683%if %{with static_libs}
531ca0ff
JB
684%files compat-static
685%defattr(644,root,root,755)
686%{_libdir}/libsnmp.a
c4627f0b 687%endif
531ca0ff 688
15c329ac 689%files -n mibs-net-snmp
60e7e283 690%defattr(644,root,root,755)
15c329ac 691%{_datadir}/mibs/*.txt
ea774f60 692
531ca0ff 693%files snmptrapd
60e7e283 694%defattr(644,root,root,755)
531ca0ff
JB
695%attr(755,root,root) %{_sbindir}/snmptrapd
696%attr(754,root,root) /etc/rc.d/init.d/snmptrapd
9e8f34e2
JB
697%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmptrapd
698%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmptrapd.conf
7470cbdb 699%if %{with perl}
f2ba5e16 700%attr(755,root,root) %{_datadir}/snmp/snmp_perl_trapd.pl
7470cbdb 701%endif
531ca0ff
JB
702%{_mandir}/man5/snmptrapd.conf.5*
703%{_mandir}/man8/snmptrapd.8*
60e7e283 704
ea774f60
AF
705%files utils
706%defattr(644,root,root,755)
afbe2a1a 707%attr(755,root,root) %{_bindir}/agentxtrap
ea774f60
AF
708%attr(755,root,root) %{_bindir}/encode_keychange
709%attr(755,root,root) %{_bindir}/snmpbulkget
710%attr(755,root,root) %{_bindir}/snmpbulkwalk
711%attr(755,root,root) %{_bindir}/snmpdelta
6789d157 712%attr(755,root,root) %{_bindir}/snmpdf
ea774f60
AF
713%attr(755,root,root) %{_bindir}/snmpget
714%attr(755,root,root) %{_bindir}/snmpgetnext
6789d157 715%attr(755,root,root) %{_bindir}/snmpinform
ea774f60
AF
716%attr(755,root,root) %{_bindir}/snmpnetstat
717%attr(755,root,root) %{_bindir}/snmpset
718%attr(755,root,root) %{_bindir}/snmpstatus
719%attr(755,root,root) %{_bindir}/snmptable
720%attr(755,root,root) %{_bindir}/snmptest
60ea29dc 721%attr(755,root,root) %{_bindir}/snmptls
ea774f60
AF
722%attr(755,root,root) %{_bindir}/snmptranslate
723%attr(755,root,root) %{_bindir}/snmptrap
724%attr(755,root,root) %{_bindir}/snmpusm
ea774f60 725%attr(755,root,root) %{_bindir}/snmpvacm
6789d157 726%attr(755,root,root) %{_bindir}/snmpwalk
afbe2a1a 727%{_mandir}/man1/agentxtrap.1*
a5fe3234 728%{_mandir}/man1/encode_keychange.1*
ea774f60
AF
729%{_mandir}/man1/snmpbulkget.1*
730%{_mandir}/man1/snmpbulkwalk.1*
731%{_mandir}/man1/snmpcmd.1*
732%{_mandir}/man1/snmpdelta.1*
6789d157 733%{_mandir}/man1/snmpdf.1*
ea774f60
AF
734%{_mandir}/man1/snmpget.1*
735%{_mandir}/man1/snmpgetnext.1*
6789d157 736%{_mandir}/man1/snmpinform.1*
ea774f60
AF
737%{_mandir}/man1/snmpnetstat.1*
738%{_mandir}/man1/snmpset.1*
739%{_mandir}/man1/snmpstatus.1*
740%{_mandir}/man1/snmptable.1*
741%{_mandir}/man1/snmptest.1*
742%{_mandir}/man1/snmptranslate.1*
743%{_mandir}/man1/snmptrap.1*
744%{_mandir}/man1/snmpusm.1*
6789d157 745%{_mandir}/man1/snmpvacm.1*
ea774f60 746%{_mandir}/man1/snmpwalk.1*
ea774f60
AF
747%{_mandir}/man5/snmp.conf.5*
748%{_mandir}/man5/snmp_config.5*
749
7bb0c439 750%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmp.conf
6e818aed 751
7470cbdb 752%if %{with perl}
531ca0ff 753%files -n perl-SNMP
c4deead5 754%defattr(644,root,root,755)
531ca0ff
JB
755%doc perl/SNMP/{BUG,README,TODO} perl/SNMP/examples
756%{perl_vendorarch}/SNMP.pm
757%{perl_vendorarch}/NetSNMP
758%dir %{perl_vendorarch}/auto/SNMP
759%{perl_vendorarch}/auto/SNMP/autosplit.ix
760%{perl_vendorarch}/auto/SNMP/SNMP.bs
761%attr(755,root,root) %{perl_vendorarch}/auto/SNMP/SNMP.so
762%dir %{perl_vendorarch}/auto/NetSNMP
763%dir %{perl_vendorarch}/auto/NetSNMP/*
764%{perl_vendorarch}/auto/NetSNMP/*/autosplit.ix
765%{perl_vendorarch}/auto/NetSNMP/*/*.bs
766%attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/*/*.so
767%dir %{perl_vendorarch}/auto/NetSNMP/agent/default_store
768%{perl_vendorarch}/auto/NetSNMP/agent/default_store/autosplit.ix
769%{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.bs
770%attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.so
771%{_mandir}/man3/NetSNMP::*.3*
772%{_mandir}/man3/SNMP.3*
773%{_examplesdir}/perl-SNMP-%{version}
774
ea774f60
AF
775%files utils-perl
776%defattr(644,root,root,755)
6789d157 777%attr(755,root,root) %{_bindir}/fixproc
afbe2a1a
JB
778%attr(755,root,root) %{_bindir}/net-snmp-cert
779%attr(755,root,root) %{_bindir}/snmp-bridge-mib
60e7e283 780%attr(755,root,root) %{_bindir}/snmpcheck
6810e918 781%attr(755,root,root) %{_bindir}/traptoemail
a5fe3234 782%{_mandir}/man1/fixproc.1*
afbe2a1a 783%{_mandir}/man1/snmp-bridge-mib.1*
a5fe3234 784%{_mandir}/man1/traptoemail.1*
7470cbdb 785%endif
531ca0ff
JB
786
787%files snmpconf
4ec38672 788%defattr(644,root,root,755)
531ca0ff 789%attr(755,root,root) %{_bindir}/snmpconf
60e7e283
AF
790%{_mandir}/man1/snmpconf.1*
791%{_datadir}/snmp/snmpconf-data
e93f5ac2 792
7470cbdb 793%if %{with perl}
e93f5ac2
AF
794%files tkmib
795%defattr(644,root,root,755)
4ec38672 796%attr(755,root,root) %{_bindir}/tkmib
a5fe3234 797%{_mandir}/man1/tkmib.1*
7470cbdb 798%endif
a5fe3234 799
7470cbdb 800%if %{with python}
a5fe3234
JB
801%files -n python-netsnmp
802%defattr(644,root,root,755)
803%dir %{py_sitedir}/netsnmp
804%attr(755,root,root) %{py_sitedir}/netsnmp/*.so
805%{py_sitedir}/netsnmp/*.py[co]
806%{py_sitedir}/netsnmp_python-*.egg-info
7470cbdb 807%endif
This page took 0.368833 seconds and 4 git commands to generate.