]> git.pld-linux.org Git - packages/net-snmp.git/blame - net-snmp.spec
- devel R: libnl-devel (used by libnetsnmpagent)
[packages/net-snmp.git] / net-snmp.spec
CommitLineData
ff3b83c0 1# TODO
8795945f
ER
2# - package or remove:
3# %{_datadir}/snmp/snmp_perl.pl
0ef2b96e 4# - make noarch -n mibs-net-snmp package (need separate .spec then)
15c329ac 5# - FHS: #define NETSNMP_AGENTX_SOCKET "/var/agentx/master"
990f7362 6# - php-snmp (and likely other bindings) use only %{_libdir}/libnetsnmp.so.*, move other libs back to main (daemon) package?
ad841d97
JB
7#
8# Conditional build:
9%bcond_without autodeps # don't BR packages only for deps resolving
7470cbdb
JK
10%bcond_without rpm # don't include RPM support
11%bcond_without kerberos5 # don't include kerberos support
12%bcond_without lm_sensors # don't include sensors support
13%bcond_without perl # don't include Perl modules and utils
14%bcond_without python # don't include Python modules
c4627f0b 15%bcond_without static_libs # don't build static library
15c329ac
ER
16
17%ifnarch %{ix86} %{x8664}
18%undefine with_lm_sensors
19%endif
20
ea774f60
AF
21%include /usr/lib/rpm/macros.perl
22Summary: A collection of SNMP protocol tools
7d4e48ba
ER
23Summary(es.UTF-8): Agente SNMP de la UCD
24Summary(pl.UTF-8): Kolekcja narzędzi do obsługi protokołu SNMP
25Summary(pt_BR.UTF-8): Agente SNMP da UCD
26Summary(ru.UTF-8): Набор утилит для протокола SNMP от UC-Davis
27Summary(uk.UTF-8): Набір утиліт для протоколу SNMP від UC-Davis
ea774f60 28Name: net-snmp
849c236b
AM
29Version: 5.5
30Release: 0.1
ea774f60
AF
31License: BSD-like
32Group: Networking/Daemons
33Source0: http://dl.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
849c236b 34# Source0-md5: 5b2551e7bd024fbbee84dca22a5f13a1
ea774f60 35Source1: %{name}d.init
6810e918 36Source2: %{name}d.conf
ea774f60
AF
37Source3: %{name}d.sysconfig
38Source4: %{name}trapd.init
6810e918 39Source5: %{name}trapd.conf
ea774f60 40Source6: %{name}trapd.sysconfig
ee18f99a 41Source7: ucd-ipchains.tar.gz
6789d157 42# Source7-md5: 29949f1008f1a04d6efefd5b3ea607da
ee18f99a
AM
43Patch0: %{name}-acfix.patch
44Patch1: %{name}-rpm-implicit-libs.patch
45Patch2: %{name}-config-noflags.patch
82f38c90
JB
46Patch3: %{name}-manpage.patch
47Patch4: %{name}-link.patch
48Patch5: %{name}-llinterfaces.patch
49Patch6: %{name}-kernel_headers.patch
50Patch7: %{name}-rpmpath.patch
51Patch8: %{name}-snmpksm.patch
52Patch9: %{name}-python.patch
713ab55c 53Patch10: %{name}-lvalue.patch
9f68faa0 54Patch11: %{name}-defaultconfig.patch
c4627f0b 55Patch12: %{name}-use-rpm-hrmib.patch
0e59b3ea 56Patch14: %{name}-lm_sensors_3.patch
5d80d411 57Patch17: %{name}-TCP_STATS_CACHE_TIMEOUT.patch
ff3b83c0 58Patch19: %{name}-loadave-writable.patch
ea774f60 59URL: http://www.net-snmp.org/
82f38c90 60BuildRequires: autoconf >= 2.61-3
ea774f60 61BuildRequires: automake
e43a09d3 62BuildRequires: elfutils-devel
335d4745 63%{?with_kerberos5:BuildRequires: heimdal-devel}
24482372 64BuildRequires: libnl-devel >= 1:1.1
ea774f60
AF
65BuildRequires: libtool >= 1.4
66BuildRequires: libwrap-devel
0e59b3ea 67%{?with_lm_sensors:BuildRequires: lm_sensors-devel >= 3.0.1}
2e25f11c 68BuildRequires: openssl-devel >= 0.9.7d
ad841d97
JB
69%{?with_autodeps:BuildRequires: perl-Term-ReadKey}
70BuildRequires: perl-devel >= 1:5.8.0
7470cbdb 71%if %{with python}
5d80d411 72BuildRequires: python-devel
ed50280b 73BuildRequires: python-modules
c2ceb56d 74BuildRequires: python-setuptools
ed50280b 75BuildRequires: rpm-pythonprov
7470cbdb
JK
76%endif
77%if %{with rpm}
2bacb8e1 78BuildRequires: rpm
ea774f60 79BuildRequires: rpm-perlprov >= 3.0.3-16
7470cbdb 80%endif
fa43c632 81BuildRequires: rpmbuild(macros) >= 1.268
ea774f60 82Requires(post,preun): /sbin/chkconfig
b0389a15 83Requires: %{name}-libs = %{version}-%{release}
ea774f60 84Requires: /usr/bin/setsid
0ef2b96e 85Requires: mibs-%{name} = %{version}-%{release}
b0389a15 86Requires: rc-scripts >= 0.2.0
ea774f60 87Provides: snmpd
ea774f60
AF
88Obsoletes: cmu-snmp
89Obsoletes: snmpd
e93f5ac2 90Obsoletes: ucd-snmp
c4627f0b 91Conflicts: rpm < 4.4.9-43.11
fa43c632 92BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ea774f60 93
37498b4b
AM
94# linking libraries is ugly in this package
95%define no_install_post_check_so 1
96
ea774f60
AF
97%define logfile /var/log/snmpd.log
98
99%description
100SNMP (Simple Network Management Protocol) is a protocol used for
531ca0ff 101network management (hence the name). The net-snmp project includes
ea774f60
AF
102various SNMP tools: an extensible agent, an SNMP library, tools for
103requesting or setting information from SNMP agents, tools for
104generating and handling SNMP traps, a version of the netstat command
105which uses SNMP, and a Tk/Perl mib browser. This package contains the
106snmpd daemon, documentation, etc.
107
b1738c7c
JR
108%description -l es.UTF-8
109Este paquete se deriva de la implementación del Protocolo Simple de
110Gestión de Redes versión 2 (SNMPv2) de la Universidad Carnegie Mellon.
111Útil para administrar redes y hacer contabilidad.
112
113%description -l pl.UTF-8
114SNMP (Simple Network Management Protocol) jest protokołem używanym do
115zarządzania sieciami. Pakiet zawiera narzędzia: rozbudowywalnego
116agenta, bibliotekę SNMP, narzędzia do odpytywania oraz ustawiania
117informacji poprzez agentów SNMP, narzędzia do generowania i obsługi
118pułapek SNMP, wersję komendy netstat używającą SNMP, przeglądarkę mib
119w Tk/Perl, demona, dokumentację itp.
120
121%description -l pt_BR.UTF-8
122Este pacote é derivado da implementação do Protocolo Simples de
123Gerenciamento de Redes versão 2 (SNMPv2) da Universidade Carnegie
124Mellon. Útil para gerenciar redes e fazer contabilidade.
125
126%description -l ru.UTF-8
127SNMP (Simple Network Management Protocol) - это протокол, используемый
128для управления сетью (отсюда и название). Проект net-snmp включает
129разнообразные SNMP-утилиты: расширяемый агент, библиотека SNMP,
130утилиты для запроса или установки информации от SNMP-агентов, утилиты
131для генерации и обработки SNMP-трапов, версия команды netstat,
132использующей SNMP, и mib-браузер на Tk/Perl. Этот пакет содержит
133демоны snmpd и snmptrapd, документацию и т.д.
134
135%description -l uk.UTF-8
136SNMP (Simple Network Management Protocol) - це протокол, який
137використовують для керування мережею (звідси і назва). Проект net-snmp
138містить різноманітні SNMP-утиліти: розширюваний агент, бібліотека
139SNMP, утиліти для запросу та встановлення інформації від NMP-агентів,
140утиліти для генерації та обробки SNMP-трапів, версія команди netstat,
141яка використовує SNMP, та mib-браузер на Tk/Perl. Цей пакет містить
142демони snmpd та snmptrapd, документацію і т.і.
ea774f60
AF
143
144%package libs
e93f5ac2 145Summary: NET SNMP libraries
7d4e48ba 146Summary(pl.UTF-8): Biblioteki SNMP
ea774f60 147Group: Libraries
0ef2b96e 148Suggests: mibs-%{name}
5ae1bff8 149Obsoletes: net-snmp-compat-libs
60e7e283 150Obsoletes: ucd-snmp-libs
ea774f60
AF
151
152%description libs
e93f5ac2 153NET SNMP libraries.
ea774f60 154
b1738c7c 155%description libs -l pl.UTF-8
ea774f60
AF
156Biblioteki SNMP.
157
ea774f60 158%package devel
531ca0ff 159Summary: The development environment for the net-snmp project
7d4e48ba
ER
160Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
161Summary(pl.UTF-8): Pliki dla programistów używających bibliotek net-snmp
162Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
163Summary(ru.UTF-8): Среда разработки для проекта UCD-SNMP
164Summary(uk.UTF-8): Середовище розробки для проекту UCD-SNMP
ea774f60 165Group: Development/Libraries
9274a72b 166Requires: %{name}-libs = %{version}-%{release}
e43a09d3 167Requires: elfutils-devel
335d4745 168%{?with_kerberos5:Requires: heimdal-devel}
ba3da9c3 169Requires: libnl-devel >= 1:1.1
b0389a15 170Requires: libwrap-devel
0e59b3ea 171%{?with_lm_sensors:Requires: lm_sensors-devel >= 3.0.1}
8d251b9e 172Requires: openssl-devel >= 0.9.7c
60e7e283 173Obsoletes: ucd-snmp-devel
ea774f60
AF
174
175%description devel
176The ucd-snmp-devel package contains the development libraries and
531ca0ff 177header files for use with the net-snmp project's network management
ea774f60
AF
178tools.
179
b1738c7c
JR
180%description devel -l es.UTF-8
181Estas son las bibliotecas y archivos de inclusión para desarrollo con
182el SNMP de la UCD. Con este paquete es posible la creación de
183programas para uso en la gestión de redes.
ea774f60 184
b1738c7c
JR
185%description devel -l pl.UTF-8
186Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
187aplikacji używających protokołu SNMP.
ea774f60 188
b1738c7c
JR
189%description devel -l pt_BR.UTF-8
190Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
191com o SNMP da UCD. Com este pacote é possível a criação de programas
ea774f60
AF
192para uso no gerenciamento de redes.
193
b1738c7c
JR
194%description devel -l ru.UTF-8
195Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
196использования с утилитами управления сетью проекта net-snmp.
ea774f60 197
b1738c7c
JR
198%description devel -l uk.UTF-8
199Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
200використання з утилітами керування мережею проекту net-snmp.
ea774f60
AF
201
202%package static
531ca0ff 203Summary: Static net-snmp libraries
7d4e48ba
ER
204Summary(pl.UTF-8): Statyczne biblioteki net-snmp
205Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com ucd-snmp
206Summary(ru.UTF-8): Статические библиотеки для проекта net-snmp
207Summary(uk.UTF-8): Статичні бібліотеки для проекту net-snmp
ea774f60 208Group: Development/Libraries
9274a72b 209Requires: %{name}-devel = %{version}-%{release}
60e7e283 210Obsoletes: ucd-snmp-static
ea774f60
AF
211
212%description static
531ca0ff 213Static net-snmp libraries.
ea774f60 214
b1738c7c 215%description static -l pl.UTF-8
531ca0ff 216Statyczne biblioteki net-snmp.
ea774f60 217
b1738c7c
JR
218%description static -l pt_BR.UTF-8
219Bibliotecas estáticas para desenvolvimento com net-snmp.
531ca0ff 220
e93f5ac2
AF
221%package compat-devel
222Summary: The development environment for the UCD-SNMP project
7d4e48ba
ER
223Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
224Summary(pl.UTF-8): Pliki dla programistów używających bibliotek UCD-SNMP
225Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
226Summary(ru.UTF-8): Среда разработки для проекта UCD-SNMP
227Summary(uk.UTF-8): Середовище розробки для проекту UCD-SNMP
e93f5ac2 228Group: Development/Libraries
9274a72b
JB
229Requires: %{name}-libs = %{version}-%{release}
230Requires: openssl-devel >= 0.9.7d
e93f5ac2
AF
231Obsoletes: cmu-snmp-devel
232Obsoletes: ucd-snmp-devel
233
234%description compat-devel
235The ucd-snmp-devel package contains the development libraries and
236header files for use with the UCD-SNMP project's network management
237tools.
238
b1738c7c
JR
239%description compat-devel -l es.UTF-8
240Estas son las bibliotecas y archivos de inclusión para desarrollo con
241el SNMP de la UCD. Con este paquete es posible la creación de
242programas para uso en la gestión de redes.
e93f5ac2 243
b1738c7c
JR
244%description compat-devel -l pl.UTF-8
245Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
246aplikacji używających protokołu SNMP.
e93f5ac2 247
b1738c7c
JR
248%description compat-devel -l pt_BR.UTF-8
249Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
250com o SNMP da UCD. Com este pacote é possível a criação de programas
e93f5ac2
AF
251para uso no gerenciamento de redes.
252
b1738c7c
JR
253%description compat-devel -l ru.UTF-8
254Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
255использования с утилитами управления сетью проекта UCD-SNMP.
e93f5ac2 256
b1738c7c
JR
257%description compat-devel -l uk.UTF-8
258Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
259використання з утилітами керування мережею проекту UCD-SNMP.
e93f5ac2
AF
260
261%package compat-static
262Summary: Static UCD-SNMP libraries
7d4e48ba
ER
263Summary(pl.UTF-8): Statyczne biblioteki UCD-SNMP
264Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com ucd-snmp
265Summary(ru.UTF-8): Статические библиотеки для проекта UCD-SNMP
266Summary(uk.UTF-8): Статичні бібліотеки для проекту UCD-SNMP
e93f5ac2 267Group: Development/Libraries
9274a72b 268Requires: %{name}-compat-devel = %{version}-%{release}
e93f5ac2
AF
269Obsoletes: ucd-snmp-static
270
271%description compat-static
272Static UCD-SNMP libraries.
273
b1738c7c 274%description compat-static -l pl.UTF-8
531ca0ff 275Statyczne biblioteki UCD-SNMP.
e93f5ac2 276
b1738c7c
JR
277%description compat-static -l pt_BR.UTF-8
278Bibliotecas estáticas para desenvolvimento com ucd-snmp.
531ca0ff 279
15c329ac
ER
280%package -n mibs-net-snmp
281Summary: Net-SNMP provided MIBs
7d4e48ba 282Summary(pl.UTF-8): Baza danych MIB
531ca0ff 283Group: Applications/System
15c329ac
ER
284Requires: mibs-dirs
285Obsoletes: net-snmp-mibs
9274a72b 286Conflicts: ucd-snmp-libs
531ca0ff 287
15c329ac
ER
288%description -n mibs-net-snmp
289Net-SNMP provided MIBs (Management Information Base).
531ca0ff 290
15c329ac 291%description -n mibs-net-snmp -l pl.UTF-8
531ca0ff
JB
292Baza danych MIB.
293
294%package snmptrapd
295Summary: SNMP trap daemon
7d4e48ba 296Summary(pl.UTF-8): Demon obsługujący pułapki SNMP
531ca0ff 297Group: Applications/System
531ca0ff 298Requires(post,preun): /sbin/chkconfig
b0389a15
ER
299Requires: %{name} = %{version}-%{release}
300Requires: rc-scripts >= 0.2.0
531ca0ff
JB
301Obsoletes: cmu-snmp-utils
302Obsoletes: ucd-snmp-snmptrapd
303
304%description snmptrapd
305The ucd-snmp-snmptrapd package contains snmp trap daemon.
306
b1738c7c
JR
307%description snmptrapd -l pl.UTF-8
308Pakiet zawiera demon obsługujący pułapki SNMP.
531ca0ff
JB
309
310%package utils
311Summary: Network management utilities using SNMP, from the NET-SNMP project
7d4e48ba
ER
312Summary(es.UTF-8): Utilitarios del SNMP de la UCD
313Summary(pl.UTF-8): Narzędzia używające protokołu SNMP
314Summary(pt_BR.UTF-8): Utilitários do SNMP da UCD
315Summary(ru.UTF-8): Утилиты управления сетью по SNMP из проекта NET-SNMP
316Summary(uk.UTF-8): Утиліти керування мережею по SNMP з проекту NET-SNMP
531ca0ff 317Group: Applications/System
9274a72b 318Requires: %{name}-libs = %{version}-%{release}
0ef2b96e 319Suggests: mibs-%{name} = %{version}-%{release}
531ca0ff
JB
320Obsoletes: cmu-snmp-utils
321Obsoletes: ucd-snmp-utils
322
323%description utils
324This package contains various utilities for managing your network
325using the SNMP protocol.
326
b1738c7c 327%description utils -l es.UTF-8
531ca0ff
JB
328Varios utilitarios para uso con el SNMP de la UCD. Contiene
329utilitarios como: snmpwalk, snmptest y otros.
330
b1738c7c
JR
331%description utils -l pl.UTF-8
332Różnego rodzaju narzędzia do zarządzania siecią przy użyciu protokołu
531ca0ff
JB
333SNMP.
334
b1738c7c
JR
335%description utils -l pt_BR.UTF-8
336Vários utilitários para uso com o SNMP da UCD. Contém utilitários
531ca0ff
JB
337como: snmpwalk, snmptest e outros.
338
b1738c7c
JR
339%description utils -l ru.UTF-8
340Пакет ucd-snmp-utils содержит разнообразные утилиты для использования
341в проекте управления сетью net-snmp.
531ca0ff 342
b1738c7c
JR
343%description utils -l uk.UTF-8
344Пакет ucd-snmp-utils містить різноманітні утиліти для використання в
345проекті керування мережею net-snmp.
531ca0ff
JB
346
347%package -n perl-SNMP
348Summary: SNMP and NetSNMP::* Perl modules
7d4e48ba 349Summary(pl.UTF-8): Moduły Perla SNMP oraz NetSNMP::*
531ca0ff 350Group: Development/Languages/Perl
9274a72b
JB
351Requires: %{name}-libs = %{version}-%{release}
352Conflicts: ucd-snmp-utils-perl
531ca0ff
JB
353
354%description -n perl-SNMP
355SNMP and NetSNMP::* Perl modules - Perl interface to net-snmp.
356
b1738c7c
JR
357%description -n perl-SNMP -l pl.UTF-8
358Moduły Perla SNMP oraz NetSNMP::* - perlowy interfejs do net-snmp.
531ca0ff
JB
359
360%package utils-perl
361Summary: Perl utilities for network management using SNMP
7d4e48ba 362Summary(pl.UTF-8): Perlowe narzędzia używające protokołu SNMP
531ca0ff 363Group: Applications/System
9274a72b 364Requires: perl-SNMP = %{version}-%{release}
531ca0ff
JB
365Obsoletes: cmu-snmp-utils
366Obsoletes: ucd-snmp-utils-perl
367
368%description utils-perl
369This package contains various Perl utilities for managing your network
370using the SNMP protocol.
371
b1738c7c
JR
372%description utils-perl -l pl.UTF-8
373Perlowe narzędzia do zarządzania siecią przy użyciu protokołu SNMP.
e93f5ac2
AF
374
375%package snmpconf
531ca0ff 376Summary: snmpconf - creating and modifying SNMP configuration files
7d4e48ba 377Summary(pl.UTF-8): snmpconf - tworzenie i modyfikowanie plików konfiguracyjnych SNMP
e93f5ac2 378Group: Applications/System
9274a72b
JB
379Requires: %{name} = %{version}-%{release}
380Requires: perl-SNMP = %{version}-%{release}
e93f5ac2
AF
381
382%description snmpconf
531ca0ff
JB
383snmpconf is a simple Perl script that walks you through setting up a
384configuration file step by step. It should be fairly straight forward
385to use.
386
b1738c7c
JR
387%description snmpconf -l pl.UTF-8
388snmpconf to prosty skrypt Perla pozwalający na tworzenie pliku
389konfiguracyjnego krok po kroku. Powinien być w miarę prosty w użyciu.
e93f5ac2
AF
390
391%package tkmib
2ffae1a4 392Summary: MIB browser in Tk
7d4e48ba 393Summary(pl.UTF-8): Przeglądarka MIB-ów w Tk
e93f5ac2 394Group: Applications/System
9274a72b 395Requires: perl-SNMP = %{version}-%{release}
531ca0ff 396Requires: perl-Tk
e93f5ac2
AF
397
398%description tkmib
2ffae1a4 399MIB browser in Tk.
531ca0ff 400
b1738c7c
JR
401%description tkmib -l pl.UTF-8
402Przeglądarka MIB-ów w Tk.
e93f5ac2 403
a5fe3234
JB
404%package -n python-netsnmp
405Summary: Python netsnmp extension module
7d4e48ba 406Summary(pl.UTF-8): Moduł rozszerzenia netsnmp dla Pythona
a5fe3234
JB
407Group: Libraries/Python
408Requires: %{name}-libs = %{version}-%{release}
409
410%description -n python-netsnmp
411The 'netsnmp' Python extension module provides a full featured,
412tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
413
b1738c7c
JR
414%description -n python-netsnmp -l pl.UTF-8
415Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
416SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
a5fe3234 417
ea774f60 418%prep
797d6879 419%setup -q -a7
ea774f60
AF
420%patch1 -p1
421%patch2 -p1
422%patch3 -p1
531ca0ff 423%patch4 -p1
edf6eebd
JB
424%patch5 -p1
425%patch6 -p1
8a2022cc 426%patch7 -p1
9274a72b 427%patch8 -p1
f42492ff 428%patch9 -p1
713ab55c 429%patch10 -p1
849c236b 430# check me
9f68faa0 431%patch11 -p1
c4627f0b 432%patch12 -p1
849c236b 433# check me
0e59b3ea 434%patch14 -p0
5d80d411 435%patch17 -p1
ff3b83c0 436%patch19 -p1
ea774f60
AF
437
438%build
439%{__libtoolize}
849c236b 440%{__aclocal} -I m4
ea774f60 441%{__autoconf}
564bc1fe 442%{__autoheader}
eca4ed56 443cp -f /usr/share/automake/config.sub .
15c329ac
ER
444
445MIBS="\
446host agentx smux \
447mibII/mta_sendmail \
448disman/event disman/schedule \
449ucd-snmp/diskio \
450target \
451misc/ipfwacc \
452"
453
454%if %{with lm_sensors}
455MIBS="$MIBS ucd-snmp/lmsensorsMib"
456%endif
457
ea774f60 458%configure \
27b5f5a2
JR
459 --disable-debugging \
460 --enable-as-needed \
c4627f0b 461 %{!?with_static_libs:--disable-static} \
f42492ff 462 --with-cflags="%{rpmcflags} -I/usr/include/et" \
ea774f60 463 --with-ldflags="%{rpmldflags}" \
c74e79f9
JB
464 --with-defaults \
465 --with-default-snmp-version=3 \
7470cbdb 466 %{?with_kerberos5:--with-krb5=%{_prefix}} \
1c79f0b7 467 %{!?with_kerberos5:--without-krb5} \
27b5f5a2
JR
468 --with-openssl=%{_prefix} \
469 --with-libwrap=%{_prefix} \
c74e79f9 470 --with-logfile="%{logfile}" \
27b5f5a2
JR
471 --with-zlib=%{_prefix} \
472 --with-bzip2=%{_prefix} \
ff4ab342 473 --with%{!?with_perl:out}-perl-modules \
474 --with%{!?with_python:out}-python-modules \
2d9facbb 475 --enable-local-smux \
15c329ac
ER
476 --with-mibdirs='$HOME/.snmp/mibs:/usr/share/mibs:%{_datadir}/snmp/mibs' \
477 --with-mib-modules="$MIBS" \
7470cbdb 478 %{?with_kerberos5:--with-security-modules="ksm"} \
ea774f60 479 --with-sys-contact="root@localhost" \
c74e79f9 480 --with-sys-location="Unknown" \
2d9facbb 481 --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback" \
27b5f5a2
JR
482 --with-persistent-directory="/var/lib/net-snmp" \
483 --enable-ucd-snmp-compatibility \
7470cbdb
JK
484 --enable-ipv6 \
485 --with%{!?with_rpm:out}-rpm
2d4ec541 486
cb52cd5b 487%{__make} -j1
ea774f60 488
531ca0ff 489cd perl
531ca0ff 490
531ca0ff 491%{__perl} Makefile.PL \
2b15ac96 492 -NET-SNMP-IN-SOURCE=true \
531ca0ff 493 INSTALLDIRS=vendor \
2b15ac96 494 OPTIMIZE="%{rpmcflags}" \
531ca0ff 495 </dev/null
2b15ac96 496
531ca0ff
JB
497# avoid rpaths generated by MakeMaker
498perl -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
499
d59f5301
JK
500%{__make} \
501 LDFLAGS="%{rpmldflags}"
ea774f60
AF
502
503%install
504rm -rf $RPM_BUILD_ROOT
d85a4807 505install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
ea774f60 506
3793442d 507%{__make} -j1 install \
15c329ac 508 mibdir=%{_datadir}/mibs \
543e900e 509 DESTDIR=$RPM_BUILD_ROOT
ea774f60 510
6810e918
AF
511install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
512:> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.local.conf
6e818aed 513:> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmp.conf
e93f5ac2 514:> $RPM_BUILD_ROOT%{logfile}
ea774f60 515
60e7e283 516install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
6810e918 517install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
60e7e283 518install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
ea774f60 519
60e7e283 520install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
6810e918 521install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
60e7e283 522install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
ea774f60 523
531ca0ff 524cd perl
3793442d 525%{__make} -j1 install \
531ca0ff 526 DESTDIR=$RPM_BUILD_ROOT
9274a72b 527
531ca0ff
JB
528install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
529install SNMP/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
b572d007 530cd ..
ea774f60 531
9274a72b
JB
532# IP-Filter (non-Linux)
533rm -f $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
534
7f35dfac 535rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
3a0b5f9c
ER
536rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/Makefile.subs.pl
537rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/.packlist
7f35dfac 538
c4627f0b
ER
539%if %{with static_libs}
540# hack: convert DynaLoader.a inside .a file to .o, as strip(1) would otherwise say invalid argument
541for a in $RPM_BUILD_ROOT%{_libdir}/libnet*.a; do
542 rm -f *.o *.a
543 ar x $a DynaLoader.a
544 if [ -f DynaLoader.a ]; then
545 ar x DynaLoader.a
546 ar cr $a DynaLoader.o
547 ar d $a DynaLoader.a
548 # remove second file too
549 ar d $a DynaLoader.a
550 fi
551done
2bacb8e1
ER
552%else
553rm -f $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
c4627f0b
ER
554%endif
555
8aa6620b 556%if %{with python}
ae60ec22
JB
557%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/tests
558%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/*.py
8aa6620b 559%endif
ae60ec22 560
ea774f60
AF
561%clean
562rm -rf $RPM_BUILD_ROOT
563
e93f5ac2 564%post
ea774f60
AF
565touch %{logfile}
566chmod 640 %{logfile}
fa43c632
ER
567/sbin/chkconfig --add snmpd
568%service snmpd restart "snmpd daemon"
ea774f60 569
60e7e283
AF
570%preun
571if [ "$1" = "0" ]; then
fa43c632 572 %service snmpd stop
60e7e283
AF
573 /sbin/chkconfig --del snmpd
574fi
ea774f60
AF
575
576%post libs -p /sbin/ldconfig
577%postun libs -p /sbin/ldconfig
578
5b201584
JB
579%triggerpostun -- ucd-snmp
580/sbin/chkconfig --add snmpd
581
e93f5ac2 582%post snmptrapd
ea774f60
AF
583touch %{logfile}
584chmod 640 %{logfile}
fa43c632
ER
585/sbin/chkconfig --add snmptrapd
586%service snmptrapd restart "snmp trap daemon"
ea774f60 587
60e7e283
AF
588%preun snmptrapd
589if [ "$1" = "0" ]; then
fa43c632 590 %service snmptrapd stop
60e7e283
AF
591 /sbin/chkconfig --del snmptrapd
592fi
ea774f60 593
605b587c 594%triggerpostun snmptrapd -- ucd-snmp-snmptrapd
5b201584
JB
595/sbin/chkconfig --add snmptrapd
596
ea774f60
AF
597%files
598%defattr(644,root,root,755)
599%doc README local
600%doc ChangeLog EXAMPLE.conf.def EXAMPLE.conf
601%doc FAQ NEWS PORTING README.snmpv3 TODO AGENT.txt
602
60e7e283 603%attr(754,root,root) /etc/rc.d/init.d/snmpd
9e8f34e2 604%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmpd
ea774f60 605
9e8f34e2
JB
606%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.conf
607%attr(640,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.local.conf
ea774f60
AF
608
609%attr(755,root,root) %{_sbindir}/snmpd
610
230d3f00
ER
611%dir %{_libdir}/snmp
612%dir %{_libdir}/snmp/dlmod
613
ea774f60 614%{_mandir}/man5/snmpd.conf.5*
a23e7817
JB
615%{_mandir}/man5/snmpd.examples.5*
616%{_mandir}/man5/snmpd.internal.5*
ea774f60 617%{_mandir}/man5/variables.5*
531ca0ff 618%{_mandir}/man8/snmpd.8*
ea774f60 619
96249811
ER
620%dir %attr(700,root,root) /var/lib/net-snmp
621
e93f5ac2 622%attr(640,root,root) %ghost %{logfile}
ea774f60
AF
623
624%files libs
625%defattr(644,root,root,755)
e043d0db 626%dir %{_sysconfdir}/snmp
0e10a309 627%dir %{_datadir}/snmp
2bacb8e1
ER
628%attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*
629%attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*
630%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*
07ee8549 631%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so.*.*
632%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so.*.*
2bacb8e1
ER
633%attr(755,root,root) %ghost %{_libdir}/libnetsnmp.so.15
634%attr(755,root,root) %ghost %{_libdir}/libnetsnmpagent.so.15
635%attr(755,root,root) %ghost %{_libdir}/libnetsnmphelpers.so.15
07ee8549 636%attr(755,root,root) %ghost %{_libdir}/libnetsnmpmibs.so.15
637%attr(755,root,root) %ghost %{_libdir}/libnetsnmptrapd.so.15
ea774f60 638
531ca0ff
JB
639%files devel
640%defattr(644,root,root,755)
641%attr(755,root,root) %{_bindir}/mib2c
f2ba5e16 642%attr(755,root,root) %{_bindir}/mib2c-update
531ca0ff 643%attr(755,root,root) %{_bindir}/net-snmp-config
2bacb8e1
ER
644%attr(755,root,root) %{_libdir}/libnetsnmp.so
645%attr(755,root,root) %{_libdir}/libnetsnmpagent.so
646%attr(755,root,root) %{_libdir}/libnetsnmphelpers.so
07ee8549 647%attr(755,root,root) %{_libdir}/libnetsnmpmibs.so
648%attr(755,root,root) %{_libdir}/libnetsnmptrapd.so
2bacb8e1
ER
649%{_libdir}/libnetsnmp.la
650%{_libdir}/libnetsnmpagent.la
651%{_libdir}/libnetsnmphelpers.la
07ee8549 652%{_libdir}/libnetsnmpmibs.la
653%{_libdir}/libnetsnmptrapd.la
531ca0ff
JB
654%{_includedir}/net-snmp
655%{_datadir}/snmp/mib2c*
656%{_mandir}/man1/mib2c.1*
a5fe3234
JB
657%{_mandir}/man1/mib2c-update.1*
658%{_mandir}/man1/net-snmp-config.1*
bdee8ff5 659%{_mandir}/man3/[!NS]*
f2ba5e16 660%{_mandir}/man5/mib2c.conf.5*
531ca0ff 661
c4627f0b 662%if %{with static_libs}
531ca0ff
JB
663%files static
664%defattr(644,root,root,755)
665%{_libdir}/libnet*.a
c4627f0b 666%endif
531ca0ff 667
531ca0ff
JB
668%files compat-devel
669%defattr(644,root,root,755)
670%attr(755,root,root) %{_libdir}/libsnmp.so
671%{_libdir}/libsnmp.la
672%{_includedir}/ucd-snmp
673
c4627f0b 674%if %{with static_libs}
531ca0ff
JB
675%files compat-static
676%defattr(644,root,root,755)
677%{_libdir}/libsnmp.a
c4627f0b 678%endif
531ca0ff 679
15c329ac 680%files -n mibs-net-snmp
60e7e283 681%defattr(644,root,root,755)
15c329ac 682%{_datadir}/mibs/*.txt
ea774f60 683
531ca0ff 684%files snmptrapd
60e7e283 685%defattr(644,root,root,755)
531ca0ff
JB
686%attr(755,root,root) %{_sbindir}/snmptrapd
687%attr(754,root,root) /etc/rc.d/init.d/snmptrapd
9e8f34e2
JB
688%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmptrapd
689%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmptrapd.conf
7470cbdb 690%if %{with perl}
f2ba5e16 691%attr(755,root,root) %{_datadir}/snmp/snmp_perl_trapd.pl
7470cbdb 692%endif
531ca0ff
JB
693%{_mandir}/man5/snmptrapd.conf.5*
694%{_mandir}/man8/snmptrapd.8*
60e7e283 695
ea774f60
AF
696%files utils
697%defattr(644,root,root,755)
698%attr(755,root,root) %{_bindir}/encode_keychange
699%attr(755,root,root) %{_bindir}/snmpbulkget
700%attr(755,root,root) %{_bindir}/snmpbulkwalk
701%attr(755,root,root) %{_bindir}/snmpdelta
6789d157 702%attr(755,root,root) %{_bindir}/snmpdf
ea774f60
AF
703%attr(755,root,root) %{_bindir}/snmpget
704%attr(755,root,root) %{_bindir}/snmpgetnext
6789d157 705%attr(755,root,root) %{_bindir}/snmpinform
ea774f60
AF
706%attr(755,root,root) %{_bindir}/snmpnetstat
707%attr(755,root,root) %{_bindir}/snmpset
708%attr(755,root,root) %{_bindir}/snmpstatus
709%attr(755,root,root) %{_bindir}/snmptable
710%attr(755,root,root) %{_bindir}/snmptest
711%attr(755,root,root) %{_bindir}/snmptranslate
712%attr(755,root,root) %{_bindir}/snmptrap
713%attr(755,root,root) %{_bindir}/snmpusm
ea774f60 714%attr(755,root,root) %{_bindir}/snmpvacm
6789d157 715%attr(755,root,root) %{_bindir}/snmpwalk
a5fe3234 716%{_mandir}/man1/encode_keychange.1*
ea774f60
AF
717%{_mandir}/man1/snmpbulkget.1*
718%{_mandir}/man1/snmpbulkwalk.1*
719%{_mandir}/man1/snmpcmd.1*
720%{_mandir}/man1/snmpdelta.1*
6789d157 721%{_mandir}/man1/snmpdf.1*
ea774f60
AF
722%{_mandir}/man1/snmpget.1*
723%{_mandir}/man1/snmpgetnext.1*
6789d157 724%{_mandir}/man1/snmpinform.1*
ea774f60
AF
725%{_mandir}/man1/snmpnetstat.1*
726%{_mandir}/man1/snmpset.1*
727%{_mandir}/man1/snmpstatus.1*
728%{_mandir}/man1/snmptable.1*
729%{_mandir}/man1/snmptest.1*
730%{_mandir}/man1/snmptranslate.1*
731%{_mandir}/man1/snmptrap.1*
732%{_mandir}/man1/snmpusm.1*
6789d157 733%{_mandir}/man1/snmpvacm.1*
ea774f60 734%{_mandir}/man1/snmpwalk.1*
ea774f60
AF
735%{_mandir}/man5/snmp.conf.5*
736%{_mandir}/man5/snmp_config.5*
737
7bb0c439 738%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmp.conf
6e818aed 739
7470cbdb 740%if %{with perl}
531ca0ff 741%files -n perl-SNMP
c4deead5 742%defattr(644,root,root,755)
531ca0ff
JB
743%doc perl/SNMP/{BUG,README,TODO} perl/SNMP/examples
744%{perl_vendorarch}/SNMP.pm
745%{perl_vendorarch}/NetSNMP
746%dir %{perl_vendorarch}/auto/SNMP
747%{perl_vendorarch}/auto/SNMP/autosplit.ix
748%{perl_vendorarch}/auto/SNMP/SNMP.bs
749%attr(755,root,root) %{perl_vendorarch}/auto/SNMP/SNMP.so
750%dir %{perl_vendorarch}/auto/NetSNMP
751%dir %{perl_vendorarch}/auto/NetSNMP/*
752%{perl_vendorarch}/auto/NetSNMP/*/autosplit.ix
753%{perl_vendorarch}/auto/NetSNMP/*/*.bs
754%attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/*/*.so
755%dir %{perl_vendorarch}/auto/NetSNMP/agent/default_store
756%{perl_vendorarch}/auto/NetSNMP/agent/default_store/autosplit.ix
757%{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.bs
758%attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.so
759%{_mandir}/man3/NetSNMP::*.3*
760%{_mandir}/man3/SNMP.3*
761%{_examplesdir}/perl-SNMP-%{version}
762
ea774f60
AF
763%files utils-perl
764%defattr(644,root,root,755)
6789d157 765%attr(755,root,root) %{_bindir}/fixproc
60e7e283 766%attr(755,root,root) %{_bindir}/snmpcheck
6810e918 767%attr(755,root,root) %{_bindir}/traptoemail
a5fe3234
JB
768%{_mandir}/man1/fixproc.1*
769%{_mandir}/man1/traptoemail.1*
7470cbdb 770%endif
531ca0ff
JB
771
772%files snmpconf
4ec38672 773%defattr(644,root,root,755)
531ca0ff 774%attr(755,root,root) %{_bindir}/snmpconf
60e7e283
AF
775%{_mandir}/man1/snmpconf.1*
776%{_datadir}/snmp/snmpconf-data
e93f5ac2 777
7470cbdb 778%if %{with perl}
e93f5ac2
AF
779%files tkmib
780%defattr(644,root,root,755)
4ec38672 781%attr(755,root,root) %{_bindir}/tkmib
a5fe3234 782%{_mandir}/man1/tkmib.1*
7470cbdb 783%endif
a5fe3234 784
7470cbdb 785%if %{with python}
a5fe3234
JB
786%files -n python-netsnmp
787%defattr(644,root,root,755)
788%dir %{py_sitedir}/netsnmp
789%attr(755,root,root) %{py_sitedir}/netsnmp/*.so
790%{py_sitedir}/netsnmp/*.py[co]
791%{py_sitedir}/netsnmp_python-*.egg-info
7470cbdb 792%endif
This page took 0.214255 seconds and 4 git commands to generate.