]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- strict jack-audio-connection-kit-libs dep (AC-branch merge)
[packages/mplayer.git] / mplayer.spec
CommitLineData
5e37db9a 1# TODO:
8a72e936 2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
b8145877 3# - update for lzo 2
841cb995 4# - try to use external lrmi and few other libs:
4d75c49f 5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
bef18474
ER
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
5e37db9a 9#
94cb018b 10# Conditional build:
8cc223f8 11%bcond_with directfb # with DirectFB video output
8cc223f8
JB
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
8cc223f8
JB
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
93ab9715 17%bcond_without altivec # without altivec support
d6014b54 18%bcond_without x264 # without x264 support
2af58a38 19%bcond_with xmms # with XMMS inputplugin support
8cc223f8 20%bcond_without aalib # without aalib video output
e5b91f83 21%bcond_without jack # without JACKD support
8cc223f8
JB
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
dd153a0d 24%bcond_without caca # without libcaca video output
3c3fdfcc 25%bcond_without cdparanoia # without cdparanoia support
8cc223f8 26%bcond_without dshow # disable DirectShow support
3c3fdfcc
JB
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
8d7378f8 31%bcond_without gui # without GTK+ GUI
8cc223f8 32%bcond_without joystick # disable joystick support
3c3fdfcc 33%bcond_without libdts # disable libdts support
a4298e0c 34%bcond_without libdv # disable libdv en/decoding support
8cc223f8 35%bcond_without lirc # without lirc support
841cb995
ER
36%bcond_with live # without LIVE555 libraries
37%bcond_without lzo # with LZO support (requires lzo 2.x)
8cc223f8 38%bcond_without mad # without mad (audio MPEG) support
86bc294f 39%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 46%bcond_without smb # disable Samba (SMB) input support
de0c2d91 47%bcond_without theora # without theora support
8cc223f8 48%bcond_without win32 # without win32 codecs support
1087e996 49%bcond_without vidix # disable vidix
3b930ad6 50%bcond_without vorbis # without Ogg-Vorbis audio support
3c3fdfcc 51%bcond_without xvid # disable XviD codec
2af58a38 52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 53%bcond_without sdl # disable SDL
aab7d90d 54%bcond_without doc # don't build docs (slow)
59a38ff4 55%bcond_with shared # experimental libmplayer.so support
439df4dd 56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
0256d486 57%bcond_without gnomess # disable controling gnome screensaver
841cb995 58%bcond_with ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
2dfabf36 59
94cb018b
JB
60%ifnarch %{ix86}
61%undefine with_win32
7a82c266 62%undefine with_quicktime
1087e996 63%undefine with_vidix
94cb018b
JB
64%endif
65
fdfd27e9 66%ifarch %{x8664} sparc sparc64
906bf13b
JB
67%undefine with_runtime
68%endif
1a8df7bd 69
70%if %{_lib} == "lib64"
71%define _suf 64
72%else
73%define _suf 32
74%endif
75
879e9f7b 76%define subver rc2
0566b89b 77%define rel 3
135255b8 78
906bf13b 79Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
80Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81Summary(es.UTF-8): Otro reproductor de películas
82Summary(ko.UTF-8): 리눅스용 미디어플레이어
83Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
84Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 85Name: mplayer
9cb1ef87 86Version: 1.0
879e9f7b 87Release: 5.%{subver}.%{rel}
1f85fd72
ER
88# DO NOT increase epoch unless it's really neccessary!
89# especially such changes like pre7->pre7try2, increase Release instead!
90# PS: $ rpmvercmp pre7try2 pre7
91# pre7try2 > pre7
59476b48 92Epoch: 3
bc426a7f 93License: GPL
906bf13b 94Group: Applications/Multimedia
879e9f7b 95Source0: ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
841cb995 96# Source0-md5: 7e27e535c2d267637df34898f1b91707
031c3c7c 97Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 98# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 99Source5: g%{name}.desktop
623ea2d1 100Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 101# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 102Source7: %{name}.png
24481cd2 103Source8: %{name}.desktop
dfd680ce 104# http://www.on2.com/gpl/mplayer/
841cb995
ER
105Source9: http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106# Source9-md5: 2361e56b40f52dfc20131e458e2aed38
aee40e50 107Patch1: %{name}-cp1250-fontdesc.patch
879e9f7b
ER
108#Patch2: %{name}-codec.patch
109#Patch3: %{name}-home_etc.patch
aee40e50 110Patch4: %{name}-350.patch
111Patch5: %{name}-configure.patch
841cb995 112#Patch6: %{name}-system-amr.patch # outdated via ffmpeg?
8cc223f8 113Patch8: %{name}-altivec.patch
879e9f7b
ER
114#Patch10: %{name}-pcmsplit.patch
115#Patch13: %{name}-mythtv.patch
11421384 116Patch14: %{name}-shared.patch
30e3739f 117#http://www.openchrome.org/snapshots/mplayer/
879e9f7b 118#Patch15: %{name}-xvmc.patch
c7699e1b 119Patch17: %{name}-auto-expand.patch
841cb995 120#Patch18: %{name}-gnome-screensaver.patch # update
dfd680ce 121Patch19: %{name}-on2flix.patch
841cb995
ER
122Patch22: %{name}-ffmpeg.patch
123Patch23: %{name}-live.patch
2b6e0df5 124Patch24: %{name}-fontconfig_sub.patch
879e9f7b 125Patch25: http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
c5b97685 126URL: http://www.mplayerhq.hu/
33c4efab 127%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 128BuildRequires: OpenAL-devel
b458005d 129BuildRequires: OpenGL-devel
11421384 130%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
131%{?with_aalib:BuildRequires: aalib-devel}
132%{?with_alsa:BuildRequires: alsa-lib-devel}
e4268e0b
JB
133%if %{with amr}
134BuildRequires: amrnb-devel
4d75c49f 135BuildRequires: amrwb-devel >= 5.3.0
e4268e0b 136%endif
dd6c659c 137%{?with_arts:BuildRequires: artsc-devel}
841cb995 138%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
3c3fdfcc 139%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
aab7d90d 140%{?with_doc:BuildRequires: docbook-style-xsl}
dd6c659c 141%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
142%{?with_enca:BuildRequires: enca-devel}
143%{?with_esd:BuildRequires: esound-devel}
30e3739f 144BuildRequires: faac-devel
3c3fdfcc 145%{?with_faad:BuildRequires: faad2-devel >= 2.0}
841cb995 146BuildRequires: ffmpeg-devel >= 0.4.9-3.20070626.1.1
d23c171d 147BuildRequires: freetype-devel
30e3739f 148BuildRequires: fribidi-devel
1087e996 149%{?with_vidix:BuildRequires: vidix-devel}
8cc223f8
JB
150%ifarch ppc
151%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
152%endif
3c3fdfcc 153%{?with_gif:BuildRequires: giflib-devel}
dd6c659c 154%if %{with gui}
aeb67db6 155BuildRequires: gtk+2-devel
dd6c659c 156%endif
1087e996 157%{?with_gnomess:BuildRequires: dbus-glib-devel}
d336e259 158%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
fdebdb50 159%{?with_jack:%requires_eq jack-audio-connection-kit-libs}
a8a0c1d1 160BuildRequires: lame-libs-devel
dd6c659c 161%{?with_caca:BuildRequires: libcaca-devel}
49aed190 162%{?with_libdts:BuildRequires: libdts-devel}
a4298e0c 163%{?with_libdv:BuildRequires: libdv-devel}
4d75c49f 164BuildRequires: libdvdnav-devel
dd6c659c 165%{?with_ggi:BuildRequires: libggi-devel}
af480c75 166BuildRequires: libjpeg-devel
dd6c659c 167%{?with_mad:BuildRequires: libmad-devel}
30e3739f 168BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 169BuildRequires: libpng-devel
a4298e0c 170%{?with_smb:BuildRequires: libsmbclient-devel}
dd6c659c 171%{?with_dshow:BuildRequires: libstdc++-devel}
de0c2d91 172%{?with_theora:BuildRequires: libtheora-devel}
1130ecb8 173# tremor is used by default, internal as we don't have system one
281ac7d0 174#%{?with_vorbis:BuildRequires: libvorbis-devel}
a9052f4d 175%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20060828_2245.1}
ceb01d0e 176BuildRequires: libxslt-progs
dd6c659c
JB
177%{?with_lirc:BuildRequires: lirc-devel}
178%{?with_live:BuildRequires: live}
841cb995 179%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 180%{?with_nas:BuildRequires: nas-devel}
b458005d 181BuildRequires: ncurses-devel
e9d22b19 182BuildRequires: pkgconfig
86bc294f 183%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
aeb67db6 184BuildRequires: speex-devel >= 1.1
dd6c659c
JB
185%{?with_svga:BuildRequires: svgalib-devel}
186%{?with_xmms:BuildRequires: xmms-libs}
627a7a97
ER
187BuildRequires: xorg-lib-libX11-devel
188BuildRequires: xorg-lib-libXext-devel
189BuildRequires: xorg-lib-libXinerama-devel
190BuildRequires: xorg-lib-libXv-devel
191BuildRequires: xorg-lib-libXvMC-devel
192BuildRequires: xorg-lib-libXxf86dga-devel
193BuildRequires: xorg-lib-libXxf86vm-devel
3c3fdfcc 194%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
c2eb8d00 195BuildRequires: zlib-devel
4d75c49f 196Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 197Requires: OpenGL
0f2a502d 198BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 199
a8e3a9a7 200%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 201%define specflags_ia32 -fomit-frame-pointer
198487b4 202%if %{with altivec}
adfd0023 203%define specflags_ppc -maltivec
20a66bdb 204%endif
2adea73e
AM
205
206%description
c902f7c6 207Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
208AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 209MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
210MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 211devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
212optionally with SHM extension, X11 using overlays with the Xvideo
213extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
214Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 215
8b146837 216If you want to use win32 codecs install w32codec package.
4228a246 217
e011d408 218%description -l de.UTF-8
deba608c 219MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
220Kennzeichnend ist die herausragende Format- und
e011d408 221Plattform-Kompatibilität.
deba608c 222
e011d408
JR
223Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
224plattformexklusive, wodurch etwa Windows Media auch außerhalb von
225Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
226Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 227ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
228Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
229installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 230
e011d408 231%description -l es.UTF-8
c902f7c6 232Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
233MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
234(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
235de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
236Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
237G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
238overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 239G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
240v1.1.7 etc.
33c4efab 241
8b146837 242Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 243
e011d408
JR
244%description -l ko.UTF-8
245MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
246파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
247MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
248Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
249(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
250수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
251크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
252있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
253부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 254
e011d408
JR
255%description -l pl.UTF-8
256Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 257RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
258(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
259Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 260Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 261rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 262G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 263
e011d408 264Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 265
e011d408
JR
266%description -l pt_BR.UTF-8
267MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
268áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 269escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
270
11421384
ER
271%package -n gmplayer
272Summary: MPlayer with GTK+ GUI interface
eeb91a66 273Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 274Group: X11/Applications/Multimedia
11421384 275Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 276Requires: %{name}-skin
906bf13b 277Provides: %{name} = %{epoch}:%{version}-%{release}
11421384
ER
278
279%description -n gmplayer
280MPlayer with GUI GTK+ interface.
281
e011d408 282%description -n gmplayer -l pl.UTF-8
906bf13b
JB
283MPlayer z graficznym interfejsem GTK+.
284
11421384 285%package common
906bf13b 286Summary: Configuration files and documentation for MPlayer
eeb91a66 287Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 288Group: Applications/Multimedia
1087e996 289Obsoletes: mplayer-vidix
11421384
ER
290
291%description common
906bf13b
JB
292Configuration files, man page and HTML documentation for MPlayer.
293
e011d408 294%description common -l pl.UTF-8
906bf13b 295Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
296
297%package -n mencoder
906bf13b 298Summary: MEncoder - a movie encoder for Linux
eeb91a66 299Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
300Group: Applications/Multimedia
301Requires: %{name}-common = %{epoch}:%{version}-%{release}
302
303%description -n mencoder
906bf13b
JB
304MEncoder is a movie encoder for Linux and is a part of the MPlayer
305package.
306
e011d408
JR
307%description -n mencoder -l pl.UTF-8
308MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 309
2adea73e 310%prep
879e9f7b 311%setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
833dbe20 312cp -f etc/codecs.conf etc/codecs.win32.conf
aee40e50 313%patch1 -p0
879e9f7b 314#%patch2 -p1
aee40e50 315##%patch3 -p1 -- old home_etc behavior
316%patch4 -p1
dd6c659c 317%patch5 -p1
841cb995 318#%patch6 -p1 # - try ffmpeg
2dfabf36 319%patch8 -p1
2b8c25a3 320#%%patch10 -p1
aeb67db6 321#%patch13 -p1 # TODO
11421384
ER
322%if %{with shared}
323%patch14 -p1
324%endif
aeb67db6 325#%patch15 -p0 # TODO
c7699e1b 326%patch17 -p1
0256d486 327%if %{with gnomess}
841cb995 328#%patch18 -p1
0992d783 329%endif
59ba0205 330
dfd680ce
ER
331# on2flix
332cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
841cb995 333rm -f mencoder-on2flixenglinux/version.diff
dfd680ce
ER
334%patch19 -p1
335for a in mencoder-on2flixenglinux/*.diff; do
336 patch -p0 < $a
337done
338
841cb995
ER
339%patch22 -p1
340%patch23 -p1
2b6e0df5 341%patch24 -p0
879e9f7b
ER
342cd stream
343%patch25 -p0
344cd -
7c31e935 345
2adea73e 346%build
68dd28e8 347%if %{with shared}
11421384 348CFLAGS="%{rpmcflags} -fPIC"
68dd28e8
ER
349%else
350CFLAGS="%{rpmcflags}"
68dd28e8 351%endif
4ed9dec4 352CC="%{__cc}"
ce8a4f6d
JB
353LDFLAGS="%{rpmldflags}"
354export CC CFLAGS LDFLAGS
11421384
ER
355
356build() {
357set -x
358 ./configure \
359 %{?debug:--enable-debug=3} \
dd6c659c
JB
360 --prefix=%{_prefix} \
361 --confdir=%{_sysconfdir}/mplayer \
dd6c659c 362 --with-extraincdir=%{_includedir}/xvid \
841cb995 363 --with-extralibdir=%{_x_libraries} \
526c0e5d 364 --enable-menu \
841cb995
ER
365 --disable-libavutil_a \
366 --disable-libavcodec_a \
367 --disable-libavformat_a \
368 --disable-libpostproc_a \
369 --enable-libavutil_so \
370 --enable-libavcodec_so \
371 --enable-libavformat_so \
372 --enable-libpostproc_so \
57f87bc2 373%ifnarch %{ix86} %{x8664}
dd6c659c 374 --disable-mmx \
a14f4270 375 --disable-mmxext \
dd6c659c 376 --disable-3dnow \
a14f4270 377 --disable-3dnowext \
dd6c659c
JB
378 --disable-sse \
379 --disable-sse2 \
380 --disable-fastmemcpy \
dfeec30a 381%endif
841cb995 382 %{!?with_ssse3:--disable-ssse3} \
1837afdf 383%ifarch ppc
384%{!?with_altivec:--disable-altivec} \
385%endif
841cb995
ER
386%{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
387%{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
6e0359a9 388%{?with_directfb:--enable-directfb} \
33c4efab 389%{!?with_directfb:--disable-directfb} \
33c4efab 390%{!?with_dxr3:--disable-dxr3} \
391%{!?with_ggi:--disable-ggi} \
841cb995 392%{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
0f2c0aed 393%{!?with_live:--disable-live} \
b8145877 394%{!?with_lzo:--disable-liblzo} \
33c4efab 395%{!?with_nas:--disable-nas} \
396%{!?with_svga:--disable-svga} \
397%{!?with_aalib:--disable-aa} \
e5b91f83 398%{!?with_jack:--disable-jack} \
33c4efab 399%{!?with_alsa:--disable-alsa} \
400%{?with_alsa:--enable-alsa --disable-select} \
401%{!?with_arts:--disable-arts} \
dd153a0d 402%{!?with_caca:--disable-caca} \
3c3fdfcc 403%{!?with_cdparanoia:--disable-cdparanoia} \
33c4efab 404%{!?with_dshow:--disable-dshow} \
3c3fdfcc
JB
405%{!?with_enca:--disable-enca} \
406%{!?with_esd:--disable-esd} \
0ffd4cd0 407%{!?with_faad:--disable-faad-external --disable-faad-internal} \
408%{?with_faad:--disable-faad-internal} \
3c3fdfcc 409%{!?with_gif:--disable-gif} \
33c4efab 410%{?with_joystick:--enable-joystick} \
a4298e0c 411%{!?with_libdv:--disable-libdv} \
49aed190 412%{!?with_libdts:--disable-libdts} \
d8f32b56 413--%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
33c4efab 414%{!?with_mad:--disable-mad} \
4143807a 415%{!?with_pulseaudio:--disable-pulse} \
7a82c266 416%{!?with_quicktime:--disable-qtx} \
33c4efab 417%{!?with_real:--disable-real} \
11421384 418--%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
33c4efab 419%{!?with_select:--disable-select} \
a4298e0c 420%{!?with_smb:--disable-smb} \
841cb995 421%{!?with_win32:--disable-win32dll} \
33c4efab 422%{!?with_vorbis:--disable-vorbis} \
423%{?with_osd:--enable-menu} \
587f4971 424%{!?with_theora:--disable-theora} \
6a8a1010 425%{!?with_x264:--disable-x264} \
dd6c659c 426%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
3c3fdfcc 427%{!?with_xvid:--disable-xvid} \
1087e996
ER
428%{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
429%{?with_vidix:--disable-vidix-internal} \
dd6c659c 430%{!?with_mencoder:--disable-mencoder} \
841cb995
ER
431 --enable-dga1 \
432 --enable-dga2 \
dd6c659c
JB
433 --enable-fbdev \
434 --enable-gl \
435 --enable-mga \
e7261209
KK
436 --enable-radio \
437 --enable-radio-capture \
11421384 438 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
dd6c659c
JB
439 --enable-tdfxfb \
440 --enable-vm \
441 --enable-x11 \
442 --enable-xmga \
443 --enable-xv \
444 --enable-xvmc \
3c3fdfcc 445 --enable-dynamic-plugins \
dd6c659c
JB
446 --enable-largefiles \
447 --language=all \
841cb995 448 --codecsdir=%{_libdir}/codecs \
3c3fdfcc 449 --with-xvmclib=XvMCW \
11421384 450 "$@"
eb52750a 451
11421384
ER
452 %{__make}
453}
2adea73e 454
11421384
ER
455%if %{with gui}
456# build GUI version
841cb995 457build --enable-gui --disable-mencoder
11421384 458mv -f mplayer gmplayer
aeb67db6 459%{__make} distclean
11421384
ER
460%endif
461
462# now build regular version
463build --disable-gui
464
aab7d90d 465%if %{with doc}
6eeeb8b4 466%{__make} -j1 -C DOCS/xml
11421384 467%endif
ceb01d0e 468
2adea73e
AM
469%install
470rm -rf $RPM_BUILD_ROOT
e0e4b963 471install -d \
d23c171d 472 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 473 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
dd20ae16 474 $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
59ba0205 475 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 476
e0e4b963 477# default config files
11421384 478sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
c455a752 479install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 480
481# executables
2af58a38 482%if %{with mencoder}
1a8df7bd 483install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
484ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 485%endif
1a8df7bd 486install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
487ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 488%if %{with gui}
1a8df7bd 489install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
490ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 491%endif
e0e4b963 492
493# fonts
9d62f689
TP
494rm -f font-*/runme
495cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 496ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 497
11421384 498%if %{with gui}
dd20ae16 499ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
f0d8c47e 500install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 501%endif
24481cd2 502install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 503install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 504
505# man pages
59ba0205 506install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 507install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
508install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
509install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
510install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
511install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 512install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 513install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 514#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
e66a8169 515install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 516
2adea73e
AM
517%clean
518rm -rf $RPM_BUILD_ROOT
519
a69eaaef 520%post -n gmplayer
cd748ae6 521umask 022
cd748ae6 522[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
523
a69eaaef 524%postun -n gmplayer
cd748ae6 525umask 022
75b3147a 526[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 527
2adea73e
AM
528%files
529%defattr(644,root,root,755)
1a8df7bd 530%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
531
532%if %{with gui}
533%files -n gmplayer
534%defattr(644,root,root,755)
1a8df7bd 535%attr(755,root,root) %{_bindir}/gmplayer*
11421384 536%{_desktopdir}/gmplayer.desktop
dd20ae16 537%dir %{_datadir}/%{name}/skins
0566b89b 538#%ghost %{_datadir}/%{name}/skins/default
11421384
ER
539%endif
540
0fb5a7ee 541%if %{with mencoder}
11421384
ER
542%files -n mencoder
543%defattr(644,root,root,755)
aeb67db6 544%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
545%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
546%doc DOCS/tech/colorspaces.txt
1a8df7bd 547%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 548%endif
11421384
ER
549
550%files common
551%defattr(644,root,root,755)
11421384
ER
552%doc DOCS/tech
553%if %{with win32}
35ac5af9 554%doc etc/codecs.win32.conf
11421384 555%endif
841cb995
ER
556%if %{with doc}
557# HTML and XML-generated docs
558%doc DOCS/HTML/en
0ffd4cd0 559%lang(cs) %doc DOCS/HTML/cs
aeb67db6 560%lang(de) %doc DOCS/HTML/de
aee40e50 561%lang(es) %doc DOCS/HTML/es
562%lang(fr) %doc DOCS/HTML/fr
8cda16b8 563%lang(hu) %doc DOCS/HTML/hu
aee40e50 564%lang(pl) %doc DOCS/HTML/pl
565%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
566#%lang(zh_CN) %doc DOCS/zh
567%endif
568%doc AUTHORS README
11421384 569
906bf13b
JB
570%dir %{_sysconfdir}/%{name}
571%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 572%{_mandir}/man1/*
59ba0205 573%lang(cs) %{_mandir}/cs/man1/*
20e1052d 574%lang(de) %{_mandir}/de/man1/*
aee40e50 575%lang(es) %{_mandir}/es/man1/*
2a9a2b75 576%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 577%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 578%lang(it) %{_mandir}/it/man1/*
2a6ed516 579%lang(pl) %{_mandir}/pl/man1/*
841cb995 580#%lang(sv) %{_mandir}/sv/man1/*
90413e82 581%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 582%{_desktopdir}/mplayer.desktop
1087e996 583%{_pixmapsdir}/mplayer.png
11421384
ER
584%dir %{_datadir}/%{name}
585%{_datadir}/%{name}/font*
This page took 0.197804 seconds and 4 git commands to generate.