]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- add CVE-2008-0485 fix (demux_mov_fix_20080129.diff)
[packages/mplayer.git] / mplayer.spec
CommitLineData
5e37db9a 1# TODO:
8a72e936 2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
b8145877 3# - update for lzo 2
841cb995 4# - try to use external lrmi and few other libs:
4d75c49f 5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
bef18474
ER
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
5e37db9a 9#
94cb018b 10# Conditional build:
8cc223f8 11%bcond_with directfb # with DirectFB video output
8cc223f8
JB
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
8cc223f8
JB
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
93ab9715 17%bcond_without altivec # without altivec support
d6014b54 18%bcond_without x264 # without x264 support
2af58a38 19%bcond_with xmms # with XMMS inputplugin support
8cc223f8 20%bcond_without aalib # without aalib video output
e5b91f83 21%bcond_without jack # without JACKD support
8cc223f8
JB
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
dd153a0d 24%bcond_without caca # without libcaca video output
3c3fdfcc 25%bcond_without cdparanoia # without cdparanoia support
8cc223f8 26%bcond_without dshow # disable DirectShow support
3c3fdfcc
JB
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
8d7378f8 31%bcond_without gui # without GTK+ GUI
8cc223f8 32%bcond_without joystick # disable joystick support
3c3fdfcc 33%bcond_without libdts # disable libdts support
a4298e0c 34%bcond_without libdv # disable libdv en/decoding support
8cc223f8 35%bcond_without lirc # without lirc support
841cb995
ER
36%bcond_with live # without LIVE555 libraries
37%bcond_without lzo # with LZO support (requires lzo 2.x)
8cc223f8 38%bcond_without mad # without mad (audio MPEG) support
86bc294f 39%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 46%bcond_without smb # disable Samba (SMB) input support
de0c2d91 47%bcond_without theora # without theora support
8cc223f8 48%bcond_without win32 # without win32 codecs support
1087e996 49%bcond_without vidix # disable vidix
3b930ad6 50%bcond_without vorbis # without Ogg-Vorbis audio support
3c3fdfcc 51%bcond_without xvid # disable XviD codec
2af58a38 52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 53%bcond_without sdl # disable SDL
aab7d90d 54%bcond_without doc # don't build docs (slow)
59a38ff4 55%bcond_with shared # experimental libmplayer.so support
439df4dd 56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
0256d486 57%bcond_without gnomess # disable controling gnome screensaver
841cb995 58%bcond_with ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
2dfabf36 59
94cb018b
JB
60%ifnarch %{ix86}
61%undefine with_win32
7a82c266 62%undefine with_quicktime
1087e996 63%undefine with_vidix
94cb018b
JB
64%endif
65
38c74592 66%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
67%undefine with_runtime
68%endif
1a8df7bd 69
70%if %{_lib} == "lib64"
422903c7 71%define _suf 64
1a8df7bd 72%else
422903c7 73%define _suf 32
1a8df7bd 74%endif
75
879e9f7b 76%define subver rc2
f10ca1d7 77%define rel 5.5
135255b8 78
906bf13b 79Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
80Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81Summary(es.UTF-8): Otro reproductor de películas
82Summary(ko.UTF-8): 리눅스용 미디어플레이어
83Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
84Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 85Name: mplayer
9cb1ef87 86Version: 1.0
879e9f7b 87Release: 5.%{subver}.%{rel}
1f85fd72
ER
88# DO NOT increase epoch unless it's really neccessary!
89# especially such changes like pre7->pre7try2, increase Release instead!
90# PS: $ rpmvercmp pre7try2 pre7
91# pre7try2 > pre7
59476b48 92Epoch: 3
bc426a7f 93License: GPL
906bf13b 94Group: Applications/Multimedia
879e9f7b 95Source0: ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
841cb995 96# Source0-md5: 7e27e535c2d267637df34898f1b91707
031c3c7c 97Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 98# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 99Source5: g%{name}.desktop
623ea2d1 100Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 101# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 102Source7: %{name}.png
24481cd2 103Source8: %{name}.desktop
dfd680ce 104# http://www.on2.com/gpl/mplayer/
841cb995
ER
105Source9: http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106# Source9-md5: 2361e56b40f52dfc20131e458e2aed38
aee40e50 107Patch1: %{name}-cp1250-fontdesc.patch
f10ca1d7
PG
108Patch2: %{name}-codec.patch
109Patch3: %{name}-home_etc.patch
aee40e50 110Patch4: %{name}-350.patch
111Patch5: %{name}-configure.patch
f10ca1d7
PG
112# outdated via ffmpeg?
113Patch6: %{name}-system-amr.patch
8cc223f8 114Patch8: %{name}-altivec.patch
f10ca1d7
PG
115Patch10: %{name}-pcmsplit.patch
116Patch13: %{name}-mythtv.patch
11421384 117Patch14: %{name}-shared.patch
30e3739f 118#http://www.openchrome.org/snapshots/mplayer/
f10ca1d7 119Patch15: %{name}-xvmc.patch
c7699e1b 120Patch17: %{name}-auto-expand.patch
f10ca1d7
PG
121# update
122Patch18: %{name}-gnome-screensaver.patch
dfd680ce 123Patch19: %{name}-on2flix.patch
841cb995
ER
124Patch22: %{name}-ffmpeg.patch
125Patch23: %{name}-live.patch
2b6e0df5 126Patch24: %{name}-fontconfig_sub.patch
879e9f7b 127Patch25: http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
38c74592 128Patch26: %{name}-check-byteswap.patch
f10ca1d7 129Patch27: http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
c5b97685 130URL: http://www.mplayerhq.hu/
33c4efab 131%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 132BuildRequires: OpenAL-devel
b458005d 133BuildRequires: OpenGL-devel
11421384 134%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
135%{?with_aalib:BuildRequires: aalib-devel}
136%{?with_alsa:BuildRequires: alsa-lib-devel}
e4268e0b
JB
137%if %{with amr}
138BuildRequires: amrnb-devel
4d75c49f 139BuildRequires: amrwb-devel >= 5.3.0
e4268e0b 140%endif
dd6c659c 141%{?with_arts:BuildRequires: artsc-devel}
841cb995 142%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
3c3fdfcc 143%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
aab7d90d 144%{?with_doc:BuildRequires: docbook-style-xsl}
dd6c659c 145%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
146%{?with_enca:BuildRequires: enca-devel}
147%{?with_esd:BuildRequires: esound-devel}
30e3739f 148BuildRequires: faac-devel
3c3fdfcc 149%{?with_faad:BuildRequires: faad2-devel >= 2.0}
841cb995 150BuildRequires: ffmpeg-devel >= 0.4.9-3.20070626.1.1
d23c171d 151BuildRequires: freetype-devel
30e3739f 152BuildRequires: fribidi-devel
1087e996 153%{?with_vidix:BuildRequires: vidix-devel}
8cc223f8
JB
154%ifarch ppc
155%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
156%endif
3c3fdfcc 157%{?with_gif:BuildRequires: giflib-devel}
dd6c659c 158%if %{with gui}
aeb67db6 159BuildRequires: gtk+2-devel
dd6c659c 160%endif
1087e996 161%{?with_gnomess:BuildRequires: dbus-glib-devel}
d336e259 162%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
422903c7 163%{?with_jack:%requires_eq jack-audio-connection-kit-libs}
a8a0c1d1 164BuildRequires: lame-libs-devel
dd6c659c 165%{?with_caca:BuildRequires: libcaca-devel}
49aed190 166%{?with_libdts:BuildRequires: libdts-devel}
a4298e0c 167%{?with_libdv:BuildRequires: libdv-devel}
4d75c49f 168BuildRequires: libdvdnav-devel
dd6c659c 169%{?with_ggi:BuildRequires: libggi-devel}
af480c75 170BuildRequires: libjpeg-devel
dd6c659c 171%{?with_mad:BuildRequires: libmad-devel}
30e3739f 172BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 173BuildRequires: libpng-devel
a4298e0c 174%{?with_smb:BuildRequires: libsmbclient-devel}
dd6c659c 175%{?with_dshow:BuildRequires: libstdc++-devel}
de0c2d91 176%{?with_theora:BuildRequires: libtheora-devel}
1130ecb8 177# tremor is used by default, internal as we don't have system one
281ac7d0 178#%{?with_vorbis:BuildRequires: libvorbis-devel}
a9052f4d 179%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20060828_2245.1}
ceb01d0e 180BuildRequires: libxslt-progs
dd6c659c
JB
181%{?with_lirc:BuildRequires: lirc-devel}
182%{?with_live:BuildRequires: live}
841cb995 183%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 184%{?with_nas:BuildRequires: nas-devel}
b458005d 185BuildRequires: ncurses-devel
e9d22b19 186BuildRequires: pkgconfig
86bc294f 187%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
aeb67db6 188BuildRequires: speex-devel >= 1.1
dd6c659c
JB
189%{?with_svga:BuildRequires: svgalib-devel}
190%{?with_xmms:BuildRequires: xmms-libs}
627a7a97
ER
191BuildRequires: xorg-lib-libX11-devel
192BuildRequires: xorg-lib-libXext-devel
193BuildRequires: xorg-lib-libXinerama-devel
194BuildRequires: xorg-lib-libXv-devel
195BuildRequires: xorg-lib-libXvMC-devel
196BuildRequires: xorg-lib-libXxf86dga-devel
197BuildRequires: xorg-lib-libXxf86vm-devel
3c3fdfcc 198%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
c2eb8d00 199BuildRequires: zlib-devel
4d75c49f 200Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 201Requires: OpenGL
0f2a502d 202BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 203
a8e3a9a7 204%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 205%define specflags_ia32 -fomit-frame-pointer
198487b4 206%if %{with altivec}
adfd0023 207%define specflags_ppc -maltivec
20a66bdb 208%endif
2adea73e
AM
209
210%description
c902f7c6 211Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
212AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 213MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
214MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 215devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
216optionally with SHM extension, X11 using overlays with the Xvideo
217extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
218Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 219
8b146837 220If you want to use win32 codecs install w32codec package.
4228a246 221
e011d408 222%description -l de.UTF-8
deba608c 223MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
224Kennzeichnend ist die herausragende Format- und
e011d408 225Plattform-Kompatibilität.
deba608c 226
e011d408
JR
227Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
228plattformexklusive, wodurch etwa Windows Media auch außerhalb von
229Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
230Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 231ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
232Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
233installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 234
e011d408 235%description -l es.UTF-8
c902f7c6 236Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
237MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
238(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
239de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
240Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
241G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
242overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 243G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
244v1.1.7 etc.
33c4efab 245
8b146837 246Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 247
e011d408
JR
248%description -l ko.UTF-8
249MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
250파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
251MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
252Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
253(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
254수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
255크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
256있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
257부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 258
e011d408
JR
259%description -l pl.UTF-8
260Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 261RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
262(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
263Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 264Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 265rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 266G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 267
e011d408 268Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 269
e011d408
JR
270%description -l pt_BR.UTF-8
271MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
272áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 273escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
274
11421384
ER
275%package -n gmplayer
276Summary: MPlayer with GTK+ GUI interface
eeb91a66 277Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 278Group: X11/Applications/Multimedia
11421384 279Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 280Requires: %{name}-skin
906bf13b 281Provides: %{name} = %{epoch}:%{version}-%{release}
11421384
ER
282
283%description -n gmplayer
284MPlayer with GUI GTK+ interface.
285
e011d408 286%description -n gmplayer -l pl.UTF-8
906bf13b
JB
287MPlayer z graficznym interfejsem GTK+.
288
11421384 289%package common
906bf13b 290Summary: Configuration files and documentation for MPlayer
eeb91a66 291Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 292Group: Applications/Multimedia
1087e996 293Obsoletes: mplayer-vidix
11421384
ER
294
295%description common
906bf13b
JB
296Configuration files, man page and HTML documentation for MPlayer.
297
e011d408 298%description common -l pl.UTF-8
906bf13b 299Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
300
301%package -n mencoder
906bf13b 302Summary: MEncoder - a movie encoder for Linux
eeb91a66 303Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
304Group: Applications/Multimedia
305Requires: %{name}-common = %{epoch}:%{version}-%{release}
306
307%description -n mencoder
906bf13b
JB
308MEncoder is a movie encoder for Linux and is a part of the MPlayer
309package.
310
e011d408
JR
311%description -n mencoder -l pl.UTF-8
312MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 313
2adea73e 314%prep
879e9f7b 315%setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
833dbe20 316cp -f etc/codecs.conf etc/codecs.win32.conf
aee40e50 317%patch1 -p0
879e9f7b 318#%patch2 -p1
aee40e50 319##%patch3 -p1 -- old home_etc behavior
320%patch4 -p1
dd6c659c 321%patch5 -p1
841cb995 322#%patch6 -p1 # - try ffmpeg
2dfabf36 323%patch8 -p1
2b8c25a3 324#%%patch10 -p1
aeb67db6 325#%patch13 -p1 # TODO
11421384
ER
326%if %{with shared}
327%patch14 -p1
328%endif
aeb67db6 329#%patch15 -p0 # TODO
c7699e1b 330%patch17 -p1
0256d486 331%if %{with gnomess}
841cb995 332#%patch18 -p1
0992d783 333%endif
59ba0205 334
dfd680ce
ER
335# on2flix
336cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
841cb995 337rm -f mencoder-on2flixenglinux/version.diff
dfd680ce
ER
338%patch19 -p1
339for a in mencoder-on2flixenglinux/*.diff; do
340 patch -p0 < $a
341done
342
841cb995
ER
343%patch22 -p1
344%patch23 -p1
2b6e0df5 345%patch24 -p0
879e9f7b
ER
346cd stream
347%patch25 -p0
348cd -
38c74592 349%patch26 -p1
f10ca1d7 350%patch27 -p0
7c31e935 351
2adea73e 352%build
68dd28e8 353%if %{with shared}
11421384 354CFLAGS="%{rpmcflags} -fPIC"
68dd28e8
ER
355%else
356CFLAGS="%{rpmcflags}"
68dd28e8 357%endif
4ed9dec4 358CC="%{__cc}"
ce8a4f6d
JB
359LDFLAGS="%{rpmldflags}"
360export CC CFLAGS LDFLAGS
11421384
ER
361
362build() {
363set -x
364 ./configure \
365 %{?debug:--enable-debug=3} \
dd6c659c
JB
366 --prefix=%{_prefix} \
367 --confdir=%{_sysconfdir}/mplayer \
dd6c659c 368 --with-extraincdir=%{_includedir}/xvid \
841cb995 369 --with-extralibdir=%{_x_libraries} \
526c0e5d 370 --enable-menu \
841cb995
ER
371 --disable-libavutil_a \
372 --disable-libavcodec_a \
373 --disable-libavformat_a \
374 --disable-libpostproc_a \
375 --enable-libavutil_so \
376 --enable-libavcodec_so \
377 --enable-libavformat_so \
378 --enable-libpostproc_so \
57f87bc2 379%ifnarch %{ix86} %{x8664}
dd6c659c 380 --disable-mmx \
a14f4270 381 --disable-mmxext \
dd6c659c 382 --disable-3dnow \
a14f4270 383 --disable-3dnowext \
dd6c659c
JB
384 --disable-sse \
385 --disable-sse2 \
386 --disable-fastmemcpy \
dfeec30a 387%endif
841cb995 388 %{!?with_ssse3:--disable-ssse3} \
1837afdf 389%ifarch ppc
390%{!?with_altivec:--disable-altivec} \
391%endif
841cb995
ER
392%{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
393%{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
6e0359a9 394%{?with_directfb:--enable-directfb} \
33c4efab 395%{!?with_directfb:--disable-directfb} \
33c4efab 396%{!?with_dxr3:--disable-dxr3} \
397%{!?with_ggi:--disable-ggi} \
841cb995 398%{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
0f2c0aed 399%{!?with_live:--disable-live} \
b8145877 400%{!?with_lzo:--disable-liblzo} \
33c4efab 401%{!?with_nas:--disable-nas} \
402%{!?with_svga:--disable-svga} \
403%{!?with_aalib:--disable-aa} \
e5b91f83 404%{!?with_jack:--disable-jack} \
33c4efab 405%{!?with_alsa:--disable-alsa} \
406%{?with_alsa:--enable-alsa --disable-select} \
407%{!?with_arts:--disable-arts} \
dd153a0d 408%{!?with_caca:--disable-caca} \
3c3fdfcc 409%{!?with_cdparanoia:--disable-cdparanoia} \
33c4efab 410%{!?with_dshow:--disable-dshow} \
3c3fdfcc
JB
411%{!?with_enca:--disable-enca} \
412%{!?with_esd:--disable-esd} \
0ffd4cd0 413%{!?with_faad:--disable-faad-external --disable-faad-internal} \
414%{?with_faad:--disable-faad-internal} \
3c3fdfcc 415%{!?with_gif:--disable-gif} \
33c4efab 416%{?with_joystick:--enable-joystick} \
a4298e0c 417%{!?with_libdv:--disable-libdv} \
49aed190 418%{!?with_libdts:--disable-libdts} \
d8f32b56 419--%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
33c4efab 420%{!?with_mad:--disable-mad} \
4143807a 421%{!?with_pulseaudio:--disable-pulse} \
7a82c266 422%{!?with_quicktime:--disable-qtx} \
33c4efab 423%{!?with_real:--disable-real} \
11421384 424--%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
33c4efab 425%{!?with_select:--disable-select} \
a4298e0c 426%{!?with_smb:--disable-smb} \
841cb995 427%{!?with_win32:--disable-win32dll} \
33c4efab 428%{!?with_vorbis:--disable-vorbis} \
429%{?with_osd:--enable-menu} \
587f4971 430%{!?with_theora:--disable-theora} \
6a8a1010 431%{!?with_x264:--disable-x264} \
dd6c659c 432%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
3c3fdfcc 433%{!?with_xvid:--disable-xvid} \
1087e996
ER
434%{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
435%{?with_vidix:--disable-vidix-internal} \
dd6c659c 436%{!?with_mencoder:--disable-mencoder} \
841cb995
ER
437 --enable-dga1 \
438 --enable-dga2 \
dd6c659c
JB
439 --enable-fbdev \
440 --enable-gl \
441 --enable-mga \
e7261209
KK
442 --enable-radio \
443 --enable-radio-capture \
11421384 444 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
dd6c659c
JB
445 --enable-tdfxfb \
446 --enable-vm \
447 --enable-x11 \
448 --enable-xmga \
449 --enable-xv \
450 --enable-xvmc \
3c3fdfcc 451 --enable-dynamic-plugins \
dd6c659c
JB
452 --enable-largefiles \
453 --language=all \
841cb995 454 --codecsdir=%{_libdir}/codecs \
3c3fdfcc 455 --with-xvmclib=XvMCW \
11421384 456 "$@"
eb52750a 457
11421384
ER
458 %{__make}
459}
2adea73e 460
11421384
ER
461%if %{with gui}
462# build GUI version
841cb995 463build --enable-gui --disable-mencoder
11421384 464mv -f mplayer gmplayer
aeb67db6 465%{__make} distclean
11421384
ER
466%endif
467
468# now build regular version
469build --disable-gui
470
aab7d90d 471%if %{with doc}
6eeeb8b4 472%{__make} -j1 -C DOCS/xml
11421384 473%endif
ceb01d0e 474
2adea73e
AM
475%install
476rm -rf $RPM_BUILD_ROOT
e0e4b963 477install -d \
d23c171d 478 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 479 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
dd20ae16 480 $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
59ba0205 481 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 482
e0e4b963 483# default config files
11421384 484sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
c455a752 485install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 486
487# executables
2af58a38 488%if %{with mencoder}
1a8df7bd 489install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
490ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 491%endif
1a8df7bd 492install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
493ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 494%if %{with gui}
1a8df7bd 495install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
496ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 497%endif
e0e4b963 498
499# fonts
9d62f689
TP
500rm -f font-*/runme
501cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 502ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 503
11421384 504%if %{with gui}
dd20ae16 505ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
f0d8c47e 506install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 507%endif
24481cd2 508install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 509install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 510
511# man pages
59ba0205 512install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 513install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
514install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
515install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
516install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
517install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 518install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 519install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 520#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
e66a8169 521install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 522
2adea73e
AM
523%clean
524rm -rf $RPM_BUILD_ROOT
525
a69eaaef 526%post -n gmplayer
cd748ae6 527umask 022
cd748ae6 528[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
529
a69eaaef 530%postun -n gmplayer
cd748ae6 531umask 022
75b3147a 532[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 533
2adea73e
AM
534%files
535%defattr(644,root,root,755)
1a8df7bd 536%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
537
538%if %{with gui}
539%files -n gmplayer
540%defattr(644,root,root,755)
1a8df7bd 541%attr(755,root,root) %{_bindir}/gmplayer*
11421384 542%{_desktopdir}/gmplayer.desktop
dd20ae16 543%dir %{_datadir}/%{name}/skins
0566b89b 544#%ghost %{_datadir}/%{name}/skins/default
11421384
ER
545%endif
546
0fb5a7ee 547%if %{with mencoder}
11421384
ER
548%files -n mencoder
549%defattr(644,root,root,755)
aeb67db6 550%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
551%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
552%doc DOCS/tech/colorspaces.txt
1a8df7bd 553%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 554%endif
11421384
ER
555
556%files common
557%defattr(644,root,root,755)
11421384
ER
558%doc DOCS/tech
559%if %{with win32}
35ac5af9 560%doc etc/codecs.win32.conf
11421384 561%endif
841cb995
ER
562%if %{with doc}
563# HTML and XML-generated docs
564%doc DOCS/HTML/en
0ffd4cd0 565%lang(cs) %doc DOCS/HTML/cs
aeb67db6 566%lang(de) %doc DOCS/HTML/de
aee40e50 567%lang(es) %doc DOCS/HTML/es
568%lang(fr) %doc DOCS/HTML/fr
8cda16b8 569%lang(hu) %doc DOCS/HTML/hu
aee40e50 570%lang(pl) %doc DOCS/HTML/pl
571%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
572#%lang(zh_CN) %doc DOCS/zh
573%endif
574%doc AUTHORS README
11421384 575
906bf13b
JB
576%dir %{_sysconfdir}/%{name}
577%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 578%{_mandir}/man1/*
59ba0205 579%lang(cs) %{_mandir}/cs/man1/*
20e1052d 580%lang(de) %{_mandir}/de/man1/*
aee40e50 581%lang(es) %{_mandir}/es/man1/*
2a9a2b75 582%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 583%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 584%lang(it) %{_mandir}/it/man1/*
2a6ed516 585%lang(pl) %{_mandir}/pl/man1/*
841cb995 586#%lang(sv) %{_mandir}/sv/man1/*
90413e82 587%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 588%{_desktopdir}/mplayer.desktop
1087e996 589%{_pixmapsdir}/mplayer.png
11421384
ER
590%dir %{_datadir}/%{name}
591%{_datadir}/%{name}/font*
This page took 0.276002 seconds and 4 git commands to generate.