]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- tabs in preamble
[packages/mplayer.git] / mplayer.spec
CommitLineData
5e37db9a 1# TODO:
8a72e936 2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
b8145877 3# - update for lzo 2
8a72e936 4# - try to use external ffmpeg, lrmi and few other libs:
4d75c49f 5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
bef18474
ER
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
5e37db9a 9#
94cb018b 10# Conditional build:
8cc223f8 11%bcond_with directfb # with DirectFB video output
8cc223f8
JB
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
8cc223f8
JB
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
93ab9715 17%bcond_without altivec # without altivec support
d6014b54 18%bcond_without x264 # without x264 support
2af58a38 19%bcond_with xmms # with XMMS inputplugin support
8cc223f8 20%bcond_without aalib # without aalib video output
e5b91f83 21%bcond_without jack # without JACKD support
8cc223f8
JB
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
dd153a0d 24%bcond_without caca # without libcaca video output
3c3fdfcc 25%bcond_without cdparanoia # without cdparanoia support
8cc223f8 26%bcond_without dshow # disable DirectShow support
3c3fdfcc
JB
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
8d7378f8 31%bcond_without gui # without GTK+ GUI
8cc223f8 32%bcond_without joystick # disable joystick support
3c3fdfcc 33%bcond_without libdts # disable libdts support
a4298e0c 34%bcond_without libdv # disable libdv en/decoding support
8cc223f8 35%bcond_without lirc # without lirc support
5f4f63f5 36%bcond_without live # without live.com libraries
b8145877 37%bcond_with lzo # with LZO support (requires lzo 1.x)
8cc223f8 38%bcond_without mad # without mad (audio MPEG) support
86bc294f 39%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 46%bcond_without smb # disable Samba (SMB) input support
de0c2d91 47%bcond_without theora # without theora support
8cc223f8 48%bcond_without win32 # without win32 codecs support
1087e996 49%bcond_without vidix # disable vidix
3b930ad6 50%bcond_without vorbis # without Ogg-Vorbis audio support
3c3fdfcc 51%bcond_without xvid # disable XviD codec
2af58a38 52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 53%bcond_without sdl # disable SDL
aab7d90d 54%bcond_without doc # don't build docs (slow)
59a38ff4 55%bcond_with shared # experimental libmplayer.so support
439df4dd 56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
0256d486 57%bcond_without gnomess # disable controling gnome screensaver
2dfabf36 58
94cb018b
JB
59%ifnarch %{ix86}
60%undefine with_win32
7a82c266 61%undefine with_quicktime
1087e996 62%undefine with_vidix
94cb018b
JB
63%endif
64
906bf13b
JB
65%ifarch %{x8664}
66%undefine with_runtime
67%endif
1a8df7bd 68
69%if %{_lib} == "lib64"
70%define _suf 64
71%else
72%define _suf 32
73%endif
74
b458005d 75%define sname MPlayer
198487b4 76%define snap %{nil}
268c9ea9 77
dfd680ce 78%define _rc rc1
93211e55 79%define _rel 4
906bf13b 80Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
81Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
82Summary(es.UTF-8): Otro reproductor de películas
83Summary(ko.UTF-8): 리눅스용 미디어플레이어
84Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
85Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 86Name: mplayer
9cb1ef87 87Version: 1.0
dfd680ce 88Release: 3.%{_rc}.%{_rel}
1f85fd72
ER
89# DO NOT increase epoch unless it's really neccessary!
90# especially such changes like pre7->pre7try2, increase Release instead!
91# PS: $ rpmvercmp pre7try2 pre7
92# pre7try2 > pre7
59476b48 93Epoch: 3
bc426a7f 94License: GPL
906bf13b 95Group: Applications/Multimedia
dfd680ce 96Source0: ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{_rc}.tar.bz2
30e3739f 97# Source0-md5: 18c05d88e22c3b815a43ca8d7152ccdc
031c3c7c 98Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 99# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 100Source5: g%{name}.desktop
623ea2d1 101Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 102# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 103Source7: %{name}.png
24481cd2 104Source8: %{name}.desktop
dfd680ce
ER
105# http://www.on2.com/gpl/mplayer/
106Source9: http://www.on2.com/gpl/mplayer/2006-11-29-mencoder-on2flixenglinux.tar.bz2
107# Source9-md5: 66fd6987f36f0b0cec6a28366ac3141c
aee40e50 108Patch1: %{name}-cp1250-fontdesc.patch
109Patch2: %{name}-codec.patch
110Patch3: %{name}-home_etc.patch
111Patch4: %{name}-350.patch
112Patch5: %{name}-configure.patch
0992d783 113Patch6: %{name}-system-amr.patch
8cc223f8 114Patch8: %{name}-altivec.patch
ceb01d0e 115Patch10: %{name}-pcmsplit.patch
d6014b54 116Patch11: ffmpeg-x264-symbol.patch
86bc294f 117Patch12: %{name}-pulse.patch
21badcc3 118Patch13: %{name}-mythtv.patch
11421384 119Patch14: %{name}-shared.patch
30e3739f 120#http://www.openchrome.org/snapshots/mplayer/
499b1aea 121Patch15: %{name}-xvmc.patch
adfd0023 122Patch16: %{name}-kill-mabi_altivec.patch
c7699e1b 123Patch17: %{name}-auto-expand.patch
ce8a4f6d 124Patch18: %{name}-gnome-screensaver.patch
dfd680ce 125Patch19: %{name}-on2flix.patch
7c31e935 126Patch20: http://www.mplayerhq.hu/MPlayer/patches/asmrules_fix_20061231.diff
c5b97685 127URL: http://www.mplayerhq.hu/
33c4efab 128%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 129BuildRequires: OpenAL-devel
b458005d 130BuildRequires: OpenGL-devel
11421384 131%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
132%{?with_aalib:BuildRequires: aalib-devel}
133%{?with_alsa:BuildRequires: alsa-lib-devel}
e4268e0b
JB
134%if %{with amr}
135BuildRequires: amrnb-devel
4d75c49f 136BuildRequires: amrwb-devel >= 5.3.0
e4268e0b 137%endif
dd6c659c 138%{?with_arts:BuildRequires: artsc-devel}
3c3fdfcc 139%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
aab7d90d 140%{?with_doc:BuildRequires: docbook-style-xsl}
dd6c659c 141%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
142%{?with_enca:BuildRequires: enca-devel}
143%{?with_esd:BuildRequires: esound-devel}
30e3739f 144BuildRequires: faac-devel
3c3fdfcc 145%{?with_faad:BuildRequires: faad2-devel >= 2.0}
d23c171d 146BuildRequires: freetype-devel
30e3739f 147BuildRequires: fribidi-devel
1087e996 148%{?with_vidix:BuildRequires: vidix-devel}
8cc223f8
JB
149%ifarch ppc
150%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
151%endif
3c3fdfcc 152%{?with_gif:BuildRequires: giflib-devel}
dd6c659c 153%if %{with gui}
aeb67db6 154BuildRequires: gtk+2-devel
dd6c659c 155%endif
1087e996 156%{?with_gnomess:BuildRequires: dbus-glib-devel}
d336e259 157%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
a8a0c1d1 158BuildRequires: lame-libs-devel
dd6c659c 159%{?with_caca:BuildRequires: libcaca-devel}
49aed190 160%{?with_libdts:BuildRequires: libdts-devel}
a4298e0c 161%{?with_libdv:BuildRequires: libdv-devel}
4d75c49f 162BuildRequires: libdvdnav-devel
dd6c659c 163%{?with_ggi:BuildRequires: libggi-devel}
af480c75 164BuildRequires: libjpeg-devel
dd6c659c 165%{?with_mad:BuildRequires: libmad-devel}
30e3739f 166BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 167BuildRequires: libpng-devel
a4298e0c 168%{?with_smb:BuildRequires: libsmbclient-devel}
dd6c659c 169%{?with_dshow:BuildRequires: libstdc++-devel}
de0c2d91 170%{?with_theora:BuildRequires: libtheora-devel}
1130ecb8 171# tremor is used by default, internal as we don't have system one
281ac7d0 172#%{?with_vorbis:BuildRequires: libvorbis-devel}
a9052f4d 173%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20060828_2245.1}
ceb01d0e 174BuildRequires: libxslt-progs
dd6c659c
JB
175%{?with_lirc:BuildRequires: lirc-devel}
176%{?with_live:BuildRequires: live}
b8145877 177%{?with_lzo:BuildRequires: lzo-devel < 2.0}
dd6c659c 178%{?with_nas:BuildRequires: nas-devel}
b458005d 179BuildRequires: ncurses-devel
e9d22b19 180BuildRequires: pkgconfig
86bc294f 181%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
aeb67db6 182BuildRequires: speex-devel >= 1.1
dd6c659c
JB
183%{?with_svga:BuildRequires: svgalib-devel}
184%{?with_xmms:BuildRequires: xmms-libs}
627a7a97
ER
185BuildRequires: xorg-lib-libX11-devel
186BuildRequires: xorg-lib-libXext-devel
187BuildRequires: xorg-lib-libXinerama-devel
188BuildRequires: xorg-lib-libXv-devel
189BuildRequires: xorg-lib-libXvMC-devel
190BuildRequires: xorg-lib-libXxf86dga-devel
191BuildRequires: xorg-lib-libXxf86vm-devel
3c3fdfcc 192%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
c2eb8d00 193BuildRequires: zlib-devel
4d75c49f 194Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 195Requires: OpenGL
0f2a502d 196BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 197
a8e3a9a7 198%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 199%define specflags_ia32 -fomit-frame-pointer
198487b4 200%if %{with altivec}
adfd0023 201%define specflags_ppc -maltivec
20a66bdb 202%endif
2adea73e
AM
203
204%description
c902f7c6 205Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
206AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 207MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
208MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 209devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
210optionally with SHM extension, X11 using overlays with the Xvideo
211extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
212Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 213
8b146837 214If you want to use win32 codecs install w32codec package.
4228a246 215
e011d408 216%description -l de.UTF-8
deba608c 217MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
218Kennzeichnend ist die herausragende Format- und
e011d408 219Plattform-Kompatibilität.
deba608c 220
e011d408
JR
221Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
222plattformexklusive, wodurch etwa Windows Media auch außerhalb von
223Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
224Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 225ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
226Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
227installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 228
e011d408 229%description -l es.UTF-8
c902f7c6 230Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
231MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
232(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
233de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
234Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
235G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
236overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 237G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
238v1.1.7 etc.
33c4efab 239
8b146837 240Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 241
e011d408
JR
242%description -l ko.UTF-8
243MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
244파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
245MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
246Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
247(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
248수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
249크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
250있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
251부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 252
e011d408
JR
253%description -l pl.UTF-8
254Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 255RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
256(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
257Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 258Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 259rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 260G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 261
e011d408 262Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 263
e011d408
JR
264%description -l pt_BR.UTF-8
265MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
266áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 267escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
268
11421384
ER
269%package -n gmplayer
270Summary: MPlayer with GTK+ GUI interface
eeb91a66 271Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 272Group: X11/Applications/Multimedia
11421384 273Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 274Requires: %{name}-skin
906bf13b 275Provides: %{name} = %{epoch}:%{version}-%{release}
11421384
ER
276
277%description -n gmplayer
278MPlayer with GUI GTK+ interface.
279
e011d408 280%description -n gmplayer -l pl.UTF-8
906bf13b
JB
281MPlayer z graficznym interfejsem GTK+.
282
11421384 283%package common
906bf13b 284Summary: Configuration files and documentation for MPlayer
eeb91a66 285Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 286Group: Applications/Multimedia
1087e996 287Obsoletes: mplayer-vidix
11421384
ER
288
289%description common
906bf13b
JB
290Configuration files, man page and HTML documentation for MPlayer.
291
e011d408 292%description common -l pl.UTF-8
906bf13b 293Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
294
295%package -n mencoder
906bf13b 296Summary: MEncoder - a movie encoder for Linux
eeb91a66 297Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
298Group: Applications/Multimedia
299Requires: %{name}-common = %{epoch}:%{version}-%{release}
300
301%description -n mencoder
906bf13b
JB
302MEncoder is a movie encoder for Linux and is a part of the MPlayer
303package.
304
e011d408
JR
305%description -n mencoder -l pl.UTF-8
306MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 307
2adea73e 308%prep
dfd680ce 309%setup -q -n %{sname}-%{version}%{_rc} -a3 -a6 -a9
833dbe20 310cp -f etc/codecs.conf etc/codecs.win32.conf
aee40e50 311%patch1 -p0
312##%patch2 -p1
313##%patch3 -p1 -- old home_etc behavior
314%patch4 -p1
dd6c659c 315%patch5 -p1
0992d783 316%patch6 -p1
2dfabf36 317%patch8 -p1
2b8c25a3 318#%%patch10 -p1
d6014b54 319%patch11 -p1
86bc294f 320%patch12 -p0
aeb67db6 321#%patch13 -p1 # TODO
11421384
ER
322%if %{with shared}
323%patch14 -p1
324%endif
aeb67db6 325#%patch15 -p0 # TODO
adfd0023 326%patch16 -p1
c7699e1b 327%patch17 -p1
0256d486 328%if %{with gnomess}
ce8a4f6d 329%patch18 -p1
0256d486 330%endif
be0d3133 331
dfd680ce 332%if 0%{?snap}
59ba0205 333find . -type d -name CVS -print | xargs rm -rf
0992d783 334%endif
59ba0205 335
dfd680ce
ER
336# on2flix
337cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
338%patch19 -p1
339for a in mencoder-on2flixenglinux/*.diff; do
340 patch -p0 < $a
341done
342
7c31e935
ER
343%patch20 -p0
344
2adea73e 345%build
68dd28e8 346%if %{with shared}
11421384 347CFLAGS="%{rpmcflags} -fPIC"
68dd28e8
ER
348%else
349CFLAGS="%{rpmcflags}"
68dd28e8 350%endif
4ed9dec4 351CC="%{__cc}"
ce8a4f6d
JB
352LDFLAGS="%{rpmldflags}"
353export CC CFLAGS LDFLAGS
11421384
ER
354
355build() {
356set -x
357 ./configure \
358 %{?debug:--enable-debug=3} \
dd6c659c
JB
359 --prefix=%{_prefix} \
360 --confdir=%{_sysconfdir}/mplayer \
dd6c659c 361 --with-extraincdir=%{_includedir}/xvid \
526c0e5d 362 --enable-menu \
57f87bc2 363%ifnarch %{ix86} %{x8664}
dd6c659c 364 --disable-mmx \
a14f4270 365 --disable-mmxext \
dd6c659c 366 --disable-3dnow \
a14f4270 367 --disable-3dnowext \
dd6c659c
JB
368 --disable-sse \
369 --disable-sse2 \
370 --disable-fastmemcpy \
dfeec30a 371%endif
1837afdf 372%ifarch ppc
373%{!?with_altivec:--disable-altivec} \
374%endif
e4268e0b 375%{!?with_amr:--disable-amr_nb --disable-amr_wb} \
30e3739f 376%{?with_amr:--enable-amr_nb --enable-amr_wb} \
6e0359a9 377%{?with_directfb:--enable-directfb} \
33c4efab 378%{!?with_directfb:--disable-directfb} \
33c4efab 379%{!?with_dxr3:--disable-dxr3} \
380%{!?with_ggi:--disable-ggi} \
11421384 381%{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
0f2c0aed 382%{!?with_live:--disable-live} \
b8145877 383%{!?with_lzo:--disable-liblzo} \
33c4efab 384%{!?with_nas:--disable-nas} \
385%{!?with_svga:--disable-svga} \
386%{!?with_aalib:--disable-aa} \
e5b91f83 387%{!?with_jack:--disable-jack} \
33c4efab 388%{!?with_alsa:--disable-alsa} \
389%{?with_alsa:--enable-alsa --disable-select} \
390%{!?with_arts:--disable-arts} \
dd153a0d 391%{!?with_caca:--disable-caca} \
3c3fdfcc 392%{!?with_cdparanoia:--disable-cdparanoia} \
33c4efab 393%{!?with_dshow:--disable-dshow} \
3c3fdfcc
JB
394%{!?with_enca:--disable-enca} \
395%{!?with_esd:--disable-esd} \
0ffd4cd0 396%{!?with_faad:--disable-faad-external --disable-faad-internal} \
397%{?with_faad:--disable-faad-internal} \
3c3fdfcc 398%{!?with_gif:--disable-gif} \
33c4efab 399%{?with_joystick:--enable-joystick} \
a4298e0c 400%{!?with_libdv:--disable-libdv} \
49aed190 401%{!?with_libdts:--disable-libdts} \
d8f32b56 402--%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
33c4efab 403%{!?with_mad:--disable-mad} \
4143807a 404%{!?with_pulseaudio:--disable-pulse} \
7a82c266 405%{!?with_quicktime:--disable-qtx} \
33c4efab 406%{!?with_real:--disable-real} \
11421384 407--%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
33c4efab 408%{!?with_select:--disable-select} \
a4298e0c 409%{!?with_smb:--disable-smb} \
33c4efab 410%{!?with_win32:--disable-win32} \
411%{!?with_vorbis:--disable-vorbis} \
412%{?with_osd:--enable-menu} \
587f4971 413%{!?with_theora:--disable-theora} \
6a8a1010 414%{!?with_x264:--disable-x264} \
dd6c659c 415%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
3c3fdfcc 416%{!?with_xvid:--disable-xvid} \
1087e996
ER
417%{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
418%{?with_vidix:--disable-vidix-internal} \
dd6c659c 419%{!?with_mencoder:--disable-mencoder} \
dd6c659c
JB
420 --enable-dga \
421 --enable-fbdev \
422 --enable-gl \
423 --enable-mga \
e7261209
KK
424 --enable-radio \
425 --enable-radio-capture \
11421384 426 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
dd6c659c
JB
427 --enable-tdfxfb \
428 --enable-vm \
429 --enable-x11 \
430 --enable-xmga \
431 --enable-xv \
432 --enable-xvmc \
3c3fdfcc 433 --enable-dynamic-plugins \
dd6c659c
JB
434 --enable-largefiles \
435 --language=all \
436 --with-codecsdir=%{_libdir}/codecs \
3c3fdfcc 437 --with-xvmclib=XvMCW \
11421384 438 "$@"
eb52750a 439
11421384
ER
440 %{__make}
441}
2adea73e 442
11421384
ER
443%if %{with gui}
444# build GUI version
445build --enable-gui
446mv -f mplayer gmplayer
aeb67db6 447%{__make} distclean
11421384
ER
448%endif
449
450# now build regular version
451build --disable-gui
452
aab7d90d 453%if %{with doc}
f7dd0c40 454%{__make} -j1 -C DOCS/xml
11421384 455%endif
ceb01d0e 456
2adea73e
AM
457%install
458rm -rf $RPM_BUILD_ROOT
e0e4b963 459install -d \
d23c171d 460 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 461 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
1087e996 462 $RPM_BUILD_ROOT%{_datadir}/mplayer/Skin \
59ba0205 463 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 464
e0e4b963 465# default config files
11421384 466sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
c455a752 467install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 468
469# executables
2af58a38 470%if %{with mencoder}
1a8df7bd 471install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
472ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 473%endif
1a8df7bd 474install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
475ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 476%if %{with gui}
1a8df7bd 477install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
478ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 479%endif
e0e4b963 480
481# fonts
9d62f689
TP
482rm -f font-*/runme
483cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 484ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 485
11421384
ER
486%if %{with gui}
487ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
488%endif
489
e0e4b963 490# X-files
68dd28e8 491%if %{with gui}
f0d8c47e 492install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 493%endif
24481cd2 494install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 495install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 496
497# man pages
59ba0205 498install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 499install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
500install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
501install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
502install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
503install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 504install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 505install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
59ba0205 506install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
e66a8169 507install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 508
2adea73e
AM
509%clean
510rm -rf $RPM_BUILD_ROOT
511
a69eaaef 512%post -n gmplayer
cd748ae6 513umask 022
cd748ae6 514[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
515
a69eaaef 516%postun -n gmplayer
cd748ae6 517umask 022
75b3147a 518[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 519
2adea73e
AM
520%files
521%defattr(644,root,root,755)
1a8df7bd 522%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
523
524%if %{with gui}
525%files -n gmplayer
526%defattr(644,root,root,755)
1a8df7bd 527%attr(755,root,root) %{_bindir}/gmplayer*
11421384
ER
528%{_desktopdir}/gmplayer.desktop
529%dir %{_datadir}/%{name}/Skin
530%ghost %{_datadir}/%{name}/Skin/default
531%endif
532
0fb5a7ee 533%if %{with mencoder}
11421384
ER
534%files -n mencoder
535%defattr(644,root,root,755)
aeb67db6 536%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
537%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
538%doc DOCS/tech/colorspaces.txt
1a8df7bd 539%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 540%endif
11421384
ER
541
542%files common
543%defattr(644,root,root,755)
11421384
ER
544# HTML and XML-generated docs
545%doc DOCS/HTML/en
546%doc DOCS/tech
547%if %{with win32}
35ac5af9 548%doc etc/codecs.win32.conf
11421384 549%endif
0ffd4cd0 550%lang(cs) %doc DOCS/HTML/cs
aeb67db6 551%lang(de) %doc DOCS/HTML/de
aee40e50 552%lang(es) %doc DOCS/HTML/es
553%lang(fr) %doc DOCS/HTML/fr
8cda16b8 554%lang(hu) %doc DOCS/HTML/hu
aee40e50 555%lang(pl) %doc DOCS/HTML/pl
556%lang(ru) %doc DOCS/HTML/ru
90413e82 557%lang(zh_CN) %doc DOCS/zh
aeb67db6 558%doc AUTHORS ChangeLog README
11421384 559
906bf13b
JB
560%dir %{_sysconfdir}/%{name}
561%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 562%{_mandir}/man1/*
59ba0205 563%lang(cs) %{_mandir}/cs/man1/*
20e1052d 564%lang(de) %{_mandir}/de/man1/*
aee40e50 565%lang(es) %{_mandir}/es/man1/*
2a9a2b75 566%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 567%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 568%lang(it) %{_mandir}/it/man1/*
2a6ed516 569%lang(pl) %{_mandir}/pl/man1/*
59ba0205 570%lang(sv) %{_mandir}/sv/man1/*
90413e82 571%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 572%{_desktopdir}/mplayer.desktop
1087e996 573%{_pixmapsdir}/mplayer.png
11421384
ER
574%dir %{_datadir}/%{name}
575%{_datadir}/%{name}/font*
This page took 0.177803 seconds and 4 git commands to generate.