]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
partial update for system ffmpeg
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44%bcond_with musepack # libmpcdec support (derecated in favour of libavcodec)
45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
d1f72115 49%bcond_with system_vorbis # use system libvorbis instead of internal tremor
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
83%undefine with_system_vorbis
84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
100
1a8df7bd 101%if %{_lib} == "lib64"
e2b12b5a 102%define binsuf 64
1a8df7bd 103%else
e2b12b5a 104%define binsuf 32
1a8df7bd 105%endif
106
906bf13b 107Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
108Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
109Summary(es.UTF-8): Otro reproductor de películas
110Summary(ko.UTF-8): 리눅스용 미디어플레이어
111Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
112Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 113Name: mplayer
df52db46 114Version: 1.1
66a6b75e 115Release: 3
1f85fd72
ER
116# DO NOT increase epoch unless it's really neccessary!
117# especially such changes like pre7->pre7try2, increase Release instead!
118# PS: $ rpmvercmp pre7try2 pre7
119# pre7try2 > pre7
59476b48 120Epoch: 3
bc426a7f 121License: GPL
906bf13b 122Group: Applications/Multimedia
e2b12b5a
JB
123# for snapshots:
124# svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
125# cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
126# tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
127Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
df52db46 128# Source0-md5: ac7bf1cfedc1c5c24bfc83107eefb1d9
031c3c7c 129Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 130# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 131Source5: g%{name}.desktop
623ea2d1 132Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 133# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 134Source7: %{name}.png
24481cd2 135Source8: %{name}.desktop
dfd680ce 136# http://www.on2.com/gpl/mplayer/
53f97285 137Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
138# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 139
140# build (configure / Makefile) related:
141Patch10: %{name}-ldflags.patch
142Patch11: %{name}-altivec.patch
143Patch12: %{name}-check-byteswap.patch
c2bf8f19 144Patch13: %{name}-visibility-hidden-fix.patch
145Patch14: %{name}-ffmpeg.patch
e2b12b5a 146Patch15: %{name}-live.patch
63bba7db
JB
147Patch16: %{name}-libcdio.patch
148Patch17: %{name}-gsm.patch
149Patch18: %{name}-openjpeg.patch
150Patch19: %{name}-shared.patch
990687b2 151Patch20: %{name}-vstream.patch
bfac6bf7 152Patch23: vstream-format-security.patch
79907b07 153
154# codecs, outputs, demuxers:
990687b2
JB
155Patch21: %{name}-auto-expand.patch
156Patch22: %{name}-release_directfb.patch
79907b07 157
158# goodies:
159Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 160Patch31: %{name}-350.patch
d1f72115 161# update, hard to fix right now because of gnome bug 579430:
162# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 163#Patch32: %{name}-gnome-screensaver.patch
79907b07 164
165Patch100: %{name}-on2flix.patch
b252aa8a 166Patch101: %{name}-link.patch
e48160f4 167Patch102: %{name}-build.patch
79907b07 168
c5b97685 169URL: http://www.mplayerhq.hu/
33c4efab 170%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 171BuildRequires: OpenAL-devel
b458005d 172BuildRequires: OpenGL-devel
11421384 173%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
63bba7db 174BuildRequires: a52dec-libs-devel
dd6c659c
JB
175%{?with_aalib:BuildRequires: aalib-devel}
176%{?with_alsa:BuildRequires: alsa-lib-devel}
177%{?with_arts:BuildRequires: artsc-devel}
841cb995 178%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 179BuildRequires: bzip2-devel
364125e7 180#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 181%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 182BuildRequires: dirac-devel
5dcdda0f
ER
183%{?with_doc:BuildRequires: docbook-dtd412-xml}
184%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 185%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 186%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
187%{?with_enca:BuildRequires: enca-devel}
188%{?with_esd:BuildRequires: esound-devel}
30e3739f 189BuildRequires: faac-devel
3c3fdfcc 190%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 191%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 192BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 193BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 194BuildRequires: fribidi-devel
3d17ae18 195%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 196%{?with_gif:BuildRequires: giflib-devel}
d1f72115 197%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 198%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 199%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 200BuildRequires: lame-libs-devel
6bd88460 201BuildRequires: libass-devel >= 0.9.10
c3a1256a 202%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 203%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 204%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
205%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
206%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 207%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 208%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 209#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 210%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 211%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 212%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
213%{?with_ggi:BuildRequires: libggiwmh-devel}
214BuildRequires: libgsm-devel
af480c75 215BuildRequires: libjpeg-devel
dd6c659c 216%{?with_mad:BuildRequires: libmad-devel}
c521a17c 217BuildRequires: libmng-devel
63bba7db
JB
218%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
219%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
220%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 221%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 222BuildRequires: libnut-devel
af480c75 223BuildRequires: libpng-devel
63bba7db 224%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 225%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 226%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 227%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 228%{?with_system_vorbis:BuildRequires: libvorbis-devel}
0431b837 229BuildRequires: libvpx-devel
bbab8eb7 230%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 231BuildRequires: libxslt-progs
dd6c659c 232%{?with_lirc:BuildRequires: lirc-devel}
5244e474 233%{?with_live:BuildRequires: live-devel}
841cb995 234%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 235%{?with_nas:BuildRequires: nas-devel}
b458005d 236BuildRequires: ncurses-devel
b69a6f83 237%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 238%{?with_openjpeg:BuildRequires: openjpeg-devel}
e9d22b19 239BuildRequires: pkgconfig
86bc294f 240%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 241BuildRequires: rpm >= 4.4.9-56
9accd5e5 242BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 243BuildRequires: schroedinger-devel
aeb67db6 244BuildRequires: speex-devel >= 1.1
dd6c659c 245%{?with_svga:BuildRequires: svgalib-devel}
3af20979 246BuildRequires: tar >= 1:1.22
c521a17c 247BuildRequires: twolame-devel
3af20979 248%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 249%{?with_vstream:BuildRequires: vstream-client-devel}
c521a17c 250%{?with_xmms:BuildRequires: xmms-devel}
5dcdda0f
ER
251%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
252%ifarch %{ix86} %{x8664}
253BuildRequires: yasm
254%endif
255BuildRequires: zlib-devel
627a7a97 256BuildRequires: xorg-lib-libX11-devel
c521a17c 257BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
258BuildRequires: xorg-lib-libXext-devel
259BuildRequires: xorg-lib-libXinerama-devel
260BuildRequires: xorg-lib-libXv-devel
261BuildRequires: xorg-lib-libXvMC-devel
262BuildRequires: xorg-lib-libXxf86dga-devel
263BuildRequires: xorg-lib-libXxf86vm-devel
4d75c49f 264Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 265Requires: OpenGL
0f2a502d 266BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 267
a8e3a9a7 268%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 269%define specflags_ia32 -fomit-frame-pointer
198487b4 270%if %{with altivec}
adfd0023 271%define specflags_ppc -maltivec
20a66bdb 272%endif
2adea73e
AM
273
274%description
c902f7c6 275Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
276AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 277MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
278MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 279devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
280optionally with SHM extension, X11 using overlays with the Xvideo
281extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
282Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 283
8b146837 284If you want to use win32 codecs install w32codec package.
4228a246 285
e011d408 286%description -l de.UTF-8
deba608c 287MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
288Kennzeichnend ist die herausragende Format- und
e011d408 289Plattform-Kompatibilität.
deba608c 290
e011d408
JR
291Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
292plattformexklusive, wodurch etwa Windows Media auch außerhalb von
293Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
294Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 295ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
296Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
297installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 298
e011d408 299%description -l es.UTF-8
c902f7c6 300Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
301MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
302(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
303de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
304Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
305G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
306overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 307G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
308v1.1.7 etc.
33c4efab 309
8b146837 310Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 311
e011d408
JR
312%description -l ko.UTF-8
313MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
314파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
315MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
316Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
317(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
318수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
319크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
320있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
321부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 322
e011d408
JR
323%description -l pl.UTF-8
324Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 325RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
326(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
327Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 328Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 329rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 330G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 331
e011d408 332Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 333
e011d408
JR
334%description -l pt_BR.UTF-8
335MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
336áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 337escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
338
11421384
ER
339%package -n gmplayer
340Summary: MPlayer with GTK+ GUI interface
eeb91a66 341Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 342Group: X11/Applications/Multimedia
11421384 343Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 344Requires: %{name}-skin
11421384
ER
345
346%description -n gmplayer
347MPlayer with GUI GTK+ interface.
348
e011d408 349%description -n gmplayer -l pl.UTF-8
906bf13b
JB
350MPlayer z graficznym interfejsem GTK+.
351
11421384 352%package common
906bf13b 353Summary: Configuration files and documentation for MPlayer
eeb91a66 354Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 355Group: Applications/Multimedia
c521a17c 356Suggests: unrar
1087e996 357Obsoletes: mplayer-vidix
11421384
ER
358
359%description common
906bf13b
JB
360Configuration files, man page and HTML documentation for MPlayer.
361
e011d408 362%description common -l pl.UTF-8
906bf13b 363Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 364
dc3c7d77 365%package doc
63bba7db
JB
366Summary: HTML documentation for MPlayer
367Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
368Group: Documentation
369
370%description doc
63bba7db
JB
371HTML Documentation for MPlayer.
372
373%description doc -l pl.UTF-8
374Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 375
11421384 376%package -n mencoder
906bf13b 377Summary: MEncoder - a movie encoder for Linux
eeb91a66 378Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
379Group: Applications/Multimedia
380Requires: %{name}-common = %{epoch}:%{version}-%{release}
381
382%description -n mencoder
906bf13b
JB
383MEncoder is a movie encoder for Linux and is a part of the MPlayer
384package.
385
e011d408
JR
386%description -n mencoder -l pl.UTF-8
387MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 388
2adea73e 389%prep
df52db46 390%setup -q -n MPlayer-%{version} -a3 -a6 -a9
833dbe20 391cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 392
393# build (configure / Makefile) related:
394%patch10 -p1
395%patch11 -p1
396%patch12 -p1
c2bf8f19 397%patch13 -p1
398%{?with_system_ffmpeg:%patch14 -p1}
e2b12b5a 399%patch15 -p1
63bba7db
JB
400%patch16 -p1
401%patch17 -p1
402%patch18 -p1
403%{?with_shared:%patch19 -p1}
990687b2 404%patch20 -p1
bfac6bf7 405%patch23 -p0
79907b07 406
407# codecs, outputs, demuxers:
79907b07 408%patch21 -p1
990687b2 409%patch22 -p1
79907b07 410
411# goodies:
412%patch30 -p0
2833f81f 413%patch31 -p1
414#%{with_gnomess:%patch32 -p1}
59ba0205 415
dfd680ce 416# on2flix
759ef2d3 417mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 418%if %{with on2}
79907b07 419#%%patch100 -p1
d1f72115 420cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
421# remove broken patches:
422# - first set does not apply
423# - second set beakes build
424for PATCH in asf-correct_movielength avi_check_idxflags \
425 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
426 mencoder_07_demux_update_pts mencoder_10_correct_pts \
427 mpegvideo-revert_r18381 \
428 \
429 reduce_spurious_logging
430do
431 rm mencoder-on2flixenglinux/patch/$PATCH.diff
432done
433for a in mencoder-on2flixenglinux/patch/*.diff; do
434 patch -p0 < $a
435done
436%endif
dfd680ce 437
b252aa8a 438%patch101 -p1
e48160f4 439%patch102 -p1
b252aa8a 440
53f97285 441cat etc/example.conf > etc/mplayer.conf
c521a17c 442cat <<'CONFIGADD' >> etc/mplayer.conf
443
d1f72115 444######################
8b2ed1fb 445# PLD Linux Defaults #
d1f72115 446######################
2833f81f 447[default]
448
449# alternate solution for CP1250-encoded subtitles
450fontconfig = yes
451subcp = cp1250
452
453# ...or if you prefer native bitmap fonts shipped with mplayer
454#fontconfig = no
455#subcp = iso-8859-1
456
457# Standard location
458unrarexec = "%{_bindir}/unrar"
459
993f72f1
ER
460# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
461joystick=no
462
c521a17c 463CONFIGADD
d1732085 464
1f8d8779
ER
465%if %{with system_ffmpeg}
466# using external ffmpeg, but mplayer adds these to includepath
c65405fc 467%{__rm} -r ffmpeg
1f8d8779
ER
468%endif
469
2adea73e 470%build
5dcdda0f 471CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
53f97285 472CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
53f97285 473
63bba7db
JB
474# NOTE:
475# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
476# - toolame is obsolete predecessor of twolame
11421384 477build() {
c521a17c 478 set -x
53f97285 479
11421384
ER
480 ./configure \
481 %{?debug:--enable-debug=3} \
dd6c659c 482 --prefix=%{_prefix} \
63bba7db 483 --codecsdir=%{_libdir}/codecs \
dd6c659c 484 --confdir=%{_sysconfdir}/mplayer \
53f97285 485 --cc="%{__cc}" \
486 --extra-cflags="$CFLAGS" \
79907b07 487 --real-ldflags="%{rpmldflags}" \
488 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 489 --language=all \
1f8d8779 490%if %{with system_ffmpeg}
841cb995
ER
491 --disable-libavutil_a \
492 --disable-libavcodec_a \
493 --disable-libavformat_a \
494 --disable-libpostproc_a \
495 --enable-libavutil_so \
496 --enable-libavcodec_so \
497 --enable-libavformat_so \
498 --enable-libpostproc_so \
1f8d8779 499%endif
57f87bc2 500%ifnarch %{ix86} %{x8664}
dd6c659c 501 --disable-3dnow \
a14f4270 502 --disable-3dnowext \
63bba7db
JB
503 --disable-fastmemcpy \
504 --disable-mmx \
505 --disable-mmxext \
dd6c659c
JB
506 --disable-sse \
507 --disable-sse2 \
dfeec30a 508%endif
9accd5e5 509 %{__disable ssse3} \
1837afdf 510%ifarch ppc
9accd5e5 511 %{__disable altivec} \
1837afdf 512%endif
9accd5e5 513 %{__disable aalib aa} \
9accd5e5 514 %{__enable_disable alsa} \
515 %{__disable arts} \
63bba7db 516 %{__disable bluray} \
9accd5e5 517 %{__disable caca} \
518 %{__disable cdparanoia} \
63bba7db
JB
519 --enable-dga1 \
520 --enable-dga2 \
521 %{__enable_disable directfb} \
522 %{__enable_disable dvdnav} \
523 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 524 %{__disable dxr2} \
63bba7db
JB
525 %{__disable dxr3} \
526 --enable-dynamic-plugins \
9accd5e5 527 %{__disable enca} \
528 %{__disable esd} \
9accd5e5 529 %{__disable faad} \
63bba7db 530 --enable-fbdev \
9accd5e5 531 %{__disable gif} \
63bba7db
JB
532 --enable-gl \
533 %{__disable ggi} \
534 %{__disable jack} \
9accd5e5 535 %{__enable joystick} \
63bba7db
JB
536 %{__disable cdio libcdio} \
537 %{__disable ladspa} \
10a6d1a6 538 %{__disable bs2b libbs2b} \
9accd5e5 539 %{__disable libdts libdca} \
63bba7db
JB
540 %{__disable libdv} \
541 %{__disable system_dvdcss libdvdcss-internal} \
542 %{__disable lzo liblzo} \
543 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 544 %{__disable nemesi} \
63bba7db
JB
545 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
546 %{__disable openjpeg} \
547 %{__disable rtmp librtmp} \
548 %{__disable vorbis libvorbis} \
9accd5e5 549 %{__enable_disable lirc} \
63bba7db
JB
550 --disable-lircc \
551 %{__disable live} \
9accd5e5 552 %{__disable mad} \
63bba7db
JB
553 %{__disable mencoder} \
554 %{__enable osd menu} \
555 --enable-mga \
556 %{__disable mpg123} \
557 %{__enable musepack} \
558 %{__disable nas} \
9accd5e5 559 %{__disable pulseaudio pulse} \
560 %{__disable quicktime qtx} \
63bba7db
JB
561 --enable-radio \
562 --enable-radio-capture \
9accd5e5 563 %{__disable real} \
564 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 565 %{__enable_disable sdl} \
9accd5e5 566 %{__disable select} \
10a6d1a6 567 --enable-s3fb \
9accd5e5 568 %{__disable smb} \
63bba7db
JB
569 %{__disable svga} \
570 --enable-tdfxfb \
10a6d1a6 571 --enable-tdfxvid \
9accd5e5 572 %{__disable theora} \
63bba7db
JB
573 --disable-toolame \
574 --disable-tremor \
575 %{__disable vorbis tremor-internal} \
576 %{__disable_if system_vorbis tremor-internal} \
577 --enable-unrarexec \
9accd5e5 578 %{__disable vdpau} \
63bba7db 579 %{__disable vidix} \
10a6d1a6 580 %{__disable vstream} \
dd6c659c 581 --enable-vm \
10a6d1a6
JB
582%ifarch ppc
583 --enable-wii \
584%endif
63bba7db 585 %{__disable win32 win32dll} \
dd6c659c 586 --enable-x11 \
63bba7db 587 %{__disable x264} \
dd6c659c 588 --enable-xmga \
63bba7db 589 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 590 --enable-xv \
63bba7db
JB
591 %{__disable xvid} \
592 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 593 %{__enable_disable zr} \
11421384 594 "$@"
eb52750a 595
d53c9a42 596 %{__make} %{?with_verbose:V=1}
11421384 597}
2adea73e 598
11421384
ER
599%if %{with gui}
600# build GUI version
841cb995 601build --enable-gui --disable-mencoder
11421384 602mv -f mplayer gmplayer
aeb67db6 603%{__make} distclean
11421384
ER
604%endif
605
606# now build regular version
607build --disable-gui
608
aab7d90d 609%if %{with doc}
ef1e3931 610%{__make} -j1 doc
11421384 611%endif
ceb01d0e 612
2adea73e
AM
613%install
614rm -rf $RPM_BUILD_ROOT
e0e4b963 615install -d \
d23c171d 616 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 617 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
9accd5e5 618 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 619 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 620
e0e4b963 621# default config files
c455a752 622install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 623
624# executables
2af58a38 625%if %{with mencoder}
85694787 626install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
e2b12b5a 627ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 628%endif
85694787 629install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
e2b12b5a 630ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 631%if %{with gui}
85694787 632install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
e2b12b5a 633ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 634%endif
e0e4b963 635
c2bf8f19 636%if %{with shared}
637install -d $RPM_BUILD_ROOT%{_libdir}
638install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
639%endif
640
e0e4b963 641# fonts
9d62f689 642cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 643ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 644
11421384 645%if %{with gui}
f0d8c47e 646install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 647%endif
9accd5e5 648touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 649install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 650install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 651
652# man pages
59ba0205 653install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 654install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
655install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
656install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
657install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
658install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 659install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 660install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 661#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
53f97285 662#install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 663
2adea73e
AM
664%clean
665rm -rf $RPM_BUILD_ROOT
666
a69eaaef 667%post -n gmplayer
cd748ae6 668umask 022
cd748ae6 669[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
670
a69eaaef 671%postun -n gmplayer
cd748ae6 672umask 022
75b3147a 673[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 674
2adea73e
AM
675%files
676%defattr(644,root,root,755)
1a8df7bd 677%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
678
679%if %{with gui}
680%files -n gmplayer
681%defattr(644,root,root,755)
1a8df7bd 682%attr(755,root,root) %{_bindir}/gmplayer*
11421384 683%{_desktopdir}/gmplayer.desktop
11421384
ER
684%endif
685
0fb5a7ee 686%if %{with mencoder}
11421384
ER
687%files -n mencoder
688%defattr(644,root,root,755)
aeb67db6 689%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
690%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
691%doc DOCS/tech/colorspaces.txt
1a8df7bd 692%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 693%endif
11421384 694
841cb995 695%if %{with doc}
dc3c7d77 696%files doc
df52db46 697%defattr(644,root,root,755)
dc3c7d77 698%doc DOCS/tech
841cb995
ER
699# HTML and XML-generated docs
700%doc DOCS/HTML/en
0ffd4cd0 701%lang(cs) %doc DOCS/HTML/cs
aeb67db6 702%lang(de) %doc DOCS/HTML/de
aee40e50 703%lang(es) %doc DOCS/HTML/es
704%lang(fr) %doc DOCS/HTML/fr
8cda16b8 705%lang(hu) %doc DOCS/HTML/hu
aee40e50 706%lang(pl) %doc DOCS/HTML/pl
707%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
708#%lang(zh_CN) %doc DOCS/zh
709%endif
dc3c7d77
ER
710
711%files common
712%defattr(644,root,root,755)
841cb995 713%doc AUTHORS README
dc3c7d77
ER
714%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
715%if %{with win32}
716%doc etc/codecs.win32.conf
717%endif
11421384 718
906bf13b
JB
719%dir %{_sysconfdir}/%{name}
720%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 721%{_mandir}/man1/*
59ba0205 722%lang(cs) %{_mandir}/cs/man1/*
20e1052d 723%lang(de) %{_mandir}/de/man1/*
aee40e50 724%lang(es) %{_mandir}/es/man1/*
2a9a2b75 725%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 726%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 727%lang(it) %{_mandir}/it/man1/*
2a6ed516 728%lang(pl) %{_mandir}/pl/man1/*
841cb995 729#%lang(sv) %{_mandir}/sv/man1/*
53f97285 730#%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 731%{_desktopdir}/mplayer.desktop
1087e996 732%{_pixmapsdir}/mplayer.png
11421384
ER
733%dir %{_datadir}/%{name}
734%{_datadir}/%{name}/font*
59ce39fb
ER
735%dir %{_datadir}/%{name}/skins
736%ghost %{_datadir}/%{name}/skins/default
This page took 0.237343 seconds and 4 git commands to generate.