]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
up to 1.1.1, bundled ffmpeg version is 0.11.3
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44%bcond_with musepack # libmpcdec support (derecated in favour of libavcodec)
45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
d1f72115 49%bcond_with system_vorbis # use system libvorbis instead of internal tremor
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
83%undefine with_system_vorbis
84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
100
1a8df7bd 101%if %{_lib} == "lib64"
e2b12b5a 102%define binsuf 64
1a8df7bd 103%else
e2b12b5a 104%define binsuf 32
1a8df7bd 105%endif
106
906bf13b 107Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
108Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
109Summary(es.UTF-8): Otro reproductor de películas
110Summary(ko.UTF-8): 리눅스용 미디어플레이어
111Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
112Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 113Name: mplayer
b57c3c6c
ER
114Version: 1.1.1
115Release: 1
1f85fd72
ER
116# DO NOT increase epoch unless it's really neccessary!
117# especially such changes like pre7->pre7try2, increase Release instead!
118# PS: $ rpmvercmp pre7try2 pre7
119# pre7try2 > pre7
59476b48 120Epoch: 3
bc426a7f 121License: GPL
906bf13b 122Group: Applications/Multimedia
e2b12b5a
JB
123# for snapshots:
124# svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
125# cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
126# tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
127Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
b57c3c6c 128# Source0-md5: 39dd55f30eb5403f219a606e79a6648a
031c3c7c 129Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 130# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 131Source5: g%{name}.desktop
623ea2d1 132Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 133# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 134Source7: %{name}.png
24481cd2 135Source8: %{name}.desktop
dfd680ce 136# http://www.on2.com/gpl/mplayer/
53f97285 137Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
138# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 139
140# build (configure / Makefile) related:
141Patch10: %{name}-ldflags.patch
142Patch11: %{name}-altivec.patch
143Patch12: %{name}-check-byteswap.patch
c2bf8f19 144Patch13: %{name}-visibility-hidden-fix.patch
145Patch14: %{name}-ffmpeg.patch
e2b12b5a 146Patch15: %{name}-live.patch
63bba7db
JB
147Patch16: %{name}-libcdio.patch
148Patch17: %{name}-gsm.patch
149Patch18: %{name}-openjpeg.patch
150Patch19: %{name}-shared.patch
990687b2 151Patch20: %{name}-vstream.patch
bfac6bf7 152Patch23: vstream-format-security.patch
79907b07 153
154# codecs, outputs, demuxers:
990687b2
JB
155Patch21: %{name}-auto-expand.patch
156Patch22: %{name}-release_directfb.patch
79907b07 157
158# goodies:
159Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 160Patch31: %{name}-350.patch
d1f72115 161# update, hard to fix right now because of gnome bug 579430:
162# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 163#Patch32: %{name}-gnome-screensaver.patch
79907b07 164
165Patch100: %{name}-on2flix.patch
b252aa8a 166Patch101: %{name}-link.patch
e48160f4 167Patch102: %{name}-build.patch
79907b07 168
c5b97685 169URL: http://www.mplayerhq.hu/
33c4efab 170%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 171BuildRequires: OpenAL-devel
b458005d 172BuildRequires: OpenGL-devel
11421384 173%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
63bba7db 174BuildRequires: a52dec-libs-devel
dd6c659c
JB
175%{?with_aalib:BuildRequires: aalib-devel}
176%{?with_alsa:BuildRequires: alsa-lib-devel}
177%{?with_arts:BuildRequires: artsc-devel}
841cb995 178%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 179BuildRequires: bzip2-devel
364125e7 180#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 181%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 182BuildRequires: dirac-devel
5dcdda0f
ER
183%{?with_doc:BuildRequires: docbook-dtd412-xml}
184%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 185%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 186%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
187%{?with_enca:BuildRequires: enca-devel}
188%{?with_esd:BuildRequires: esound-devel}
30e3739f 189BuildRequires: faac-devel
3c3fdfcc 190%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 191%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 192BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 193BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 194BuildRequires: fribidi-devel
3d17ae18 195%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 196%{?with_gif:BuildRequires: giflib-devel}
d1f72115 197%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 198%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 199%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 200BuildRequires: lame-libs-devel
6bd88460 201BuildRequires: libass-devel >= 0.9.10
c3a1256a 202%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 203%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 204%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
205%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
206%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 207%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 208%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 209#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 210%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 211%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 212%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
213%{?with_ggi:BuildRequires: libggiwmh-devel}
214BuildRequires: libgsm-devel
af480c75 215BuildRequires: libjpeg-devel
dd6c659c 216%{?with_mad:BuildRequires: libmad-devel}
c521a17c 217BuildRequires: libmng-devel
63bba7db
JB
218%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
219%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
220%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 221%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 222BuildRequires: libnut-devel
af480c75 223BuildRequires: libpng-devel
63bba7db 224%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 225%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 226%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 227%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 228%{?with_system_vorbis:BuildRequires: libvorbis-devel}
0431b837 229BuildRequires: libvpx-devel
bbab8eb7 230%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 231BuildRequires: libxslt-progs
dd6c659c 232%{?with_lirc:BuildRequires: lirc-devel}
5244e474 233%{?with_live:BuildRequires: live-devel}
841cb995 234%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 235%{?with_nas:BuildRequires: nas-devel}
b458005d 236BuildRequires: ncurses-devel
b69a6f83 237%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 238%{?with_openjpeg:BuildRequires: openjpeg-devel}
e9d22b19 239BuildRequires: pkgconfig
86bc294f 240%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 241BuildRequires: rpm >= 4.4.9-56
9accd5e5 242BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 243BuildRequires: schroedinger-devel
aeb67db6 244BuildRequires: speex-devel >= 1.1
dd6c659c 245%{?with_svga:BuildRequires: svgalib-devel}
3af20979 246BuildRequires: tar >= 1:1.22
c521a17c 247BuildRequires: twolame-devel
3af20979 248%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 249%{?with_vstream:BuildRequires: vstream-client-devel}
c521a17c 250%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 251BuildRequires: xorg-lib-libX11-devel
c521a17c 252BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
253BuildRequires: xorg-lib-libXext-devel
254BuildRequires: xorg-lib-libXinerama-devel
255BuildRequires: xorg-lib-libXv-devel
256BuildRequires: xorg-lib-libXvMC-devel
257BuildRequires: xorg-lib-libXxf86dga-devel
258BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
259%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
260BuildRequires: xz
261%ifarch %{ix86} %{x8664}
262BuildRequires: yasm
263%endif
264BuildRequires: zlib-devel
4d75c49f 265Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 266Requires: OpenGL
0f2a502d 267BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 268
a8e3a9a7 269%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 270%define specflags_ia32 -fomit-frame-pointer
198487b4 271%if %{with altivec}
adfd0023 272%define specflags_ppc -maltivec
20a66bdb 273%endif
2adea73e
AM
274
275%description
c902f7c6 276Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
277AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 278MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
279MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 280devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
281optionally with SHM extension, X11 using overlays with the Xvideo
282extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
283Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 284
8b146837 285If you want to use win32 codecs install w32codec package.
4228a246 286
e011d408 287%description -l de.UTF-8
deba608c 288MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
289Kennzeichnend ist die herausragende Format- und
e011d408 290Plattform-Kompatibilität.
deba608c 291
e011d408
JR
292Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
293plattformexklusive, wodurch etwa Windows Media auch außerhalb von
294Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
295Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 296ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
297Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
298installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 299
e011d408 300%description -l es.UTF-8
c902f7c6 301Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
302MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
303(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
304de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
305Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
306G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
307overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 308G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
309v1.1.7 etc.
33c4efab 310
8b146837 311Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 312
e011d408
JR
313%description -l ko.UTF-8
314MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
315파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
316MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
317Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
318(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
319수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
320크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
321있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
322부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 323
e011d408
JR
324%description -l pl.UTF-8
325Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 326RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
327(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
328Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 329Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 330rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 331G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 332
e011d408 333Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 334
e011d408
JR
335%description -l pt_BR.UTF-8
336MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
337áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 338escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
339
11421384
ER
340%package -n gmplayer
341Summary: MPlayer with GTK+ GUI interface
eeb91a66 342Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 343Group: X11/Applications/Multimedia
11421384 344Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 345Requires: %{name}-skin
11421384
ER
346
347%description -n gmplayer
348MPlayer with GUI GTK+ interface.
349
e011d408 350%description -n gmplayer -l pl.UTF-8
906bf13b
JB
351MPlayer z graficznym interfejsem GTK+.
352
11421384 353%package common
906bf13b 354Summary: Configuration files and documentation for MPlayer
eeb91a66 355Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 356Group: Applications/Multimedia
c521a17c 357Suggests: unrar
1087e996 358Obsoletes: mplayer-vidix
11421384
ER
359
360%description common
906bf13b
JB
361Configuration files, man page and HTML documentation for MPlayer.
362
e011d408 363%description common -l pl.UTF-8
906bf13b 364Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 365
dc3c7d77 366%package doc
63bba7db
JB
367Summary: HTML documentation for MPlayer
368Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
369Group: Documentation
370
371%description doc
63bba7db
JB
372HTML Documentation for MPlayer.
373
374%description doc -l pl.UTF-8
375Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 376
11421384 377%package -n mencoder
906bf13b 378Summary: MEncoder - a movie encoder for Linux
eeb91a66 379Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
380Group: Applications/Multimedia
381Requires: %{name}-common = %{epoch}:%{version}-%{release}
382
383%description -n mencoder
906bf13b
JB
384MEncoder is a movie encoder for Linux and is a part of the MPlayer
385package.
386
e011d408
JR
387%description -n mencoder -l pl.UTF-8
388MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 389
2adea73e 390%prep
df52db46 391%setup -q -n MPlayer-%{version} -a3 -a6 -a9
833dbe20 392cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 393
394# build (configure / Makefile) related:
395%patch10 -p1
396%patch11 -p1
397%patch12 -p1
c2bf8f19 398%patch13 -p1
399%{?with_system_ffmpeg:%patch14 -p1}
e2b12b5a 400%patch15 -p1
63bba7db
JB
401%patch16 -p1
402%patch17 -p1
403%patch18 -p1
404%{?with_shared:%patch19 -p1}
990687b2 405%patch20 -p1
bfac6bf7 406%patch23 -p0
79907b07 407
408# codecs, outputs, demuxers:
79907b07 409%patch21 -p1
990687b2 410%patch22 -p1
79907b07 411
412# goodies:
413%patch30 -p0
2833f81f 414%patch31 -p1
415#%{with_gnomess:%patch32 -p1}
59ba0205 416
dfd680ce 417# on2flix
759ef2d3 418mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 419%if %{with on2}
79907b07 420#%%patch100 -p1
d1f72115 421cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
422# remove broken patches:
423# - first set does not apply
424# - second set beakes build
425for PATCH in asf-correct_movielength avi_check_idxflags \
426 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
427 mencoder_07_demux_update_pts mencoder_10_correct_pts \
428 mpegvideo-revert_r18381 \
429 \
430 reduce_spurious_logging
431do
432 rm mencoder-on2flixenglinux/patch/$PATCH.diff
433done
434for a in mencoder-on2flixenglinux/patch/*.diff; do
435 patch -p0 < $a
436done
437%endif
dfd680ce 438
b252aa8a 439%patch101 -p1
e48160f4 440%patch102 -p1
b252aa8a 441
53f97285 442cat etc/example.conf > etc/mplayer.conf
c521a17c 443cat <<'CONFIGADD' >> etc/mplayer.conf
444
d1f72115 445######################
8b2ed1fb 446# PLD Linux Defaults #
d1f72115 447######################
2833f81f 448[default]
449
450# alternate solution for CP1250-encoded subtitles
451fontconfig = yes
452subcp = cp1250
453
454# ...or if you prefer native bitmap fonts shipped with mplayer
455#fontconfig = no
456#subcp = iso-8859-1
457
458# Standard location
459unrarexec = "%{_bindir}/unrar"
460
993f72f1
ER
461# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
462joystick=no
463
c521a17c 464CONFIGADD
d1732085 465
1f8d8779
ER
466%if %{with system_ffmpeg}
467# using external ffmpeg, but mplayer adds these to includepath
c65405fc 468%{__rm} -r ffmpeg
1f8d8779
ER
469%endif
470
2adea73e 471%build
5dcdda0f 472CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
53f97285 473CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
53f97285 474
63bba7db
JB
475# NOTE:
476# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
477# - toolame is obsolete predecessor of twolame
11421384 478build() {
c521a17c 479 set -x
53f97285 480
11421384
ER
481 ./configure \
482 %{?debug:--enable-debug=3} \
dd6c659c 483 --prefix=%{_prefix} \
63bba7db 484 --codecsdir=%{_libdir}/codecs \
dd6c659c 485 --confdir=%{_sysconfdir}/mplayer \
53f97285 486 --cc="%{__cc}" \
487 --extra-cflags="$CFLAGS" \
79907b07 488 --real-ldflags="%{rpmldflags}" \
489 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 490 --language=all \
1f8d8779 491%if %{with system_ffmpeg}
841cb995
ER
492 --disable-libavutil_a \
493 --disable-libavcodec_a \
494 --disable-libavformat_a \
495 --disable-libpostproc_a \
496 --enable-libavutil_so \
497 --enable-libavcodec_so \
498 --enable-libavformat_so \
499 --enable-libpostproc_so \
1f8d8779 500%endif
57f87bc2 501%ifnarch %{ix86} %{x8664}
dd6c659c 502 --disable-3dnow \
a14f4270 503 --disable-3dnowext \
63bba7db
JB
504 --disable-fastmemcpy \
505 --disable-mmx \
506 --disable-mmxext \
dd6c659c
JB
507 --disable-sse \
508 --disable-sse2 \
dfeec30a 509%endif
9accd5e5 510 %{__disable ssse3} \
1837afdf 511%ifarch ppc
9accd5e5 512 %{__disable altivec} \
1837afdf 513%endif
9accd5e5 514 %{__disable aalib aa} \
9accd5e5 515 %{__enable_disable alsa} \
516 %{__disable arts} \
63bba7db 517 %{__disable bluray} \
9accd5e5 518 %{__disable caca} \
519 %{__disable cdparanoia} \
63bba7db
JB
520 --enable-dga1 \
521 --enable-dga2 \
522 %{__enable_disable directfb} \
523 %{__enable_disable dvdnav} \
524 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 525 %{__disable dxr2} \
63bba7db
JB
526 %{__disable dxr3} \
527 --enable-dynamic-plugins \
9accd5e5 528 %{__disable enca} \
529 %{__disable esd} \
9accd5e5 530 %{__disable faad} \
63bba7db 531 --enable-fbdev \
9accd5e5 532 %{__disable gif} \
63bba7db
JB
533 --enable-gl \
534 %{__disable ggi} \
535 %{__disable jack} \
9accd5e5 536 %{__enable joystick} \
63bba7db
JB
537 %{__disable cdio libcdio} \
538 %{__disable ladspa} \
10a6d1a6 539 %{__disable bs2b libbs2b} \
9accd5e5 540 %{__disable libdts libdca} \
63bba7db
JB
541 %{__disable libdv} \
542 %{__disable system_dvdcss libdvdcss-internal} \
543 %{__disable lzo liblzo} \
544 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 545 %{__disable nemesi} \
63bba7db
JB
546 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
547 %{__disable openjpeg} \
548 %{__disable rtmp librtmp} \
549 %{__disable vorbis libvorbis} \
9accd5e5 550 %{__enable_disable lirc} \
63bba7db
JB
551 --disable-lircc \
552 %{__disable live} \
9accd5e5 553 %{__disable mad} \
63bba7db
JB
554 %{__disable mencoder} \
555 %{__enable osd menu} \
556 --enable-mga \
557 %{__disable mpg123} \
558 %{__enable musepack} \
559 %{__disable nas} \
9accd5e5 560 %{__disable pulseaudio pulse} \
561 %{__disable quicktime qtx} \
63bba7db
JB
562 --enable-radio \
563 --enable-radio-capture \
9accd5e5 564 %{__disable real} \
565 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 566 %{__enable_disable sdl} \
9accd5e5 567 %{__disable select} \
10a6d1a6 568 --enable-s3fb \
9accd5e5 569 %{__disable smb} \
63bba7db
JB
570 %{__disable svga} \
571 --enable-tdfxfb \
10a6d1a6 572 --enable-tdfxvid \
9accd5e5 573 %{__disable theora} \
63bba7db
JB
574 --disable-toolame \
575 --disable-tremor \
576 %{__disable vorbis tremor-internal} \
577 %{__disable_if system_vorbis tremor-internal} \
578 --enable-unrarexec \
9accd5e5 579 %{__disable vdpau} \
63bba7db 580 %{__disable vidix} \
10a6d1a6 581 %{__disable vstream} \
dd6c659c 582 --enable-vm \
10a6d1a6
JB
583%ifarch ppc
584 --enable-wii \
585%endif
63bba7db 586 %{__disable win32 win32dll} \
dd6c659c 587 --enable-x11 \
63bba7db 588 %{__disable x264} \
dd6c659c 589 --enable-xmga \
63bba7db 590 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 591 --enable-xv \
63bba7db
JB
592 %{__disable xvid} \
593 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 594 %{__enable_disable zr} \
11421384 595 "$@"
eb52750a 596
d53c9a42 597 %{__make} %{?with_verbose:V=1}
11421384 598}
2adea73e 599
11421384
ER
600%if %{with gui}
601# build GUI version
841cb995 602build --enable-gui --disable-mencoder
11421384 603mv -f mplayer gmplayer
aeb67db6 604%{__make} distclean
11421384
ER
605%endif
606
607# now build regular version
608build --disable-gui
609
aab7d90d 610%if %{with doc}
ef1e3931 611%{__make} -j1 doc
11421384 612%endif
ceb01d0e 613
2adea73e
AM
614%install
615rm -rf $RPM_BUILD_ROOT
e0e4b963 616install -d \
d23c171d 617 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 618 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
9accd5e5 619 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 620 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 621
e0e4b963 622# default config files
c455a752 623install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 624
625# executables
2af58a38 626%if %{with mencoder}
85694787 627install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
e2b12b5a 628ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 629%endif
85694787 630install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
e2b12b5a 631ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 632%if %{with gui}
85694787 633install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
e2b12b5a 634ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 635%endif
e0e4b963 636
c2bf8f19 637%if %{with shared}
638install -d $RPM_BUILD_ROOT%{_libdir}
639install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
640%endif
641
e0e4b963 642# fonts
9d62f689 643cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 644ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 645
11421384 646%if %{with gui}
f0d8c47e 647install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 648%endif
9accd5e5 649touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 650install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 651install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 652
653# man pages
59ba0205 654install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 655install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
656install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
657install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
658install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
659install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 660install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 661install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 662#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
53f97285 663#install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 664
2adea73e
AM
665%clean
666rm -rf $RPM_BUILD_ROOT
667
a69eaaef 668%post -n gmplayer
cd748ae6 669umask 022
cd748ae6 670[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
671
a69eaaef 672%postun -n gmplayer
cd748ae6 673umask 022
75b3147a 674[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 675
2adea73e
AM
676%files
677%defattr(644,root,root,755)
1a8df7bd 678%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
679
680%if %{with gui}
681%files -n gmplayer
682%defattr(644,root,root,755)
1a8df7bd 683%attr(755,root,root) %{_bindir}/gmplayer*
11421384 684%{_desktopdir}/gmplayer.desktop
11421384
ER
685%endif
686
0fb5a7ee 687%if %{with mencoder}
11421384
ER
688%files -n mencoder
689%defattr(644,root,root,755)
aeb67db6 690%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
691%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
692%doc DOCS/tech/colorspaces.txt
1a8df7bd 693%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 694%endif
11421384 695
841cb995 696%if %{with doc}
dc3c7d77 697%files doc
df52db46 698%defattr(644,root,root,755)
dc3c7d77 699%doc DOCS/tech
841cb995
ER
700# HTML and XML-generated docs
701%doc DOCS/HTML/en
0ffd4cd0 702%lang(cs) %doc DOCS/HTML/cs
aeb67db6 703%lang(de) %doc DOCS/HTML/de
aee40e50 704%lang(es) %doc DOCS/HTML/es
705%lang(fr) %doc DOCS/HTML/fr
8cda16b8 706%lang(hu) %doc DOCS/HTML/hu
aee40e50 707%lang(pl) %doc DOCS/HTML/pl
708%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
709#%lang(zh_CN) %doc DOCS/zh
710%endif
dc3c7d77
ER
711
712%files common
713%defattr(644,root,root,755)
841cb995 714%doc AUTHORS README
dc3c7d77
ER
715%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
716%if %{with win32}
717%doc etc/codecs.win32.conf
718%endif
11421384 719
906bf13b
JB
720%dir %{_sysconfdir}/%{name}
721%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 722%{_mandir}/man1/*
59ba0205 723%lang(cs) %{_mandir}/cs/man1/*
20e1052d 724%lang(de) %{_mandir}/de/man1/*
aee40e50 725%lang(es) %{_mandir}/es/man1/*
2a9a2b75 726%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 727%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 728%lang(it) %{_mandir}/it/man1/*
2a6ed516 729%lang(pl) %{_mandir}/pl/man1/*
841cb995 730#%lang(sv) %{_mandir}/sv/man1/*
53f97285 731#%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 732%{_desktopdir}/mplayer.desktop
1087e996 733%{_pixmapsdir}/mplayer.png
11421384
ER
734%dir %{_datadir}/%{name}
735%{_datadir}/%{name}/font*
59ce39fb
ER
736%dir %{_datadir}/%{name}/skins
737%ghost %{_datadir}/%{name}/skins/default
This page took 0.25454 seconds and 4 git commands to generate.