]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
clean ac conditions
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44%bcond_with musepack # libmpcdec support (derecated in favour of libavcodec)
45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
d1f72115 49%bcond_with system_vorbis # use system libvorbis instead of internal tremor
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
83%undefine with_system_vorbis
84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
100
1a8df7bd 101%if %{_lib} == "lib64"
e2b12b5a 102%define binsuf 64
1a8df7bd 103%else
e2b12b5a 104%define binsuf 32
1a8df7bd 105%endif
106
906bf13b 107Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
108Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
109Summary(es.UTF-8): Otro reproductor de películas
110Summary(ko.UTF-8): 리눅스용 미디어플레이어
111Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
112Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 113Name: mplayer
df52db46 114Version: 1.1
66a6b75e 115Release: 3
1f85fd72
ER
116# DO NOT increase epoch unless it's really neccessary!
117# especially such changes like pre7->pre7try2, increase Release instead!
118# PS: $ rpmvercmp pre7try2 pre7
119# pre7try2 > pre7
59476b48 120Epoch: 3
bc426a7f 121License: GPL
906bf13b 122Group: Applications/Multimedia
e2b12b5a
JB
123# for snapshots:
124# svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
125# cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
126# tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
127Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
df52db46 128# Source0-md5: ac7bf1cfedc1c5c24bfc83107eefb1d9
031c3c7c 129Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 130# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 131Source5: g%{name}.desktop
623ea2d1 132Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 133# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 134Source7: %{name}.png
24481cd2 135Source8: %{name}.desktop
dfd680ce 136# http://www.on2.com/gpl/mplayer/
53f97285 137Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
138# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 139
140# build (configure / Makefile) related:
141Patch10: %{name}-ldflags.patch
142Patch11: %{name}-altivec.patch
143Patch12: %{name}-check-byteswap.patch
c2bf8f19 144Patch13: %{name}-visibility-hidden-fix.patch
145Patch14: %{name}-ffmpeg.patch
e2b12b5a 146Patch15: %{name}-live.patch
63bba7db
JB
147Patch16: %{name}-libcdio.patch
148Patch17: %{name}-gsm.patch
149Patch18: %{name}-openjpeg.patch
150Patch19: %{name}-shared.patch
990687b2 151Patch20: %{name}-vstream.patch
79907b07 152
153# codecs, outputs, demuxers:
990687b2
JB
154Patch21: %{name}-auto-expand.patch
155Patch22: %{name}-release_directfb.patch
79907b07 156
157# goodies:
158Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 159Patch31: %{name}-350.patch
d1f72115 160# update, hard to fix right now because of gnome bug 579430:
161# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 162#Patch32: %{name}-gnome-screensaver.patch
79907b07 163
164Patch100: %{name}-on2flix.patch
b252aa8a 165Patch101: %{name}-link.patch
e48160f4 166Patch102: %{name}-build.patch
79907b07 167
c5b97685 168URL: http://www.mplayerhq.hu/
33c4efab 169%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 170BuildRequires: OpenAL-devel
b458005d 171BuildRequires: OpenGL-devel
11421384 172%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
63bba7db 173BuildRequires: a52dec-libs-devel
dd6c659c
JB
174%{?with_aalib:BuildRequires: aalib-devel}
175%{?with_alsa:BuildRequires: alsa-lib-devel}
176%{?with_arts:BuildRequires: artsc-devel}
841cb995 177%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 178BuildRequires: bzip2-devel
3c3fdfcc 179%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 180%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 181BuildRequires: dirac-devel
5dcdda0f
ER
182%{?with_doc:BuildRequires: docbook-dtd412-xml}
183%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 184%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 185%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
186%{?with_enca:BuildRequires: enca-devel}
187%{?with_esd:BuildRequires: esound-devel}
30e3739f 188BuildRequires: faac-devel
3c3fdfcc 189%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 190%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 191BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 192BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 193BuildRequires: fribidi-devel
3d17ae18 194%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 195%{?with_gif:BuildRequires: giflib-devel}
d1f72115 196%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 197%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 198%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 199BuildRequires: lame-libs-devel
6bd88460 200BuildRequires: libass-devel >= 0.9.10
c3a1256a 201%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 202%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 203%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
204%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
205%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 206%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 207%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
63bba7db 208%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 209%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 210%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 211%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
212%{?with_ggi:BuildRequires: libggiwmh-devel}
213BuildRequires: libgsm-devel
af480c75 214BuildRequires: libjpeg-devel
dd6c659c 215%{?with_mad:BuildRequires: libmad-devel}
c521a17c 216BuildRequires: libmng-devel
63bba7db
JB
217%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
218%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
219%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 220%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 221BuildRequires: libnut-devel
af480c75 222BuildRequires: libpng-devel
63bba7db 223%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 224%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 225%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 226%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 227%{?with_system_vorbis:BuildRequires: libvorbis-devel}
0431b837 228BuildRequires: libvpx-devel
bbab8eb7 229%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 230BuildRequires: libxslt-progs
dd6c659c 231%{?with_lirc:BuildRequires: lirc-devel}
5244e474 232%{?with_live:BuildRequires: live-devel}
841cb995 233%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 234%{?with_nas:BuildRequires: nas-devel}
b458005d 235BuildRequires: ncurses-devel
b69a6f83 236%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 237%{?with_openjpeg:BuildRequires: openjpeg-devel}
e9d22b19 238BuildRequires: pkgconfig
86bc294f 239%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 240BuildRequires: rpm >= 4.4.9-56
9accd5e5 241BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 242BuildRequires: schroedinger-devel
aeb67db6 243BuildRequires: speex-devel >= 1.1
dd6c659c 244%{?with_svga:BuildRequires: svgalib-devel}
3af20979 245BuildRequires: tar >= 1:1.22
c521a17c 246BuildRequires: twolame-devel
3af20979 247%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 248%{?with_vstream:BuildRequires: vstream-client-devel}
c521a17c 249%{?with_xmms:BuildRequires: xmms-devel}
5dcdda0f
ER
250%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
251%ifarch %{ix86} %{x8664}
252BuildRequires: yasm
253%endif
254BuildRequires: zlib-devel
627a7a97 255BuildRequires: xorg-lib-libX11-devel
c521a17c 256BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
257BuildRequires: xorg-lib-libXext-devel
258BuildRequires: xorg-lib-libXinerama-devel
259BuildRequires: xorg-lib-libXv-devel
260BuildRequires: xorg-lib-libXvMC-devel
261BuildRequires: xorg-lib-libXxf86dga-devel
262BuildRequires: xorg-lib-libXxf86vm-devel
4d75c49f 263Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 264Requires: OpenGL
0f2a502d 265BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 266
a8e3a9a7 267%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 268%define specflags_ia32 -fomit-frame-pointer
198487b4 269%if %{with altivec}
adfd0023 270%define specflags_ppc -maltivec
20a66bdb 271%endif
2adea73e
AM
272
273%description
c902f7c6 274Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
275AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 276MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
277MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 278devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
279optionally with SHM extension, X11 using overlays with the Xvideo
280extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
281Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 282
8b146837 283If you want to use win32 codecs install w32codec package.
4228a246 284
e011d408 285%description -l de.UTF-8
deba608c 286MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
287Kennzeichnend ist die herausragende Format- und
e011d408 288Plattform-Kompatibilität.
deba608c 289
e011d408
JR
290Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
291plattformexklusive, wodurch etwa Windows Media auch außerhalb von
292Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
293Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 294ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
295Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
296installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 297
e011d408 298%description -l es.UTF-8
c902f7c6 299Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
300MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
301(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
302de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
303Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
304G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
305overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 306G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
307v1.1.7 etc.
33c4efab 308
8b146837 309Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 310
e011d408
JR
311%description -l ko.UTF-8
312MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
313파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
314MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
315Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
316(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
317수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
318크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
319있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
320부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 321
e011d408
JR
322%description -l pl.UTF-8
323Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 324RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
325(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
326Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 327Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 328rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 329G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 330
e011d408 331Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 332
e011d408
JR
333%description -l pt_BR.UTF-8
334MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
335áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 336escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
337
11421384
ER
338%package -n gmplayer
339Summary: MPlayer with GTK+ GUI interface
eeb91a66 340Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 341Group: X11/Applications/Multimedia
11421384 342Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 343Requires: %{name}-skin
11421384
ER
344
345%description -n gmplayer
346MPlayer with GUI GTK+ interface.
347
e011d408 348%description -n gmplayer -l pl.UTF-8
906bf13b
JB
349MPlayer z graficznym interfejsem GTK+.
350
11421384 351%package common
906bf13b 352Summary: Configuration files and documentation for MPlayer
eeb91a66 353Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 354Group: Applications/Multimedia
c521a17c 355Suggests: unrar
1087e996 356Obsoletes: mplayer-vidix
11421384
ER
357
358%description common
906bf13b
JB
359Configuration files, man page and HTML documentation for MPlayer.
360
e011d408 361%description common -l pl.UTF-8
906bf13b 362Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 363
dc3c7d77 364%package doc
63bba7db
JB
365Summary: HTML documentation for MPlayer
366Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
367Group: Documentation
368
369%description doc
63bba7db
JB
370HTML Documentation for MPlayer.
371
372%description doc -l pl.UTF-8
373Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 374
11421384 375%package -n mencoder
906bf13b 376Summary: MEncoder - a movie encoder for Linux
eeb91a66 377Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
378Group: Applications/Multimedia
379Requires: %{name}-common = %{epoch}:%{version}-%{release}
380
381%description -n mencoder
906bf13b
JB
382MEncoder is a movie encoder for Linux and is a part of the MPlayer
383package.
384
e011d408
JR
385%description -n mencoder -l pl.UTF-8
386MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 387
2adea73e 388%prep
df52db46 389%setup -q -n MPlayer-%{version} -a3 -a6 -a9
833dbe20 390cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 391
392# build (configure / Makefile) related:
393%patch10 -p1
394%patch11 -p1
395%patch12 -p1
c2bf8f19 396%patch13 -p1
397%{?with_system_ffmpeg:%patch14 -p1}
e2b12b5a 398%patch15 -p1
63bba7db
JB
399%patch16 -p1
400%patch17 -p1
401%patch18 -p1
402%{?with_shared:%patch19 -p1}
990687b2 403%patch20 -p1
79907b07 404
405# codecs, outputs, demuxers:
79907b07 406%patch21 -p1
990687b2 407%patch22 -p1
79907b07 408
409# goodies:
410%patch30 -p0
2833f81f 411%patch31 -p1
412#%{with_gnomess:%patch32 -p1}
59ba0205 413
dfd680ce 414# on2flix
759ef2d3 415mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 416%if %{with on2}
79907b07 417#%%patch100 -p1
d1f72115 418cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
419# remove broken patches:
420# - first set does not apply
421# - second set beakes build
422for PATCH in asf-correct_movielength avi_check_idxflags \
423 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
424 mencoder_07_demux_update_pts mencoder_10_correct_pts \
425 mpegvideo-revert_r18381 \
426 \
427 reduce_spurious_logging
428do
429 rm mencoder-on2flixenglinux/patch/$PATCH.diff
430done
431for a in mencoder-on2flixenglinux/patch/*.diff; do
432 patch -p0 < $a
433done
434%endif
dfd680ce 435
b252aa8a 436%patch101 -p1
e48160f4 437%patch102 -p1
b252aa8a 438
53f97285 439cat etc/example.conf > etc/mplayer.conf
c521a17c 440cat <<'CONFIGADD' >> etc/mplayer.conf
441
d1f72115 442######################
8b2ed1fb 443# PLD Linux Defaults #
d1f72115 444######################
2833f81f 445[default]
446
447# alternate solution for CP1250-encoded subtitles
448fontconfig = yes
449subcp = cp1250
450
451# ...or if you prefer native bitmap fonts shipped with mplayer
452#fontconfig = no
453#subcp = iso-8859-1
454
455# Standard location
456unrarexec = "%{_bindir}/unrar"
457
c521a17c 458CONFIGADD
d1732085 459
1f8d8779
ER
460%if %{with system_ffmpeg}
461# using external ffmpeg, but mplayer adds these to includepath
e2b12b5a 462%{__rm} -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
1f8d8779
ER
463%endif
464
2adea73e 465%build
5dcdda0f 466CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
53f97285 467CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
53f97285 468
63bba7db
JB
469# NOTE:
470# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
471# - toolame is obsolete predecessor of twolame
11421384 472build() {
c521a17c 473 set -x
53f97285 474
11421384
ER
475 ./configure \
476 %{?debug:--enable-debug=3} \
dd6c659c 477 --prefix=%{_prefix} \
63bba7db 478 --codecsdir=%{_libdir}/codecs \
dd6c659c 479 --confdir=%{_sysconfdir}/mplayer \
53f97285 480 --cc="%{__cc}" \
481 --extra-cflags="$CFLAGS" \
79907b07 482 --real-ldflags="%{rpmldflags}" \
483 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 484 --language=all \
1f8d8779 485%if %{with system_ffmpeg}
841cb995
ER
486 --disable-libavutil_a \
487 --disable-libavcodec_a \
488 --disable-libavformat_a \
489 --disable-libpostproc_a \
490 --enable-libavutil_so \
491 --enable-libavcodec_so \
492 --enable-libavformat_so \
493 --enable-libpostproc_so \
1f8d8779 494%endif
57f87bc2 495%ifnarch %{ix86} %{x8664}
dd6c659c 496 --disable-3dnow \
a14f4270 497 --disable-3dnowext \
63bba7db
JB
498 --disable-fastmemcpy \
499 --disable-mmx \
500 --disable-mmxext \
dd6c659c
JB
501 --disable-sse \
502 --disable-sse2 \
dfeec30a 503%endif
9accd5e5 504 %{__disable ssse3} \
1837afdf 505%ifarch ppc
9accd5e5 506 %{__disable altivec} \
1837afdf 507%endif
9accd5e5 508 %{__disable aalib aa} \
9accd5e5 509 %{__enable_disable alsa} \
510 %{__disable arts} \
63bba7db 511 %{__disable bluray} \
9accd5e5 512 %{__disable caca} \
513 %{__disable cdparanoia} \
63bba7db
JB
514 --enable-dga1 \
515 --enable-dga2 \
516 %{__enable_disable directfb} \
517 %{__enable_disable dvdnav} \
518 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 519 %{__disable dxr2} \
63bba7db
JB
520 %{__disable dxr3} \
521 --enable-dynamic-plugins \
9accd5e5 522 %{__disable enca} \
523 %{__disable esd} \
9accd5e5 524 %{__disable faad} \
63bba7db 525 --enable-fbdev \
9accd5e5 526 %{__disable gif} \
63bba7db
JB
527 --enable-gl \
528 %{__disable ggi} \
529 %{__disable jack} \
9accd5e5 530 %{__enable joystick} \
63bba7db
JB
531 %{__disable cdio libcdio} \
532 %{__disable ladspa} \
10a6d1a6 533 %{__disable bs2b libbs2b} \
9accd5e5 534 %{__disable libdts libdca} \
63bba7db
JB
535 %{__disable libdv} \
536 %{__disable system_dvdcss libdvdcss-internal} \
537 %{__disable lzo liblzo} \
538 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 539 %{__disable nemesi} \
63bba7db
JB
540 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
541 %{__disable openjpeg} \
542 %{__disable rtmp librtmp} \
543 %{__disable vorbis libvorbis} \
9accd5e5 544 %{__enable_disable lirc} \
63bba7db
JB
545 --disable-lircc \
546 %{__disable live} \
9accd5e5 547 %{__disable mad} \
63bba7db
JB
548 %{__disable mencoder} \
549 %{__enable osd menu} \
550 --enable-mga \
551 %{__disable mpg123} \
552 %{__enable musepack} \
553 %{__disable nas} \
9accd5e5 554 %{__disable pulseaudio pulse} \
555 %{__disable quicktime qtx} \
63bba7db
JB
556 --enable-radio \
557 --enable-radio-capture \
9accd5e5 558 %{__disable real} \
559 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 560 %{__enable_disable sdl} \
9accd5e5 561 %{__disable select} \
10a6d1a6 562 --enable-s3fb \
9accd5e5 563 %{__disable smb} \
63bba7db
JB
564 %{__disable svga} \
565 --enable-tdfxfb \
10a6d1a6 566 --enable-tdfxvid \
9accd5e5 567 %{__disable theora} \
63bba7db
JB
568 --disable-toolame \
569 --disable-tremor \
570 %{__disable vorbis tremor-internal} \
571 %{__disable_if system_vorbis tremor-internal} \
572 --enable-unrarexec \
9accd5e5 573 %{__disable vdpau} \
63bba7db 574 %{__disable vidix} \
10a6d1a6 575 %{__disable vstream} \
dd6c659c 576 --enable-vm \
10a6d1a6
JB
577%ifarch ppc
578 --enable-wii \
579%endif
63bba7db 580 %{__disable win32 win32dll} \
dd6c659c 581 --enable-x11 \
63bba7db 582 %{__disable x264} \
dd6c659c 583 --enable-xmga \
63bba7db 584 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 585 --enable-xv \
63bba7db
JB
586 %{__disable xvid} \
587 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 588 %{__enable_disable zr} \
11421384 589 "$@"
eb52750a 590
d53c9a42 591 %{__make} %{?with_verbose:V=1}
11421384 592}
2adea73e 593
11421384
ER
594%if %{with gui}
595# build GUI version
841cb995 596build --enable-gui --disable-mencoder
11421384 597mv -f mplayer gmplayer
aeb67db6 598%{__make} distclean
11421384
ER
599%endif
600
601# now build regular version
602build --disable-gui
603
aab7d90d 604%if %{with doc}
ef1e3931 605%{__make} -j1 doc
11421384 606%endif
ceb01d0e 607
2adea73e
AM
608%install
609rm -rf $RPM_BUILD_ROOT
e0e4b963 610install -d \
d23c171d 611 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 612 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
9accd5e5 613 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 614 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 615
e0e4b963 616# default config files
c455a752 617install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 618
619# executables
2af58a38 620%if %{with mencoder}
85694787 621install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
e2b12b5a 622ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 623%endif
85694787 624install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
e2b12b5a 625ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 626%if %{with gui}
85694787 627install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
e2b12b5a 628ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 629%endif
e0e4b963 630
c2bf8f19 631%if %{with shared}
632install -d $RPM_BUILD_ROOT%{_libdir}
633install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
634%endif
635
e0e4b963 636# fonts
9d62f689 637cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 638ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 639
11421384 640%if %{with gui}
f0d8c47e 641install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 642%endif
9accd5e5 643touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 644install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 645install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 646
647# man pages
59ba0205 648install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 649install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
650install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
651install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
652install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
653install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 654install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 655install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 656#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
53f97285 657#install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 658
2adea73e
AM
659%clean
660rm -rf $RPM_BUILD_ROOT
661
a69eaaef 662%post -n gmplayer
cd748ae6 663umask 022
cd748ae6 664[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
665
a69eaaef 666%postun -n gmplayer
cd748ae6 667umask 022
75b3147a 668[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 669
2adea73e
AM
670%files
671%defattr(644,root,root,755)
1a8df7bd 672%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
673
674%if %{with gui}
675%files -n gmplayer
676%defattr(644,root,root,755)
1a8df7bd 677%attr(755,root,root) %{_bindir}/gmplayer*
11421384 678%{_desktopdir}/gmplayer.desktop
11421384
ER
679%endif
680
0fb5a7ee 681%if %{with mencoder}
11421384
ER
682%files -n mencoder
683%defattr(644,root,root,755)
aeb67db6 684%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
685%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
686%doc DOCS/tech/colorspaces.txt
1a8df7bd 687%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 688%endif
11421384 689
841cb995 690%if %{with doc}
dc3c7d77 691%files doc
df52db46 692%defattr(644,root,root,755)
dc3c7d77 693%doc DOCS/tech
841cb995
ER
694# HTML and XML-generated docs
695%doc DOCS/HTML/en
0ffd4cd0 696%lang(cs) %doc DOCS/HTML/cs
aeb67db6 697%lang(de) %doc DOCS/HTML/de
aee40e50 698%lang(es) %doc DOCS/HTML/es
699%lang(fr) %doc DOCS/HTML/fr
8cda16b8 700%lang(hu) %doc DOCS/HTML/hu
aee40e50 701%lang(pl) %doc DOCS/HTML/pl
702%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
703#%lang(zh_CN) %doc DOCS/zh
704%endif
dc3c7d77
ER
705
706%files common
707%defattr(644,root,root,755)
841cb995 708%doc AUTHORS README
dc3c7d77
ER
709%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
710%if %{with win32}
711%doc etc/codecs.win32.conf
712%endif
11421384 713
906bf13b
JB
714%dir %{_sysconfdir}/%{name}
715%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 716%{_mandir}/man1/*
59ba0205 717%lang(cs) %{_mandir}/cs/man1/*
20e1052d 718%lang(de) %{_mandir}/de/man1/*
aee40e50 719%lang(es) %{_mandir}/es/man1/*
2a9a2b75 720%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 721%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 722%lang(it) %{_mandir}/it/man1/*
2a6ed516 723%lang(pl) %{_mandir}/pl/man1/*
841cb995 724#%lang(sv) %{_mandir}/sv/man1/*
53f97285 725#%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 726%{_desktopdir}/mplayer.desktop
1087e996 727%{_pixmapsdir}/mplayer.png
11421384
ER
728%dir %{_datadir}/%{name}
729%{_datadir}/%{name}/font*
59ce39fb
ER
730%dir %{_datadir}/%{name}/skins
731%ghost %{_datadir}/%{name}/skins/default
This page took 0.530127 seconds and 4 git commands to generate.