]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- merged 1.0 rc2 from DEVEL
[packages/mplayer.git] / mplayer.spec
CommitLineData
5e37db9a 1# TODO:
8a72e936 2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
b8145877 3# - update for lzo 2
841cb995 4# - try to use external lrmi and few other libs:
4d75c49f 5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
bef18474
ER
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
5e37db9a 9#
94cb018b 10# Conditional build:
8cc223f8 11%bcond_with directfb # with DirectFB video output
8cc223f8
JB
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
8cc223f8
JB
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
93ab9715 17%bcond_without altivec # without altivec support
d6014b54 18%bcond_without x264 # without x264 support
2af58a38 19%bcond_with xmms # with XMMS inputplugin support
8cc223f8 20%bcond_without aalib # without aalib video output
e5b91f83 21%bcond_without jack # without JACKD support
8cc223f8
JB
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
dd153a0d 24%bcond_without caca # without libcaca video output
3c3fdfcc 25%bcond_without cdparanoia # without cdparanoia support
8cc223f8 26%bcond_without dshow # disable DirectShow support
3c3fdfcc
JB
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
8d7378f8 31%bcond_without gui # without GTK+ GUI
8cc223f8 32%bcond_without joystick # disable joystick support
3c3fdfcc 33%bcond_without libdts # disable libdts support
a4298e0c 34%bcond_without libdv # disable libdv en/decoding support
8cc223f8 35%bcond_without lirc # without lirc support
841cb995
ER
36%bcond_with live # without LIVE555 libraries
37%bcond_without lzo # with LZO support (requires lzo 2.x)
8cc223f8 38%bcond_without mad # without mad (audio MPEG) support
86bc294f 39%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 46%bcond_without smb # disable Samba (SMB) input support
de0c2d91 47%bcond_without theora # without theora support
8cc223f8 48%bcond_without win32 # without win32 codecs support
1087e996 49%bcond_without vidix # disable vidix
3b930ad6 50%bcond_without vorbis # without Ogg-Vorbis audio support
3c3fdfcc 51%bcond_without xvid # disable XviD codec
2af58a38 52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 53%bcond_without sdl # disable SDL
aab7d90d 54%bcond_without doc # don't build docs (slow)
59a38ff4 55%bcond_with shared # experimental libmplayer.so support
439df4dd 56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
0256d486 57%bcond_without gnomess # disable controling gnome screensaver
841cb995 58%bcond_with ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
2dfabf36 59
94cb018b
JB
60%ifnarch %{ix86}
61%undefine with_win32
7a82c266 62%undefine with_quicktime
1087e996 63%undefine with_vidix
94cb018b
JB
64%endif
65
906bf13b
JB
66%ifarch %{x8664}
67%undefine with_runtime
68%endif
1a8df7bd 69
70%if %{_lib} == "lib64"
71%define _suf 64
72%else
73%define _suf 32
74%endif
75
841cb995
ER
76%define _rel 0.1
77%define _rc rc2
135255b8 78
906bf13b 79Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
80Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81Summary(es.UTF-8): Otro reproductor de películas
82Summary(ko.UTF-8): 리눅스용 미디어플레이어
83Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
84Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 85Name: mplayer
9cb1ef87 86Version: 1.0
841cb995 87Release: 5.%{_rc}.%{_rel}
1f85fd72
ER
88# DO NOT increase epoch unless it's really neccessary!
89# especially such changes like pre7->pre7try2, increase Release instead!
90# PS: $ rpmvercmp pre7try2 pre7
91# pre7try2 > pre7
59476b48 92Epoch: 3
bc426a7f 93License: GPL
906bf13b 94Group: Applications/Multimedia
841cb995
ER
95Source0: ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{_rc}.tar.bz2
96# Source0-md5: 7e27e535c2d267637df34898f1b91707
031c3c7c 97Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 98# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 99Source5: g%{name}.desktop
623ea2d1 100Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 101# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 102Source7: %{name}.png
24481cd2 103Source8: %{name}.desktop
dfd680ce 104# http://www.on2.com/gpl/mplayer/
841cb995
ER
105Source9: http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106# Source9-md5: 2361e56b40f52dfc20131e458e2aed38
aee40e50 107Patch1: %{name}-cp1250-fontdesc.patch
108Patch2: %{name}-codec.patch
109Patch3: %{name}-home_etc.patch
110Patch4: %{name}-350.patch
111Patch5: %{name}-configure.patch
841cb995 112#Patch6: %{name}-system-amr.patch # outdated via ffmpeg?
8cc223f8 113Patch8: %{name}-altivec.patch
ceb01d0e 114Patch10: %{name}-pcmsplit.patch
21badcc3 115Patch13: %{name}-mythtv.patch
11421384 116Patch14: %{name}-shared.patch
30e3739f 117#http://www.openchrome.org/snapshots/mplayer/
499b1aea 118Patch15: %{name}-xvmc.patch
c7699e1b 119Patch17: %{name}-auto-expand.patch
841cb995 120#Patch18: %{name}-gnome-screensaver.patch # update
dfd680ce 121Patch19: %{name}-on2flix.patch
841cb995
ER
122Patch22: %{name}-ffmpeg.patch
123Patch23: %{name}-live.patch
c5b97685 124URL: http://www.mplayerhq.hu/
33c4efab 125%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 126BuildRequires: OpenAL-devel
b458005d 127BuildRequires: OpenGL-devel
11421384 128%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
129%{?with_aalib:BuildRequires: aalib-devel}
130%{?with_alsa:BuildRequires: alsa-lib-devel}
e4268e0b
JB
131%if %{with amr}
132BuildRequires: amrnb-devel
4d75c49f 133BuildRequires: amrwb-devel >= 5.3.0
e4268e0b 134%endif
dd6c659c 135%{?with_arts:BuildRequires: artsc-devel}
841cb995 136%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
3c3fdfcc 137%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
aab7d90d 138%{?with_doc:BuildRequires: docbook-style-xsl}
dd6c659c 139%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
140%{?with_enca:BuildRequires: enca-devel}
141%{?with_esd:BuildRequires: esound-devel}
30e3739f 142BuildRequires: faac-devel
3c3fdfcc 143%{?with_faad:BuildRequires: faad2-devel >= 2.0}
841cb995 144BuildRequires: ffmpeg-devel >= 0.4.9-3.20070626.1.1
d23c171d 145BuildRequires: freetype-devel
30e3739f 146BuildRequires: fribidi-devel
1087e996 147%{?with_vidix:BuildRequires: vidix-devel}
8cc223f8
JB
148%ifarch ppc
149%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
150%endif
3c3fdfcc 151%{?with_gif:BuildRequires: giflib-devel}
dd6c659c 152%if %{with gui}
aeb67db6 153BuildRequires: gtk+2-devel
dd6c659c 154%endif
1087e996 155%{?with_gnomess:BuildRequires: dbus-glib-devel}
d336e259 156%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
a8a0c1d1 157BuildRequires: lame-libs-devel
dd6c659c 158%{?with_caca:BuildRequires: libcaca-devel}
49aed190 159%{?with_libdts:BuildRequires: libdts-devel}
a4298e0c 160%{?with_libdv:BuildRequires: libdv-devel}
4d75c49f 161BuildRequires: libdvdnav-devel
dd6c659c 162%{?with_ggi:BuildRequires: libggi-devel}
af480c75 163BuildRequires: libjpeg-devel
dd6c659c 164%{?with_mad:BuildRequires: libmad-devel}
30e3739f 165BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 166BuildRequires: libpng-devel
a4298e0c 167%{?with_smb:BuildRequires: libsmbclient-devel}
dd6c659c 168%{?with_dshow:BuildRequires: libstdc++-devel}
de0c2d91 169%{?with_theora:BuildRequires: libtheora-devel}
1130ecb8 170# tremor is used by default, internal as we don't have system one
281ac7d0 171#%{?with_vorbis:BuildRequires: libvorbis-devel}
a9052f4d 172%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20060828_2245.1}
ceb01d0e 173BuildRequires: libxslt-progs
dd6c659c
JB
174%{?with_lirc:BuildRequires: lirc-devel}
175%{?with_live:BuildRequires: live}
841cb995 176%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 177%{?with_nas:BuildRequires: nas-devel}
b458005d 178BuildRequires: ncurses-devel
e9d22b19 179BuildRequires: pkgconfig
86bc294f 180%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
aeb67db6 181BuildRequires: speex-devel >= 1.1
dd6c659c
JB
182%{?with_svga:BuildRequires: svgalib-devel}
183%{?with_xmms:BuildRequires: xmms-libs}
627a7a97
ER
184BuildRequires: xorg-lib-libX11-devel
185BuildRequires: xorg-lib-libXext-devel
186BuildRequires: xorg-lib-libXinerama-devel
187BuildRequires: xorg-lib-libXv-devel
188BuildRequires: xorg-lib-libXvMC-devel
189BuildRequires: xorg-lib-libXxf86dga-devel
190BuildRequires: xorg-lib-libXxf86vm-devel
3c3fdfcc 191%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
c2eb8d00 192BuildRequires: zlib-devel
4d75c49f 193Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 194Requires: OpenGL
0f2a502d 195BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 196
a8e3a9a7 197%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 198%define specflags_ia32 -fomit-frame-pointer
198487b4 199%if %{with altivec}
adfd0023 200%define specflags_ppc -maltivec
20a66bdb 201%endif
2adea73e
AM
202
203%description
c902f7c6 204Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
205AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 206MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
207MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 208devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
209optionally with SHM extension, X11 using overlays with the Xvideo
210extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
211Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 212
8b146837 213If you want to use win32 codecs install w32codec package.
4228a246 214
e011d408 215%description -l de.UTF-8
deba608c 216MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
217Kennzeichnend ist die herausragende Format- und
e011d408 218Plattform-Kompatibilität.
deba608c 219
e011d408
JR
220Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
221plattformexklusive, wodurch etwa Windows Media auch außerhalb von
222Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
223Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 224ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
225Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
226installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 227
e011d408 228%description -l es.UTF-8
c902f7c6 229Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
230MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
231(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
232de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
233Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
234G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
235overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 236G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
237v1.1.7 etc.
33c4efab 238
8b146837 239Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 240
e011d408
JR
241%description -l ko.UTF-8
242MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
243파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
244MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
245Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
246(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
247수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
248크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
249있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
250부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 251
e011d408
JR
252%description -l pl.UTF-8
253Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 254RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
255(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
256Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 257Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 258rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 259G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 260
e011d408 261Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 262
e011d408
JR
263%description -l pt_BR.UTF-8
264MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
265áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 266escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
267
11421384
ER
268%package -n gmplayer
269Summary: MPlayer with GTK+ GUI interface
eeb91a66 270Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 271Group: X11/Applications/Multimedia
11421384 272Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 273Requires: %{name}-skin
906bf13b 274Provides: %{name} = %{epoch}:%{version}-%{release}
11421384
ER
275
276%description -n gmplayer
277MPlayer with GUI GTK+ interface.
278
e011d408 279%description -n gmplayer -l pl.UTF-8
906bf13b
JB
280MPlayer z graficznym interfejsem GTK+.
281
11421384 282%package common
906bf13b 283Summary: Configuration files and documentation for MPlayer
eeb91a66 284Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 285Group: Applications/Multimedia
1087e996 286Obsoletes: mplayer-vidix
11421384
ER
287
288%description common
906bf13b
JB
289Configuration files, man page and HTML documentation for MPlayer.
290
e011d408 291%description common -l pl.UTF-8
906bf13b 292Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
293
294%package -n mencoder
906bf13b 295Summary: MEncoder - a movie encoder for Linux
eeb91a66 296Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
297Group: Applications/Multimedia
298Requires: %{name}-common = %{epoch}:%{version}-%{release}
299
300%description -n mencoder
906bf13b
JB
301MEncoder is a movie encoder for Linux and is a part of the MPlayer
302package.
303
e011d408
JR
304%description -n mencoder -l pl.UTF-8
305MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 306
2adea73e 307%prep
841cb995 308%setup -q -n MPlayer-%{version}%{_rc} -a3 -a6 -a9
833dbe20 309cp -f etc/codecs.conf etc/codecs.win32.conf
aee40e50 310%patch1 -p0
311##%patch2 -p1
312##%patch3 -p1 -- old home_etc behavior
313%patch4 -p1
dd6c659c 314%patch5 -p1
841cb995 315#%patch6 -p1 # - try ffmpeg
2dfabf36 316%patch8 -p1
2b8c25a3 317#%%patch10 -p1
aeb67db6 318#%patch13 -p1 # TODO
11421384
ER
319%if %{with shared}
320%patch14 -p1
321%endif
aeb67db6 322#%patch15 -p0 # TODO
c7699e1b 323%patch17 -p1
0256d486 324%if %{with gnomess}
841cb995 325#%patch18 -p1
0992d783 326%endif
59ba0205 327
dfd680ce
ER
328# on2flix
329cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
841cb995 330rm -f mencoder-on2flixenglinux/version.diff
dfd680ce
ER
331%patch19 -p1
332for a in mencoder-on2flixenglinux/*.diff; do
333 patch -p0 < $a
334done
335
841cb995
ER
336%patch22 -p1
337%patch23 -p1
7c31e935 338
2adea73e 339%build
68dd28e8 340%if %{with shared}
11421384 341CFLAGS="%{rpmcflags} -fPIC"
68dd28e8
ER
342%else
343CFLAGS="%{rpmcflags}"
68dd28e8 344%endif
4ed9dec4 345CC="%{__cc}"
ce8a4f6d
JB
346LDFLAGS="%{rpmldflags}"
347export CC CFLAGS LDFLAGS
11421384
ER
348
349build() {
350set -x
351 ./configure \
352 %{?debug:--enable-debug=3} \
dd6c659c
JB
353 --prefix=%{_prefix} \
354 --confdir=%{_sysconfdir}/mplayer \
dd6c659c 355 --with-extraincdir=%{_includedir}/xvid \
841cb995 356 --with-extralibdir=%{_x_libraries} \
526c0e5d 357 --enable-menu \
841cb995
ER
358 --disable-libavutil_a \
359 --disable-libavcodec_a \
360 --disable-libavformat_a \
361 --disable-libpostproc_a \
362 --enable-libavutil_so \
363 --enable-libavcodec_so \
364 --enable-libavformat_so \
365 --enable-libpostproc_so \
57f87bc2 366%ifnarch %{ix86} %{x8664}
dd6c659c 367 --disable-mmx \
a14f4270 368 --disable-mmxext \
dd6c659c 369 --disable-3dnow \
a14f4270 370 --disable-3dnowext \
dd6c659c
JB
371 --disable-sse \
372 --disable-sse2 \
373 --disable-fastmemcpy \
dfeec30a 374%endif
841cb995 375 %{!?with_ssse3:--disable-ssse3} \
1837afdf 376%ifarch ppc
377%{!?with_altivec:--disable-altivec} \
378%endif
841cb995
ER
379%{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
380%{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
6e0359a9 381%{?with_directfb:--enable-directfb} \
33c4efab 382%{!?with_directfb:--disable-directfb} \
33c4efab 383%{!?with_dxr3:--disable-dxr3} \
384%{!?with_ggi:--disable-ggi} \
841cb995 385%{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
0f2c0aed 386%{!?with_live:--disable-live} \
b8145877 387%{!?with_lzo:--disable-liblzo} \
33c4efab 388%{!?with_nas:--disable-nas} \
389%{!?with_svga:--disable-svga} \
390%{!?with_aalib:--disable-aa} \
e5b91f83 391%{!?with_jack:--disable-jack} \
33c4efab 392%{!?with_alsa:--disable-alsa} \
393%{?with_alsa:--enable-alsa --disable-select} \
394%{!?with_arts:--disable-arts} \
dd153a0d 395%{!?with_caca:--disable-caca} \
3c3fdfcc 396%{!?with_cdparanoia:--disable-cdparanoia} \
33c4efab 397%{!?with_dshow:--disable-dshow} \
3c3fdfcc
JB
398%{!?with_enca:--disable-enca} \
399%{!?with_esd:--disable-esd} \
0ffd4cd0 400%{!?with_faad:--disable-faad-external --disable-faad-internal} \
401%{?with_faad:--disable-faad-internal} \
3c3fdfcc 402%{!?with_gif:--disable-gif} \
33c4efab 403%{?with_joystick:--enable-joystick} \
a4298e0c 404%{!?with_libdv:--disable-libdv} \
49aed190 405%{!?with_libdts:--disable-libdts} \
d8f32b56 406--%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
33c4efab 407%{!?with_mad:--disable-mad} \
4143807a 408%{!?with_pulseaudio:--disable-pulse} \
7a82c266 409%{!?with_quicktime:--disable-qtx} \
33c4efab 410%{!?with_real:--disable-real} \
11421384 411--%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
33c4efab 412%{!?with_select:--disable-select} \
a4298e0c 413%{!?with_smb:--disable-smb} \
841cb995 414%{!?with_win32:--disable-win32dll} \
33c4efab 415%{!?with_vorbis:--disable-vorbis} \
416%{?with_osd:--enable-menu} \
587f4971 417%{!?with_theora:--disable-theora} \
6a8a1010 418%{!?with_x264:--disable-x264} \
dd6c659c 419%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
3c3fdfcc 420%{!?with_xvid:--disable-xvid} \
1087e996
ER
421%{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
422%{?with_vidix:--disable-vidix-internal} \
dd6c659c 423%{!?with_mencoder:--disable-mencoder} \
841cb995
ER
424 --enable-dga1 \
425 --enable-dga2 \
dd6c659c
JB
426 --enable-fbdev \
427 --enable-gl \
428 --enable-mga \
e7261209
KK
429 --enable-radio \
430 --enable-radio-capture \
11421384 431 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
dd6c659c
JB
432 --enable-tdfxfb \
433 --enable-vm \
434 --enable-x11 \
435 --enable-xmga \
436 --enable-xv \
437 --enable-xvmc \
3c3fdfcc 438 --enable-dynamic-plugins \
dd6c659c
JB
439 --enable-largefiles \
440 --language=all \
841cb995 441 --codecsdir=%{_libdir}/codecs \
3c3fdfcc 442 --with-xvmclib=XvMCW \
11421384 443 "$@"
eb52750a 444
11421384
ER
445 %{__make}
446}
2adea73e 447
11421384
ER
448%if %{with gui}
449# build GUI version
841cb995 450build --enable-gui --disable-mencoder
11421384 451mv -f mplayer gmplayer
aeb67db6 452%{__make} distclean
11421384
ER
453%endif
454
455# now build regular version
456build --disable-gui
457
aab7d90d 458%if %{with doc}
841cb995 459%{__make} -C DOCS/xml
11421384 460%endif
ceb01d0e 461
2adea73e
AM
462%install
463rm -rf $RPM_BUILD_ROOT
e0e4b963 464install -d \
d23c171d 465 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 466 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
1087e996 467 $RPM_BUILD_ROOT%{_datadir}/mplayer/Skin \
59ba0205 468 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 469
e0e4b963 470# default config files
11421384 471sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
c455a752 472install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 473
474# executables
2af58a38 475%if %{with mencoder}
1a8df7bd 476install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
477ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 478%endif
1a8df7bd 479install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
480ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 481%if %{with gui}
1a8df7bd 482install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
483ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 484%endif
e0e4b963 485
486# fonts
9d62f689
TP
487rm -f font-*/runme
488cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 489ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 490
11421384
ER
491%if %{with gui}
492ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
f0d8c47e 493install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 494%endif
24481cd2 495install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 496install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 497
498# man pages
59ba0205 499install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 500install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
501install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
502install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
503install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
504install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 505install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 506install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 507#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
e66a8169 508install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 509
2adea73e
AM
510%clean
511rm -rf $RPM_BUILD_ROOT
512
a69eaaef 513%post -n gmplayer
cd748ae6 514umask 022
cd748ae6 515[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
516
a69eaaef 517%postun -n gmplayer
cd748ae6 518umask 022
75b3147a 519[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 520
2adea73e
AM
521%files
522%defattr(644,root,root,755)
1a8df7bd 523%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
524
525%if %{with gui}
526%files -n gmplayer
527%defattr(644,root,root,755)
1a8df7bd 528%attr(755,root,root) %{_bindir}/gmplayer*
11421384
ER
529%{_desktopdir}/gmplayer.desktop
530%dir %{_datadir}/%{name}/Skin
531%ghost %{_datadir}/%{name}/Skin/default
532%endif
533
0fb5a7ee 534%if %{with mencoder}
11421384
ER
535%files -n mencoder
536%defattr(644,root,root,755)
aeb67db6 537%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
538%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
539%doc DOCS/tech/colorspaces.txt
1a8df7bd 540%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 541%endif
11421384
ER
542
543%files common
544%defattr(644,root,root,755)
11421384
ER
545%doc DOCS/tech
546%if %{with win32}
35ac5af9 547%doc etc/codecs.win32.conf
11421384 548%endif
841cb995
ER
549%if %{with doc}
550# HTML and XML-generated docs
551%doc DOCS/HTML/en
0ffd4cd0 552%lang(cs) %doc DOCS/HTML/cs
aeb67db6 553%lang(de) %doc DOCS/HTML/de
aee40e50 554%lang(es) %doc DOCS/HTML/es
555%lang(fr) %doc DOCS/HTML/fr
8cda16b8 556%lang(hu) %doc DOCS/HTML/hu
aee40e50 557%lang(pl) %doc DOCS/HTML/pl
558%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
559#%lang(zh_CN) %doc DOCS/zh
560%endif
561%doc AUTHORS README
11421384 562
906bf13b
JB
563%dir %{_sysconfdir}/%{name}
564%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 565%{_mandir}/man1/*
59ba0205 566%lang(cs) %{_mandir}/cs/man1/*
20e1052d 567%lang(de) %{_mandir}/de/man1/*
aee40e50 568%lang(es) %{_mandir}/es/man1/*
2a9a2b75 569%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 570%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 571%lang(it) %{_mandir}/it/man1/*
2a6ed516 572%lang(pl) %{_mandir}/pl/man1/*
841cb995 573#%lang(sv) %{_mandir}/sv/man1/*
90413e82 574%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 575%{_desktopdir}/mplayer.desktop
1087e996 576%{_pixmapsdir}/mplayer.png
11421384
ER
577%dir %{_datadir}/%{name}
578%{_datadir}/%{name}/font*
This page took 0.242043 seconds and 4 git commands to generate.