]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- rel 2
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
8cc223f8 3%bcond_with directfb # with DirectFB video output
8cc223f8
JB
4%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
5%bcond_with ggi # with ggi video output
8cc223f8
JB
6%bcond_with nas # with NAS audio output
7%bcond_with svga # with svgalib video output
01a889a4 8%bcond_without osd # with osd menu support
93ab9715 9%bcond_without altivec # without altivec support
bbab8eb7 10%bcond_without x264 # without x264 support
2af58a38 11%bcond_with xmms # with XMMS inputplugin support
8cc223f8 12%bcond_without aalib # without aalib video output
e5b91f83 13%bcond_without jack # without JACKD support
8cc223f8 14%bcond_without alsa # without ALSA audio output
12768ddc 15%bcond_with arts # with arts audio output
dd153a0d 16%bcond_without caca # without libcaca video output
3c3fdfcc 17%bcond_without cdparanoia # without cdparanoia support
32272421 18%bcond_without dvdnav # without dvdnav support
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
18c746ca 20%bcond_with esd # enable EsounD sound support
3c3fdfcc
JB
21%bcond_without faad # disable FAAD2 (AAC) support
22%bcond_without gif # disable GIF support
8d7378f8 23%bcond_without gui # without GTK+ GUI
8cc223f8 24%bcond_without joystick # disable joystick support
3c3fdfcc 25%bcond_without libdts # disable libdts support
a4298e0c 26%bcond_without libdv # disable libdv en/decoding support
8cc223f8 27%bcond_without lirc # without lirc support
5244e474 28%bcond_without live # without LIVE555 libraries
841cb995 29%bcond_without lzo # with LZO support (requires lzo 2.x)
8cc223f8 30%bcond_without mad # without mad (audio MPEG) support
7d814b48 31%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
32%bcond_without quicktime # without binary quicktime dll support
33%bcond_without real # without Real* 8/9 codecs support
34%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
35 # in compile time (advertised by mplayer authors as working faster); in this case
36 # mplayer may not work on machine other then where it was compiled
37%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 38%bcond_without smb # disable Samba (SMB) input support
de0c2d91 39%bcond_without theora # without theora support
8cc223f8 40%bcond_without win32 # without win32 codecs support
53f97285 41%bcond_without vdpau # disable vdpau
1087e996 42%bcond_without vidix # disable vidix
3b930ad6 43%bcond_without vorbis # without Ogg-Vorbis audio support
d1f72115 44%bcond_with system_vorbis # use system libvorbis instead of internal tremor
3c3fdfcc 45%bcond_without xvid # disable XviD codec
2af58a38 46%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 47%bcond_without sdl # disable SDL
aab7d90d 48%bcond_without doc # don't build docs (slow)
59a38ff4 49%bcond_with shared # experimental libmplayer.so support
b69a6f83 50%bcond_without amr # enable Adaptive Multi Rate (AMR) speech codec support
0256d486 51%bcond_without gnomess # disable controling gnome screensaver
759ef2d3
ER
52%bcond_without ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
53%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
d1f72115 54%bcond_with on2 # with patches from On2 Flix Engine for Linux
5dcdda0f
ER
55%if "%{pld_release}" == "ac"
56%bcond_with hidden_visibility # no gcc hidden visibility
57%else
58%bcond_without hidden_visibility # no gcc hidden visibility
59%endif
2dfabf36 60
9accd5e5 61%if %{with alsa}
62%undefine with_select
63%endif
64
d1f72115 65%if %{without vorbis}
66%undefine with_system_vorbis
67%endif
68
94cb018b
JB
69%ifnarch %{ix86}
70%undefine with_win32
7a82c266 71%undefine with_quicktime
1087e996 72%undefine with_vidix
94cb018b
JB
73%endif
74
38c74592 75%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
76%undefine with_runtime
77%endif
1a8df7bd 78
ca278bdf
ER
79%ifnarch %{ix86} %{x8664}
80%undefine with_vdpau
81%endif
82
3d17ae18
ER
83%ifnarch ppc
84%undefine with_altivec
85%endif
86
1a8df7bd 87%if %{_lib} == "lib64"
422903c7 88%define _suf 64
1a8df7bd 89%else
422903c7 90%define _suf 32
1a8df7bd 91%endif
92
5bcd4a3c
BZ
93%define subver rc5
94%define svnver 32923
7ada3e74 95%define rel 2
906bf13b 96Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
97Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
98Summary(es.UTF-8): Otro reproductor de películas
99Summary(ko.UTF-8): 리눅스용 미디어플레이어
100Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
101Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 102Name: mplayer
9cb1ef87 103Version: 1.0
71d2d72a 104Release: 5.%{subver}_svn%{svnver}.%{rel}
1f85fd72
ER
105# DO NOT increase epoch unless it's really neccessary!
106# especially such changes like pre7->pre7try2, increase Release instead!
107# PS: $ rpmvercmp pre7try2 pre7
108# pre7try2 > pre7
59476b48 109Epoch: 3
bc426a7f 110License: GPL
906bf13b 111Group: Applications/Multimedia
ffa24b78
PS
112# svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
113# tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
5bcd4a3c
BZ
114# for ffmpeg git://git.videolan.org/ffmpeg.git
115Source0: http://carme.pld-linux.org/~cactus/snaps/mplayer/%{name}-r%{svnver}.tar.xz
116# Source0-md5: 8de311873d5a9342387197b0a16c7756
031c3c7c 117Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 118# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 119Source5: g%{name}.desktop
623ea2d1 120Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 121# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 122Source7: %{name}.png
24481cd2 123Source8: %{name}.desktop
dfd680ce 124# http://www.on2.com/gpl/mplayer/
53f97285 125Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
126# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 127
128# build (configure / Makefile) related:
129Patch10: %{name}-ldflags.patch
130Patch11: %{name}-altivec.patch
131Patch12: %{name}-check-byteswap.patch
c2bf8f19 132Patch13: %{name}-visibility-hidden-fix.patch
133Patch14: %{name}-ffmpeg.patch
134Patch15: %{name}-shared_live.patch
135Patch16: %{name}-shared.patch
79907b07 136
137# codecs, outputs, demuxers:
138Patch20: %{name}-auto-expand.patch
139Patch21: %{name}-release_directfb.patch
140
141# goodies:
142Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 143Patch31: %{name}-350.patch
d1f72115 144# update, hard to fix right now because of gnome bug 579430:
145# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 146#Patch32: %{name}-gnome-screensaver.patch
79907b07 147
148Patch100: %{name}-on2flix.patch
b252aa8a 149Patch101: %{name}-link.patch
79907b07 150
c5b97685 151URL: http://www.mplayerhq.hu/
33c4efab 152%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 153BuildRequires: OpenAL-devel
b458005d 154BuildRequires: OpenGL-devel
11421384 155%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
156%{?with_aalib:BuildRequires: aalib-devel}
157%{?with_alsa:BuildRequires: alsa-lib-devel}
158%{?with_arts:BuildRequires: artsc-devel}
841cb995 159%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
3c3fdfcc 160%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
c521a17c 161BuildRequires: dirac-devel
5dcdda0f
ER
162%{?with_doc:BuildRequires: docbook-dtd412-xml}
163%{?with_doc:BuildRequires: docbook-style-xsl}
dd6c659c 164%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
165%{?with_enca:BuildRequires: enca-devel}
166%{?with_esd:BuildRequires: esound-devel}
30e3739f 167BuildRequires: faac-devel
3c3fdfcc 168%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 169%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
c521a17c 170BuildRequires: freetype-devel >= 2.0.9
30e3739f 171BuildRequires: fribidi-devel
d6542bb9 172BuildRequires: tar >= 1:1.22
1087e996 173%{?with_vidix:BuildRequires: vidix-devel}
3d17ae18 174%{?with_altivec:BuildRequires: gcc >= 5:4.1}
5dcdda0f 175%{?with_gnomess:BuildRequires: dbus-glib-devel}
3c3fdfcc 176%{?with_gif:BuildRequires: giflib-devel}
d1f72115 177%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 178%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
a8a0c1d1 179BuildRequires: lame-libs-devel
dd6c659c 180%{?with_caca:BuildRequires: libcaca-devel}
49aed190 181%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 182%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
759ef2d3 183%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
dd6c659c 184%{?with_ggi:BuildRequires: libggi-devel}
af480c75 185BuildRequires: libjpeg-devel
dd6c659c 186%{?with_mad:BuildRequires: libmad-devel}
c521a17c 187BuildRequires: libmng-devel
30e3739f 188BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 189BuildRequires: libpng-devel
a4298e0c 190%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 191%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 192%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 193%{?with_system_vorbis:BuildRequires: libvorbis-devel}
bbab8eb7 194%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 195BuildRequires: libxslt-progs
dd6c659c 196%{?with_lirc:BuildRequires: lirc-devel}
5244e474 197%{?with_live:BuildRequires: live-devel}
841cb995 198%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 199%{?with_nas:BuildRequires: nas-devel}
b458005d 200BuildRequires: ncurses-devel
b69a6f83 201%{?with_amr:BuildRequires: opencore-amr-devel}
e9d22b19 202BuildRequires: pkgconfig
86bc294f 203%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 204BuildRequires: rpm >= 4.4.9-56
9accd5e5 205BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 206BuildRequires: schroedinger-devel
aeb67db6 207BuildRequires: speex-devel >= 1.1
dd6c659c 208%{?with_svga:BuildRequires: svgalib-devel}
c521a17c 209BuildRequires: twolame-devel
210%{?with_xmms:BuildRequires: xmms-devel}
5dcdda0f
ER
211%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
212%ifarch %{ix86} %{x8664}
213BuildRequires: yasm
214%endif
215BuildRequires: zlib-devel
216%if "%{pld_release}" == "ac"
217BuildRequires: XFree86-devel >= 4.0.2
218%else
627a7a97 219BuildRequires: xorg-lib-libX11-devel
c521a17c 220BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
221BuildRequires: xorg-lib-libXext-devel
222BuildRequires: xorg-lib-libXinerama-devel
223BuildRequires: xorg-lib-libXv-devel
224BuildRequires: xorg-lib-libXvMC-devel
225BuildRequires: xorg-lib-libXxf86dga-devel
226BuildRequires: xorg-lib-libXxf86vm-devel
c521a17c 227%endif
4d75c49f 228Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 229Requires: OpenGL
0f2a502d 230BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 231
a8e3a9a7 232%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 233%define specflags_ia32 -fomit-frame-pointer
198487b4 234%if %{with altivec}
adfd0023 235%define specflags_ppc -maltivec
20a66bdb 236%endif
2adea73e 237
e245ad6d
ER
238%if "%{pld_release}" == "ac"
239%ifarch ppc
240%define __cc gcc4
241%endif
242%endif
243
2adea73e 244%description
c902f7c6 245Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
246AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 247MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
248MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 249devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
250optionally with SHM extension, X11 using overlays with the Xvideo
251extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
252Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 253
8b146837 254If you want to use win32 codecs install w32codec package.
4228a246 255
e011d408 256%description -l de.UTF-8
deba608c 257MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
258Kennzeichnend ist die herausragende Format- und
e011d408 259Plattform-Kompatibilität.
deba608c 260
e011d408
JR
261Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
262plattformexklusive, wodurch etwa Windows Media auch außerhalb von
263Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
264Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 265ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
266Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
267installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 268
e011d408 269%description -l es.UTF-8
c902f7c6 270Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
271MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
272(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
273de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
274Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
275G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
276overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 277G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
278v1.1.7 etc.
33c4efab 279
8b146837 280Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 281
e011d408
JR
282%description -l ko.UTF-8
283MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
284파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
285MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
286Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
287(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
288수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
289크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
290있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
291부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 292
e011d408
JR
293%description -l pl.UTF-8
294Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 295RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
296(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
297Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 298Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 299rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 300G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 301
e011d408 302Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 303
e011d408
JR
304%description -l pt_BR.UTF-8
305MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
306áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 307escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
308
11421384
ER
309%package -n gmplayer
310Summary: MPlayer with GTK+ GUI interface
eeb91a66 311Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 312Group: X11/Applications/Multimedia
11421384 313Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 314Requires: %{name}-skin
11421384
ER
315
316%description -n gmplayer
317MPlayer with GUI GTK+ interface.
318
e011d408 319%description -n gmplayer -l pl.UTF-8
906bf13b
JB
320MPlayer z graficznym interfejsem GTK+.
321
11421384 322%package common
906bf13b 323Summary: Configuration files and documentation for MPlayer
eeb91a66 324Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 325Group: Applications/Multimedia
c521a17c 326Suggests: unrar
1087e996 327Obsoletes: mplayer-vidix
11421384
ER
328
329%description common
906bf13b
JB
330Configuration files, man page and HTML documentation for MPlayer.
331
e011d408 332%description common -l pl.UTF-8
906bf13b 333Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
334
335%package -n mencoder
906bf13b 336Summary: MEncoder - a movie encoder for Linux
eeb91a66 337Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
338Group: Applications/Multimedia
339Requires: %{name}-common = %{epoch}:%{version}-%{release}
340
341%description -n mencoder
906bf13b
JB
342MEncoder is a movie encoder for Linux and is a part of the MPlayer
343package.
344
e011d408
JR
345%description -n mencoder -l pl.UTF-8
346MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 347
2adea73e 348%prep
5dcdda0f 349%setup -q -n %{name}-r%{svnver} -a3 -a6 -a9
833dbe20 350cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 351
352# build (configure / Makefile) related:
353%patch10 -p1
354%patch11 -p1
355%patch12 -p1
c2bf8f19 356%patch13 -p1
357%{?with_system_ffmpeg:%patch14 -p1}
358%{?with_live:%patch15 -p1}
359%{?with_shared:%patch16 -p1}
79907b07 360
361# codecs, outputs, demuxers:
362%patch20 -p1
363%patch21 -p1
364
365# goodies:
366%patch30 -p0
2833f81f 367%patch31 -p1
368#%{with_gnomess:%patch32 -p1}
59ba0205 369
dfd680ce 370# on2flix
759ef2d3 371mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 372%if %{with on2}
79907b07 373#%%patch100 -p1
d1f72115 374cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
375# remove broken patches:
376# - first set does not apply
377# - second set beakes build
378for PATCH in asf-correct_movielength avi_check_idxflags \
379 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
380 mencoder_07_demux_update_pts mencoder_10_correct_pts \
381 mpegvideo-revert_r18381 \
382 \
383 reduce_spurious_logging
384do
385 rm mencoder-on2flixenglinux/patch/$PATCH.diff
386done
387for a in mencoder-on2flixenglinux/patch/*.diff; do
388 patch -p0 < $a
389done
390%endif
dfd680ce 391
b252aa8a
PS
392%patch101 -p1
393
79907b07 394# Set version
53f97285 395%if "x%{svnver}" != "x%{nil}"
d1f72115 396 echo "SVN-r%{svnver}%{?with_on2:-on2}" > VERSION
53f97285 397%endif
759ef2d3 398
53f97285 399cat etc/example.conf > etc/mplayer.conf
c521a17c 400cat <<'CONFIGADD' >> etc/mplayer.conf
401
d1f72115 402######################
8b2ed1fb 403# PLD Linux Defaults #
d1f72115 404######################
2833f81f 405[default]
406
407# alternate solution for CP1250-encoded subtitles
408fontconfig = yes
409subcp = cp1250
410
411# ...or if you prefer native bitmap fonts shipped with mplayer
412#fontconfig = no
413#subcp = iso-8859-1
414
415# Standard location
416unrarexec = "%{_bindir}/unrar"
417
c521a17c 418CONFIGADD
d1732085 419
1f8d8779
ER
420%if %{with system_ffmpeg}
421# using external ffmpeg, but mplayer adds these to includepath
53f97285 422rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
1f8d8779
ER
423%endif
424
c521a17c 425# *** HOT FIXES ***
426
427# typo, fixed in recent svn
53f97285 428sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
53f97285 429
c521a17c 430# mjpeg encoder is required for Zoran hardware
431sed '/_libavencoders="MPEG/s/"$/ MJPEG_ENCODER"/' -i configure
432
2adea73e 433%build
5dcdda0f 434CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
53f97285 435CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
436%{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
437
11421384 438build() {
c521a17c 439 set -x
53f97285 440
11421384
ER
441 ./configure \
442 %{?debug:--enable-debug=3} \
dd6c659c
JB
443 --prefix=%{_prefix} \
444 --confdir=%{_sysconfdir}/mplayer \
53f97285 445 --cc="%{__cc}" \
446 --extra-cflags="$CFLAGS" \
79907b07 447 --real-ldflags="%{rpmldflags}" \
448 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
1f8d8779 449%if %{with system_ffmpeg}
841cb995
ER
450 --disable-libavutil_a \
451 --disable-libavcodec_a \
452 --disable-libavformat_a \
453 --disable-libpostproc_a \
454 --enable-libavutil_so \
455 --enable-libavcodec_so \
456 --enable-libavformat_so \
457 --enable-libpostproc_so \
1f8d8779 458%endif
57f87bc2 459%ifnarch %{ix86} %{x8664}
dd6c659c 460 --disable-mmx \
a14f4270 461 --disable-mmxext \
dd6c659c 462 --disable-3dnow \
a14f4270 463 --disable-3dnowext \
dd6c659c
JB
464 --disable-sse \
465 --disable-sse2 \
466 --disable-fastmemcpy \
dfeec30a 467%endif
9accd5e5 468 %{__disable ssse3} \
1837afdf 469%ifarch ppc
9accd5e5 470 %{__disable altivec} \
1837afdf 471%endif
9accd5e5 472 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
473 %{__enable_disable directfb} \
474 %{__disable dxr3} \
475 %{__disable ggi} \
476 %{__disable live} \
477 %{__disable lzo liblzo} \
478 %{__disable nas} \
479 %{__disable svga} \
480 %{__disable aalib aa} \
481 %{__disable jack} \
482 %{__enable_disable alsa} \
483 %{__disable arts} \
484 %{__disable caca} \
485 %{__disable cdparanoia} \
486 %{__disable enca} \
487 %{__disable esd} \
9accd5e5 488 %{__disable faad} \
489 %{__disable gif} \
490 %{__enable joystick} \
491 %{__disable libdv} \
492 %{__disable libdts libdca} \
493 %{__enable_disable lirc} \
494 %{__disable mad} \
495 %{__disable pulseaudio pulse} \
496 %{__disable quicktime qtx} \
497 %{__disable real} \
498 %{__enable_disable runtime runtime-cpudetection} \
499 %{__disable select} \
500 %{__disable smb} \
501 %{__disable win32 win32dll} \
d1f72115 502 %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis} \
503 %{__disable_if system_vorbis tremor-internal} \
9accd5e5 504 %{__enable osd menu} \
505 %{__disable theora} \
506 %{__disable x264} \
d1732085 507 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
9accd5e5 508 %{__disable xvid} \
509 %{__disable vidix} \
510 %{__disable vdpau} \
511 %{__disable mencoder} \
841cb995
ER
512 --enable-dga1 \
513 --enable-dga2 \
9accd5e5 514 %{__enable_disable dvdnav} \
dd6c659c
JB
515 --enable-fbdev \
516 --enable-gl \
517 --enable-mga \
e7261209
KK
518 --enable-radio \
519 --enable-radio-capture \
9accd5e5 520 %{__enable_disable sdl} \
dd6c659c
JB
521 --enable-tdfxfb \
522 --enable-vm \
523 --enable-x11 \
524 --enable-xmga \
525 --enable-xv \
526 --enable-xvmc \
0c2d081d 527 --with-xvmclib=XvMCW \
c521a17c 528 --enable-zr \
529 --enable-unrarexec \
3c3fdfcc 530 --enable-dynamic-plugins \
dd6c659c
JB
531 --enable-largefiles \
532 --language=all \
841cb995 533 --codecsdir=%{_libdir}/codecs \
11421384 534 "$@"
eb52750a 535
11421384
ER
536 %{__make}
537}
2adea73e 538
11421384
ER
539%if %{with gui}
540# build GUI version
841cb995 541build --enable-gui --disable-mencoder
11421384 542mv -f mplayer gmplayer
aeb67db6 543%{__make} distclean
11421384
ER
544%endif
545
546# now build regular version
547build --disable-gui
548
aab7d90d 549%if %{with doc}
6eeeb8b4 550%{__make} -j1 -C DOCS/xml
11421384 551%endif
ceb01d0e 552
2adea73e
AM
553%install
554rm -rf $RPM_BUILD_ROOT
e0e4b963 555install -d \
d23c171d 556 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 557 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
9accd5e5 558 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 559 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 560
e0e4b963 561# default config files
c455a752 562install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 563
564# executables
2af58a38 565%if %{with mencoder}
1a8df7bd 566install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
567ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 568%endif
1a8df7bd 569install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
570ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 571%if %{with gui}
1a8df7bd 572install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
573ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 574%endif
e0e4b963 575
c2bf8f19 576%if %{with shared}
577install -d $RPM_BUILD_ROOT%{_libdir}
578install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
579%endif
580
e0e4b963 581# fonts
9d62f689 582cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 583ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 584
11421384 585%if %{with gui}
f0d8c47e 586install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 587%endif
9accd5e5 588touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 589install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 590install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 591
592# man pages
59ba0205 593install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 594install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
595install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
596install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
597install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
598install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 599install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 600install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 601#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
53f97285 602#install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 603
2adea73e
AM
604%clean
605rm -rf $RPM_BUILD_ROOT
606
a69eaaef 607%post -n gmplayer
cd748ae6 608umask 022
cd748ae6 609[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
610
a69eaaef 611%postun -n gmplayer
cd748ae6 612umask 022
75b3147a 613[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 614
2adea73e
AM
615%files
616%defattr(644,root,root,755)
1a8df7bd 617%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
618
619%if %{with gui}
620%files -n gmplayer
621%defattr(644,root,root,755)
1a8df7bd 622%attr(755,root,root) %{_bindir}/gmplayer*
11421384 623%{_desktopdir}/gmplayer.desktop
11421384
ER
624%endif
625
0fb5a7ee 626%if %{with mencoder}
11421384
ER
627%files -n mencoder
628%defattr(644,root,root,755)
aeb67db6 629%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
630%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
631%doc DOCS/tech/colorspaces.txt
1a8df7bd 632%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 633%endif
11421384
ER
634
635%files common
636%defattr(644,root,root,755)
11421384 637%doc DOCS/tech
c2bf8f19 638%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
11421384 639%if %{with win32}
35ac5af9 640%doc etc/codecs.win32.conf
11421384 641%endif
841cb995
ER
642%if %{with doc}
643# HTML and XML-generated docs
644%doc DOCS/HTML/en
0ffd4cd0 645%lang(cs) %doc DOCS/HTML/cs
aeb67db6 646%lang(de) %doc DOCS/HTML/de
aee40e50 647%lang(es) %doc DOCS/HTML/es
648%lang(fr) %doc DOCS/HTML/fr
8cda16b8 649%lang(hu) %doc DOCS/HTML/hu
aee40e50 650%lang(pl) %doc DOCS/HTML/pl
651%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
652#%lang(zh_CN) %doc DOCS/zh
653%endif
654%doc AUTHORS README
11421384 655
906bf13b
JB
656%dir %{_sysconfdir}/%{name}
657%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 658%{_mandir}/man1/*
59ba0205 659%lang(cs) %{_mandir}/cs/man1/*
20e1052d 660%lang(de) %{_mandir}/de/man1/*
aee40e50 661%lang(es) %{_mandir}/es/man1/*
2a9a2b75 662%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 663%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 664%lang(it) %{_mandir}/it/man1/*
2a6ed516 665%lang(pl) %{_mandir}/pl/man1/*
841cb995 666#%lang(sv) %{_mandir}/sv/man1/*
53f97285 667#%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 668%{_desktopdir}/mplayer.desktop
1087e996 669%{_pixmapsdir}/mplayer.png
11421384
ER
670%dir %{_datadir}/%{name}
671%{_datadir}/%{name}/font*
59ce39fb
ER
672%dir %{_datadir}/%{name}/skins
673%ghost %{_datadir}/%{name}/skins/default
This page took 0.214582 seconds and 4 git commands to generate.