]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- release 16
[packages/mplayer.git] / mplayer.spec
CommitLineData
5e37db9a 1# TODO:
8a72e936 2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
b8145877 3# - update for lzo 2
841cb995 4# - try to use external lrmi and few other libs:
4d75c49f 5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
bef18474
ER
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
5e37db9a 9#
94cb018b 10# Conditional build:
8cc223f8 11%bcond_with directfb # with DirectFB video output
8cc223f8
JB
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
8cc223f8
JB
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
01a889a4 16%bcond_without osd # with osd menu support
93ab9715 17%bcond_without altivec # without altivec support
d6014b54 18%bcond_without x264 # without x264 support
2af58a38 19%bcond_with xmms # with XMMS inputplugin support
8cc223f8 20%bcond_without aalib # without aalib video output
e5b91f83 21%bcond_without jack # without JACKD support
8cc223f8
JB
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
dd153a0d 24%bcond_without caca # without libcaca video output
3c3fdfcc 25%bcond_without cdparanoia # without cdparanoia support
32272421 26%bcond_without dvdnav # without dvdnav support
3c3fdfcc
JB
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
8d7378f8 31%bcond_without gui # without GTK+ GUI
8cc223f8 32%bcond_without joystick # disable joystick support
3c3fdfcc 33%bcond_without libdts # disable libdts support
a4298e0c 34%bcond_without libdv # disable libdv en/decoding support
8cc223f8 35%bcond_without lirc # without lirc support
841cb995
ER
36%bcond_with live # without LIVE555 libraries
37%bcond_without lzo # with LZO support (requires lzo 2.x)
8cc223f8 38%bcond_without mad # without mad (audio MPEG) support
7d814b48 39%bcond_without pulseaudio # without pulseaudio output
8cc223f8
JB
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
11421384
ER
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
a4298e0c 46%bcond_without smb # disable Samba (SMB) input support
de0c2d91 47%bcond_without theora # without theora support
8cc223f8 48%bcond_without win32 # without win32 codecs support
1087e996 49%bcond_without vidix # disable vidix
3b930ad6 50%bcond_without vorbis # without Ogg-Vorbis audio support
3c3fdfcc 51%bcond_without xvid # disable XviD codec
2af58a38 52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
906bf13b 53%bcond_without sdl # disable SDL
aab7d90d 54%bcond_without doc # don't build docs (slow)
59a38ff4 55%bcond_with shared # experimental libmplayer.so support
439df4dd 56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
0256d486 57%bcond_without gnomess # disable controling gnome screensaver
759ef2d3
ER
58%bcond_without ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
59%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
2dfabf36 60
94cb018b
JB
61%ifnarch %{ix86}
62%undefine with_win32
7a82c266 63%undefine with_quicktime
1087e996 64%undefine with_vidix
94cb018b
JB
65%endif
66
38c74592 67%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
68%undefine with_runtime
69%endif
1a8df7bd 70
71%if %{_lib} == "lib64"
422903c7 72%define _suf 64
1a8df7bd 73%else
422903c7 74%define _suf 32
1a8df7bd 75%endif
76
879e9f7b 77%define subver rc2
759ef2d3 78%define svnver 27725
73ce8e1c 79%define rel 16
135255b8 80
906bf13b 81Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
82Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
83Summary(es.UTF-8): Otro reproductor de películas
84Summary(ko.UTF-8): 리눅스용 미디어플레이어
85Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
86Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 87Name: mplayer
9cb1ef87 88Version: 1.0
879e9f7b 89Release: 5.%{subver}.%{rel}
1f85fd72
ER
90# DO NOT increase epoch unless it's really neccessary!
91# especially such changes like pre7->pre7try2, increase Release instead!
92# PS: $ rpmvercmp pre7try2 pre7
93# pre7try2 > pre7
59476b48 94Epoch: 3
bc426a7f 95License: GPL
906bf13b 96Group: Applications/Multimedia
759ef2d3
ER
97Source0: http://distfiles.gentoo.org/distfiles/mplayer-%{version}_%{subver}_p%{svnver}.tar.bz2
98# Source0-md5: d89e86d9183d1a52a7a754d9a3c74724
031c3c7c 99Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 100# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 101Source5: g%{name}.desktop
623ea2d1 102Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 103# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 104Source7: %{name}.png
24481cd2 105Source8: %{name}.desktop
dfd680ce 106# http://www.on2.com/gpl/mplayer/
759ef2d3
ER
107Source9: http://support.on2.com/gpl/mplayer/2008-09-30-mencoder-on2flixenglinux.tar.bz2
108# Source9-md5: a8a078c38eda90dff980f9bf1768960f
aee40e50 109Patch1: %{name}-cp1250-fontdesc.patch
e63fb437
ER
110#Patch2: %{name}-codec.patch
111#Patch3: %{name}-home_etc.patch
aee40e50 112Patch4: %{name}-350.patch
113Patch5: %{name}-configure.patch
f10ca1d7
PG
114# outdated via ffmpeg?
115Patch6: %{name}-system-amr.patch
8cc223f8 116Patch8: %{name}-altivec.patch
e63fb437
ER
117#Patch10: %{name}-pcmsplit.patch
118#Patch13: %{name}-mythtv.patch
11421384 119Patch14: %{name}-shared.patch
30e3739f 120#http://www.openchrome.org/snapshots/mplayer/
e63fb437 121#Patch15: %{name}-xvmc.patch
c7699e1b 122Patch17: %{name}-auto-expand.patch
f10ca1d7 123# update
e63fb437 124#Patch18: %{name}-gnome-screensaver.patch
dfd680ce 125Patch19: %{name}-on2flix.patch
841cb995 126Patch22: %{name}-ffmpeg.patch
2b6e0df5 127Patch24: %{name}-fontconfig_sub.patch
38c74592 128Patch26: %{name}-check-byteswap.patch
c5b97685 129URL: http://www.mplayerhq.hu/
33c4efab 130%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 131BuildRequires: OpenAL-devel
b458005d 132BuildRequires: OpenGL-devel
11421384 133%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
dd6c659c
JB
134%{?with_aalib:BuildRequires: aalib-devel}
135%{?with_alsa:BuildRequires: alsa-lib-devel}
e4268e0b
JB
136%if %{with amr}
137BuildRequires: amrnb-devel
4d75c49f 138BuildRequires: amrwb-devel >= 5.3.0
e4268e0b 139%endif
dd6c659c 140%{?with_arts:BuildRequires: artsc-devel}
841cb995 141%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
3c3fdfcc 142%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
aab7d90d 143%{?with_doc:BuildRequires: docbook-style-xsl}
d4e18ae5 144%{?with_doc:BuildRequires: docbook-dtd412-xml}
dd6c659c 145%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
146%{?with_enca:BuildRequires: enca-devel}
147%{?with_esd:BuildRequires: esound-devel}
30e3739f 148BuildRequires: faac-devel
3c3fdfcc 149%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 150%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
d23c171d 151BuildRequires: freetype-devel
30e3739f 152BuildRequires: fribidi-devel
1087e996 153%{?with_vidix:BuildRequires: vidix-devel}
8cc223f8
JB
154%ifarch ppc
155%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
156%endif
3c3fdfcc 157%{?with_gif:BuildRequires: giflib-devel}
dd6c659c 158%if %{with gui}
aeb67db6 159BuildRequires: gtk+2-devel
dd6c659c 160%endif
1087e996 161%{?with_gnomess:BuildRequires: dbus-glib-devel}
d336e259 162%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
422903c7 163%{?with_jack:%requires_eq jack-audio-connection-kit-libs}
a8a0c1d1 164BuildRequires: lame-libs-devel
dd6c659c 165%{?with_caca:BuildRequires: libcaca-devel}
49aed190 166%{?with_libdts:BuildRequires: libdts-devel}
a4298e0c 167%{?with_libdv:BuildRequires: libdv-devel}
759ef2d3 168%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
dd6c659c 169%{?with_ggi:BuildRequires: libggi-devel}
af480c75 170BuildRequires: libjpeg-devel
dd6c659c 171%{?with_mad:BuildRequires: libmad-devel}
30e3739f 172BuildRequires: libmpcdec-devel >= 1.2.1
af480c75 173BuildRequires: libpng-devel
a4298e0c 174%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 175%{?with_theora:BuildRequires: libtheora-devel}
1130ecb8 176# tremor is used by default, internal as we don't have system one
281ac7d0 177#%{?with_vorbis:BuildRequires: libvorbis-devel}
3e33b534 178%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20081023_2245.1}
ceb01d0e 179BuildRequires: libxslt-progs
dd6c659c
JB
180%{?with_lirc:BuildRequires: lirc-devel}
181%{?with_live:BuildRequires: live}
841cb995 182%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 183%{?with_nas:BuildRequires: nas-devel}
b458005d 184BuildRequires: ncurses-devel
e9d22b19 185BuildRequires: pkgconfig
86bc294f 186%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
aeb67db6 187BuildRequires: speex-devel >= 1.1
dd6c659c
JB
188%{?with_svga:BuildRequires: svgalib-devel}
189%{?with_xmms:BuildRequires: xmms-libs}
627a7a97
ER
190BuildRequires: xorg-lib-libX11-devel
191BuildRequires: xorg-lib-libXext-devel
192BuildRequires: xorg-lib-libXinerama-devel
193BuildRequires: xorg-lib-libXv-devel
194BuildRequires: xorg-lib-libXvMC-devel
195BuildRequires: xorg-lib-libXxf86dga-devel
196BuildRequires: xorg-lib-libXxf86vm-devel
3c3fdfcc 197%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
c2eb8d00 198BuildRequires: zlib-devel
4d75c49f 199Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 200Requires: OpenGL
0f2a502d 201BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 202
a8e3a9a7 203%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 204%define specflags_ia32 -fomit-frame-pointer
198487b4 205%if %{with altivec}
adfd0023 206%define specflags_ppc -maltivec
20a66bdb 207%endif
2adea73e
AM
208
209%description
c902f7c6 210Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
211AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 212MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
213MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 214devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
215optionally with SHM extension, X11 using overlays with the Xvideo
216extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
217Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 218
8b146837 219If you want to use win32 codecs install w32codec package.
4228a246 220
e011d408 221%description -l de.UTF-8
deba608c 222MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
223Kennzeichnend ist die herausragende Format- und
e011d408 224Plattform-Kompatibilität.
deba608c 225
e011d408
JR
226Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
227plattformexklusive, wodurch etwa Windows Media auch außerhalb von
228Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
229Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 230ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
231Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
232installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 233
e011d408 234%description -l es.UTF-8
c902f7c6 235Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
236MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
237(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
238de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
239Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
240G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
241overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 242G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
243v1.1.7 etc.
33c4efab 244
8b146837 245Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 246
e011d408
JR
247%description -l ko.UTF-8
248MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
249파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
250MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
251Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
252(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
253수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
254크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
255있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
256부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 257
e011d408
JR
258%description -l pl.UTF-8
259Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 260RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
261(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
262Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 263Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 264rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 265G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 266
e011d408 267Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 268
e011d408
JR
269%description -l pt_BR.UTF-8
270MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
271áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 272escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
273
11421384
ER
274%package -n gmplayer
275Summary: MPlayer with GTK+ GUI interface
eeb91a66 276Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 277Group: X11/Applications/Multimedia
11421384 278Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 279Requires: %{name}-skin
11421384
ER
280
281%description -n gmplayer
282MPlayer with GUI GTK+ interface.
283
e011d408 284%description -n gmplayer -l pl.UTF-8
906bf13b
JB
285MPlayer z graficznym interfejsem GTK+.
286
11421384 287%package common
906bf13b 288Summary: Configuration files and documentation for MPlayer
eeb91a66 289Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 290Group: Applications/Multimedia
1087e996 291Obsoletes: mplayer-vidix
11421384
ER
292
293%description common
906bf13b
JB
294Configuration files, man page and HTML documentation for MPlayer.
295
e011d408 296%description common -l pl.UTF-8
906bf13b 297Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384
ER
298
299%package -n mencoder
906bf13b 300Summary: MEncoder - a movie encoder for Linux
eeb91a66 301Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
302Group: Applications/Multimedia
303Requires: %{name}-common = %{epoch}:%{version}-%{release}
304
305%description -n mencoder
906bf13b
JB
306MEncoder is a movie encoder for Linux and is a part of the MPlayer
307package.
308
e011d408
JR
309%description -n mencoder -l pl.UTF-8
310MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 311
2adea73e 312%prep
759ef2d3 313%setup -q -n mplayer-%{version}_%{subver}_p%{svnver} -a3 -a6 -a9
833dbe20 314cp -f etc/codecs.conf etc/codecs.win32.conf
aee40e50 315%patch1 -p0
d1732085
ER
316#%%patch2 -p1 -- still needed?
317##%%patch3 -p1 -- old home_etc behavior
aee40e50 318%patch4 -p1
dd6c659c 319%patch5 -p1
d1732085 320#%%patch6 -p1 # - try ffmpeg
2dfabf36 321%patch8 -p1
2b8c25a3 322#%%patch10 -p1
d1732085 323#%%patch13 -p1 # TODO
11421384
ER
324%if %{with shared}
325%patch14 -p1
326%endif
d1732085 327#%%patch15 -p0 # TODO
c7699e1b 328%patch17 -p1
0256d486 329%if %{with gnomess}
d1732085 330#%%patch18 -p1
0992d783 331%endif
59ba0205 332
dfd680ce 333# on2flix
759ef2d3
ER
334mv mencoder-on2flixenglinux{-*-*-*,}
335cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
336#rm -f mencoder-on2flixenglinux/patch/version.diff
dfd680ce 337%patch19 -p1
759ef2d3 338for a in mencoder-on2flixenglinux/patch/*.diff; do
dfd680ce
ER
339 patch -p0 < $a
340done
341
1f8d8779 342%{?with_system_ffmpeg:%patch22 -p1}
2b6e0df5 343%patch24 -p0
38c74592 344%patch26 -p1
7c31e935 345
52641151
PS
346# recent dvdnav-config doesn't support --minilibs.
347sed -i 's:--minilibs:--libs:g' configure
348
759ef2d3
ER
349# Set version #
350%{__sed} -i s/UNKNOWN/%{svnver}/ version.sh
351
d1732085
ER
352sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
353rm -f font-*/runme
354
1f8d8779
ER
355%if %{with system_ffmpeg}
356# using external ffmpeg, but mplayer adds these to includepath
357rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
358%endif
359
2adea73e 360%build
68dd28e8 361%if %{with shared}
11421384 362CFLAGS="%{rpmcflags} -fPIC"
68dd28e8
ER
363%else
364CFLAGS="%{rpmcflags}"
68dd28e8 365%endif
4ed9dec4 366CC="%{__cc}"
ce8a4f6d
JB
367LDFLAGS="%{rpmldflags}"
368export CC CFLAGS LDFLAGS
11421384
ER
369
370build() {
371set -x
372 ./configure \
373 %{?debug:--enable-debug=3} \
dd6c659c
JB
374 --prefix=%{_prefix} \
375 --confdir=%{_sysconfdir}/mplayer \
dd6c659c 376 --with-extraincdir=%{_includedir}/xvid \
d1732085 377 --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
1f8d8779 378%if %{with system_ffmpeg}
841cb995
ER
379 --disable-libavutil_a \
380 --disable-libavcodec_a \
381 --disable-libavformat_a \
382 --disable-libpostproc_a \
383 --enable-libavutil_so \
384 --enable-libavcodec_so \
385 --enable-libavformat_so \
386 --enable-libpostproc_so \
1f8d8779 387%endif
57f87bc2 388%ifnarch %{ix86} %{x8664}
dd6c659c 389 --disable-mmx \
a14f4270 390 --disable-mmxext \
dd6c659c 391 --disable-3dnow \
a14f4270 392 --disable-3dnowext \
dd6c659c
JB
393 --disable-sse \
394 --disable-sse2 \
395 --disable-fastmemcpy \
dfeec30a 396%endif
841cb995 397 %{!?with_ssse3:--disable-ssse3} \
1837afdf 398%ifarch ppc
d1732085 399 %{!?with_altivec:--disable-altivec} \
1837afdf 400%endif
d1732085
ER
401 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
402 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
403 %{?with_directfb:--enable-directfb} \
404 %{!?with_directfb:--disable-directfb} \
405 %{!?with_dxr3:--disable-dxr3} \
406 %{!?with_ggi:--disable-ggi} \
407 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
408 %{!?with_live:--disable-live} \
409 %{!?with_lzo:--disable-liblzo} \
410 %{!?with_nas:--disable-nas} \
411 %{!?with_svga:--disable-svga} \
412 %{!?with_aalib:--disable-aa} \
413 %{!?with_jack:--disable-jack} \
414 %{!?with_alsa:--disable-alsa} \
415 %{?with_alsa:--enable-alsa --disable-select} \
416 %{!?with_arts:--disable-arts} \
417 %{!?with_caca:--disable-caca} \
418 %{!?with_cdparanoia:--disable-cdparanoia} \
d1732085
ER
419 %{!?with_enca:--disable-enca} \
420 %{!?with_esd:--disable-esd} \
421 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
422 %{?with_faad:--disable-faad-internal} \
423 %{!?with_gif:--disable-gif} \
424 %{?with_joystick:--enable-joystick} \
425 %{!?with_libdv:--disable-libdv} \
426 %{!?with_libdts:--disable-libdts} \
427 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
428 %{!?with_mad:--disable-mad} \
7d814b48 429 %{!?with_pulseaudio:--disable-polyp} \
d1732085
ER
430 %{!?with_quicktime:--disable-qtx} \
431 %{!?with_real:--disable-real} \
432 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
433 %{!?with_select:--disable-select} \
434 %{!?with_smb:--disable-smb} \
435 %{!?with_win32:--disable-win32dll} \
436 %{!?with_vorbis:--disable-vorbis} \
437 %{?with_osd:--enable-menu} \
438 %{!?with_theora:--disable-theora} \
439 %{!?with_x264:--disable-x264} \
440 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
441 %{!?with_xvid:--disable-xvid} \
759ef2d3 442 %{!?with_vidix:--disable-vidix} \
d1732085 443 %{!?with_mencoder:--disable-mencoder} \
841cb995
ER
444 --enable-dga1 \
445 --enable-dga2 \
759ef2d3 446 --%{!?with_dvdnav:dis}%{?with_dvdnav:en}able-dvdnav \
dd6c659c
JB
447 --enable-fbdev \
448 --enable-gl \
449 --enable-mga \
e7261209
KK
450 --enable-radio \
451 --enable-radio-capture \
11421384 452 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
dd6c659c
JB
453 --enable-tdfxfb \
454 --enable-vm \
455 --enable-x11 \
456 --enable-xmga \
457 --enable-xv \
458 --enable-xvmc \
3c3fdfcc 459 --enable-dynamic-plugins \
dd6c659c
JB
460 --enable-largefiles \
461 --language=all \
841cb995 462 --codecsdir=%{_libdir}/codecs \
3c3fdfcc 463 --with-xvmclib=XvMCW \
11421384 464 "$@"
eb52750a 465
11421384
ER
466 %{__make}
467}
2adea73e 468
11421384
ER
469%if %{with gui}
470# build GUI version
841cb995 471build --enable-gui --disable-mencoder
11421384 472mv -f mplayer gmplayer
aeb67db6 473%{__make} distclean
11421384
ER
474%endif
475
476# now build regular version
477build --disable-gui
478
aab7d90d 479%if %{with doc}
6eeeb8b4 480%{__make} -j1 -C DOCS/xml
11421384 481%endif
ceb01d0e 482
2adea73e
AM
483%install
484rm -rf $RPM_BUILD_ROOT
e0e4b963 485install -d \
d23c171d 486 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 487 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
dd20ae16 488 $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
59ba0205 489 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 490
e0e4b963 491# default config files
c455a752 492install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 493
494# executables
2af58a38 495%if %{with mencoder}
1a8df7bd 496install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
497ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 498%endif
1a8df7bd 499install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
500ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 501%if %{with gui}
1a8df7bd 502install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
503ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 504%endif
e0e4b963 505
506# fonts
9d62f689 507cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 508ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 509
11421384 510%if %{with gui}
d1732085 511touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
f0d8c47e 512install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 513%endif
24481cd2 514install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 515install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 516
517# man pages
59ba0205 518install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 519install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
520install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
521install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
522install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
523install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 524install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 525install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 526#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
e66a8169 527install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 528
2adea73e
AM
529%clean
530rm -rf $RPM_BUILD_ROOT
531
a69eaaef 532%post -n gmplayer
cd748ae6 533umask 022
cd748ae6 534[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
535
a69eaaef 536%postun -n gmplayer
cd748ae6 537umask 022
75b3147a 538[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 539
2adea73e
AM
540%files
541%defattr(644,root,root,755)
1a8df7bd 542%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
543
544%if %{with gui}
545%files -n gmplayer
546%defattr(644,root,root,755)
1a8df7bd 547%attr(755,root,root) %{_bindir}/gmplayer*
11421384 548%{_desktopdir}/gmplayer.desktop
dd20ae16 549%dir %{_datadir}/%{name}/skins
d1732085 550%ghost %{_datadir}/%{name}/skins/default
11421384
ER
551%endif
552
0fb5a7ee 553%if %{with mencoder}
11421384
ER
554%files -n mencoder
555%defattr(644,root,root,755)
aeb67db6 556%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
557%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
558%doc DOCS/tech/colorspaces.txt
1a8df7bd 559%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 560%endif
11421384
ER
561
562%files common
563%defattr(644,root,root,755)
11421384
ER
564%doc DOCS/tech
565%if %{with win32}
35ac5af9 566%doc etc/codecs.win32.conf
11421384 567%endif
841cb995
ER
568%if %{with doc}
569# HTML and XML-generated docs
570%doc DOCS/HTML/en
0ffd4cd0 571%lang(cs) %doc DOCS/HTML/cs
aeb67db6 572%lang(de) %doc DOCS/HTML/de
aee40e50 573%lang(es) %doc DOCS/HTML/es
574%lang(fr) %doc DOCS/HTML/fr
8cda16b8 575%lang(hu) %doc DOCS/HTML/hu
aee40e50 576%lang(pl) %doc DOCS/HTML/pl
577%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
578#%lang(zh_CN) %doc DOCS/zh
579%endif
580%doc AUTHORS README
11421384 581
906bf13b
JB
582%dir %{_sysconfdir}/%{name}
583%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 584%{_mandir}/man1/*
59ba0205 585%lang(cs) %{_mandir}/cs/man1/*
20e1052d 586%lang(de) %{_mandir}/de/man1/*
aee40e50 587%lang(es) %{_mandir}/es/man1/*
2a9a2b75 588%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 589%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 590%lang(it) %{_mandir}/it/man1/*
2a6ed516 591%lang(pl) %{_mandir}/pl/man1/*
841cb995 592#%lang(sv) %{_mandir}/sv/man1/*
90413e82 593%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 594%{_desktopdir}/mplayer.desktop
1087e996 595%{_pixmapsdir}/mplayer.png
11421384
ER
596%dir %{_datadir}/%{name}
597%{_datadir}/%{name}/font*
This page took 0.930382 seconds and 4 git commands to generate.