]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- release 8 (by relup.sh)
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_without osd # osd menu support
27%bcond_without rtmp # RTMPDump Streaming Media support
28%bcond_with shared # experimental libmplayer.so support
29%bcond_without smb # Samba (SMB) input support
10a6d1a6 30%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
31# - codecs:
32%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 33%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
34%bcond_without crystalhd # CrystalHD support
35%bcond_without faad # FAAD2 (AAC) support
36%bcond_without gif # GIF support
63bba7db
JB
37%bcond_without ladspa # LADSPA plugin support
38%bcond_without libdts # libdts support
39%bcond_without libdv # libdv en/decoding support
63bba7db
JB
40%bcond_without lzo # LZO support (requires lzo 2.x)
41%bcond_without mad # mad (audio MPEG) support
42%bcond_without mpg123 # libmpg123 MP3 decoding support
44d571a0 43%bcond_with musepack # libmpcdec support (deprecated in favour of libavcodec)
63bba7db 44%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
45%bcond_without quicktime # binary quicktime dll support
46%bcond_without real # Real* 8/9 codecs support
63bba7db 47%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
44d571a0 48%bcond_with tremor # use tremor instead of libvorbis
62ba71a7
JB
49%bcond_without theora # Ogg Theora video support
50%bcond_without win32 # Win32 codecs support
51%bcond_without x264 # x264 support
52%bcond_with xmms # XMMS inputplugin support
63bba7db 53%bcond_without xvid # XviD codec
62ba71a7 54%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 55%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
56# - video output:
57%bcond_without aalib # aalib video output
58%bcond_without caca # libcaca video output
59%bcond_with directfb # DirectFB video output
10a6d1a6
JB
60%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
61%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
62%bcond_with ggi # GGI video output
63%bcond_without sdl # SDL video output
64%bcond_with svga # svgalib video output
65%bcond_without vdpau # VDPAU acceleration
66%bcond_without vidix # VIDIX video drivers
63bba7db 67%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
68%bcond_with gnomess # controling gnome screensaver [patch not updated]
69# - audio output:
70%bcond_without alsa # ALSA audio output
71%bcond_with arts # aRts audio output
72%bcond_with esd # EsounD sound support
73%bcond_without jack # JACKD support
74%bcond_with nas # NAS audio output
75%bcond_without pulseaudio # pulseaudio output
76%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 77
9accd5e5 78%if %{with alsa}
79%undefine with_select
80%endif
d1f72115 81%if %{without vorbis}
44d571a0 82%undefine with_tremor
d1f72115 83%endif
84
94cb018b
JB
85%ifnarch %{ix86}
86%undefine with_win32
7a82c266 87%undefine with_quicktime
1087e996 88%undefine with_vidix
94cb018b 89%endif
38c74592 90%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
91%undefine with_runtime
92%endif
ca278bdf
ER
93%ifnarch %{ix86} %{x8664}
94%undefine with_vdpau
95%endif
3d17ae18
ER
96%ifnarch ppc
97%undefine with_altivec
98%endif
810f3f3d
ER
99%ifnarch i686 pentium4 athlon %{x8664}
100%undefine with_crystalhd
101%endif
3d17ae18 102
40ce9ce9
JB
103%if %{_lib} != "lib"
104%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 105%else
40ce9ce9 106%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 107%define binsuf 32
40ce9ce9
JB
108%else
109%define binsuf %{nil}
110%endif
1a8df7bd 111%endif
112
0cd1ec52 113# date from directory inside of tarball (like mplayer-export-2014-04-29)
b13d3bd9 114%define snap 2018-05-22
0cd1ec52 115%define ssnap %(echo %{snap} | tr -d -)
5a8aa4ce 116%define rel 8
906bf13b 117Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
118Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
119Summary(es.UTF-8): Otro reproductor de películas
120Summary(ko.UTF-8): 리눅스용 미디어플레이어
121Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
122Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 123Name: mplayer
03487a7d 124Version: 1.3
c748315c 125Release: 1.%{ssnap}.%{rel}
1f85fd72
ER
126# DO NOT increase epoch unless it's really neccessary!
127# especially such changes like pre7->pre7try2, increase Release instead!
128# PS: $ rpmvercmp pre7try2 pre7
129# pre7try2 > pre7
59476b48 130Epoch: 3
bc426a7f 131License: GPL
906bf13b 132Group: Applications/Multimedia
0cd1ec52
AM
133# Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
134Source0: ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
b13d3bd9 135# Source0-md5: d7447a6838ff3055d5ccb93534b88609
0cd1ec52 136Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
dea0f5a7 137# Source1-md5: b1b71cc56b15da49cee1ede9a7b8134e
031c3c7c 138Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 139# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 140Source5: g%{name}.desktop
623ea2d1 141Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 142# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 143Source7: %{name}.png
24481cd2 144Source8: %{name}.desktop
79907b07 145
146# build (configure / Makefile) related:
147Patch10: %{name}-ldflags.patch
148Patch11: %{name}-altivec.patch
149Patch12: %{name}-check-byteswap.patch
c2bf8f19 150Patch13: %{name}-visibility-hidden-fix.patch
2bb2f3d6 151Patch14: cflags.patch
1ee1ef52 152Patch15: %{name}-live555-async.patch
e156db0d 153
63bba7db 154Patch17: %{name}-gsm.patch
7eb1aa3e 155
63bba7db 156Patch19: %{name}-shared.patch
990687b2 157Patch20: %{name}-vstream.patch
79907b07 158
159# codecs, outputs, demuxers:
990687b2
JB
160Patch21: %{name}-auto-expand.patch
161Patch22: %{name}-release_directfb.patch
79907b07 162
163# goodies:
164Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 165Patch31: %{name}-350.patch
d1f72115 166# update, hard to fix right now because of gnome bug 579430:
167# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 168#Patch32: %{name}-gnome-screensaver.patch
79907b07 169
b252aa8a 170Patch101: %{name}-link.patch
79907b07 171
c5b97685 172URL: http://www.mplayerhq.hu/
44d571a0
JB
173%{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
174BuildRequires: EGL-devel
aeb67db6 175BuildRequires: OpenAL-devel
44d571a0 176BuildRequires: OpenGL-GLX-devel
11421384 177%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
44d571a0
JB
178# checked, but seems actually not used
179#%{?with_sdl:BuildRequires: SDL_image-devel}
63bba7db 180BuildRequires: a52dec-libs-devel
dd6c659c
JB
181%{?with_aalib:BuildRequires: aalib-devel}
182%{?with_alsa:BuildRequires: alsa-lib-devel}
183%{?with_arts:BuildRequires: artsc-devel}
44d571a0 184BuildRequires: binutils >= 2.10.1
841cb995 185%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 186BuildRequires: bzip2-devel
364125e7 187#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 188%{?with_gnomess:BuildRequires: dbus-glib-devel}
d6da6cb0 189%{?with_doc:BuildRequires: docbook-dtd45-xml}
5dcdda0f 190%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 191%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 192%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
193%{?with_enca:BuildRequires: enca-devel}
194%{?with_esd:BuildRequires: esound-devel}
30e3739f 195BuildRequires: faac-devel
3c3fdfcc 196%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 197%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 198BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 199BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 200BuildRequires: fribidi-devel
3d17ae18 201%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 202%{?with_gif:BuildRequires: giflib-devel}
44d571a0
JB
203%{?with_gui:BuildRequires: glib2-devel >= 1:2.6.0}
204BuildRequires: gnutls-devel
205%{?with_gui:BuildRequires: gtk+2-devel >= 2:2.4.0}
d336e259 206%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 207%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 208BuildRequires: lame-libs-devel
6bd88460 209BuildRequires: libass-devel >= 0.9.10
c3a1256a 210%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 211%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 212%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
213%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
214%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 215%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 216%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 217#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 218%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 219%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 220%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
221%{?with_ggi:BuildRequires: libggiwmh-devel}
222BuildRequires: libgsm-devel
af480c75 223BuildRequires: libjpeg-devel
dd6c659c 224%{?with_mad:BuildRequires: libmad-devel}
c521a17c 225BuildRequires: libmng-devel
63bba7db
JB
226%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
227%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
228%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 229%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 230BuildRequires: libnut-devel
af480c75 231BuildRequires: libpng-devel
63bba7db 232%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 233%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 234%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 235%{?with_vdpau:BuildRequires: libvdpau-devel}
44d571a0
JB
236%if %{with vorbis} && %{without tremor}
237BuildRequires: libvorbis-devel
238%endif
0431b837 239BuildRequires: libvpx-devel
44d571a0 240# build >= 118
bbab8eb7 241%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 242BuildRequires: libxslt-progs
44d571a0
JB
243# with v4l2 headers
244BuildRequires: linux-libc-headers >= 7:2.6.22
dd6c659c 245%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 246%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 247%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 248%{?with_nas:BuildRequires: nas-devel}
b458005d 249BuildRequires: ncurses-devel
b69a6f83 250%{?with_amr:BuildRequires: opencore-amr-devel}
4362ee26 251%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
44d571a0 252BuildRequires: opus-devel
e9d22b19 253BuildRequires: pkgconfig
86bc294f 254%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 255BuildRequires: rpm >= 4.4.9-56
9accd5e5 256BuildRequires: rpmbuild(macros) >= 1.527
aeb67db6 257BuildRequires: speex-devel >= 1.1
dd6c659c 258%{?with_svga:BuildRequires: svgalib-devel}
3af20979 259BuildRequires: tar >= 1:1.22
44d571a0 260%{?with_tremor:BuildRequires: tremor-devel}
c521a17c 261BuildRequires: twolame-devel
3af20979 262%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 263%{?with_vstream:BuildRequires: vstream-client-devel}
44d571a0 264BuildRequires: webrtc-libilbc-devel
c521a17c 265%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 266BuildRequires: xorg-lib-libX11-devel
c521a17c 267BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
268BuildRequires: xorg-lib-libXext-devel
269BuildRequires: xorg-lib-libXinerama-devel
270BuildRequires: xorg-lib-libXv-devel
271BuildRequires: xorg-lib-libXvMC-devel
272BuildRequires: xorg-lib-libXxf86dga-devel
273BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
274%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
275BuildRequires: xz
276%ifarch %{ix86} %{x8664}
277BuildRequires: yasm
278%endif
279BuildRequires: zlib-devel
4d75c49f 280Requires: %{name}-common = %{epoch}:%{version}-%{release}
4362ee26 281%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
0f2a502d 282BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 283
bb27cfbd 284%define specflags_ia32 -fomit-frame-pointer
198487b4 285%if %{with altivec}
adfd0023 286%define specflags_ppc -maltivec
20a66bdb 287%endif
2adea73e
AM
288
289%description
c902f7c6 290Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
291AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 292MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
293MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 294devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
295optionally with SHM extension, X11 using overlays with the Xvideo
296extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
297Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 298
8b146837 299If you want to use win32 codecs install w32codec package.
4228a246 300
e011d408 301%description -l de.UTF-8
deba608c 302MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
303Kennzeichnend ist die herausragende Format- und
e011d408 304Plattform-Kompatibilität.
deba608c 305
e011d408
JR
306Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
307plattformexklusive, wodurch etwa Windows Media auch außerhalb von
308Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
309Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 310ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
311Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
312installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 313
e011d408 314%description -l es.UTF-8
c902f7c6 315Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
316MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
317(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
318de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
319Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
320G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
321overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 322G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
323v1.1.7 etc.
33c4efab 324
8b146837 325Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 326
e011d408
JR
327%description -l ko.UTF-8
328MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
329파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
330MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
331Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
332(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
333수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
334크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
335있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
336부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 337
e011d408
JR
338%description -l pl.UTF-8
339Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 340RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
341(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
342Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 343Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 344rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 345G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 346
e011d408 347Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 348
e011d408
JR
349%description -l pt_BR.UTF-8
350MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
351áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 352escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
353
11421384
ER
354%package -n gmplayer
355Summary: MPlayer with GTK+ GUI interface
eeb91a66 356Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 357Group: X11/Applications/Multimedia
11421384 358Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 359Requires: %{name}-skin
11421384
ER
360
361%description -n gmplayer
362MPlayer with GUI GTK+ interface.
363
e011d408 364%description -n gmplayer -l pl.UTF-8
906bf13b
JB
365MPlayer z graficznym interfejsem GTK+.
366
11421384 367%package common
906bf13b 368Summary: Configuration files and documentation for MPlayer
eeb91a66 369Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 370Group: Applications/Multimedia
c521a17c 371Suggests: unrar
1087e996 372Obsoletes: mplayer-vidix
11421384
ER
373
374%description common
906bf13b
JB
375Configuration files, man page and HTML documentation for MPlayer.
376
e011d408 377%description common -l pl.UTF-8
906bf13b 378Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 379
dc3c7d77 380%package doc
63bba7db
JB
381Summary: HTML documentation for MPlayer
382Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
383Group: Documentation
384
385%description doc
63bba7db
JB
386HTML Documentation for MPlayer.
387
388%description doc -l pl.UTF-8
389Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 390
11421384 391%package -n mencoder
906bf13b 392Summary: MEncoder - a movie encoder for Linux
eeb91a66 393Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
394Group: Applications/Multimedia
395Requires: %{name}-common = %{epoch}:%{version}-%{release}
396
397%description -n mencoder
906bf13b
JB
398MEncoder is a movie encoder for Linux and is a part of the MPlayer
399package.
400
e011d408
JR
401%description -n mencoder -l pl.UTF-8
402MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 403
2adea73e 404%prep
3fbc4305 405%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6
833dbe20 406cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 407
408# build (configure / Makefile) related:
409%patch10 -p1
410%patch11 -p1
411%patch12 -p1
c2bf8f19 412%patch13 -p1
2bb2f3d6 413%patch14 -p1
e2b12b5a 414%patch15 -p1
e156db0d 415
63bba7db 416%patch17 -p1
7eb1aa3e 417
63bba7db 418%{?with_shared:%patch19 -p1}
990687b2 419%patch20 -p1
79907b07 420
421# codecs, outputs, demuxers:
79907b07 422%patch21 -p1
990687b2 423%patch22 -p1
79907b07 424
425# goodies:
426%patch30 -p0
2833f81f 427%patch31 -p1
428#%{with_gnomess:%patch32 -p1}
59ba0205 429
b252aa8a
PS
430%patch101 -p1
431
53f97285 432cat etc/example.conf > etc/mplayer.conf
c521a17c 433cat <<'CONFIGADD' >> etc/mplayer.conf
434
d1f72115 435######################
8b2ed1fb 436# PLD Linux Defaults #
d1f72115 437######################
2833f81f 438[default]
439
440# alternate solution for CP1250-encoded subtitles
441fontconfig = yes
442subcp = cp1250
443
444# ...or if you prefer native bitmap fonts shipped with mplayer
445#fontconfig = no
446#subcp = iso-8859-1
447
448# Standard location
449unrarexec = "%{_bindir}/unrar"
450
993f72f1
ER
451# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
452joystick=no
453
c521a17c 454CONFIGADD
d1732085 455
1f8d8779
ER
456%if %{with system_ffmpeg}
457# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 458%{__rm} -rf ffmpeg
1f8d8779
ER
459%endif
460
2adea73e 461%build
5dcdda0f 462CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
3c96218e 463CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 464
63bba7db
JB
465# NOTE:
466# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
467# - toolame is obsolete predecessor of twolame
44d571a0 468# - libcdio-paranoia is preferred over cdparanoia-III libs
11421384 469build() {
c521a17c 470 set -x
53f97285 471
11421384
ER
472 ./configure \
473 %{?debug:--enable-debug=3} \
dd6c659c 474 --prefix=%{_prefix} \
63bba7db 475 --codecsdir=%{_libdir}/codecs \
dd6c659c 476 --confdir=%{_sysconfdir}/mplayer \
53f97285 477 --cc="%{__cc}" \
478 --extra-cflags="$CFLAGS" \
79907b07 479 --real-ldflags="%{rpmldflags}" \
480 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 481 --language=all \
1f8d8779 482%if %{with system_ffmpeg}
0cd1ec52 483 --disable-ffmpeg_a \
1f8d8779 484%endif
57f87bc2 485%ifnarch %{ix86} %{x8664}
dd6c659c 486 --disable-3dnow \
a14f4270 487 --disable-3dnowext \
63bba7db
JB
488 --disable-fastmemcpy \
489 --disable-mmx \
490 --disable-mmxext \
dd6c659c
JB
491 --disable-sse \
492 --disable-sse2 \
dfeec30a 493%endif
9accd5e5 494 %{__disable ssse3} \
1837afdf 495%ifarch ppc
9accd5e5 496 %{__disable altivec} \
1837afdf 497%endif
9accd5e5 498 %{__disable aalib aa} \
9accd5e5 499 %{__enable_disable alsa} \
500 %{__disable arts} \
63bba7db 501 %{__disable bluray} \
9accd5e5 502 %{__disable caca} \
503 %{__disable cdparanoia} \
63bba7db
JB
504 --enable-dga1 \
505 --enable-dga2 \
506 %{__enable_disable directfb} \
507 %{__enable_disable dvdnav} \
508 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 509 %{__disable dxr2} \
63bba7db
JB
510 %{__disable dxr3} \
511 --enable-dynamic-plugins \
9accd5e5 512 %{__disable enca} \
513 %{__disable esd} \
9accd5e5 514 %{__disable faad} \
63bba7db 515 --enable-fbdev \
9accd5e5 516 %{__disable gif} \
63bba7db
JB
517 --enable-gl \
518 %{__disable ggi} \
519 %{__disable jack} \
9accd5e5 520 %{__enable joystick} \
63bba7db
JB
521 %{__disable cdio libcdio} \
522 %{__disable ladspa} \
10a6d1a6 523 %{__disable bs2b libbs2b} \
9accd5e5 524 %{__disable libdts libdca} \
63bba7db
JB
525 %{__disable libdv} \
526 %{__disable system_dvdcss libdvdcss-internal} \
527 %{__disable lzo liblzo} \
528 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 529 %{__disable nemesi} \
63bba7db
JB
530 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
531 %{__disable openjpeg} \
532 %{__disable rtmp librtmp} \
533 %{__disable vorbis libvorbis} \
9accd5e5 534 %{__enable_disable lirc} \
63bba7db
JB
535 --disable-lircc \
536 %{__disable live} \
9accd5e5 537 %{__disable mad} \
63bba7db
JB
538 %{__disable mencoder} \
539 %{__enable osd menu} \
540 --enable-mga \
541 %{__disable mpg123} \
542 %{__enable musepack} \
543 %{__disable nas} \
9accd5e5 544 %{__disable pulseaudio pulse} \
545 %{__disable quicktime qtx} \
63bba7db
JB
546 --enable-radio \
547 --enable-radio-capture \
9accd5e5 548 %{__disable real} \
549 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 550 %{__enable_disable sdl} \
9accd5e5 551 %{__disable select} \
10a6d1a6 552 --enable-s3fb \
9accd5e5 553 %{__disable smb} \
63bba7db
JB
554 %{__disable svga} \
555 --enable-tdfxfb \
10a6d1a6 556 --enable-tdfxvid \
9accd5e5 557 %{__disable theora} \
63bba7db 558 --disable-toolame \
44d571a0 559 %{!?with_tremor:--disable-tremor} \
63bba7db 560 --enable-unrarexec \
9accd5e5 561 %{__disable vdpau} \
63bba7db 562 %{__disable vidix} \
10a6d1a6 563 %{__disable vstream} \
dd6c659c 564 --enable-vm \
10a6d1a6
JB
565%ifarch ppc
566 --enable-wii \
567%endif
63bba7db 568 %{__disable win32 win32dll} \
dd6c659c 569 --enable-x11 \
63bba7db 570 %{__disable x264} \
dd6c659c 571 --enable-xmga \
63bba7db 572 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 573 --enable-xv \
63bba7db
JB
574 %{__disable xvid} \
575 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 576 %{__enable_disable zr} \
11421384 577 "$@"
eb52750a 578
d53c9a42 579 %{__make} %{?with_verbose:V=1}
11421384 580}
2adea73e 581
11421384
ER
582%if %{with gui}
583# build GUI version
841cb995 584build --enable-gui --disable-mencoder
d6da6cb0 585%{__mv} mplayer gmplayer
aeb67db6 586%{__make} distclean
11421384
ER
587%endif
588
589# now build regular version
590build --disable-gui
591
aab7d90d 592%if %{with doc}
ef1e3931 593%{__make} -j1 doc
11421384 594%endif
ceb01d0e 595
2adea73e
AM
596%install
597rm -rf $RPM_BUILD_ROOT
e0e4b963 598install -d \
d23c171d 599 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 600 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 601 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 602 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 603
e0e4b963 604# default config files
c455a752 605install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 606
607# executables
40ce9ce9
JB
608for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
609install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
610%if "%{binsuf}" != ""
611ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 612%endif
40ce9ce9 613done
e0e4b963 614
c2bf8f19 615%if %{with shared}
616install -d $RPM_BUILD_ROOT%{_libdir}
617install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
618%endif
619
e0e4b963 620# fonts
9d62f689 621cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 622ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 623
11421384 624%if %{with gui}
f0d8c47e 625install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 626%endif
9accd5e5 627touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 628install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 629install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 630
631# man pages
59ba0205 632install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 633install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
634install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
635install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
636install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
637install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 638install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 639install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 640install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 641#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 642install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 643
2adea73e
AM
644%clean
645rm -rf $RPM_BUILD_ROOT
646
a69eaaef 647%post -n gmplayer
cd748ae6 648umask 022
cd748ae6 649[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
650
a69eaaef 651%postun -n gmplayer
cd748ae6 652umask 022
75b3147a 653[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 654
2adea73e
AM
655%files
656%defattr(644,root,root,755)
1a8df7bd 657%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
658
659%if %{with gui}
660%files -n gmplayer
661%defattr(644,root,root,755)
1a8df7bd 662%attr(755,root,root) %{_bindir}/gmplayer*
11421384 663%{_desktopdir}/gmplayer.desktop
11421384
ER
664%endif
665
0fb5a7ee 666%if %{with mencoder}
11421384
ER
667%files -n mencoder
668%defattr(644,root,root,755)
aeb67db6 669%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
670%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
671%doc DOCS/tech/colorspaces.txt
1a8df7bd 672%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 673%endif
11421384 674
841cb995 675%if %{with doc}
dc3c7d77 676%files doc
df52db46 677%defattr(644,root,root,755)
dc3c7d77 678%doc DOCS/tech
841cb995
ER
679# HTML and XML-generated docs
680%doc DOCS/HTML/en
0ffd4cd0 681%lang(cs) %doc DOCS/HTML/cs
aeb67db6 682%lang(de) %doc DOCS/HTML/de
aee40e50 683%lang(es) %doc DOCS/HTML/es
684%lang(fr) %doc DOCS/HTML/fr
8cda16b8 685%lang(hu) %doc DOCS/HTML/hu
d6da6cb0 686%lang(it) %doc DOCS/HTML/it
aee40e50 687%lang(pl) %doc DOCS/HTML/pl
688%lang(ru) %doc DOCS/HTML/ru
d6da6cb0 689%lang(zh_CN) %doc DOCS/HTML/zh_CN
841cb995 690%endif
dc3c7d77
ER
691
692%files common
693%defattr(644,root,root,755)
841cb995 694%doc AUTHORS README
dc3c7d77
ER
695%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
696%if %{with win32}
697%doc etc/codecs.win32.conf
698%endif
11421384 699
906bf13b
JB
700%dir %{_sysconfdir}/%{name}
701%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
702%{_mandir}/man1/mplayer.1*
703%lang(cs) %{_mandir}/cs/man1/mplayer.1*
704%lang(de) %{_mandir}/de/man1/mplayer.1*
705%lang(es) %{_mandir}/es/man1/mplayer.1*
706%lang(fr) %{_mandir}/fr/man1/mplayer.1*
707%lang(hu) %{_mandir}/hu/man1/mplayer.1*
708%lang(it) %{_mandir}/it/man1/mplayer.1*
709%lang(pl) %{_mandir}/pl/man1/mplayer.1*
710%lang(ru) %{_mandir}/ru/man1/mplayer.1*
711#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
712%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 713%{_desktopdir}/mplayer.desktop
1087e996 714%{_pixmapsdir}/mplayer.png
11421384
ER
715%dir %{_datadir}/%{name}
716%{_datadir}/%{name}/font*
59ce39fb
ER
717%dir %{_datadir}/%{name}/skins
718%ghost %{_datadir}/%{name}/skins/default
This page took 0.426318 seconds and 4 git commands to generate.