]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- more general binsuf setting (support also x32)
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44%bcond_with musepack # libmpcdec support (derecated in favour of libavcodec)
45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
d1f72115 49%bcond_with system_vorbis # use system libvorbis instead of internal tremor
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
83%undefine with_system_vorbis
84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
810f3f3d
ER
100%ifnarch i686 pentium4 athlon %{x8664}
101%undefine with_crystalhd
102%endif
3d17ae18 103
40ce9ce9
JB
104%if %{_lib} != "lib"
105%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 106%else
40ce9ce9 107%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 108%define binsuf 32
40ce9ce9
JB
109%else
110%define binsuf %{nil}
111%endif
1a8df7bd 112%endif
113
0cd1ec52 114# date from directory inside of tarball (like mplayer-export-2014-04-29)
d2135324 115%define snap 2015-03-01
0cd1ec52 116%define ssnap %(echo %{snap} | tr -d -)
f6862649 117%define rel 1
906bf13b 118Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
119Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
120Summary(es.UTF-8): Otro reproductor de películas
121Summary(ko.UTF-8): 리눅스용 미디어플레이어
122Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
123Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 124Name: mplayer
b57c3c6c 125Version: 1.1.1
b73ed986 126Release: 6.%{ssnap}.%{rel}
1f85fd72
ER
127# DO NOT increase epoch unless it's really neccessary!
128# especially such changes like pre7->pre7try2, increase Release instead!
129# PS: $ rpmvercmp pre7try2 pre7
130# pre7try2 > pre7
59476b48 131Epoch: 3
bc426a7f 132License: GPL
906bf13b 133Group: Applications/Multimedia
0cd1ec52
AM
134# Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
135Source0: ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
d2135324 136# Source0-md5: a81c567aefa1653bc1153d441628d605
0cd1ec52 137Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
d2135324 138# Source1-md5: ee3ec33bfff1bb2a6204b6d629fec473
031c3c7c 139Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 140# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 141Source5: g%{name}.desktop
623ea2d1 142Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 143# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 144Source7: %{name}.png
24481cd2 145Source8: %{name}.desktop
dfd680ce 146# http://www.on2.com/gpl/mplayer/
53f97285 147Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
148# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 149
150# build (configure / Makefile) related:
151Patch10: %{name}-ldflags.patch
152Patch11: %{name}-altivec.patch
153Patch12: %{name}-check-byteswap.patch
c2bf8f19 154Patch13: %{name}-visibility-hidden-fix.patch
0cd1ec52 155
1ee1ef52 156Patch15: %{name}-live555-async.patch
63bba7db
JB
157Patch16: %{name}-libcdio.patch
158Patch17: %{name}-gsm.patch
159Patch18: %{name}-openjpeg.patch
160Patch19: %{name}-shared.patch
990687b2 161Patch20: %{name}-vstream.patch
79907b07 162
163# codecs, outputs, demuxers:
990687b2
JB
164Patch21: %{name}-auto-expand.patch
165Patch22: %{name}-release_directfb.patch
79907b07 166
167# goodies:
168Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 169Patch31: %{name}-350.patch
d1f72115 170# update, hard to fix right now because of gnome bug 579430:
171# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 172#Patch32: %{name}-gnome-screensaver.patch
79907b07 173
174Patch100: %{name}-on2flix.patch
b252aa8a 175Patch101: %{name}-link.patch
79907b07 176
c5b97685 177URL: http://www.mplayerhq.hu/
33c4efab 178%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 179BuildRequires: OpenAL-devel
b458005d 180BuildRequires: OpenGL-devel
11421384 181%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
63bba7db 182BuildRequires: a52dec-libs-devel
dd6c659c
JB
183%{?with_aalib:BuildRequires: aalib-devel}
184%{?with_alsa:BuildRequires: alsa-lib-devel}
185%{?with_arts:BuildRequires: artsc-devel}
841cb995 186%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 187BuildRequires: bzip2-devel
364125e7 188#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 189%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 190BuildRequires: dirac-devel
5dcdda0f
ER
191%{?with_doc:BuildRequires: docbook-dtd412-xml}
192%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 193%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 194%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
195%{?with_enca:BuildRequires: enca-devel}
196%{?with_esd:BuildRequires: esound-devel}
30e3739f 197BuildRequires: faac-devel
3c3fdfcc 198%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 199%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 200BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 201BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 202BuildRequires: fribidi-devel
3d17ae18 203%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 204%{?with_gif:BuildRequires: giflib-devel}
d1f72115 205%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 206%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 207%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 208BuildRequires: lame-libs-devel
6bd88460 209BuildRequires: libass-devel >= 0.9.10
c3a1256a 210%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 211%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 212%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
213%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
214%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 215%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 216%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 217#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 218%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 219%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 220%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
221%{?with_ggi:BuildRequires: libggiwmh-devel}
222BuildRequires: libgsm-devel
af480c75 223BuildRequires: libjpeg-devel
dd6c659c 224%{?with_mad:BuildRequires: libmad-devel}
c521a17c 225BuildRequires: libmng-devel
63bba7db
JB
226%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
227%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
228%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 229%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 230BuildRequires: libnut-devel
af480c75 231BuildRequires: libpng-devel
63bba7db 232%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 233%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 234%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 235%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 236%{?with_system_vorbis:BuildRequires: libvorbis-devel}
0431b837 237BuildRequires: libvpx-devel
bbab8eb7 238%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 239BuildRequires: libxslt-progs
dd6c659c 240%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 241%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 242%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 243%{?with_nas:BuildRequires: nas-devel}
b458005d 244BuildRequires: ncurses-devel
b69a6f83 245%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 246%{?with_openjpeg:BuildRequires: openjpeg-devel}
e9d22b19 247BuildRequires: pkgconfig
86bc294f 248%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 249BuildRequires: rpm >= 4.4.9-56
9accd5e5 250BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 251BuildRequires: schroedinger-devel
aeb67db6 252BuildRequires: speex-devel >= 1.1
dd6c659c 253%{?with_svga:BuildRequires: svgalib-devel}
3af20979 254BuildRequires: tar >= 1:1.22
c521a17c 255BuildRequires: twolame-devel
3af20979 256%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 257%{?with_vstream:BuildRequires: vstream-client-devel}
c521a17c 258%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 259BuildRequires: xorg-lib-libX11-devel
c521a17c 260BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
261BuildRequires: xorg-lib-libXext-devel
262BuildRequires: xorg-lib-libXinerama-devel
263BuildRequires: xorg-lib-libXv-devel
264BuildRequires: xorg-lib-libXvMC-devel
265BuildRequires: xorg-lib-libXxf86dga-devel
266BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
267%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
268BuildRequires: xz
269%ifarch %{ix86} %{x8664}
270BuildRequires: yasm
271%endif
272BuildRequires: zlib-devel
4d75c49f 273Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 274Requires: OpenGL
0f2a502d 275BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 276
a8e3a9a7 277%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 278%define specflags_ia32 -fomit-frame-pointer
198487b4 279%if %{with altivec}
adfd0023 280%define specflags_ppc -maltivec
20a66bdb 281%endif
2adea73e
AM
282
283%description
c902f7c6 284Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
285AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 286MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
287MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 288devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
289optionally with SHM extension, X11 using overlays with the Xvideo
290extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
291Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 292
8b146837 293If you want to use win32 codecs install w32codec package.
4228a246 294
e011d408 295%description -l de.UTF-8
deba608c 296MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
297Kennzeichnend ist die herausragende Format- und
e011d408 298Plattform-Kompatibilität.
deba608c 299
e011d408
JR
300Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
301plattformexklusive, wodurch etwa Windows Media auch außerhalb von
302Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
303Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 304ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
305Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
306installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 307
e011d408 308%description -l es.UTF-8
c902f7c6 309Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
310MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
311(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
312de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
313Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
314G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
315overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 316G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
317v1.1.7 etc.
33c4efab 318
8b146837 319Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 320
e011d408
JR
321%description -l ko.UTF-8
322MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
323파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
324MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
325Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
326(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
327수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
328크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
329있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
330부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 331
e011d408
JR
332%description -l pl.UTF-8
333Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 334RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
335(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
336Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 337Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 338rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 339G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 340
e011d408 341Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 342
e011d408
JR
343%description -l pt_BR.UTF-8
344MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
345áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 346escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
347
11421384
ER
348%package -n gmplayer
349Summary: MPlayer with GTK+ GUI interface
eeb91a66 350Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 351Group: X11/Applications/Multimedia
11421384 352Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 353Requires: %{name}-skin
11421384
ER
354
355%description -n gmplayer
356MPlayer with GUI GTK+ interface.
357
e011d408 358%description -n gmplayer -l pl.UTF-8
906bf13b
JB
359MPlayer z graficznym interfejsem GTK+.
360
11421384 361%package common
906bf13b 362Summary: Configuration files and documentation for MPlayer
eeb91a66 363Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 364Group: Applications/Multimedia
c521a17c 365Suggests: unrar
1087e996 366Obsoletes: mplayer-vidix
11421384
ER
367
368%description common
906bf13b
JB
369Configuration files, man page and HTML documentation for MPlayer.
370
e011d408 371%description common -l pl.UTF-8
906bf13b 372Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 373
dc3c7d77 374%package doc
63bba7db
JB
375Summary: HTML documentation for MPlayer
376Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
377Group: Documentation
378
379%description doc
63bba7db
JB
380HTML Documentation for MPlayer.
381
382%description doc -l pl.UTF-8
383Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 384
11421384 385%package -n mencoder
906bf13b 386Summary: MEncoder - a movie encoder for Linux
eeb91a66 387Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
388Group: Applications/Multimedia
389Requires: %{name}-common = %{epoch}:%{version}-%{release}
390
391%description -n mencoder
906bf13b
JB
392MEncoder is a movie encoder for Linux and is a part of the MPlayer
393package.
394
e011d408
JR
395%description -n mencoder -l pl.UTF-8
396MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 397
2adea73e 398%prep
0cd1ec52 399%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
833dbe20 400cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 401
402# build (configure / Makefile) related:
403%patch10 -p1
404%patch11 -p1
405%patch12 -p1
c2bf8f19 406%patch13 -p1
0cd1ec52 407
e2b12b5a 408%patch15 -p1
63bba7db
JB
409%patch16 -p1
410%patch17 -p1
411%patch18 -p1
412%{?with_shared:%patch19 -p1}
990687b2 413%patch20 -p1
79907b07 414
415# codecs, outputs, demuxers:
79907b07 416%patch21 -p1
990687b2 417%patch22 -p1
79907b07 418
419# goodies:
420%patch30 -p0
2833f81f 421%patch31 -p1
422#%{with_gnomess:%patch32 -p1}
59ba0205 423
dfd680ce 424# on2flix
759ef2d3 425mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 426%if %{with on2}
79907b07 427#%%patch100 -p1
d1f72115 428cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
429# remove broken patches:
430# - first set does not apply
431# - second set beakes build
432for PATCH in asf-correct_movielength avi_check_idxflags \
433 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
434 mencoder_07_demux_update_pts mencoder_10_correct_pts \
435 mpegvideo-revert_r18381 \
436 \
437 reduce_spurious_logging
438do
439 rm mencoder-on2flixenglinux/patch/$PATCH.diff
440done
441for a in mencoder-on2flixenglinux/patch/*.diff; do
442 patch -p0 < $a
443done
444%endif
dfd680ce 445
b252aa8a
PS
446%patch101 -p1
447
53f97285 448cat etc/example.conf > etc/mplayer.conf
c521a17c 449cat <<'CONFIGADD' >> etc/mplayer.conf
450
d1f72115 451######################
8b2ed1fb 452# PLD Linux Defaults #
d1f72115 453######################
2833f81f 454[default]
455
456# alternate solution for CP1250-encoded subtitles
457fontconfig = yes
458subcp = cp1250
459
460# ...or if you prefer native bitmap fonts shipped with mplayer
461#fontconfig = no
462#subcp = iso-8859-1
463
464# Standard location
465unrarexec = "%{_bindir}/unrar"
466
993f72f1
ER
467# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
468joystick=no
469
c521a17c 470CONFIGADD
d1732085 471
1f8d8779
ER
472%if %{with system_ffmpeg}
473# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 474%{__rm} -rf ffmpeg
1f8d8779
ER
475%endif
476
2adea73e 477%build
5dcdda0f 478CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
3c96218e 479CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 480
63bba7db
JB
481# NOTE:
482# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
483# - toolame is obsolete predecessor of twolame
11421384 484build() {
c521a17c 485 set -x
53f97285 486
11421384
ER
487 ./configure \
488 %{?debug:--enable-debug=3} \
dd6c659c 489 --prefix=%{_prefix} \
63bba7db 490 --codecsdir=%{_libdir}/codecs \
dd6c659c 491 --confdir=%{_sysconfdir}/mplayer \
53f97285 492 --cc="%{__cc}" \
493 --extra-cflags="$CFLAGS" \
79907b07 494 --real-ldflags="%{rpmldflags}" \
495 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 496 --language=all \
1f8d8779 497%if %{with system_ffmpeg}
0cd1ec52 498 --disable-ffmpeg_a \
1f8d8779 499%endif
57f87bc2 500%ifnarch %{ix86} %{x8664}
dd6c659c 501 --disable-3dnow \
a14f4270 502 --disable-3dnowext \
63bba7db
JB
503 --disable-fastmemcpy \
504 --disable-mmx \
505 --disable-mmxext \
dd6c659c
JB
506 --disable-sse \
507 --disable-sse2 \
dfeec30a 508%endif
9accd5e5 509 %{__disable ssse3} \
1837afdf 510%ifarch ppc
9accd5e5 511 %{__disable altivec} \
1837afdf 512%endif
9accd5e5 513 %{__disable aalib aa} \
9accd5e5 514 %{__enable_disable alsa} \
515 %{__disable arts} \
63bba7db 516 %{__disable bluray} \
9accd5e5 517 %{__disable caca} \
518 %{__disable cdparanoia} \
63bba7db
JB
519 --enable-dga1 \
520 --enable-dga2 \
521 %{__enable_disable directfb} \
522 %{__enable_disable dvdnav} \
523 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 524 %{__disable dxr2} \
63bba7db
JB
525 %{__disable dxr3} \
526 --enable-dynamic-plugins \
9accd5e5 527 %{__disable enca} \
528 %{__disable esd} \
9accd5e5 529 %{__disable faad} \
63bba7db 530 --enable-fbdev \
9accd5e5 531 %{__disable gif} \
63bba7db
JB
532 --enable-gl \
533 %{__disable ggi} \
534 %{__disable jack} \
9accd5e5 535 %{__enable joystick} \
63bba7db
JB
536 %{__disable cdio libcdio} \
537 %{__disable ladspa} \
10a6d1a6 538 %{__disable bs2b libbs2b} \
9accd5e5 539 %{__disable libdts libdca} \
63bba7db
JB
540 %{__disable libdv} \
541 %{__disable system_dvdcss libdvdcss-internal} \
542 %{__disable lzo liblzo} \
543 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 544 %{__disable nemesi} \
63bba7db
JB
545 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
546 %{__disable openjpeg} \
547 %{__disable rtmp librtmp} \
548 %{__disable vorbis libvorbis} \
9accd5e5 549 %{__enable_disable lirc} \
63bba7db
JB
550 --disable-lircc \
551 %{__disable live} \
9accd5e5 552 %{__disable mad} \
63bba7db
JB
553 %{__disable mencoder} \
554 %{__enable osd menu} \
555 --enable-mga \
556 %{__disable mpg123} \
557 %{__enable musepack} \
558 %{__disable nas} \
9accd5e5 559 %{__disable pulseaudio pulse} \
560 %{__disable quicktime qtx} \
63bba7db
JB
561 --enable-radio \
562 --enable-radio-capture \
9accd5e5 563 %{__disable real} \
564 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 565 %{__enable_disable sdl} \
9accd5e5 566 %{__disable select} \
10a6d1a6 567 --enable-s3fb \
9accd5e5 568 %{__disable smb} \
63bba7db
JB
569 %{__disable svga} \
570 --enable-tdfxfb \
10a6d1a6 571 --enable-tdfxvid \
9accd5e5 572 %{__disable theora} \
63bba7db
JB
573 --disable-toolame \
574 --disable-tremor \
575 %{__disable vorbis tremor-internal} \
576 %{__disable_if system_vorbis tremor-internal} \
577 --enable-unrarexec \
9accd5e5 578 %{__disable vdpau} \
63bba7db 579 %{__disable vidix} \
10a6d1a6 580 %{__disable vstream} \
dd6c659c 581 --enable-vm \
10a6d1a6
JB
582%ifarch ppc
583 --enable-wii \
584%endif
63bba7db 585 %{__disable win32 win32dll} \
dd6c659c 586 --enable-x11 \
63bba7db 587 %{__disable x264} \
dd6c659c 588 --enable-xmga \
63bba7db 589 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 590 --enable-xv \
63bba7db
JB
591 %{__disable xvid} \
592 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 593 %{__enable_disable zr} \
11421384 594 "$@"
eb52750a 595
d53c9a42 596 %{__make} %{?with_verbose:V=1}
11421384 597}
2adea73e 598
11421384
ER
599%if %{with gui}
600# build GUI version
841cb995 601build --enable-gui --disable-mencoder
11421384 602mv -f mplayer gmplayer
aeb67db6 603%{__make} distclean
11421384
ER
604%endif
605
606# now build regular version
607build --disable-gui
608
aab7d90d 609%if %{with doc}
ef1e3931 610%{__make} -j1 doc
11421384 611%endif
ceb01d0e 612
2adea73e
AM
613%install
614rm -rf $RPM_BUILD_ROOT
e0e4b963 615install -d \
d23c171d 616 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 617 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 618 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 619 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 620
e0e4b963 621# default config files
c455a752 622install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 623
624# executables
40ce9ce9
JB
625for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
626install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
627%if "%{binsuf}" != ""
628ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 629%endif
40ce9ce9 630done
e0e4b963 631
c2bf8f19 632%if %{with shared}
633install -d $RPM_BUILD_ROOT%{_libdir}
634install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
635%endif
636
e0e4b963 637# fonts
9d62f689 638cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 639ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 640
11421384 641%if %{with gui}
f0d8c47e 642install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 643%endif
9accd5e5 644touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 645install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 646install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 647
648# man pages
59ba0205 649install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 650install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
651install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
652install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
653install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
654install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 655install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 656install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 657install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 658#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 659install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 660
2adea73e
AM
661%clean
662rm -rf $RPM_BUILD_ROOT
663
a69eaaef 664%post -n gmplayer
cd748ae6 665umask 022
cd748ae6 666[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
667
a69eaaef 668%postun -n gmplayer
cd748ae6 669umask 022
75b3147a 670[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 671
2adea73e
AM
672%files
673%defattr(644,root,root,755)
1a8df7bd 674%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
675
676%if %{with gui}
677%files -n gmplayer
678%defattr(644,root,root,755)
1a8df7bd 679%attr(755,root,root) %{_bindir}/gmplayer*
11421384 680%{_desktopdir}/gmplayer.desktop
11421384
ER
681%endif
682
0fb5a7ee 683%if %{with mencoder}
11421384
ER
684%files -n mencoder
685%defattr(644,root,root,755)
aeb67db6 686%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
687%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
688%doc DOCS/tech/colorspaces.txt
1a8df7bd 689%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 690%endif
11421384 691
841cb995 692%if %{with doc}
dc3c7d77 693%files doc
df52db46 694%defattr(644,root,root,755)
dc3c7d77 695%doc DOCS/tech
841cb995
ER
696# HTML and XML-generated docs
697%doc DOCS/HTML/en
0ffd4cd0 698%lang(cs) %doc DOCS/HTML/cs
aeb67db6 699%lang(de) %doc DOCS/HTML/de
aee40e50 700%lang(es) %doc DOCS/HTML/es
701%lang(fr) %doc DOCS/HTML/fr
8cda16b8 702%lang(hu) %doc DOCS/HTML/hu
aee40e50 703%lang(pl) %doc DOCS/HTML/pl
704%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
705#%lang(zh_CN) %doc DOCS/zh
706%endif
dc3c7d77
ER
707
708%files common
709%defattr(644,root,root,755)
841cb995 710%doc AUTHORS README
dc3c7d77
ER
711%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
712%if %{with win32}
713%doc etc/codecs.win32.conf
714%endif
11421384 715
906bf13b
JB
716%dir %{_sysconfdir}/%{name}
717%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
718%{_mandir}/man1/mplayer.1*
719%lang(cs) %{_mandir}/cs/man1/mplayer.1*
720%lang(de) %{_mandir}/de/man1/mplayer.1*
721%lang(es) %{_mandir}/es/man1/mplayer.1*
722%lang(fr) %{_mandir}/fr/man1/mplayer.1*
723%lang(hu) %{_mandir}/hu/man1/mplayer.1*
724%lang(it) %{_mandir}/it/man1/mplayer.1*
725%lang(pl) %{_mandir}/pl/man1/mplayer.1*
726%lang(ru) %{_mandir}/ru/man1/mplayer.1*
727#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
728%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 729%{_desktopdir}/mplayer.desktop
1087e996 730%{_pixmapsdir}/mplayer.png
11421384
ER
731%dir %{_datadir}/%{name}
732%{_datadir}/%{name}/font*
59ce39fb
ER
733%dir %{_datadir}/%{name}/skins
734%ghost %{_datadir}/%{name}/skins/default
This page took 0.177943 seconds and 4 git commands to generate.