]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- old live patch replaced by live555-async patch from mplayer ml (port to async RTSPC...
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44%bcond_with musepack # libmpcdec support (derecated in favour of libavcodec)
45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
d1f72115 49%bcond_with system_vorbis # use system libvorbis instead of internal tremor
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
83%undefine with_system_vorbis
84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
810f3f3d
ER
100%ifnarch i686 pentium4 athlon %{x8664}
101%undefine with_crystalhd
102%endif
3d17ae18 103
1a8df7bd 104%if %{_lib} == "lib64"
e2b12b5a 105%define binsuf 64
1a8df7bd 106%else
e2b12b5a 107%define binsuf 32
1a8df7bd 108%endif
109
906bf13b 110Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
111Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
112Summary(es.UTF-8): Otro reproductor de películas
113Summary(ko.UTF-8): 리눅스용 미디어플레이어
114Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
115Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 116Name: mplayer
b57c3c6c 117Version: 1.1.1
a45b020d 118Release: 3
1f85fd72
ER
119# DO NOT increase epoch unless it's really neccessary!
120# especially such changes like pre7->pre7try2, increase Release instead!
121# PS: $ rpmvercmp pre7try2 pre7
122# pre7try2 > pre7
59476b48 123Epoch: 3
bc426a7f 124License: GPL
906bf13b 125Group: Applications/Multimedia
e2b12b5a
JB
126# for snapshots:
127# svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
128# cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
129# tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
130Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
b57c3c6c 131# Source0-md5: 39dd55f30eb5403f219a606e79a6648a
031c3c7c 132Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 133# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 134Source5: g%{name}.desktop
623ea2d1 135Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 136# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 137Source7: %{name}.png
24481cd2 138Source8: %{name}.desktop
dfd680ce 139# http://www.on2.com/gpl/mplayer/
53f97285 140Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
141# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 142
143# build (configure / Makefile) related:
144Patch10: %{name}-ldflags.patch
145Patch11: %{name}-altivec.patch
146Patch12: %{name}-check-byteswap.patch
c2bf8f19 147Patch13: %{name}-visibility-hidden-fix.patch
148Patch14: %{name}-ffmpeg.patch
1ee1ef52 149Patch15: %{name}-live555-async.patch
63bba7db
JB
150Patch16: %{name}-libcdio.patch
151Patch17: %{name}-gsm.patch
152Patch18: %{name}-openjpeg.patch
153Patch19: %{name}-shared.patch
990687b2 154Patch20: %{name}-vstream.patch
bfac6bf7 155Patch23: vstream-format-security.patch
79907b07 156
157# codecs, outputs, demuxers:
990687b2
JB
158Patch21: %{name}-auto-expand.patch
159Patch22: %{name}-release_directfb.patch
79907b07 160
161# goodies:
162Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 163Patch31: %{name}-350.patch
d1f72115 164# update, hard to fix right now because of gnome bug 579430:
165# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 166#Patch32: %{name}-gnome-screensaver.patch
3749cd32 167Patch33: %{name}-growing-files.patch
79907b07 168
169Patch100: %{name}-on2flix.patch
b252aa8a 170Patch101: %{name}-link.patch
e48160f4 171Patch102: %{name}-build.patch
79907b07 172
c5b97685 173URL: http://www.mplayerhq.hu/
33c4efab 174%{?with_directfb:BuildRequires: DirectFB-devel}
aeb67db6 175BuildRequires: OpenAL-devel
b458005d 176BuildRequires: OpenGL-devel
11421384 177%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
63bba7db 178BuildRequires: a52dec-libs-devel
dd6c659c
JB
179%{?with_aalib:BuildRequires: aalib-devel}
180%{?with_alsa:BuildRequires: alsa-lib-devel}
181%{?with_arts:BuildRequires: artsc-devel}
841cb995 182%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 183BuildRequires: bzip2-devel
364125e7 184#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 185%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 186BuildRequires: dirac-devel
5dcdda0f
ER
187%{?with_doc:BuildRequires: docbook-dtd412-xml}
188%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 189%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 190%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
191%{?with_enca:BuildRequires: enca-devel}
192%{?with_esd:BuildRequires: esound-devel}
30e3739f 193BuildRequires: faac-devel
3c3fdfcc 194%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 195%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 196BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 197BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 198BuildRequires: fribidi-devel
3d17ae18 199%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 200%{?with_gif:BuildRequires: giflib-devel}
d1f72115 201%{?with_gui:BuildRequires: gtk+2-devel}
d336e259 202%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 203%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 204BuildRequires: lame-libs-devel
6bd88460 205BuildRequires: libass-devel >= 0.9.10
c3a1256a 206%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 207%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 208%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
209%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
210%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 211%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 212%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 213#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 214%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 215%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 216%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
217%{?with_ggi:BuildRequires: libggiwmh-devel}
218BuildRequires: libgsm-devel
af480c75 219BuildRequires: libjpeg-devel
dd6c659c 220%{?with_mad:BuildRequires: libmad-devel}
c521a17c 221BuildRequires: libmng-devel
63bba7db
JB
222%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
223%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
224%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 225%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 226BuildRequires: libnut-devel
af480c75 227BuildRequires: libpng-devel
63bba7db 228%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 229%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 230%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 231%{?with_vdpau:BuildRequires: libvdpau-devel}
d1f72115 232%{?with_system_vorbis:BuildRequires: libvorbis-devel}
0431b837 233BuildRequires: libvpx-devel
bbab8eb7 234%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 235BuildRequires: libxslt-progs
dd6c659c 236%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 237%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 238%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 239%{?with_nas:BuildRequires: nas-devel}
b458005d 240BuildRequires: ncurses-devel
b69a6f83 241%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 242%{?with_openjpeg:BuildRequires: openjpeg-devel}
e9d22b19 243BuildRequires: pkgconfig
86bc294f 244%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 245BuildRequires: rpm >= 4.4.9-56
9accd5e5 246BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 247BuildRequires: schroedinger-devel
aeb67db6 248BuildRequires: speex-devel >= 1.1
dd6c659c 249%{?with_svga:BuildRequires: svgalib-devel}
3af20979 250BuildRequires: tar >= 1:1.22
c521a17c 251BuildRequires: twolame-devel
3af20979 252%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 253%{?with_vstream:BuildRequires: vstream-client-devel}
c521a17c 254%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 255BuildRequires: xorg-lib-libX11-devel
c521a17c 256BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
257BuildRequires: xorg-lib-libXext-devel
258BuildRequires: xorg-lib-libXinerama-devel
259BuildRequires: xorg-lib-libXv-devel
260BuildRequires: xorg-lib-libXvMC-devel
261BuildRequires: xorg-lib-libXxf86dga-devel
262BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
263%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
264BuildRequires: xz
265%ifarch %{ix86} %{x8664}
266BuildRequires: yasm
267%endif
268BuildRequires: zlib-devel
4d75c49f 269Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 270Requires: OpenGL
0f2a502d 271BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 272
a8e3a9a7 273%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 274%define specflags_ia32 -fomit-frame-pointer
198487b4 275%if %{with altivec}
adfd0023 276%define specflags_ppc -maltivec
20a66bdb 277%endif
2adea73e
AM
278
279%description
c902f7c6 280Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
281AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 282MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
283MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 284devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
285optionally with SHM extension, X11 using overlays with the Xvideo
286extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
287Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 288
8b146837 289If you want to use win32 codecs install w32codec package.
4228a246 290
e011d408 291%description -l de.UTF-8
deba608c 292MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
293Kennzeichnend ist die herausragende Format- und
e011d408 294Plattform-Kompatibilität.
deba608c 295
e011d408
JR
296Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
297plattformexklusive, wodurch etwa Windows Media auch außerhalb von
298Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
299Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 300ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
301Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
302installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 303
e011d408 304%description -l es.UTF-8
c902f7c6 305Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
306MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
307(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
308de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
309Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
310G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
311overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 312G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
313v1.1.7 etc.
33c4efab 314
8b146837 315Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 316
e011d408
JR
317%description -l ko.UTF-8
318MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
319파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
320MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
321Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
322(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
323수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
324크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
325있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
326부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 327
e011d408
JR
328%description -l pl.UTF-8
329Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 330RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
331(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
332Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 333Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 334rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 335G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 336
e011d408 337Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 338
e011d408
JR
339%description -l pt_BR.UTF-8
340MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
341áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 342escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
343
11421384
ER
344%package -n gmplayer
345Summary: MPlayer with GTK+ GUI interface
eeb91a66 346Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 347Group: X11/Applications/Multimedia
11421384 348Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 349Requires: %{name}-skin
11421384
ER
350
351%description -n gmplayer
352MPlayer with GUI GTK+ interface.
353
e011d408 354%description -n gmplayer -l pl.UTF-8
906bf13b
JB
355MPlayer z graficznym interfejsem GTK+.
356
11421384 357%package common
906bf13b 358Summary: Configuration files and documentation for MPlayer
eeb91a66 359Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 360Group: Applications/Multimedia
c521a17c 361Suggests: unrar
1087e996 362Obsoletes: mplayer-vidix
11421384
ER
363
364%description common
906bf13b
JB
365Configuration files, man page and HTML documentation for MPlayer.
366
e011d408 367%description common -l pl.UTF-8
906bf13b 368Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 369
dc3c7d77 370%package doc
63bba7db
JB
371Summary: HTML documentation for MPlayer
372Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
373Group: Documentation
374
375%description doc
63bba7db
JB
376HTML Documentation for MPlayer.
377
378%description doc -l pl.UTF-8
379Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 380
11421384 381%package -n mencoder
906bf13b 382Summary: MEncoder - a movie encoder for Linux
eeb91a66 383Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
384Group: Applications/Multimedia
385Requires: %{name}-common = %{epoch}:%{version}-%{release}
386
387%description -n mencoder
906bf13b
JB
388MEncoder is a movie encoder for Linux and is a part of the MPlayer
389package.
390
e011d408
JR
391%description -n mencoder -l pl.UTF-8
392MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 393
2adea73e 394%prep
df52db46 395%setup -q -n MPlayer-%{version} -a3 -a6 -a9
833dbe20 396cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 397
398# build (configure / Makefile) related:
399%patch10 -p1
400%patch11 -p1
401%patch12 -p1
c2bf8f19 402%patch13 -p1
403%{?with_system_ffmpeg:%patch14 -p1}
e2b12b5a 404%patch15 -p1
63bba7db
JB
405%patch16 -p1
406%patch17 -p1
407%patch18 -p1
408%{?with_shared:%patch19 -p1}
990687b2 409%patch20 -p1
bfac6bf7 410%patch23 -p0
79907b07 411
412# codecs, outputs, demuxers:
79907b07 413%patch21 -p1
990687b2 414%patch22 -p1
79907b07 415
416# goodies:
417%patch30 -p0
2833f81f 418%patch31 -p1
419#%{with_gnomess:%patch32 -p1}
3749cd32 420%patch33 -p1
59ba0205 421
dfd680ce 422# on2flix
759ef2d3 423mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 424%if %{with on2}
79907b07 425#%%patch100 -p1
d1f72115 426cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
427# remove broken patches:
428# - first set does not apply
429# - second set beakes build
430for PATCH in asf-correct_movielength avi_check_idxflags \
431 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
432 mencoder_07_demux_update_pts mencoder_10_correct_pts \
433 mpegvideo-revert_r18381 \
434 \
435 reduce_spurious_logging
436do
437 rm mencoder-on2flixenglinux/patch/$PATCH.diff
438done
439for a in mencoder-on2flixenglinux/patch/*.diff; do
440 patch -p0 < $a
441done
442%endif
dfd680ce 443
b252aa8a 444%patch101 -p1
e48160f4 445%patch102 -p1
b252aa8a 446
53f97285 447cat etc/example.conf > etc/mplayer.conf
c521a17c 448cat <<'CONFIGADD' >> etc/mplayer.conf
449
d1f72115 450######################
8b2ed1fb 451# PLD Linux Defaults #
d1f72115 452######################
2833f81f 453[default]
454
455# alternate solution for CP1250-encoded subtitles
456fontconfig = yes
457subcp = cp1250
458
459# ...or if you prefer native bitmap fonts shipped with mplayer
460#fontconfig = no
461#subcp = iso-8859-1
462
463# Standard location
464unrarexec = "%{_bindir}/unrar"
465
993f72f1
ER
466# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
467joystick=no
468
c521a17c 469CONFIGADD
d1732085 470
1f8d8779
ER
471%if %{with system_ffmpeg}
472# using external ffmpeg, but mplayer adds these to includepath
c65405fc 473%{__rm} -r ffmpeg
1f8d8779
ER
474%endif
475
2adea73e 476%build
5dcdda0f 477CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
53f97285 478CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
53f97285 479
63bba7db
JB
480# NOTE:
481# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
482# - toolame is obsolete predecessor of twolame
11421384 483build() {
c521a17c 484 set -x
53f97285 485
11421384
ER
486 ./configure \
487 %{?debug:--enable-debug=3} \
dd6c659c 488 --prefix=%{_prefix} \
63bba7db 489 --codecsdir=%{_libdir}/codecs \
dd6c659c 490 --confdir=%{_sysconfdir}/mplayer \
53f97285 491 --cc="%{__cc}" \
492 --extra-cflags="$CFLAGS" \
79907b07 493 --real-ldflags="%{rpmldflags}" \
494 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 495 --language=all \
1f8d8779 496%if %{with system_ffmpeg}
841cb995
ER
497 --disable-libavutil_a \
498 --disable-libavcodec_a \
499 --disable-libavformat_a \
500 --disable-libpostproc_a \
501 --enable-libavutil_so \
502 --enable-libavcodec_so \
503 --enable-libavformat_so \
504 --enable-libpostproc_so \
1f8d8779 505%endif
57f87bc2 506%ifnarch %{ix86} %{x8664}
dd6c659c 507 --disable-3dnow \
a14f4270 508 --disable-3dnowext \
63bba7db
JB
509 --disable-fastmemcpy \
510 --disable-mmx \
511 --disable-mmxext \
dd6c659c
JB
512 --disable-sse \
513 --disable-sse2 \
dfeec30a 514%endif
9accd5e5 515 %{__disable ssse3} \
1837afdf 516%ifarch ppc
9accd5e5 517 %{__disable altivec} \
1837afdf 518%endif
9accd5e5 519 %{__disable aalib aa} \
9accd5e5 520 %{__enable_disable alsa} \
521 %{__disable arts} \
63bba7db 522 %{__disable bluray} \
9accd5e5 523 %{__disable caca} \
524 %{__disable cdparanoia} \
63bba7db
JB
525 --enable-dga1 \
526 --enable-dga2 \
527 %{__enable_disable directfb} \
528 %{__enable_disable dvdnav} \
529 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 530 %{__disable dxr2} \
63bba7db
JB
531 %{__disable dxr3} \
532 --enable-dynamic-plugins \
9accd5e5 533 %{__disable enca} \
534 %{__disable esd} \
9accd5e5 535 %{__disable faad} \
63bba7db 536 --enable-fbdev \
9accd5e5 537 %{__disable gif} \
63bba7db
JB
538 --enable-gl \
539 %{__disable ggi} \
540 %{__disable jack} \
9accd5e5 541 %{__enable joystick} \
63bba7db
JB
542 %{__disable cdio libcdio} \
543 %{__disable ladspa} \
10a6d1a6 544 %{__disable bs2b libbs2b} \
9accd5e5 545 %{__disable libdts libdca} \
63bba7db
JB
546 %{__disable libdv} \
547 %{__disable system_dvdcss libdvdcss-internal} \
548 %{__disable lzo liblzo} \
549 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 550 %{__disable nemesi} \
63bba7db
JB
551 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
552 %{__disable openjpeg} \
553 %{__disable rtmp librtmp} \
554 %{__disable vorbis libvorbis} \
9accd5e5 555 %{__enable_disable lirc} \
63bba7db
JB
556 --disable-lircc \
557 %{__disable live} \
9accd5e5 558 %{__disable mad} \
63bba7db
JB
559 %{__disable mencoder} \
560 %{__enable osd menu} \
561 --enable-mga \
562 %{__disable mpg123} \
563 %{__enable musepack} \
564 %{__disable nas} \
9accd5e5 565 %{__disable pulseaudio pulse} \
566 %{__disable quicktime qtx} \
63bba7db
JB
567 --enable-radio \
568 --enable-radio-capture \
9accd5e5 569 %{__disable real} \
570 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 571 %{__enable_disable sdl} \
9accd5e5 572 %{__disable select} \
10a6d1a6 573 --enable-s3fb \
9accd5e5 574 %{__disable smb} \
63bba7db
JB
575 %{__disable svga} \
576 --enable-tdfxfb \
10a6d1a6 577 --enable-tdfxvid \
9accd5e5 578 %{__disable theora} \
63bba7db
JB
579 --disable-toolame \
580 --disable-tremor \
581 %{__disable vorbis tremor-internal} \
582 %{__disable_if system_vorbis tremor-internal} \
583 --enable-unrarexec \
9accd5e5 584 %{__disable vdpau} \
63bba7db 585 %{__disable vidix} \
10a6d1a6 586 %{__disable vstream} \
dd6c659c 587 --enable-vm \
10a6d1a6
JB
588%ifarch ppc
589 --enable-wii \
590%endif
63bba7db 591 %{__disable win32 win32dll} \
dd6c659c 592 --enable-x11 \
63bba7db 593 %{__disable x264} \
dd6c659c 594 --enable-xmga \
63bba7db 595 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 596 --enable-xv \
63bba7db
JB
597 %{__disable xvid} \
598 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 599 %{__enable_disable zr} \
11421384 600 "$@"
eb52750a 601
d53c9a42 602 %{__make} %{?with_verbose:V=1}
11421384 603}
2adea73e 604
11421384
ER
605%if %{with gui}
606# build GUI version
841cb995 607build --enable-gui --disable-mencoder
11421384 608mv -f mplayer gmplayer
aeb67db6 609%{__make} distclean
11421384
ER
610%endif
611
612# now build regular version
613build --disable-gui
614
aab7d90d 615%if %{with doc}
ef1e3931 616%{__make} -j1 doc
11421384 617%endif
ceb01d0e 618
2adea73e
AM
619%install
620rm -rf $RPM_BUILD_ROOT
e0e4b963 621install -d \
d23c171d 622 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
59ba0205 623 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
9accd5e5 624 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 625 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 626
e0e4b963 627# default config files
c455a752 628install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 629
630# executables
2af58a38 631%if %{with mencoder}
85694787 632install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
e2b12b5a 633ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
2af58a38 634%endif
85694787 635install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
e2b12b5a 636ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
11421384 637%if %{with gui}
85694787 638install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
e2b12b5a 639ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
11421384 640%endif
e0e4b963 641
c2bf8f19 642%if %{with shared}
643install -d $RPM_BUILD_ROOT%{_libdir}
644install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
645%endif
646
e0e4b963 647# fonts
9d62f689 648cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 649ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 650
11421384 651%if %{with gui}
f0d8c47e 652install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 653%endif
9accd5e5 654touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 655install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 656install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 657
658# man pages
59ba0205 659install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 660install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
661install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
662install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
663install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
664install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 665install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 666install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
841cb995 667#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
53f97285 668#install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 669
2adea73e
AM
670%clean
671rm -rf $RPM_BUILD_ROOT
672
a69eaaef 673%post -n gmplayer
cd748ae6 674umask 022
cd748ae6 675[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
676
a69eaaef 677%postun -n gmplayer
cd748ae6 678umask 022
75b3147a 679[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 680
2adea73e
AM
681%files
682%defattr(644,root,root,755)
1a8df7bd 683%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
684
685%if %{with gui}
686%files -n gmplayer
687%defattr(644,root,root,755)
1a8df7bd 688%attr(755,root,root) %{_bindir}/gmplayer*
11421384 689%{_desktopdir}/gmplayer.desktop
11421384
ER
690%endif
691
0fb5a7ee 692%if %{with mencoder}
11421384
ER
693%files -n mencoder
694%defattr(644,root,root,755)
aeb67db6 695%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
696%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
697%doc DOCS/tech/colorspaces.txt
1a8df7bd 698%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 699%endif
11421384 700
841cb995 701%if %{with doc}
dc3c7d77 702%files doc
df52db46 703%defattr(644,root,root,755)
dc3c7d77 704%doc DOCS/tech
841cb995
ER
705# HTML and XML-generated docs
706%doc DOCS/HTML/en
0ffd4cd0 707%lang(cs) %doc DOCS/HTML/cs
aeb67db6 708%lang(de) %doc DOCS/HTML/de
aee40e50 709%lang(es) %doc DOCS/HTML/es
710%lang(fr) %doc DOCS/HTML/fr
8cda16b8 711%lang(hu) %doc DOCS/HTML/hu
aee40e50 712%lang(pl) %doc DOCS/HTML/pl
713%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
714#%lang(zh_CN) %doc DOCS/zh
715%endif
dc3c7d77
ER
716
717%files common
718%defattr(644,root,root,755)
841cb995 719%doc AUTHORS README
dc3c7d77
ER
720%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
721%if %{with win32}
722%doc etc/codecs.win32.conf
723%endif
11421384 724
906bf13b
JB
725%dir %{_sysconfdir}/%{name}
726%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
2adea73e 727%{_mandir}/man1/*
59ba0205 728%lang(cs) %{_mandir}/cs/man1/*
20e1052d 729%lang(de) %{_mandir}/de/man1/*
aee40e50 730%lang(es) %{_mandir}/es/man1/*
2a9a2b75 731%lang(fr) %{_mandir}/fr/man1/*
daef2f4a 732%lang(hu) %{_mandir}/hu/man1/*
8cda16b8 733%lang(it) %{_mandir}/it/man1/*
2a6ed516 734%lang(pl) %{_mandir}/pl/man1/*
841cb995 735#%lang(sv) %{_mandir}/sv/man1/*
53f97285 736#%lang(zh_CN) %{_mandir}/zh_CN/man1/*
24481cd2 737%{_desktopdir}/mplayer.desktop
1087e996 738%{_pixmapsdir}/mplayer.png
11421384
ER
739%dir %{_datadir}/%{name}
740%{_datadir}/%{name}/font*
59ce39fb
ER
741%dir %{_datadir}/%{name}/skins
742%ghost %{_datadir}/%{name}/skins/default
This page took 0.366558 seconds and 4 git commands to generate.