]> git.pld-linux.org Git - packages/mosh.git/blame - mosh.spec
- fix gcc epoch
[packages/mosh.git] / mosh.spec
CommitLineData
0e141888
ER
1#
2# Conditional build:
3%bcond_without verbose # verbose build (V=1)
4
b0706f31
ER
5%if "%{pld_release}" == "ac"
6# add suffix, but allow ccache, etc in ~/.rpmmacros
7%{expand:%%define __cc %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
8%{expand:%%define __cxx %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
9%{expand:%%define __cpp %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
10%endif
11
37060d63 12%include /usr/lib/rpm/macros.perl
dc576455
CM
13Summary: Mosh mobile shell
14Name: mosh
9a44ab85 15Version: 1.2.2
ec1247c8 16Release: 1
dc576455
CM
17License: GPL v3+
18Group: X11/Applications
19Source0: https://github.com/downloads/keithw/mosh/%{name}-%{version}.tar.gz
9a44ab85 20# Source0-md5: 7ed5b857307685794dcd120afe5bdf52
dc576455 21URL: http://mosh.mit.edu/
b0706f31 22BuildRequires: binutils >= 2.20.51.0.2
246f59c7 23BuildRequires: libstdc++-devel >= 5:4.0
dc576455
CM
24BuildRequires: libutempter-devel
25BuildRequires: ncurses-devel
ab99cc95 26BuildRequires: protobuf
dc576455 27BuildRequires: protobuf-devel
37060d63
ER
28BuildRequires: rpm-perlprov >= 4.1-13
29BuildRequires: sed >= 4.0
dc576455 30BuildRequires: zlib-devel
b0706f31
ER
31# gcc4 might be installed, but not current __cc
32%if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
33BuildRequires: __cc >= 4.0
34%endif
dc576455
CM
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Remote terminal application that allows roaming, supports intermittent
39connectivity, and provides intelligent local echo and line editing of
40user keystrokes.
41
42Mosh is a replacement for SSH. It's more robust and responsive,
43especially over Wi-Fi, cellular, and long-distance links.
44
45%prep
46%setup -q
37060d63 47%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh
dc576455
CM
48
49%build
50%configure \
349c173b 51 --enable-compile-warnings=error \
dc576455 52 CPPFLAGS="-I/usr/include/ncurses"
0e141888
ER
53%{__make} \
54 %{?with_verbose:V=1}
dc576455
CM
55
56%install
57rm -rf $RPM_BUILD_ROOT
dc576455
CM
58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc AUTHORS ChangeLog NEWS THANKS
dc576455
CM
67%attr(755,root,root) %{_bindir}/%{name}
68%attr(755,root,root) %{_bindir}/%{name}-client
69%attr(755,root,root) %{_bindir}/%{name}-server
70%{_mandir}/man1/%{name}.1*
71%{_mandir}/man1/%{name}-client.1*
72%{_mandir}/man1/%{name}-server.1*
This page took 0.095106 seconds and 4 git commands to generate.