]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- added BC: mono < 2.4
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
94b2d9a7 3# TODO:
01794b7a 4# - C# 4.0 (--with-profile4=yes)
4ef2f41c 5#
245657c9 6# Conditional build:
fef1a4c5 7%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 8%bcond_without static_libs # don't build static libraries
8cabdc4d 9%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 10%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 11#
75873ca6
JB
12%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
13# JIT not supported on hppa
a465d985 14%define with_mint 1
f1c5438d 15%endif
5114c445 16%define glib_ver 1:2.4
8cabdc4d 17#
728c2265 18Summary: Common Language Infrastructure implementation
d1081961 19Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 20Name: mono
01794b7a 21Version: 2.6.1
4ef2f41c 22Release: 1
5114c445 23License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 24Group: Development/Languages
0f6bc6e4
JB
25# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
26Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
01794b7a 27# Source0-md5: 4cd2157c9eabbe9f49232d5ee3a2a57e
ddb02eae
JB
28Patch0: %{name}-alpha-float.patch
29Patch1: %{name}-mint.patch
30Patch2: %{name}-sonames.patch
3cdc32b9
JB
31Patch3: %{name}-awk.patch
32Patch4: %{name}-console-no-utf8-bom.patch
5114c445 33Patch5: %{name}-pc.patch
0f6bc6e4 34Patch6: %{name}-ARG_MAX.patch
68174c6e 35URL: http://www.mono-project.com/
39176ea5 36%if %(test -r /dev/random; echo $?)
96185d3a
JB
37BuildRequires: ACCESSIBLE_/dev/random
38%endif
8aa3dace 39BuildRequires: autoconf
40BuildRequires: automake
3c4b0944 41BuildRequires: bison
4f07b841 42BuildRequires: gettext-devel
5114c445 43BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 44BuildRequires: libtool
609d5e15 45%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 46BuildRequires: pkgconfig
71415791 47BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 48BuildRequires: rpmbuild(monoautodeps)
246c9898 49BuildRequires: zlib-devel
6838d20b 50BuildConflicts: mono < 2.4
8c34c74b 51Suggests: binfmt-detector
5114c445 52# for System.Drawing
246c9898 53Suggests: libgdiplus >= 2.6
e19321c3 54ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
55# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
56ExcludeArch: i386
728c2265
AM
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
ad29385a 59%define _rpmlibdir /usr/lib/rpm
60
baf6636c 61# debugger doesn't work with stripped mono
62%define _noautostrip .*/mono
63
39176ea5 64%if %{without bootstrap}
d0023a38 65%define __mono_provides %{_rpmlibdir}/mono-find-provides
66%define __mono_requires %{_rpmlibdir}/mono-find-requires
67%endif
68
728c2265
AM
69%description
70The Common Language Infrastructure platform. Microsoft has created a
71new development platform. The highlights of this new development
72platform are:
86d7bbf3 73- A runtime environment that provides garbage collection, threading
728c2265 74 and a virtual machine specification (The Virtual Execution System,
8aa3dace 75 VES),
76- A comprehensive class library,
728c2265 77- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 78 use all the features available on the .NET runtime,
728c2265
AM
79- A language specification that compilers can follow if they want to
80 generate classes and code that can interoperate with other programming
8aa3dace 81 languages (The Common Language Specification: CLS).
728c2265 82
39176ea5 83%{?with_tls:This version was built with TLS __thread.}
245657c9 84
a86cd9c8
JR
85%description -l pl.UTF-8
86Platforma CLI (Common Language Infrastructure). Microsoft stworzył
87nową platformę developerską. Zalety tej platformy to:
88- środowisko, które dostarcza garbage collector, wątki oraz
89 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
90- bibliotekę klas,
91- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
92 używanie wszystkich możliwości dostarczanych przez platformę .NET,
93- specyfikacja dla kompilatorów, które chcą generować kod
94 współpracujący z innymi językami programowania (The Common Language
8aa3dace 95 Specification: CLS).
96
a86cd9c8 97%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 98
8aa3dace 99%package devel
100Summary: Development resources for mono
d1081961 101Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 102License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 103Group: Development/Libraries
76e7cb31 104Requires: %{name} = %{version}-%{release}
5114c445 105Requires: glib2-devel >= %{glib_ver}
8aa3dace 106
107%description devel
108Development resources for mono.
109
a86cd9c8 110%description devel -l pl.UTF-8
18ff84b2
MM
111Zasoby programisty dla mono.
112
5dab3216 113%package debug
114Summary: Mono libraries debugging resources
d1081961 115Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 116Group: Development/Libraries
117Requires: %{name} = %{version}-%{release}
118
119%description debug
120Mono libraries debugging resources.
121
a86cd9c8
JR
122%description debug -l pl.UTF-8
123Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 124
18ff84b2
MM
125%package csharp
126Summary: C# compiler for mono
d1081961 127Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 128License: GPL
18ff84b2 129Group: Development/Languages
76e7cb31 130Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
131
132%description csharp
133C# compiler for mono.
134
a86cd9c8 135%description csharp -l pl.UTF-8
18ff84b2
MM
136Kompilator C# dla mono.
137
138%package ilasm
139Summary: ILasm compiler for mono
d1081961 140Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
141# implied
142License: MIT X11
18ff84b2 143Group: Development/Languages
76e7cb31 144Requires: %{name}-devel = %{version}-%{release}
6ec58c77 145Provides: ilasm
146Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
147
148%description ilasm
149ILasm compiler for mono.
150
a86cd9c8 151%description ilasm -l pl.UTF-8
18ff84b2 152Kompilator ILasm dla mono.
71c7a580 153
245657c9
MM
154%package jscript
155Summary: jscript compiler for mono
d1081961 156Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 157License: MIT X11
245657c9
MM
158Group: Development/Languages
159Requires: %{name}-devel = %{version}-%{release}
160
161%description jscript
162jscript compiler for mono.
163
a86cd9c8 164%description jscript -l pl.UTF-8
245657c9
MM
165Kompilator jscript dla mono.
166
e9945d9e 167%package monodoc
168Summary: Documentation for Mono class libraries and tools to produce and edit the documentation
169Summary(pl.UTF-8): Dokumentacja klas Mono wraz z narzędziami do jej generowania i przeglądania
170License: LGPL
171Group: Development/Libraries
172Requires: %{name}-devel = %{version}-%{release}
9bfc17bb 173Provides: monodoc = %{version}-%{release}
e9945d9e 174Obsoletes: monodoc
175
176%description monodoc
177This package contains the documentation for the Mono class libraries,
178tools to produce and edit the documentation, and a documentation
179browser.
180
181%description monodoc -l pl.UTF-8
182Ten pakiet zawiera dokumentację klas Mono wraz z narzędziami do jej
183generowania i przeglądania.
184
8aa3dace 185%package static
186Summary: Static mono library
d1081961 187Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 188License: LGPL
8aa3dace 189Group: Development/Libraries
76e7cb31 190Requires: %{name}-devel = %{version}-%{release}
8aa3dace 191
192%description static
193Static mono library.
194
a86cd9c8 195%description static -l pl.UTF-8
71c7a580
JB
196Statyczna biblioteka mono.
197
ea0e88d4
MM
198%package jay
199Summary: Yacc-like parser generator for Java and C#
d1081961 200Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 201License: BSD
ea0e88d4
MM
202Group: Development/Tools
203
204%description jay
205Yacc-like parser generator for Java and C#.
206
a86cd9c8
JR
207%description jay -l pl.UTF-8
208Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 209
f327d485
MM
210%package compat-links
211Summary: Mono compatibility links
d1081961 212Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
213# resgen license
214License: MIT X11
f327d485
MM
215Group: Development/Languages
216Requires: %{name}-devel = %{version}-%{release}
217
218%description compat-links
219This package contains links to binaries with names used in .NET and
220dotGNU.
221
a86cd9c8
JR
222%description compat-links -l pl.UTF-8
223Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
224oraz dotGNU.
225
728c2265 226%prep
245657c9 227%setup -q
ddb02eae 228%patch0 -p1
24b388af 229%patch1 -p1
b3bdc9af 230%patch2 -p1
3cdc32b9 231%patch3 -p1
4a893061 232%patch4 -p1
246c9898 233%patch5 -p1
0f6bc6e4 234%patch6 -p1
394cba3f 235
5114c445
JB
236# for jay
237cat >>mcs/build/config-default.make <<EOF
238CC = %{__cc}
239CFLAGS = %{rpmcflags}
240EOF
241
728c2265 242%build
7f02b7bf
JB
243cp -f /usr/share/automake/config.sub .
244cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
245%{__libtoolize}
246%{__aclocal}
245657c9 247%{__autoheader}
18ff84b2
MM
248%{__autoconf}
249%{__automake}
245657c9
MM
250cd libgc
251%{__libtoolize}
252%{__aclocal}
253%{__autoconf}
254%{__automake}
255cd ..
256
5114c445
JB
257# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
258# CPPFLAGS override that CPPFLAGS
259CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 260%configure \
f1c5438d 261 %{!?with_static_libs:--disable-static} \
91164168 262 --enable-fast-install \
f1c5438d 263 --with-gc=included \
245657c9 264 --with-icu=no \
f1c5438d
JB
265 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
266 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
267 --with-preview=yes \
fef1a4c5 268 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 269
a317f685
JB
270# mint uses heap to make trampolines, which need to be executable
271# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
272# (ifdef NEED_MPROTECT, which is never defined)
273# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
274# -z execheap doesn't seem to do anything currently
275# -z execstack for library makes only stack executable, but not heap
246c9898 276%{__make} -j1 \
a317f685 277 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
278
279%install
280rm -rf $RPM_BUILD_ROOT
ad29385a 281install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 282
25055f19 283%{__make} install \
866e5301 284 DESTDIR=$RPM_BUILD_ROOT
b11f008f 285
65a9c4dc 286strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
287
ea0e88d4 288rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 289
18ff84b2
MM
290# this way we can run rpmbuild -bi several times, and directories
291# have more meaningful name.
292rm -rf pld-doc
e6c59841 293install -d pld-doc/{webpage,notes}
5385129f 294cp -a web/* pld-doc/webpage
03ad8b19 295cp -a docs/* pld-doc/notes
18ff84b2 296rm -f pld-doc/*/Makefile*
728c2265 297
245657c9
MM
298rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
299
5114c445
JB
300mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
301
302# loadable modules
94b2d9a7
ER
303rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.la
304%if %{with static_libs}
305rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.a
306%endif
ad29385a 307
728c2265
AM
308%clean
309rm -rf $RPM_BUILD_ROOT
310
71c7a580
JB
311%post -p /sbin/ldconfig
312%postun -p /sbin/ldconfig
313
728c2265
AM
314%files
315%defattr(644,root,root,755)
4ffe85ea 316%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 317%if %{with mint}
245657c9 318%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
319%else
320%attr(755,root,root) %{_bindir}/mono
48941467 321%endif
840f8203 322%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
323%attr(755,root,root) %{_bindir}/cert2spc
324%attr(755,root,root) %{_bindir}/certmgr
325%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 326%attr(755,root,root) %{_bindir}/dtd2rng
e6c59841 327%attr(755,root,root) %{_bindir}/gacutil1
5114c445 328%attr(755,root,root) %{_bindir}/gacutil
7b0dd1f7 329%attr(755,root,root) %{_bindir}/gacutil2
4f35821b 330%attr(755,root,root) %{_bindir}/httpcfg
331%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
332%attr(755,root,root) %{_bindir}/makecert
333%attr(755,root,root) %{_bindir}/mconfig
334%attr(755,root,root) %{_bindir}/mkbundle
7b0dd1f7 335%attr(755,root,root) %{_bindir}/mkbundle1
5114c445 336%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 337%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 338%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 339%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 340%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 341%attr(755,root,root) %{_bindir}/mozroots
25055f19 342%attr(755,root,root) %{_bindir}/pdb2mdb
5114c445
JB
343%attr(755,root,root) %{_bindir}/secutil
344%attr(755,root,root) %{_bindir}/setreg
8ef557a4 345%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
346%attr(755,root,root) %{_bindir}/signcode
347%attr(755,root,root) %{_bindir}/sn
25055f19 348%attr(755,root,root) %{_bindir}/sqlmetal
349%attr(755,root,root) %{_bindir}/svcutil
5114c445
JB
350%if %{with mint}
351%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
352%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
353%else
354%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
355%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
356%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
357%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
358%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
359%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
7b0dd1f7 360%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so.*.*.*
361%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-logging.so.0
5114c445 362%endif
2c1ff86a 363%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 364%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 365%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
366%dir %{_prefix}/lib/mono
367%dir %{_prefix}/lib/mono/1.0
5114c445
JB
368%{_prefix}/lib/mono/1.0/*.dll
369%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
370%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
371%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
372%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
373%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
374%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 375%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
376%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
377%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
378%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
379%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
25055f19 380%attr(755,root,root) %{_prefix}/lib/mono/2.0/pdb2mdb.exe
381%attr(755,root,root) %{_prefix}/lib/mono/2.0/svcutil.exe
382
5114c445
JB
383%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
384%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
385%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
386%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
25055f19 387%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlmetal.exe
388%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlmetal.exe.config
f1c5438d 389%dir %{_prefix}/lib/mono/2.0
5114c445 390%{_prefix}/lib/mono/2.0/*.dll
7b0dd1f7 391%attr(755,root,root) %{_prefix}/lib/mono/2.0/gacutil.exe
5114c445 392%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 393%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
394%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
395%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
396%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
397%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
7b0dd1f7 398%attr(755,root,root) %{_prefix}/lib/mono/2.0/xsd.exe
f3b0e346 399%dir %{_prefix}/lib/mono/3.5
400%{_prefix}/lib/mono/3.5/*.dll
6d20487b 401%dir %{_prefix}/lib/mono/compat-1.0
5114c445 402%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 403%dir %{_prefix}/lib/mono/compat-2.0
5114c445 404%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 405%{_prefix}/lib/mono/gac
5dab3216 406%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
246c9898 407%{_prefix}/lib/mono-source-libs
5114c445
JB
408%{_mandir}/man1/cert2spc.1*
409%{_mandir}/man1/certmgr.1*
245657c9
MM
410%{_mandir}/man1/chktrust.1*
411%{_mandir}/man1/gacutil.1*
4a893061 412%{_mandir}/man1/httpcfg.1*
5385129f 413%{_mandir}/man1/makecert.1*
5114c445 414%{_mandir}/man1/mconfig.1*
245657c9
MM
415%{_mandir}/man1/mkbundle.1*
416%{_mandir}/man1/mint.1*
417%{_mandir}/man1/mono.1*
418%{_mandir}/man1/mono-service.1*
840f8203 419%{_mandir}/man1/mozroots.1*
25055f19 420%{_mandir}/man1/pdb2mdb.1*
5385129f 421%{_mandir}/man1/secutil.1*
5385129f 422%{_mandir}/man1/setreg.1*
8ef557a4 423%{_mandir}/man1/sgen.1*
245657c9
MM
424%{_mandir}/man1/signcode.1*
425%{_mandir}/man1/sn.1*
245657c9 426%{_mandir}/man5/mono-config.5*
fdd46781 427%dir %{_sysconfdir}/mono
f1c5438d 428%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 429%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
430%dir %{_sysconfdir}/mono/mconfig
431%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 432%dir %{_sysconfdir}/mono/1.0
f1c5438d 433%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 434%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 435%dir %{_sysconfdir}/mono/2.0
f1c5438d 436%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 437%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
438%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 439%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
7b0dd1f7 440%dir %{_sysconfdir}/mono/2.0/Browsers
441%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
8aa3dace 442
9f4cf2f1 443%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
444%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
445%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
504c4464 446%exclude %{_prefix}/lib/mono/gac/monodoc
9f4cf2f1 447
ea0e88d4
MM
448%files jay
449%defattr(644,root,root,755)
245657c9 450%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
451%attr(755,root,root) %{_bindir}/jay
452%dir %{_datadir}/jay
453%{_datadir}/jay/skeleton*
454%{_mandir}/man1/jay.1*
455
245657c9
MM
456%files jscript
457%defattr(644,root,root,755)
458%attr(755,root,root) %{_bindir}/mjs
5114c445 459%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 460%{_prefix}/lib/mono/gac/Microsoft.JScript
461%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
462%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 463%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 464
f327d485
MM
465%files compat-links
466%defattr(644,root,root,755)
467%attr(755,root,root) %{_bindir}/resgen
7b0dd1f7 468%attr(755,root,root) %{_bindir}/resgen1
3d1af25b 469%attr(755,root,root) %{_bindir}/resgen2
f327d485 470
8aa3dace 471%files devel
472%defattr(644,root,root,755)
5114c445 473%attr(755,root,root) %{_bindir}/al
7b0dd1f7 474%attr(755,root,root) %{_bindir}/al1
5114c445
JB
475%attr(755,root,root) %{_bindir}/al2
476%attr(755,root,root) %{_bindir}/cilc
477%attr(755,root,root) %{_bindir}/disco
994ec6f9 478%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 479%attr(755,root,root) %{_bindir}/genxs
7b0dd1f7 480%attr(755,root,root) %{_bindir}/genxs1
994ec6f9 481%attr(755,root,root) %{_bindir}/macpack
39d58cda 482%attr(755,root,root) %{_bindir}/mono-api-info
e6c59841 483%attr(755,root,root) %{_bindir}/mono-cil-strip
245657c9 484%attr(755,root,root) %{_bindir}/monodis
2affc12a 485%attr(755,root,root) %{_bindir}/monograph
613285b2 486%attr(755,root,root) %{_bindir}/monolinker
5114c445 487%attr(755,root,root) %{_bindir}/monop
7b0dd1f7 488%attr(755,root,root) %{_bindir}/monop1
5114c445
JB
489%attr(755,root,root) %{_bindir}/monop2
490%attr(755,root,root) %{_bindir}/mono-shlib-cop
25055f19 491%attr(755,root,root) %{_bindir}/mono-gdb.py
01794b7a 492%attr(755,root,root) %{_bindir}/lc
ff3439a4 493%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 494%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 495%attr(755,root,root) %{_bindir}/pedump
994ec6f9 496%attr(755,root,root) %{_bindir}/permview
497%attr(755,root,root) %{_bindir}/prj2make
5114c445
JB
498%attr(755,root,root) %{_bindir}/soapsuds
499%attr(755,root,root) %{_bindir}/sqlsharp
500%attr(755,root,root) %{_bindir}/wsdl
7b0dd1f7 501%attr(755,root,root) %{_bindir}/wsdl1
5114c445 502%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 503%attr(755,root,root) %{_bindir}/xbuild
5114c445 504%attr(755,root,root) %{_bindir}/xsd
7b0dd1f7 505%attr(755,root,root) %{_bindir}/xsd2
f1c5438d
JB
506%if %{with mint}
507%attr(755,root,root) %{_libdir}/libmint.so
5114c445 508%{_libdir}/libmint.la
f1c5438d 509%else
2c1ff86a 510%attr(755,root,root) %{_libdir}/libmono.so
5114c445 511%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 512%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
7b0dd1f7 513%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so
5114c445
JB
514%{_libdir}/libmono.la
515%{_libdir}/libmono-profiler-aot.la
516%{_libdir}/libmono-profiler-cov.la
7b0dd1f7 517%{_libdir}/libmono-profiler-logging.la
f1c5438d 518%endif
5114c445
JB
519%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
520%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
521%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
522%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
523%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
524%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
525%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
526%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
527%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
528%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
e6c59841 529%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-cil-strip.exe
5114c445
JB
530%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
531%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
532%{_prefix}/lib/mono/1.0/nunit-console.exe.config
533%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
534%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
535%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
536%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
5114c445
JB
537%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
538%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
539%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
01794b7a 540%attr(755,root,root) %{_prefix}/lib/mono/2.0/lc.exe
541%attr(755,root,root) %{_prefix}/lib/mono/2.0/monolinker.exe
5114c445 542%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
e6c59841 543%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-shlib-cop.exe
01794b7a 544%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-xmltool.exe
e6c59841 545%{_prefix}/lib/mono/2.0/mono-shlib-cop.exe.config
5114c445
JB
546%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
547%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
548%{_prefix}/lib/mono/2.0/nunit-console.exe.config
549%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
e6c59841 550%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlsharp.exe
5114c445
JB
551%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
552%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
553%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 554%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
555%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
556%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
557%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
558%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
559%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
246c9898 560%{_prefix}/lib/mono/xbuild
5114c445
JB
561%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
562%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 563%{_datadir}/%{name}-1.0
5114c445
JB
564%{_pkgconfigdir}/cecil.pc
565%{_pkgconfigdir}/dotnet.pc
7b0dd1f7 566%{_pkgconfigdir}/dotnet35.pc
5114c445
JB
567%{_pkgconfigdir}/mono-cairo.pc
568%{_pkgconfigdir}/mono-nunit.pc
569%if %{with mint}
570%{_pkgconfigdir}/mint.pc
571%else
572%{_pkgconfigdir}/mono.pc
573%endif
25055f19 574%{_pkgconfigdir}/mono-lineeditor.pc
575%{_pkgconfigdir}/mono-options.pc
576%{_pkgconfigdir}/mono.web.pc
577%{_pkgconfigdir}/system.web.extensions.design_1.0.pc
578%{_pkgconfigdir}/system.web.extensions_1.0.pc
579%{_pkgconfigdir}/system.web.mvc.pc
580%{_pkgconfigdir}/wcf.pc
4a893061 581%{_includedir}/%{name}-1.0
ff3439a4 582%{_mandir}/man1/al.1*
c8f3b110 583%{_mandir}/man1/cilc.1*
994ec6f9 584%{_mandir}/man1/disco.1*
585%{_mandir}/man1/dtd2xsd.1*
e0aee78b 586%{_mandir}/man1/genxs.1*
01794b7a 587%{_mandir}/man1/lc.1*
994ec6f9 588%{_mandir}/man1/macpack.1*
2affc12a 589%{_mandir}/man1/monodis.1*
613285b2 590%{_mandir}/man1/monolinker.1*
994ec6f9 591%{_mandir}/man1/monop.1*
e9945d9e 592%{_mandir}/man1/mono-cil-strip.1*
994ec6f9 593%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 594%{_mandir}/man1/monostyle.1*
613285b2 595%{_mandir}/man1/mono-xmltool.1*
994ec6f9 596%{_mandir}/man1/oldmono.1*
5114c445 597%{_mandir}/man1/permview.1*
994ec6f9 598%{_mandir}/man1/prj2make.1*
613285b2 599%{_mandir}/man1/resgen.1*
994ec6f9 600%{_mandir}/man1/soapsuds.1*
18ff84b2 601%{_mandir}/man1/sqlsharp.1*
ff112d9b 602%{_mandir}/man1/wsdl.1*
25055f19 603%{_mandir}/man1/xbuild.1*
a66172db 604%{_mandir}/man1/xsd.1*
18ff84b2 605
b6aa60a1
JB
606%files debug
607%defattr(644,root,root,755)
608%{_prefix}/lib/mono/1.0/*.mdb
609%{_prefix}/lib/mono/2.0/*.mdb
610%{_prefix}/lib/mono/gac/*/*/*.mdb
611
18ff84b2 612%files csharp
609883c4 613%defattr(644,root,root,755)
e6c59841 614%attr(755,root,root) %{_bindir}/csharp
a66172db 615%attr(755,root,root) %{_bindir}/mcs
7b0dd1f7 616%attr(755,root,root) %{_bindir}/mcs1
a66172db 617%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
618%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
619%{_prefix}/lib/mono/1.0/mcs.exe.config
620%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
621%{_prefix}/lib/mono/2.0/gmcs.exe.config
e6c59841 622%attr(755,root,root) %{_prefix}/lib/mono/2.0/csharp.exe
18ff84b2 623%{_mandir}/man1/mcs.1*
e6c59841 624%{_mandir}/man1/csharp.1*
18ff84b2 625
18ff84b2 626%files ilasm
609883c4 627%defattr(644,root,root,755)
5114c445 628%attr(755,root,root) %{_bindir}/ilasm
7b0dd1f7 629%attr(755,root,root) %{_bindir}/ilasm1
5114c445
JB
630%attr(755,root,root) %{_bindir}/ilasm2
631%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
632%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 633%{_mandir}/man1/ilasm.1*
8aa3dace 634
e9945d9e 635%files monodoc
636%defattr(644,root,root,755)
637%attr(755,root,root) %{_bindir}/mdassembler
638%attr(755,root,root) %{_bindir}/mdoc*
639%attr(755,root,root) %{_bindir}/mod
640%attr(755,root,root) %{_bindir}/monodocer
641%attr(755,root,root) %{_bindir}/monodocs2html
642%attr(755,root,root) %{_bindir}/monodocs2slashdoc
643%attr(755,root,root) %{_bindir}/mdvalidater
7bad922f 644%attr(755,root,root) %{_prefix}/lib/mono/1.0/mod.exe
645%attr(755,root,root) %{_prefix}/lib/mono/2.0/mdoc.exe
e65b976c 646%attr(755,root,root) %{_prefix}/lib/mono/monodoc/monodoc.dll
e9945d9e 647%{_prefix}/lib/mono/gac/monodoc
7bad922f 648%dir %{_prefix}/lib/mono/monodoc
fa67b165 649%dir %{_prefix}/lib/monodoc
7bad922f 650%{_prefix}/lib/monodoc/*
e9945d9e 651%{_pkgconfigdir}/monodoc.pc
652%{_mandir}/man1/mdassembler.1*
653%{_mandir}/man1/mdoc*.1*
654%{_mandir}/man1/monodocer.1*
655%{_mandir}/man1/monodocs2html.1*
656%{_mandir}/man1/mdvalidater.1*
657%{_mandir}/man5/mdoc.5*
658
4d9455d0 659%if %{with static_libs}
8aa3dace 660%files static
661%defattr(644,root,root,755)
5114c445
JB
662%if %{with mint}
663%{_libdir}/libmint.a
664%else
665%{_libdir}/libmono.a
666%{_libdir}/libmono-profiler-aot.a
667%{_libdir}/libmono-profiler-cov.a
7b0dd1f7 668%{_libdir}/libmono-profiler-logging.a
5114c445 669%endif
4d9455d0 670%endif
This page took 0.242467 seconds and 4 git commands to generate.